none
Extremely slow access to host hard drive RRS feed

  • Question

  • Has anybody experienced (and fixed) extremely slow access to the host hard drive, from within a VM run by Windows Virtual PC on Windows 7?

    I used pretty much all of Microsoft's virtualization products before and their access to the host HD was almost seamless - Windows Virtual PC in Win7 is incredibly slow at that. Everything else runs fine: overall performance of the VM and its local processes, internet access through the host machine, etc.

    Any thoughts?

    Tuesday, October 6, 2009 3:47 PM

Answers

  • I finally figured out what was going on.
     
    The problem is TCP Offloading and Windows VPC not getting along, here's how to work around the problem by turning off offloading:
     
     
    The fix is to edit the registry, use at your own risk and only if you are comfortable with editing the registry!

    To turn off TCP Offloading, add a DWORD value in

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\Parameters

    label it  DisableTaskOffload , and change the value to 1, then reboot.


    Bob Comer - Microsoft MVP Virtual Machine
    Tuesday, March 9, 2010 8:57 PM

All replies

  • Are you still using the RC of Windows Virtual PC and XP Mode? 

    The released version should be available soon and it should help quite a bit.


    Bob Comer - Microsoft MVP Virtual Machine
    Wednesday, October 7, 2009 8:38 PM
  • Nope, I'm using the released version that was made available to ISVs a few weeks ago (6.1 build 7600).
    When I upgraded I was also hoping the released version would help, but it didn't :(

    Wednesday, October 7, 2009 8:47 PM
  • Please install http://support.microsoft.com/kb/972435/EN-US
    Thanks, -Rahul -- "This posting is provided "AS IS" with no warranties, and confers no rights. You assume all risk for your use."
    Thursday, October 8, 2009 4:03 AM
  • I didn't mean the released version of Windows 7, I meant Windows VPC release candidate...


    Bob Comer - Microsoft MVP Virtual Machine
    Thursday, October 8, 2009 1:07 PM
  • Well I never mentioned it before, but the virtual machine I'm running is Win2K3 SP1 - the KB Article you pointed me to states that this patch is for WinXP. I tried to install anyways but it gave me some "The updaterbr.inf file is invalid".

    Thanks for trying anyways!
    Friday, October 9, 2009 8:19 PM
  • I know this is the version of Windows, but unfortunately that's the only version I could find... when I click "About Virtual PC" in the VPC environment, it brings this same "About Windows" window that comes up if you run WinVer.exe - with title changed to About Virtual PC. Also, going in the "Uninstall an Update" applet (the Win7 equivalent of Add/Remove Programs with the Show Updates option) won't show the version that's installed... it just says "Windows Virtual PC (KB958559)".

    Any thought?

    Friday, October 9, 2009 8:25 PM
  • Unless you got KB958559 from MSDN late last week, you're could still be running the RC and not the released product.  It should be available pretty soon on the Microsoft  VPC download site.

    Otherwise, I don't really know what the problem might be.



    Bob Comer - Microsoft MVP Virtual Machine
    Monday, October 12, 2009 2:57 PM
  • Just to close the loop here (better later than never!), I just updated VPC with the latest KB958559 update - it used to be v6.1.7234.0 and it is now v6.1.7600.16393. I hoped that this would fix the problem but it does not... file copy from/to the host to/from the VM is still extremely slow. For instance, it took me a little over an hour to copy a 100 MB file, where both the host and the VM are the same machine (different hard drives, but same machine).

    I hope Microsoft gets to see this post and tackle this bug eventually...
    Cheers!

    Tuesday, March 9, 2010 7:28 PM
  • I finally figured out what was going on.
     
    The problem is TCP Offloading and Windows VPC not getting along, here's how to work around the problem by turning off offloading:
     
     
    The fix is to edit the registry, use at your own risk and only if you are comfortable with editing the registry!

    To turn off TCP Offloading, add a DWORD value in

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\Parameters

    label it  DisableTaskOffload , and change the value to 1, then reboot.


    Bob Comer - Microsoft MVP Virtual Machine
    Tuesday, March 9, 2010 8:57 PM
  • That did the trick!!! Thank you so much! (and sorry for the late reply... didn't have to use my VMs in a while)

    For those other readers who need to implement this solution, note that the registry edit needs to take place on the host machine, not the VM.

    Thanks again!

    Friday, May 14, 2010 9:38 PM
  • You're welcome!

    And yes, it's the host that you need to make the change in, sorry I didn't make that clear.

     

     


    Bob Comer - Microsoft MVP Virtual Machine
    Friday, May 14, 2010 11:04 PM
  • Genius. Thank you!
    Monday, June 13, 2011 8:07 PM
  • if the host is x64 does the dword have to be 64 or 32 bit?
    Wednesday, June 15, 2011 12:55 PM
  • I'm pretty sure just a 32-bit DWORD.
     
     
     
     

    Bob Comer - Microsoft MVP Virtual Machine
    Wednesday, June 15, 2011 1:44 PM
  • Disabling the TCP and UDP offload fix also works if you make the change via the network card properties.

    I.e. you can skip going into the registry and open the network card properties of the host.

    A copy of a 90MB file appears as if it would take 2 hours before the fix and about 20 seconds after.

    Phew

    Friday, June 8, 2012 7:22 PM