none
Windows 7 Backup - System image includes non system disk

    Question

  • Hi,

    I am trying out windows 7 backup, hoping at last that I won't need a 3rd party backup solution.  So far so bad!

    My first problem is how ridicilously slow the backup is, but this has been discussed at length elsewhere.  My second problem is the backup stalls when I try to backup a folder which I know has got various bits of malware in.  I am an IT pro and use the files in this folder for testing purposes.  OK fair enough I guess, although I think the backup should handle this event a bit more elegantly.  So I've zipped and password protected the offending files to hide them from the AV (security essentials by the way)

    The final problem which I just can't understand is that when I try to create an image of my system drive, backup wants to add my D drive (which is purely a data drive) to the image.  My D drive is huge and I don't want to include it in a system image.  I keep my system drive lean and mean for exactly this purpose but now I can't back it up because the total size of C and D drives combined exceed the capacity of my backup drive.

    I know for a fact that the D drive has no consequence to the system boooting or operating, I have disconnected it and windows boots up just fine.  In computer management the D Drive is not showing up as a system drive, so why does windows think it is?  And why isn't there a power user mode wher I can choose exactly what I want in a system image, I understand you're trying to make windows easy to use for the average Joe, but this lack of functionality and in depth control feels more like a Mac than windows.... and I hate macs.

    So can anyone shed any light as to why my D drive is being flagged as a system disk, otherwise it's back to 3rd party solutions... AGAIN

    Thanks
    Tuesday, December 01, 2009 10:02 PM

Answers

  • I suggest you check your hard drive jumpers. There should be only one Active drive. If you disconnect the data partition the Active partition will be changed. We are not clear why the partition will be Active partition when you connect it.

    You may open Disk Management, set the 100MB system served partition or your Windows partition as Active and check the result again.


    Arthur Xie - MSFT
    Friday, December 04, 2009 8:17 AM
    Moderator

All replies

  • Same issue for me.  I do not see an option to exclude my data drives.  Surely the guys at MSFT have considered this so I suspect it is operator headspace but considering the lack of  answers from MSFT about the backup slowness and backing up to network drives, who knows?

    -glenn
    Wednesday, December 02, 2009 3:35 AM
  • This behavior occurs if your boot files are stored in that drive, or that is system partition for another Windows system. If you want to change the location of the boot files, the best way is re-formatting and reinstalling Windows 7. Otherwise you need to change the Active drive from Disk Management, then restart and run Startup Repair.
    Arthur Xie - MSFT
    Wednesday, December 02, 2009 9:27 AM
    Moderator
  • Arthur

    As I stated in my first post, there are no boot files on this drive... I disconnected the data drive and and windows booted and operated fine, there is no other windows system on this drive and never has been.

    Computer management shows the drive as Healthy (Active, Primary Partition) with only a single partition, exactly the same as my other data drive which isn't included in the system image.

    Only the C drive is showing as having boot and system status.

    I'll keep this post short since you obviously couldn't be bothered to read the first one, shame there is no button for "vote as unhelpful"



    Wednesday, December 02, 2009 11:08 AM
  • I have the same issue. However I have previously been able to make a image of only the system drive.
    Wednesday, December 02, 2009 2:00 PM
  • Same issue here. I've watched the builds and tried each one's image backup hoping this would stop. It hasn't. The only thing I can think of is those programs that I've installed on my D drive but who put lots of ancillary files in my C:\Prog. Files (x86)\Common Files\...  and sometimes C:\Program Files (x86) (MS Office 2007), My Roxio Creator., etc. and the more I add to D, at some point they incur the C & D inclusion. 

    Way off base ??? It's just an amateur guess.
    • Edited by jimrx4 Thursday, December 03, 2009 1:28 PM
    Wednesday, December 02, 2009 6:59 PM
  • I'm also having the same issue, and like the rest of you my G drive (the drive it randomly wants to add to the backup) is just a storage drive and has nothing to do with my Windows installation.   Annoyingly, I can see that the drive is checked to be included, but the checkbox is greyed out so I have no option to disable it.   Very annoying.
    Wednesday, December 02, 2009 11:49 PM
  • I suggest you check your hard drive jumpers. There should be only one Active drive. If you disconnect the data partition the Active partition will be changed. We are not clear why the partition will be Active partition when you connect it.

    You may open Disk Management, set the 100MB system served partition or your Windows partition as Active and check the result again.


    Arthur Xie - MSFT
    Friday, December 04, 2009 8:17 AM
    Moderator
  • I have same problem and now figured it out.

    When I just finish the installation of windows 7, it's no problem, I can select C (my system partition) or D (my data partition) drives for creating system image. Then I installed antivirus (avast) and firewall (COMODO) to D drive, the problem you mentioned happens. So I check programs starting at Startup and I found avast and comodo. Just uninstall and reinstall them into C drive. Now only C drive you can choose for system image. 
    Friday, December 04, 2009 2:12 PM
  • I'm having this problem to.

    Last week when I first used the program, it worked EXACTLY as I wanted it. It backed up my C: (system drive) to my d drive.

    Today I can't, it wants to include the d drive as part of the system.

    I am suspecting that one of the programs I installed today is running a service that accesses a file from the D drive (I put my sql data store on my d drive)

    Anyone know a good fix for this?
    Monday, January 11, 2010 10:17 PM
  • Well you can add me to the club too!

    Like andonevris, I'm using Windows 7 and whenever I try to do a system image the Backup and Restore tool includes my C: *and* E: drive and I am unable to deselect the latter. As a result I cannot create a system image because the total size of the backup exceeds the available space I have on my backup hard drive. I do NOT want to backup E:, thank you!!!

    I've checked with Computer Management and only my C: drive is shown as Healthy (System, Boot, Page file, Active, Primary Partition); the other three hard drives including E: are shown as Healthy (Primary Partition) only. I've checked to see if there are any other hidden files on the E: drive but apart for the hidden System Information folder and the Recycle Bin, all that's on the drive are data files and some installed games and demos.

    The strange thing is that straight after I'd installed Windows 7 I was able to create a system image of C: only just fine but, for whatever reason, I can't do it now.

    I've even spoken with someone from Microsoft who attempted to help me solve the problem but he could only suggest I reformatted the hard drive at some point to see if that would fix it. Well I backed up the contents of the drive and deleted the partition before Christmas. I could then do a system image of C: and my system loaded fine so evidently there are no system files it needs to load up on E:. However, when I formatted the drive and restored the contents the Backup and Restore tool went back to thinking E: was a system drive!!!

    This is clearly a bug of some kind IMO.

    Incidentally, I was dual-booting with Vista on C: and 7 RC on E: prior to installing the final version of 7 as an in-place upgrade. I then deleted all the 7 RC folders and files from E: manually as I had games and data on there and didn't want to reformat. There is only one entry for Windows 7 in the bootloader however.

    If you ask me, the Backup and Restore tool should be rewritten so they the user can choose which drives to be included in the system image because at the moment the option is greyed out and we cannot do it.
    Wednesday, January 20, 2010 11:42 PM
  • I *FINALLY* solved this annoying issue... thanks to m72899 over on the Guru3D.com forum.

    What had happened on my machine was that Dragon Age Origin had been installed to the E: drive but the game also installed an updater service in the same folder. Windows 7 sees services as system files so it flagged E: as a system drive. I'd also installed the Dragon Age Toolset as well which also installs a SQL Server (BWDATOOLSET) service that is referenced to the E: drive too. This also causes Windows to see E: as a system drive.

    I've had to copy the DA Updater Service to a new folder on my C: drive (Program Files/Dragon Age Origins Updater) and change the reference to the service from E: to C: in the registry. I can now do a system image of C: and C: alone!!!

    My advice to anyone with this issue is to check carefully through the services and see where they're linked to. If you have any services running on drives other than C: then Windows will see it as a system drive.
    Thursday, January 21, 2010 1:12 AM
  • I ran into this issue as well. The issue is that the E drive is marked as system, because it has the boot information. If you go to command prompt (run as administrator) and type bcdedit, it'll probably say under boot manager that the partition is E:

    In disk manager, make sure that c: is marked as active, then in an administrator prompt type

    bcdboot c:\windows /s c:
    this will move the boot files to the c drive. then reboot and the other drive should no longer show as a system drive. more in depth overview:

    Saturday, January 23, 2010 5:21 PM

  • Yes this solved the problem for me!  I have Win-7 Honme Premium on a Dell laptop).

    After a lot of searching through the services section of the registry, I found three references to one executable on the  D: (non-boot) drive, which was
                                                   D:\program files(x86)\Microsoft Office\Office\Office 12\GrooveAuditService.exe

    Perhaps this was installed by Microsoft Office?

    It is surprising that this would cause a problem, since it is a Microsoft product........

    I changed the three registry entries from  C:\..... to D:\....

    I also copied the Gooveaudit*.* files to the equivalent path on the C: drive

    The corresponding service in the  Admin menu is called  "Microsoft Office Groove Office Service"

    It was not running, and configured to "manual" start.

    When I tried to start the service, it failed with a 1053 timeout error. (I am not sure it ever worked anyway)

    But I really could care less about that.

    I am delighted that I can now make system backups of only the bootable partitions, without wasting time and media backing up the data partitions.

    One feature request:   It would be great if Microsoft would provide an option to breakup the image file into multiple smaller files instead of one huge file (like Norton Ghost does).

    Sunday, January 24, 2010 7:12 PM
  • I am having this same problem, my E:\ drive is blank and it is still showing up as a system disk in Backup, it is not marked active in Disk Management and there are no jumpers to set as it is an SATA drive.  There are no references to it in my registry.  BCDEdit shows C:\ not E:\ as the startup disk.  So I don't know what's going on...
    Sunday, January 31, 2010 1:22 AM
  • ran into this problem of non-system disk D: being include in the backup all of a sudden.
    backup previously ran fine with just drive C: imaged until just the day before.

    Check bcdedit, it showed only C: as system.

    D: contained only data, application profiles, /temp directory and pagefile.sys.

    I had installed some motherboard software the day before which left some install files/scripts in the temp drive.
    What I did was to run CCleaner to clear up the temp drive and rebooted the machine.

    I now go into Backup and Restore and see that D: is no longer identified as a system drive. Have not done backup yet, will know in a couple of days, but I believe that cleared it.
    My guess is that the software installation left some post install boot scripts/exe in the temp drive which Windows Backup associated as necesary for system image.

    Now if only Backup could exclude hiberfil.sys and have automatic purging of old backups.... *sigh*
    • Proposed as answer by cupper24 Tuesday, August 20, 2013 9:01 PM
    Friday, February 05, 2010 5:03 AM
  • BTW, now that I have this problem fixed, how do I go about deleting the humongous backup image of the D: drive without losing the C: drive image?
    Friday, February 05, 2010 5:04 AM
  • Hi, guys. I'm with you :)

    For me the solution was in uninstalling radmin service (d:\utils\Radmin\r_server.exe) windows service. After reboot radmin had been excluded from svchost list, and now I can swith on or off disk D: in system image tool list.

    As I got it. You need to unlink all the links to executables (maybe also resources) that are concerned to  startup process: startup items, svchost items, something else I didn't notice for a while.

    And also of course you can temporary break down these links by changing disk letter. For example: I changed 'd:' to 'g:'. And after backup changed back the letter from 'g:' to 'd:'

    P.S.
    And in this context the suggestions about active drive and jumpers look like a bit bullshit
    • Proposed as answer by Cter Thursday, February 11, 2010 10:09 AM
    Thursday, February 11, 2010 9:59 AM
  • Yeah, I changed the drive letter and it didn't help.  Good idea, though.
    Thursday, February 11, 2010 1:23 PM
  • Thanks Dazza1967, your post here helped me resolve the same issue I was having with Windows 7 backup.

    It had been working great and was only backing up the appropriate system drives on my computer.
    Then one day a couple of weeks back, I noticed that my E: drive, which is another partition on my main HDD, was suddenly being identified as a system drive, and thus, being included in the Win7 system image backups.  I've kept my Games, My Documents, Favorites, Music, etc, off my main boot volume for many years now, and only run my operating system, and some of my apps from the C: drive.

    As it turns out, I had purchased Dragon Age through Steam, and my Steam folder is installed on my E: drive.

    I followed your steps regarding the DA Updater service, rebooted my machine, and that did the trick.  My E: drive is no longer being included in my system image backup.

    Thanks,
    u2sparky
    Sunday, February 14, 2010 7:59 PM
  • Seems to me that Microsoft need to either alter the way Windows 7 sees services so that any installed to the non-system drive don't cause Backup and Restore to flag two or more system drivers, or ensure that developers only install game-related services, such as those used by BioWare for Dragon Age: Origins, to the system drive only.

    What amazes me is that I had two consultations with Microsoft over this issue and they couldn't fix the issue for me. One of the suggestions was to reformat the E: drive, which worked initially, but once I restored the backup it was back to being flagged as a system drive because of the DA: Origin services.

    @Patrick Johnston - Your E: drive might be empty but are you sure you don't have any old services that are still linked to that drive? I've noticed that some services aren't uninstalled properly and cannot be removed by running a registry cleaner. Instead you have to go into the command prompt (cmd.exe) as the Administrator and type the following:

    sc delete "SERVICE NAME"

    to remove it. It may be that you have such a service so you may have to go through them one by one and check the properties to see where these services are installed. If they're all on the system drive (usually C:) then your problem lies elsewhere.
    Tuesday, February 16, 2010 1:29 PM
  • You hit it right on the head with Dragon Age being the culprit - that's exactly what caused the same issue for me and it was driving me nuts trying to figure out what happened (I was thinking virus). Thank you!!!
    Tuesday, March 30, 2010 9:43 PM
  • So I have only one partition (c:\), and Windows Backup & Restore puts EVERYTHING on that drive into the "system image" -- including all of c:\users.  That makes the system image humongous, which causes two problems: 1) really long backup of system image, and 2) system image backup uses too much space on my (not-humongous) backup drive (enough so that I can't have more than "system image" on the backup drive that's the same size as my primary -- there's no space for no incrementals). 

    I can not have any services running on a different drive, because I don't have a different drive.

    This did not used to be the case: my initial backups (months ago) worked fine. 

    Is there a way to take "c:\users" out of "system image?"  (I have already tried deselecting all drives and just doing "system image" backup, so don't bother to suggest that -- the "system image" is still the size of system+windows+program files, etc. PLUS c:\users). 

    Alternately, is there a safe way to move c:\users to d: partition without screwing up restores?  (A backup isn't valid if it can't be restored to usable condition....)

    -- mdeck

     

    Saturday, June 26, 2010 2:27 AM
  • I tried everything else in this thread with no help removing a D: (1TB half full) from the system image; no programs, services, boot stuff on it; changed drive letter, no help.  There used to be a temp folder on it but there isn't any more.

    But after running ccleaner it was removed from the list of system drives and my system image when from 450GB to 42GB.   THANKS FOR THE TIP!

    On my 12GB memory system I've removed the paging file, but I'd like to keep the hybrid sleep setting, so yes it would be reasonable for the system image to exclude the hiberfil.sys.

    Besides that, I too need automatic purging of old backups.

    Monday, August 02, 2010 1:05 PM
  • i hv d same prblm nd i hv d solution:

    i hv a dual boot system with vista on D: drive and 7 on C: drive. first i made C: drive active and than changed dirveD:'s letter.

    Now i can create system image of drive C: only.

    note: don't forget to reset drive D: to ACTIVE and with the same drive letter as it  was before.

    Thursday, August 19, 2010 1:55 PM
  • I have the same problem. The Windows folder is only 15GB, but the System Image only of Win7 (C:) (System) is up to 871GB. Most of this is Windows Media Centre TV recordings. But I presume the problem is that D: data is being included in the image because the system partition is on the same drive, even though it is not listed in teh System Image which only says C:.

    When I first installed Win7 on the machine, I don't recall seeing any options for which drives to install on. Consequently, the installer put the System partition on Drive 1 while installing C: on mirrored disk 2 and 3. (Disk 0 is Linux. Certainly I had a lot of trouble even getting Win7 to even install in the beginning, but once it was fixed to be able to install, options were scant.)

    Anyone got any ideas on how I can fix this. Or is the only solution to have to reinstall everything??????

    Saturday, October 23, 2010 11:30 PM
  • My D: partition was marked as a system drive by portable skype. I used cleanafterme to remove the reg entry it created and then problem dissapeared.
    • Proposed as answer by logicbear Wednesday, November 17, 2010 2:43 PM
    Wednesday, November 17, 2010 2:42 PM
  • I *FINALLY* solved this annoying issue... thanks to m72899 over on the Guru3D.com forum.

    What had happened on my machine was that Dragon Age Origin had been installed to the E: drive but the game also installed an updater service in the same folder. Windows 7 sees services as system files so it flagged E: as a system drive. I'd also installed the Dragon Age Toolset as well which also installs a SQL Server (BWDATOOLSET) service that is referenced to the E: drive too. This also causes Windows to see E: as a system drive.

    I've had to copy the DA Updater Service to a new folder on my C: drive (Program Files/Dragon Age Origins Updater) and change the reference to the service from E: to C: in the registry. I can now do a system image of C: and C: alone!!!

    My advice to anyone with this issue is to check carefully through the services and see where they're linked to. If you have any services running on drives other than C: then Windows will see it as a system drive.


    Thanks Dazza1967,

    I had a service for Altera, which was installed in D: drive, after uninstalling Altera everything was ok. Now only System Reserved and C: are listed.

    Thanks

    Sunday, December 26, 2010 8:06 PM
  • I agree. There should be an admin and/or power users version of backup. I'd much rather choose my options than pour over my services looking for programs that may be running from my secondary drive. When I test my restore I will decide if the missing files need to be delt with immediately or if this backup is sufficient.
    Friday, February 11, 2011 2:43 AM
  • I feel the best way to use system image, is to do it once, right after a clean install.  After you have created your system image, just run file backups.  If the occasion occurs where you need to restore, you can restore using the system image, install all software manually, then restore file backups. 
    Friday, February 18, 2011 7:43 PM
  • I feel the best way to use system image, is to do it once, right after a clean install.  After you have created your system image, just run file backups.  If the occasion occurs where you need to restore, you can restore using the system image, install all software manually, then restore file backups. 


    A) I realize this thread is a month old..

     

    B) This doesn't really work for people that are bringing home virus's from clients to fix em. On the rare occasion I need to re-install Windows and I can not devote hours on end to re-installing all of my tools and applications.

    C) All the posters here have a legitimate issue.

    I just went through 3 days of trouble shooting and lost partitions / volumes to get SP1 for Windows 7 Installed. I had to work through at least 5 issue's to get the bugger to install. Its not my software. I didn't write it... I shouldn't have to fix it... nor spend hours troubleshooting minor "flaws."

    So here I am with a clean SP1 install... and here I go fixing issue's with the backup tool so that I can pull "a clean image" down if something like this happens again.

    Saturday, March 19, 2011 9:56 PM
  • I just solved this problem on my rig.  I had added an internal blank drive and windows 7 was seeing it as a system drive.  I went in to Diskpart, selected the disk, ran the clean command.  I then started the backup software.  While the back up program was open I initialized the drive and formatted the new disk. A scan of backup locations and the drive was found and I was able to use it as a backup location for a system image of my C Drive.  I currently have one drive with windows (C), another with user profiles (D).  The Third disk was one I had laying around (E).

    I think it may have had something to do with the MBR on the hard drive before I ran the clean command.  This had previously been a system drive for this computer

    Monday, July 11, 2011 4:25 AM
  • I just solved this problem on my rig.  I had added an internal blank drive and windows 7 was seeing it as a system drive.  I went in to Diskpart, selected the disk, ran the clean command.  I then started the backup software.  While the back up program was open I initialized the drive and formatted the new disk. A scan of backup locations and the drive was found and I was able to use it as a backup location for a system image of my C Drive.  I currently have one drive with windows (C), another with user profiles (D).  The Third disk was one I had laying around (E).

    I think it may have had something to do with the MBR on the hard drive before I ran the clean command.  This had previously been a system drive for this computer


    Thanks WITech, this was the only solution of all the suggestions above; I had previous copied all data off, DISPART CLEANed the disk, but every time I re-created the disk, Backup would complain.  However, re-creating it while backup was running and hitting refresh solved this problem - at least initially.  Will see if it survives a reboot :)
    Tuesday, September 20, 2011 10:07 PM
  • I have the same problem, my I: drive (I have a lot of drives) shows up as a system drive, even tho it contains ONLY data files. I've deleted EVERY single reference to I: in the registry, doesnt work. Windows backup still thinks it is a system drive.

    I copied every file on the drive to an external drive. Then i did diskpart clean, recreated the partition. This drive was now 100% empty. Still, Windows wanted to back it up as a system drive.

    I then tried the tip of doing the same thing while Windows backup was open, and voila, I: was no longer a system drive. I then proceeded to copy my files back. This was a few hours ago.

    I just started Windows backup again, and now it thinks I: is a system drive.

    This behaviour is frankly ridiculous, if there is no info in the registry on the drive, the drive is NOT active, the partition is brand new, it has no system files, how can windows backup (and ONLY windows backup) think it is a system drive?

    The only thing that works for me is to either change the drive letter and reboot, or mark the drive as OFFLINE in disk management before i run the image backup. 

    Of course, I could just change the drive letter permanently, and then "go around" the problem, but I have other software (non-system software) that requires data that is on I:, and I dont want to manually change all these links in various programs. 

     

    Basically Windows backup now refuses to let me have a drive named I: as a data drive, it will only consider it as a system drive. There must be some way to fix this without reinstalling Windows?

     

    Wednesday, September 21, 2011 4:48 PM
  • Because Microsoft tried to make their backup of your system as complete as they could, they wanted to include as much of it as they could...and much of the data on the one drive is referred to by icons, pointers and lines of code residing on the others. Items in the d drive are included in the registry also, which is part of the problem...restoring the registry without restoring the data it references would be pointless and possibly destructive! That being said, I for one, wish the new backup was as good as the ntbackup that came with xp professional. It simply worked, backed up what you wanted, from where you wanted, and allowed you total control over where you wanted to put it, and how. It would even back up to or from a dvd/rw drive.

    The best advice I can give you is to use the disk manager to unmount the drive before the backup...you can re-mount it after the fact. After the dis mount, restart windows, so the fact it is is removed is apparent to windows when you run the backup.


    "http://support.microsoft.com/fixit/default.aspx/". This is MICROSOFT'S new, FREE, fully automated, anonymous support portal, which can help users resolve windows and other product issues with a few mouse clicks. BOOKMARK THIS SITE, EVERYBODY !!!
    Thursday, September 22, 2011 3:50 AM
  • Hi All,

    If you have installed software that creates a windows service on a drive; Windows 7 will mark that drivea as a "system drive".

    So remove the windows service software and install it on your intended system drive [C:].

    If backup still marks a non "system drive" for system image; backup your data using robocopy, drop that volume using Disk Management in Computer Management, then recreate it.

    Good luck,

    Mac McRae

    http://www.datanetzs.co.cc


    Keep on Truck'in

    • Proposed as answer by Mac McRae Sunday, March 04, 2012 3:05 AM
    Sunday, March 04, 2012 3:03 AM
  • So, in summary, I think these are the three reasons for this phenomenon (the last one wasn't really delved into above).

    1) Somehow, almost certainly by your installing a program onto what was supposed to be your data drive, a service was installed there. Autoruns is an efficient way of finding which service it is.

    2) Your data drive is actually marked as "System" according to Disk Management.

    3) You've told Windows to relocate common system folders, such as My Documents and My Pictures, to the data drive. This has to be the most common of the three.

    Sunday, March 04, 2012 4:53 AM
  • I'm sure that Your HDD is marked as active.

    Hard drive image include every HDD marked as ACTIVE DISK.If You had operating system before HDD is marked as ACTIVE DISK and even after formatting it stays ACTIVE DISK.

    1.) So take some Disk Director and You'll see that is marked as ACTIVE DISK. Click on it and remark those HDD as Dinamic disk.

    2.) check BIOS because can be wrong BOOT sequence and ensure that first HDD BOOT is marked HDD where is OS instaled.

    And Your problem is gone

    And for those ''  I do not see an option to exclude my data drives.'' ACTIVE DISK can't be excluded so check ACTIVE DISK staus and You'll se the same. Also check BIOS HDD boot sequence.

    I know that will help :-)

    Bye

    Saturday, April 14, 2012 9:08 PM
  • Sorry to open an old thread, but I'm having this problem with a RAM disk!  Being a RAM disk, it gets created each time my laptop boots; there's absolutely nothing on it except a TEMP folder that gets created automatically.  The image backup always tries to include this drive, and even though the drive has nothing on it and so I'm willing to back it up too, it's a FAT32 partition and the image backup fails immediately.  Strangely enough, I have the same configuration on a second laptop, and the image backup works fine there.  Thanks!

    Tuesday, July 10, 2012 2:19 AM
  • I had the same problem - I made my "O" drive my temporary video repository and the Windows 7 "Library" took it as a system object. I removed it later, but did realize the "Library" didn't! It also had my server "\\hvs2\SG0300" in my "Music Library", but fortunately, that was just a complaint item with no wasted 120 MB of metadata archived for something I didn't need! I dredged through my registry blowing away all references to "o:\tmp", etc, to no avail. Sorry this thread is 3 years old, but it was still a good reminder of things to check, besides hardware (when it's all software :->).

    - Art


    Me

    Wednesday, August 29, 2012 6:32 AM
  • What if the service is disabled?

    Sunday, December 02, 2012 10:00 AM
  • There is a solution.

    Microsoft usually have stuff that is not documented. For example Windows server 2008 comes with a command line utility that will allow the backup (in this case a shadow copy) of any drive you wish to a  backup target. The program is wbadmin.exe.

    According to some Microsoft sources it doesn't exists on Windows 7 but let me assure you that it does; I use it all the time, specifically to get round the problems you have described in your posts.

    I build VHD images and test them until I am happy with them and then I back them up as a system image and then rewrite them on to a system drive. I can only do this with wbadmin.exe

    To backup your c: to your d: (or what ever other drive you have space on in this case we will use d:)

     - Open a command prompt as Administrator

     - Run the following command:

    Wbadmin start backup -backupTarget:d: -include:c: -quiet
     - You should get output something like this:

    wbadmin 1.0 - Backup command-line tool
    (C) Copyright 2004 Microsoft Corp.

    Retrieving volume information...
    This will back up volume System(C:) to D:.

    The backup operation to D: is starting.
    Creating a shadow copy of the volumes specified for backup...
    Creating a backup of volume System(C:), copied (1%).
    Creating a backup of volume System(C:), copied (29%).
    Creating a backup of volume System(C:), copied (57%).
    Creating a backup of volume System(C:), copied (79%).
    Creating a backup of volume System(C:), copied (98%).
    The backup of volume System(C:) successfully completed.
    The backup operation successfully completed.
    Summary of the backup operation:
    ------------------

    The backup of volume System(C:) successfully completed.

    That should complete the backup. It should create a WindowsImageBackup folder in the dirve you backed up to.

    Restore as normal.

    There is one small but very important caveat: If you have any system files or programs that are linked to the system drive on your d: drive or elsewhere you may find that when you restore your system the links are broken. it should not happen if you have not made any changes before you restore but if you are like me who use the d: to store the bulk of the program files and just use the c: to store the system OS (on SSD... the need for speed! :) ) then you need to be careful... be warned!!

    That's all folks!

    Bick

    • Proposed as answer by Bickleigh1 Tuesday, June 25, 2013 5:43 PM
    Tuesday, June 25, 2013 5:39 PM
  • The (free) software I use (RAM Disk) lets me format the RAM disk using NTFS.
    Tuesday, July 16, 2013 1:38 PM
  • Use CCleaner as someone below suggests. I had some software installed for one of my son's toys, and it placed a start-up item on the Desktop which I have mapped to my data disk (my HDD not my SSD with OS). Once I re-installed that piece of software on my OS drive, I was then given to include/exclude the data drive from the back-up.

    Cheers,

    cupper24

    Tuesday, August 20, 2013 8:54 PM
  • Moving those common system folders doesn't matter. I have them mapped to my D:/ drive still, and Windows Back-Up does NOT include it in the image automatically. I have the option of including/excluding it. The answer is that somewhere the OP probably does have one miniscule file/folder/program that Win7 relies upon during startup. Once he rids himself of it on his data drive, he too will have the option as I mentioned above.

    cupper24


    • Edited by cupper24 Tuesday, August 20, 2013 9:05 PM
    • Proposed as answer by kalakhr Thursday, October 10, 2013 6:55 AM
    Tuesday, August 20, 2013 9:05 PM
  • Make sure that there are no services installed on the other drives, even if the services are not started.  If your having the D: drive being included in the system image search the registry starting at HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services for "D:

    delete/move any service found from the search above.


    • Edited by kalakhr Thursday, October 10, 2013 7:05 AM
    Thursday, October 10, 2013 7:03 AM
  • I had this exact same problems and thanks to many in this forum, I solved it.  I had 3 problems: (a) user files on another drive, (b) a Service that had some files on another drive and (c) some old registry entries pointing to software on another drive. 

    Here's how I solved it:

    For (a): Just move all the user file areas back to the C: drive.  Right click on each main user folder (e.g. My Videos), then click Location, and the Move. In my case I just clicked Restore Default.

    For (b): I ran Microsoft's Autoruns for Windows, looked under the "everything" tab, and under the "Image Path" column identified that I was running some SQL server files on my other drive.   I uninstalled it (wasn't using it anyway).

    For (c): I ran CCleaner and in the registry section looked for anything pointing to my other drive. I found some uninstalled program files that still had entries. Deleted those.

    Went back to system backup and sure enough, I could just backup my C: only.  Worked like a charm. Thanks to everyone here that gave great advice. It really helped!

    • Proposed as answer by Peter Kay Friday, December 06, 2013 7:00 PM
    Friday, December 06, 2013 7:00 PM
  • I suggest you check your hard drive jumpers. There should be only one Active drive. If you disconnect the data partition the Active partition will be changed. We are not clear why the partition will be Active partition when you connect it.

    You may open Disk Management, set the 100MB system served partition or your Windows partition as Active and check the result again.


    Arthur Xie - MSFT

    How can this be Marked as the ANSWER? when you refer to the "100MB system served partition" I presume you are referring to the "MICROSOFT SYSTEM RESERVED" Partition? My question is this...

    What if you have a GPT formatted SSD that runs in EFI Mode?  (ie.. No Physical Hardware Jumpers on the drive... Not since PATA IDE have I seen a ""Quote Un-Quote"" Jumper setting on a HDD.) There is no way to set your MS Reserved partition as active. Or any other volume or partition on the disk for that mater... "DISKPART", mentions that the "Active" setting is for MBR Formatted Drives Only.

    If there is something I'm just Not getting, then I apologize,  please set me strait.


    Sincerely, YOUR_FRIENDLY_BLS_SERVICE_PROVIDER

    Friday, January 24, 2014 5:52 AM
  • IT turns out I had the exact same issue. IT was driving me crazy and I had already deleted a few folders before I found this post.

    And all it takes is one moved file and 1 change in the registry.

    so here i am in win 8.1  (cars can fly now!! :P) ... 5 years later, with the same issue.  So a belated much thanks for the fix!! :)))


    • Edited by RedStarSQD Saturday, March 15, 2014 8:33 PM
    Saturday, March 15, 2014 8:31 PM