How to fix Windows 7 SP1 x6 Readyboot?


  • Hello, after working on this for days, I'm at my wits end, so hopefully someone with a similar problem knows of a solution.

    My system is slow to boot (not as bad as some I've read that take hours) because Windows decided to break Readyboot. How do I know? There used to be effect files (tracex.fx) in %windir%\prefetch\readyboot and, after 4 reinstalls with the same problem, I can consistently reproduce the symptoms (but not the just...happens): at some point, the files stagnate and there's only 4 left, the latest one gets created and erased after a while during the same session while the previous ones remain untouched.

    First I did try the obvious sfc / problems found and the issue is not solved. Reading somewhere that booting 5 times should unlock the thing that got caught somewhere in the twilight zone...I spend 30 mins. Of my life doing no avail; reading somewhere else that deleting the folder contents should fix it (after said 5 reboots) I spend another 30 mins. doing success either.

    Following a suggestion elsewhere (here, probably) of running xbootmgr -trace boot -prepSystem -verboseReadyBoot and waiting more than 30 minutes because it defrags and does some other things ("Preparing system" quite a useful statement...right) it doesn't get fixed either, after dealing with xbootmgr's own problems and managing to get it to sort of run, after the sixth reboot, there was supposed to be another trace that failed with "kernel logger not found" or similar error message (at least, not the unable to defrag message).

    I decided to trace what was erasing the file with process monitor...I do get to the point where it's erased, but it's useless: its listed as svchost.

    I tried treating Windows like a kid, see if it would fix itself after walking it through the process and regenerating the whole cycle, 1 to 10: wait for the readyboot.etl file to distill into trace1.fx and write-protect it...sure enough, trace2, 3 and so started creating themselves and not getting erased, since by the time trace6.fx should appear it should be able to erase trace1.fx, I removed the write protection on that one and put it on trace5.fx, this time Windows was smoother: it erased trace1.fx to trace4.fx, except for trace5, which was write-protected, it did create trace6.fx, I repeated the process until trace9.fx, removed the write protection on trace5.fx, put it on 9 and the same behaviour occurred: everything but trace9.fx was erased, trace10.fx was created; after another reboot (that created trace1.fx) I decided it was time for Windows to walk on its own and removed the write protection from trace10.fx and...sure enough, trace1.fx and trace10.fx were promptly erased.

    After some more research, I found somewhere a suggestion to reset the BootPlan registry key...

    First problem: it wasn't there. I created it, put a binary value of 00 on it and rebooted; after that boot, it filled with binary values, like it should and when trace1.fx dissappeared (again) it took with it the BootPlan registry key.

    I've looked for any registry settings that could help (quite a long and tedious process, since the registry search function of regedit is lame) and found none.

    This never happened to me before, it started with SP1 on my old machine, I decided to format it to fix it with a disc that has integrated SP1, true enough, it was fixed...for a while, I didn't have to put up with that for too long: I switched machines, wiped that hard drive and used it on my new rig, then the problem started again, the first time after the extremely smart Visual Studio Express installer decided that if I install Visual Web Developer Express before installing C++ or C# (to avoid, ironically, changing a single registry value that prevents installing some Web Developer Express components due to VS2010's SP1) the rest of the suite doesn't work (among other assorted problems), I used system restore to fix the mess and...Readyboot was broken again, same symptoms. Another format (clean installs, all of them) to fix it and it lasted for about 12 glorious days before breaking again, not before scaring me (I do keep an eye on it after all those reformats in a relatively short time span, I did put up with it for quite a while after SP1 thinking it would go back to normal after a while or n reboots and it was annoying as hell): at some point Windows decided I have an SSD drive...which I don't and turned off superfetch (that seems to be a result of the Windows Experience Index? Above 7 or so it deems the drive as SSD? I have a 7.1 drives score, fast hard drives...yes...that, hell, they're SATA II 7200 RPM). I turned it back on and set it to automatic and it was a happy world...until about 6 days ago when the nightmare began all over again. I've been at this for days, and I'm now all out of ideas and patience. Please help.

    Additional data: I do have the boot hotfixes installed, two of them: KB2510636 and KB2555428, the last one shouldn't be needed, the system drive is a 200 Gb. Harddrive but I installed it just in case, there's another: KB2505454 that I don't think I need since I do have a 1.5 Tb. drive, but that one isn't watched by system restore and doesn't hold any system files or shadow copies (as far as I know).

    I have, indeed, checked the system for virii and such with: Avast Free (the resident antivirus for day to day use); malware bytes antimalware and Spybot Search and Destroy, I think I used Superantispyware too, I'm not sure, since I don't keep that one around: I hate applications that think themselves extremely important and fill my system with crappy services and autostarts (yeah...most of them do these days).


    • Edited by Bloodbat Tuesday, September 13, 2011 6:36 AM
    Tuesday, September 13, 2011 6:27 AM

All replies

  • So how much time does the system take to boot? From selecting the OS/powerON to the welcome screen.

    Are you suspecting readyboot to be the cause because of the missing trace files or is there some other means using which you narrowed down to readyboot?

    Have you identified at which stage the boot takes longer than expected?


    Sumesh P - Microsoft Online Community Support
    Friday, September 16, 2011 12:47 PM
  • Load the etl files in xperf, and there should be a readyboot graph that tells how many hits it got.  You should have a c:\windows\prefetch\layout.ini or readyboot will not work.  This gets created when the system is idle, or run 'start /wait rundll32.exe advapi32.dll,ProcessIdleTasks' (it does boot defrag too).  In perfmon you can see if readyboot in enabled.  Also the Superfetch service must be enabled, since it's tightly involved with readyboot.


    Friday, September 16, 2011 3:02 PM
  • I did format, but it's useful to answer since someone else might have the same problem.

    I cannot clock now, as I did format the machine; as stated above, the files get deleted (along with the BootPlan registry entry) by svchost, with too many entries under it to pinpoint which one did it, but it does affect readyboot, the stages at which it takes longer is before showing the welcome screen and after logging in.

    Layout.ini was present there, I made sure; SuperFetch was enabled in services (I checked that too, since Windows disabled it itself at one point after deeming my HDD as an SDD drive) and, indeed, Readyboot was too in Perfmon.

    Friday, September 16, 2011 9:11 PM
  • What does "x6" mean?

    Saturday, September 17, 2011 7:12 AM
  • It means I forgot, for whatever reason, to type a 4 after it. It should read x64.
    Saturday, September 17, 2011 9:18 AM
  • As of now there are no known issues with the symptoms that you specified involving Readyboot.

    I am unable to provide you any insight into what the issue might be without looking at some logs and traces from time of issue along with additional details about the environment and occurrence.


    Sumesh P - Microsoft Online Community Support
    Wednesday, September 21, 2011 11:47 AM
  • Hmm, I have the same problem now on a mini-mac.


    Friday, October 21, 2011 3:56 PM
  • Does this hotfix fix Readyboot for you?

    The Windows 7 startup process is slow when you create many restore points (bootplan creation failure)


    • Proposed as answer by JS2010 Monday, October 24, 2011 10:19 PM
    Monday, October 24, 2011 10:18 PM
  • this is an old thread but here's one thing you could try. Look for a setup log made by the OS after the first install of Windows. I would tell you which one but I do not remember what the name is. Another area you could try is wmic and look for your boot param there could be an issue with the OS and hardware that you’re installing on.

    One thing is that the OS is finding an driver for the CMOS or BIOS is not correct. The bios driver is keeping at uninstall. Since the OS needs a different one does Your OS install correct?

    I have this same problem. I find a driver for my bios but because dell suggests that I install the most recent when I need an older version before I install the OS. Why I have no Idea. Windows says it need an older version such as a PowerEdge 860 Bios A05 created in 2007, when the Bios version installed is an a09 Phoenix for a D170L.

    I have updated every driver so far except the Bios which is the most recent. This is also the cause of an usb component out of date and in another language version.

    Spend some time rummaging through the logs until you find one made by the setup after the first install but before boot. Your OS should spit out the version requirements it needs or it will just continue on without the right version meaning you'll have an OS that installed without the right bios version needed...

    your number ONE!

    Monday, August 06, 2012 8:40 PM