Add Windows 7 PC to Workgroup - Cannot see XP machines


  • New W7 box on LAN with XP clients and (1) Server 2008. DHCP server is on router. Network  discovery and file sharing "on".

    Current profile is "work" - Common workgroup name assigned to all elements on LAN

    W7 box can only see Server 2008 machine.

    Typing resourse name in address bar fails.

    Can ping XP clients.



    Wednesday, June 09, 2010 2:47 PM


  • Found the problem:

    NODE TYPE was set to "PEER-TO-PEEER"

    Changed to "HYBRID" (8)

    Now all devices on network are visible.

    Tuesday, June 15, 2010 4:15 PM

All replies




    Can you access the Windows 7 machine from Windows XP machine?


    To troubleshoot the issue, please perform the following steps.


    1. Write down the Windows XP’s IP address. Click Start button in Windows 7 and type \\Windows XP’s IP address, and then press enter. Can you access the network computer now?


    If it works, the issue can be related to DNS. You may check Hosts file. Please refer the following article.


    Modify the Hosts file 


    In the hosts file, ignore all the lines that start with *, and pay attention to other lines. Please only keep the line "localhost", delete others.  


    2. Modify relevant settings on Windows 7 machine.


    a. Click Start and open Control Panel.

    b. Open "Network and Sharing Center" and click "Advanced sharing settings".

    c. Expand the current network profile (such as "Home or Work"), and then select the following options:


    "Turn on Network Discovery",

    "Turn on file and printer sharing",

    "Turn on sharing so anyone with network access can read and write files in the Public folders",

    "Turn off password protected sharing"


    3. Temporarily disable firewall and antivirus program for a test.




    Thursday, June 10, 2010 2:41 AM
  • Can you access the Windows 7 machine from Windows XP machine?


    \\XPIPADDRESS Can you access the network computer now?


    Please only keep the line "localhost", delete others

    Entire HOSTS file commented out (#) also:  "localhost name resolution is handled within DNS itself"

    2. Modify relevant settings on Windows 7 machine.

    Previously done

    3. Temporarily disable firewall and antivirus program for a test.

    Previously done

    Thursday, June 10, 2010 2:45 PM
  • Hi,


    Please also try the following steps to troubleshoot the issue.


    1. Reset WinSock


    a. Click Start, click "All programs", and click "Accessories". 

    b. Right-click "Command Prompt", and click "Run as administrator". If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

    c. Please enter the following command, and press Enter.


    Netsh winsock reset


    d. A message stating "Successfully reset the Winsock Catalog" will appear. Please restart the computer.


    2. Clear the Hosts file and Domain Name Resolution (DNS) cache


    a. Click the Start Button, type "%SystemRoot%\system32\drivers\etc" (without quotation marks) and press Enter.

    b. Right-click on the file "Hosts" (without quotations) and choose Delete.

    c. Click Continue to confirm the deletion and verify the administrator permission.


    d Click the Start Button, type "cmd" (without quotation marks), in the search result list, right click on Cmd.exe and select Run as administrator.

    e. Click Continue button to verify the administrator permission.

    f. In the popup window, type: "ipconfig /flushdns" (without quotation marks) and press Enter.


    Then, please access the network machine again. What’s the result?






    Friday, June 11, 2010 1:42 AM
  • I have a small problem, quite similar to what you described but not exactly the same.

    I can access the Windows 7 machine from every Windows XP machine and I can make a ping from the Windows 7 Pc to all Xp's Pc, but if write on the windows 7 PC a  \\Windows XP’s IP address, it's impossible to see all Xp's machines and on the network list i can see only a printer ad a router, but i can't see any Pc's.


    Thank for everybody can help me.




    Friday, June 11, 2010 7:36 AM
  • Winsock reset / flushdns done

    Same condition.

    Can see Server 08 machine in network

    Can see shares only if entered as: \\ipaddress

    Friday, June 11, 2010 12:17 PM
  • Reset Winsock and flushdns complete.

    Same condition (See SVR 08 and \\ipaddress) nothing else in network

    Friday, June 11, 2010 1:07 PM
  • Also tried editing LAN manager authentication level to "send LM & NTLM responses"

    Still not working.

    Disabled firewall.

    Still not working.


    Friday, June 11, 2010 5:59 PM
  • Is Windows 7 "Broken"?

    I run a network with two servers ('08 & '03) and thirty P.C.'s (XP Pro)

    Everything works seamlessly.

    We skipped Vista as it was a dog with fleas.

    Our hardware upgrades for the past year and a half have all been with an XP downgrade as I imagine most businesses have done.

    We purchased a new box with W7 because I know that at some point we will have to transition to the new OS. I really like W7 and it seems to perform better than Vista or XP except when it comes to networking.

    So one must ask the question: "Why?"

    From the multiple posts on this subject, It looks like we are not alone. Considering the inability of the MSFT Moderators to fix our problem (or anyone elses) I can only assume that MS not only knows about the issue, but that it is allowed to exist to push business customers to adopt W7.

    Until we can buy a system with an OS with true backwards networking capability without tweaking, we will continue to go the XP downgrade route. As all our systems can run XP and our apps without trouble, our new hardware buys will be very limited.

    Monday, June 14, 2010 11:51 AM
  • From the dos prompt of my windows 7  Pc, I can "ping" all the pc's on the network, with ip adresses or with their names.

    If i try to see all the pc's on the network from windows 7, i can't see any pc and i can see only periperals with the protocol ssdp like printers, router and pc's seen like multimedial devices.

    i can't see any kind of peripheral with netbios protocol, but netbios is present and activated in the network parameter of my windows 7 Pc. 

    From any other xp's pc's in the network, I can see my windows 7 PC with it's name and from them, and after signing my user name and password, I can open my files.

    This failure begun last 9th of june, i think after a lot of updates downloaded and installed by microsoft update. I don't know if this can be the origin, but i don't know what i can do to resolve this problem !

    Thank for everybody can help me.





    Monday, June 14, 2010 12:04 PM
  • Hi Chris

    I think you're right but now  need to resolve my problem with windows 7. The sinptoms are exactly the same of when I disable netbios, I made the experiment on another Pc with windows 7 home edition and all the Pc's with XP disappeared !

    I don't know what has happened !

    Monday, June 14, 2010 12:13 PM
  • Hi,


    Since the Windows XP machine can be accessed by typing \\IPaddress. Please try the following steps.


    Modify the Hosts file 


    If the issue persists, please create  a DWORD named LmCompatibilityLevel set to value of 1(one) at HKLM\SYSTEM\CurrentControlSet\Control\Lsa


    For more information about the key, please refer to the link below:




    Hope this helps.



    Tuesday, June 15, 2010 2:35 AM
  • The problem is that I can't access xp machines from windows 7, both with name and with ip adress, but only from the dos prompt i can ping each machine both with name and with ip address. For this reason, i think it's not a DNS malfunction.

    The sinptoms are like the netbios has been stopped, infact in the network resources I can only find peripheral with SSDP (a printer, a router and so on) or WSD, but I can't see any PC with NETBIOS.

    I'm working on this pc from 3 months (HP ProBook 4710s Notebook PC) and till one week ago, everything was good. The problem began one week ago, I think after a windows update, because i didn't install any other software.

    On the pc is installed Norton Internet Security and i tried to disable the firewall, but nothing happened!

    Thank for everybody can help me.



    Tuesday, June 15, 2010 3:07 PM
  • Found the problem:

    NODE TYPE was set to "PEER-TO-PEEER"

    Changed to "HYBRID" (8)

    Now all devices on network are visible.

    Tuesday, June 15, 2010 4:15 PM
  • Can you elaborate exactly what you changed/where?  I'm having the same problem but I'm not familiar with the setting that you changed.  Thanks.
    Wednesday, June 16, 2010 1:25 PM
  • I made the change but nothing happened. Anyway, if I write ipconfig /all from the dos prompt, NETBIOS on TCP/IP is activated, infact from the dos prompt i can ping  other PC  both with their name and with their ip address.

    Thank for everybody can help me.




    Thursday, June 17, 2010 11:42 AM
  • Chris

    How do you change the node type in Windows 7?

    Monday, June 28, 2010 9:13 PM