none
Disable cmd.exe's administrator title RRS feed

  • Question

  • Is there any way I can disable cmd.exe from adding "Administrator: " to the title of all escalated console windows in Vista?
    Wednesday, May 30, 2007 11:32 PM

All replies

  • what do you want it to say and why ?
    Monday, June 4, 2007 1:23 PM
  • I thought my question was pretty simple:  I'd like to prevent it from showing anything at all.

     

    Since I doubt I have the option of changing what it says, I wanted to prevent it from saying anything at all so the scripts I need to run elevated aren't effectively limited to a few characters of useful text in the title before they get cut off on the task bar.  In a perfect world cmd.exe would use a different icon or append text to the title.

    Monday, June 4, 2007 3:55 PM
  • i'd like to have this too!!

    as a developer i have quite a bunch of CMDs open and i give them titels according to their purpose, these are usually short 3-4 letter word b/c i cant see much more in the taskbar anyhow.
    prepending administrator is now destroing that! how about appending it if u really need to print that in the title bar or give it another icon or so?
    Monday, February 4, 2008 11:05 PM
  •  

    All right, I finally figured this out, after a fashion.  It can be done, but requires modifying system files.  If you'd like, here's what you need to do to change the title to something (it has to be something apparently, in these directions, I replace it with a space)

     

    You’ll need to modify the MUI data file for cmd.exe.   This file is called cmd.exe.mui, and is located in C:\Windows\System32\en-US on a standard 32-bit, United States installation.  For other languages, the en-US will be different, and for 64-bit installations, you’ll need to modify both the version in System32 and in SysWOW64.

    ·         First off, take ownership of cmd.exe.mui.  Right-click on the file, click Advanced on the security tab.  On the Owner tab, click Edit, and select the Administrators account.

    ·         Now, give access to modify the file.  Go back into the properties for the file, click Edit on the Security tab, click Add, and enter Administrators, then make sure they have the Full Control option set to Allow.

    ·         Using a hex editor, resource editor, or other editor of your choice, modify the string in the file from “Administrator: %0” to “  %0” (That’s two spaces before the %0, don’t forget the null character at the end).

    ·         Save the file

    ·         Run mcbuilder.exe (this could take some time to run)

    ·         Reboot the computer.

     

    Thursday, March 27, 2008 11:34 PM
  • Another (less destructive) solution I use is to just copy cmd.exe from an XP machine and use that one instead.

     

    Monday, June 30, 2008 3:55 PM
  • arent all these files protected by the system and when it detects that they got chnaged just replaces them with the original version?
    how do u go about that?
    Tuesday, July 1, 2008 9:05 AM
  • hi, my name is deborah, owner of this computer, recently the motherbord was rebuilt, and i am having a time setting things up because it says i need administrator privileges,they rebuilt the system in my cousin kenny's name, do u understand what i'm asking?, altho i have managed to go exploring and have opened up some things...sincerely awaiting your response...i am the girly

    Friday, September 12, 2008 9:41 PM