Teredo Tunneling adapter will not start up, IPv6 is checked on in Network adapter settings, recently upgraded to 7 Ultimate from Vista biz 32bit


  • I keep getting a Teredo Tunneling adapter error code in device manager under device list.  I have checked the settings for the wireless network adapter and the list is checked for IPv6 to be in use but I keep getting an error. I have taken screen shots of the errors etc.  What just is teredo tunneling adapter.  I use to be able to send photos from my laptop to my hd Direct TV receiver but since I have upgraded I have not been able to.
    Thursday, January 14, 2010 3:20 PM

All replies

  • You probably got a code 10 error  and its used for IPv6 connections. You need to update the drivers. What machine do you have - be specific as to make, model and model #

    The Code 10 error code is generated when Device Manager has insufficient information or the error that is bubbled up by the device drivers is not recognized by Device Manager. Additionally, this error may occur when one of the drivers that the device needs does not start. If many drivers are being used by a particular device, it can be difficult to determine the one that failed.


    One of the major cause for this is that network adapter is not currently supporting this feature. You may download the latest driver / update the driver for your network adapter or chipset, and then try to uninstall and reinstall this component.


    Reference Link:  Description of Code 10-related errors that Device Manager generates in Windows-based computers


    Update the driver

    Open Device Manager, in the device Properties dialog box, click the Driver tab, and then click Update Driver to start the Hardware Update Wizard. Follow the instructions to update the driver.

    You may be prompted to provide the path of the driver to the location where you have download the latest driver from the hardware vendor’s Web site.

    Reference link:

    1: Get help with Device Manager errors

    2: Update a driver for hardware that isn't working properly

    3: Tips for fixing common driver problems


    Before installing the updated drivers you can create a system restore point, so that if something gets corrupted, there is a backup in place and where can use a roll back option.


    Follow the steps below to create a system restore point:

    1. Click Start, type systempropertiesprotection in the Start Search box, and then press ENTER. If you are prompted for an administrator password or for a confirmation, type the password, or click Allow.

    2. Wait for Windows to search for available disks and most recent restore points. In the System Properties dialog box, on the System Protection tab, click Create.

    3. Type a name for the restore point and then click Create.

    4. After the restore point has been created successfully, click OK two times.

    Note:   If System Restore is turned off, click to select the local disk, click Apply and then click Create.


    For more information check this link: System Restore: frequently asked questions

    MCSE, MCSA, MCDST [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Thursday, January 14, 2010 4:43 PM
  • Hi,
    I will work thru your solutions.  The laptop has an Intel(R) PRO/Wireless 3945ABG Network Connection in an HP Compaq 6710b laptop about two years old.  M

    I tried to update the driver and it says it is current.  Yes it was error code 10 as well.  Now what?
    • Proposed as answer by pureel Monday, May 30, 2011 3:55 AM
    Friday, January 15, 2010 12:46 AM
  • The complications escalate.  IPv6 shows up as checked off under properties for the wireless adapter then in status it is no connectivity, just IPv4.  I can not join a HomeGroup.  I get an error message to turn on IPv6 and when I go to turn it on it is already checked off.  I tried unchecking the IPv6 and rebooted my laptop and had NO internet connection.  I had to disable the wireless connection then enable and reconnect.  I have a Direct TV 2 pc program which if I could find out how to add in Windows Media player I should be able" to play" my laptop photos on the tv but because I can't join a homegroup that doesn't work. 
    Friday, January 15, 2010 1:36 PM
  • Review this for setting your network up to do homegroup sharing between Windows 7/Vista and XP with printers

    As for the TV thingy (not my thing) review this Windows 7 Media Center. What version of 7 are you running?
    MCSE, MCSA, MCDST [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Saturday, January 16, 2010 12:45 AM
  • Hi,

    All of the computers, one desktop and two laptops are using Windows 7. The desktop and one laptop are running 7 Home Premium 64 bit and one laptop is Windows Ultimate 32 bit.  The desktop is connected to the wired/wireless router WRT 300 N Linksys.  I figured I would let the desktop generate the home group password.  With all three computers on I try to use the generated password to log the two laptops on to the home group.  It ends up doing home group troubleshooter then network troubleshooter and I get the message to "enable IPv6"  If I enter the properties of the network adapter on the two laptops it says IPv6 is checked off in the box but when I check the status on either laptop IPv4 is connected and IPv6 is not connected.  On the desktop network adapter the Teredo tunnel adapter is not installed.  I did a trouble shoot on that, contacted HP who told me to uninstall the Teredo tunnel adapter and how to reinstall it.  It will not start code 10.

    Now when I view my full network on the laptops I see all of the items on my network.  All three computers, my wireless printer, my Direct TV bridge(DVR) and my Linksys router.  I can printer from all three computers wirelessly.  I am experiencing some offline issues when the printer goes offline with all of the resetting of my network etc.  I simply find the printer again and I am able to print.  

    I do believe the Teredo Tunell adpater and IPv6 issues are interconnected.  The Direct TV thingy is partially resolved. However, I haven't configured how to send my laptop photos over media share to my Direct TV DVR so that it can play my photos on my big screen.  But that is a Media Center problem and I am hoping the inability to join a homegroup, teredo tunnel adapter unable to start code 10, and the weird IPv6 is in properties but is not present in status will perhaps clear up the media center difficulties.

    Why can't the teredo tunnell adapter start, and why can't IPv6 be truly enabled???  Under my previous network I had XP and Vista computers networking fine even had IPv6 connectivity.  I am wondering if a patch or update is needed for Windows 7?
    Sunday, January 17, 2010 1:37 AM
  • Yes on the IPv6 and Teredo (interconnected). You also need IPv6. Have you tried removing the device then from Action run the hardware scan to let it put the device back in and reinstall the software?

    As for devices going offline, make sure on your network adapters that power saving is disabled. Speaking of your Linksys router, have you updated the firmware for it and restarted it? (just checking). found some more info for you, but just ignore the XP part of it. I also do not share my desktop or public folders (my option)

    I still would take a look at the firewall and user accounts per the general instructions below.

    Here are general network troubleshooting steps. Not everything may be applicable to your situation, so just take the bits that are. It may look daunting, but if you follow the steps at the links and suggestions below systematically and calmly, you will have no difficulty in setting up your sharing.

    Problems sharing files between computers on a network are generally caused by 1) a misconfigured firewall or overlooked firewall (including a stateful firewall in a VPN); or 2) inadvertently running two firewalls such as the built-in Windows Firewall and a third-party firewall; and/or 3) not having identical user accounts and passwords on all Workgroup machines; 4) trying to create shares where the operating system does not permit it.

    In Windows 7, go to Control Panel>All Control Panel Items>Network and Sharing Center. Click on "Change advanced sharing settings". You don't want to use Homegroup unless you have all Windows 7 machines. If you do and you want to use Homegroup, see Windows 7's Help & Support. Otherwise, in the Advanced Sharing:

    Turn ON network discovery
    Turn ON file and printer sharing
    Turn ON sharing in the Public folder sharing section
    Turn ON password protected sharing

    A. Configure firewalls on all machines to allow the Local Area Network (LAN) traffic as trusted. With Windows Firewall, turning on Window's File and Printer Sharing as above will take care of this for you. If you aren't running a third-party firewall or have an antivirus/security program with its own firewall component, then you're fine.  With third-party firewalls, I usually configure the LAN allowance with an IP range. Ex. would be Obviously you would substitute your correct subnet. Refer to any third party security program's Help or user forums for how to properly configure its firewall. Do not run more than one firewall. DO NOT TURN OFF FIREWALLS; CONFIGURE THEM CORRECTLY.

    B. For ease of organization, put all computers in the same Workgroup. This is done from the System applet in Control Panel, Computer Name tab.

    C. Create matching user accounts and passwords on all machines. You do not need to be logged into the same account on all machines and the passwords assigned to each user account can be different; the accounts/passwords just need to exist and match on all machines. DO NOT NEGLECT TO CREATE PASSWORDS, EVEN IF ONLY SIMPLE ONES . If you wish a machine to boot directly to the Desktop (into one particular user's account) for convenience, you can do this:

    Start>Search box>type: netplwiz [enter]
    Click on Continue (or supply an administrator's password) when prompted by UAC

    Uncheck the option "Users must enter a user name and password to use this computer". Select a user account to automatically log on by clicking on the desired account to highlight it and then hit OK. Enter the correct password for that user account (if there is one) when prompted. Leave it blank if there is no password (null).

    XP - Configure Windows to Automatically Login (MVP Ramesh) -

    D. If one or more of the computers on your network is XP Pro or Media Center, turn off Simple File Sharing (Folder Options>View tab).

    E. Create shares as desired. In Windows 7 I usually share out the user's Desktop and the Public directory.

    MCSE, MCSA, MCDST [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Sunday, January 17, 2010 1:49 AM
  • Hi,

    I have worked thru all of your suggestions and I still have no IPv6 connectivity.  I did add the router range into my Zone Alarm safe zone.  I also updated the firmware for the router and the router is Windows 7 compatible.  I reinstalled Teredo Tunnel Adapter and tried to update the driver and received the drive is up to date and " the device can not start (Code 10). 
    I have let the hard wired desktop generate the homeshare passwords and tried to log the two laptops using the passwords that were generated and both of them give me the message"IPv6 needs to be connected"or activated.  Then if I enter the home share trouble shooter it defers to the network troubleshooter and again when I check the adapter properties IPv4 and IPv6 are both checked off but under status only IPv4 is connected to internet.  IPv6 is not connected to the internet.
    My wireless printer does work from all three computers.  Any other suggestions?
    Tuesday, January 19, 2010 1:51 AM
  • And you do know of the issues with Zone Alarm and Windows 7 right?  Just for fun, disabled (might even have to be uninstalled) and try connecting again. Rule the firewall completely out of the picture.
    MCSE, MCSA, MCDST [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Tuesday, January 19, 2010 3:41 AM
  • Hi,
    I have run the desktop and one laptop with Windows 7 firewall on and Zone Alarm turned off.  The Teredo tunneling adapter still will not start Code 10.  Again in the properites the IPv6 is checked off and in status it states note connected.  The only info I could see re: conflict between Zone Alarm was with their version 8 which was last September/October.  The Zone Alarm we are running is version installed 12/10/2009.  Zone Alarm says this version is Windows 7 compatible.   Since we spent $$ for Zone Alarm protection and are comfortable with its level of security and had no prior problems running Xp and Vista, Zone Alarm for firewall and anti virus and a router that worked fine why has my home network become no IPv6 connected after the only thing we have done is switched to Windows 7?   I also can still not join the Home group or enter the password on either of the laptops because it states to run the HomeNetwork group IPv6 has to be enabled.  I do not wish to uninstall Zone Alarm and do not see the need for it.  If I am able to shut off the firewall and enable Windows 7 why do I need to uninstall it?  Any other suggestions other than that?
    Wednesday, January 20, 2010 10:13 PM
  • I have to agree, this is a crazy situation. Almost to the point where my 3 computers, 2 laptops and PC and a friends 5 computers will all go back to Win XP.
    I have read through this and various other forums and tried all the recommendations and no luck at all in getting the computers to talk to each other. I can get the networks "Seeing each other but no communications. The Teredo and the IPv6 are a right pain and with the update to Win 7 this just shouldn't be so difficult. I also have tried closing all firewalls ZA and windows and it makes no difference. It all comes back to the Teredo and IPv6 issue.
    Saturday, January 23, 2010 11:03 AM
  • If anyone with this problem is running ZA free this is your problem. ZA retail has an area where you can select an option to fix it but they don't seem to care about the "Free" users if a reply to my post in ZA forums is any indication. AND I quote

    "How do I setup ZoneAlarm so that it does not block IPV6 traffic?ZA ,

    Firewall / Advanced / Put check mark in last option on the page
    (enable iP6 Networking)

    However, I think that option is ONLY available in the Paid versions..

    Sorry, You only get Basic features in the FREE version of Zone Alarm.. "

    However I found this an offensive reply and a very poor way for such a large company to treat, all be it their free users;
    Stuffing up my computer, costing me many hours of problem solving is not something I think is the done thing.
    I for one won't be using ZA again and won't be recommending it either on the strength of their reply. If they think this is a way to get free users off the free list and buy the product I feel it will sadly backfire on them.

    So I In the end it was just 2 things we had to do in Win 7. Uninstall ZA not just disable it.
    Secondly when accessing the regedit area do so as administrator using the following method. I assumed I was always logged in as administrator but for a lot of the system
    programs you need to "Run as administrator.
     Click on the start button type in regedit in the "Search programs and files" area find the link in the pop up screen and right mouse click on it and click on "Run as administrator" This was the system will retain the changes you make as per the instructions above. So far now all is good. Fixed my friends computers as well.

    Thank you to the friendly patient Local Microsoft technician, 6 computers are happily talking to each other.
    • Proposed as answer by Voyager1300 Saturday, December 25, 2010 9:37 PM
    Friday, January 29, 2010 8:12 AM

  • This was the system will retain the changes you make as per the instructions above.
    Which changes please ?
    Saturday, September 11, 2010 7:24 PM
  • I had a similar prblem with an AT&T- 2WIRE Wireless Network Adapter, had UNINSTALL ZA Extreme Security,then reboot,let the network locate the adapter,then reinstall ZA. Lot of trouble for simple fix. The Drivers were fine.
    Saturday, December 25, 2010 9:41 PM
  • "Here's what worked for me. It's in the windows knowledge base. In the start menu search bar type in REGEDIT to open the registry editor. Navigate through the following: HKEY_LOCAL_MACHINE\SYSTEM\CURRENTCONTROLSET\SERVICES\TCPIP6\PARAMETERS. In the right pane, right click Disabled Components and select edit. Set the DWord value to 0." [ In my computer DWord was set to ff. You must Restart your computer and the teredo tunneling adapter will now start. ]
    Friday, April 29, 2011 10:21 AM
  • Thanks so much Deathlocke. This worked for my HP tablet too. After all the above.......what a relatively simple fix.


    Monday, May 02, 2011 12:17 AM
  • Cool Beans... 

    I found the Knowledge Base link;

    "Your network connection must have IPv6 enabled to create or join a homegroup" error message when you try to create a homegroup in Windows 7"


    Saturday, May 28, 2011 9:50 PM