none
I need working driver for my ati radeon x1600 (windows 7)

    Question

  • I need working driver for my ati radeon  x1600 becouse i cant play Counter strike on opengl mode.
    Monday, May 18, 2009 2:08 PM

Answers

  • they don't have windows 7 driver for my graphic card!
    Hi

    If ATI has not released Windows 7 drivers for that graphic card, there isn't anything we can do?

    You might want to try the latest Windows Vista drivers and install these in Compatibility Mode in Windows 7.


    Hope this helps.

    Thank You for testing Windows 7

    Ronnie Vernon MVP
    Monday, May 18, 2009 4:42 PM
    Moderator
  • I need working driver for my ati radeon  x1600 becouse i cant play Counter strike on opengl mode.
    The latest legacy driver 9.11 will work with the x1600 fine.


    Vote if answered or helpful, I am running for Office (joke)! IT/Developer, Windows/Linux/Mainframe

    See my site for detailed machine information

    Saturday, January 23, 2010 3:02 AM

All replies

  • Go to the ATI web site they make the drivers for windows 7

    Monday, May 18, 2009 3:42 PM
  • Go to the ATI web site they make the drivers for windows 7


    they don't have windows 7 driver for my graphic card!
    Monday, May 18, 2009 4:25 PM
  • they don't have windows 7 driver for my graphic card!
    Hi

    If ATI has not released Windows 7 drivers for that graphic card, there isn't anything we can do?

    You might want to try the latest Windows Vista drivers and install these in Compatibility Mode in Windows 7.


    Hope this helps.

    Thank You for testing Windows 7

    Ronnie Vernon MVP
    Monday, May 18, 2009 4:42 PM
    Moderator
  • Actually, I've found the Catalyst 9.2's work best with my 1650.

    The issue with the older cards is that ATI is only including formal Windows 7 support for DirectX 10 cards, so anything prior to the 2400HD isn't going to have official Windows 7 drivers.
    Monday, May 18, 2009 5:28 PM
  • Go to the ATI web site they make the drivers for windows 7


    they don't have windows 7 driver for my graphic card!

    Try the latest Win7 driver from ATI and Mobility Modder, supposed to make driver backward compatable with yours...

    http://game.amd.com/us-en/drivers_catalyst.aspx

    http://www.driverheaven.net/modtool.php

    As a matter of fact, think I will switch to my Win7 hard drive and try it with my X1400...

    Update... No, the drivers from ATI do not work with the modder, I suggest the drivers at http://catalog.update.microsoft.com/v7/site/Search.aspx?q=ati+x1600 the site does not say whether drivers are 32 or 64 bit, my experience says that the larger download with the same date and version number is 64 bit, the smaller is 32 bit (at least with ATI drivers, download, extract and install with device manager, or have you tried these drivers? have you tried windows update for drivers?
    • Edited by shakeyplace Monday, May 18, 2009 7:01 PM
    • Proposed as answer by jstegm Sunday, December 25, 2011 6:57 PM
    Monday, May 18, 2009 6:12 PM
  • I have a mobility x1600, and Windows 7 was able to install semi-working drivers for it through windows update. I can run source games like Team Fortress 2 and Left 4 Dead with no slow-down, but after ~5 minutes they start a cycle of freezing (graphical glitches, sound starts repeating, screen turns black for ~10 seconds then normal picture/control comes back) which repeats every 2-3 minutes. This problem is described in valve's steam support , and I have verified that it is definitely a driver problem in my case, not a paged memory problem.

    I also have a strange problem with hibernation. When my laptop is running off battery power, hibernation works perfectly. When it is plugged in, however, hibernation results in a blue screen with a "DRIVER_POWER_STATE_FAILURE". This happens 100% of the time.

    I've tried the mobility modder software with newer ATI drivers (9.4, 9.3) and neither has worked. I'm guessing the only course of action at this point is to wait until for ATI to (hopefully) release an updated driver. My current driver - the one downloaded through windows update - is version 8.561.0.0, dated 01/12/2008.
    Monday, May 18, 2009 8:19 PM
  • i think there is nothing to do,just have to wait unntil ati make new driver.
    thnx all guy hwo try to help me.
    Monday, May 18, 2009 9:27 PM
  • i think there is nothing to do,just have to wait unntil ati make new driver.
    thnx all guy hwo try to help me.

    Please see the ATI card link in my signature for more on this driver issue.

    Hello! Please reply back, promptly if possible with the results to solutions to your problem!

    Curious about Win7 min. system requirements?
    Readme for older ATI graphics card and Windows 7 users
    - JoelbX
    Monday, August 10, 2009 12:13 AM
  • Update:  AMD/ATI has Legacy 9.11 drivers posted. Use these and all should be fine. For you laptop folks, use the Mobility Modder 1.2 from driverheaven.net and you should be in business.
    I have modded drivers working on my X1600 laptop with Win7 64 bit. I get a graphics Aero score of 4.2. Not bad! :)
    Saturday, November 28, 2009 9:26 PM
  • didnt work 9 11 and 9 12, i have radeon x1600 benq p52, i dl all versions of catalyst mob and simpl and use mobile modder and all useless....

    some one know somethink work?????? windows 7 or ati make all my life on XP I RLY WANT PLAY !!!!!!!!
     btw sry for eng....

    p.s. popeye u talking ____ x1600 with 9 11 dont work...
    Monday, January 04, 2010 3:21 PM
  • You have to use the LEGACY driver located here: ATI Catalyst™ Legacy Display Driver

    Make sure you use the Mobility Modder from DriverHeaven.net on them. They do work, I have an Aero score of 4.2 and have had no problems playing recent games.
    You may also need to clean your old graphics drivers out using a driver cleaner.
    Wednesday, January 06, 2010 8:30 PM
  • I fix same problem! download >>>>Driver Genius Professional Edition<<< give you the link wher you downloading this program:
    https://www.dropbox.com/home#/Photos/Sample%20Album/
    login for this is.....
    pasword.....   I upload  in the dropbox . First ,download and instal , fix drivers and instal ati catalyst <> driver genius is give you a option. sory for my bad engl!
    Friday, January 22, 2010 10:07 AM
  • I fix same problem! download >>>>Driver Genius Professional Edition<<< give you the link wher you downloading this program:
    https://www.dropbox.com/home#/Photos/Sample%20Album/
    login for this is.....
    pasword.....   I upload  in the dropbox . First ,download and instal , fix drivers and instal ati catalyst <> driver genius is give you a option. sory for my bad engl!
    Hi

    Driver Genius Professional is a commercial, licensed product.

    It is a violation of the license agreement for that product to post information obtained by that product.

    Thanks for understanding.


    Ronnie Vernon MVP

    Forum Moderator
    Friday, January 22, 2010 10:40 AM
    Moderator
  • I need working driver for my ati radeon  x1600 becouse i cant play Counter strike on opengl mode.
    The latest legacy driver 9.11 will work with the x1600 fine.


    Vote if answered or helpful, I am running for Office (joke)! IT/Developer, Windows/Linux/Mainframe

    See my site for detailed machine information

    Saturday, January 23, 2010 3:02 AM
  • Use this:

    http://support.amd.com/us/gpudownload/windows/Legacy/Pages/radeonaiw_xp.aspx
    Thursday, February 18, 2010 11:10 PM
  • Hi,

    I'm using the catalyst 9.11 driver and its working fine on Windows 7 32bit. For Windows 64 bit you have to use the latest AMD driver for Vista 64bit.

    Cheers
    Andre
    Tuesday, February 23, 2010 10:13 AM
  • I've had Windows 7 64bit for months and took it out after 2 weeks of not figuring out how to get a display driver to load.  Steps I was taken was ..

    1. Unistall the driver that Windows 7 auto installed for my video card when I installed Win 7

    2. Install the lastest  ATI X1950 Pro from driver from ATI website.



    I have installed Win 7 again 3 days ago hoping by now there was a cure :)


    But still everytime I install a new Video Card driver Windows 7 keeps installing the one that came with Win7 when I reboot, and never finds the driver I have insatlled.

    Anyone have a clue how to fix this..


    If I posted this in the wrong place sorry... I am a noob here :)


    Thanks for any help...


     
    Friday, February 26, 2010 10:32 PM
  • Try these. You have to use the Vista Legacy drivers. Let Windows install the driver it wants, then install this one. I have this working on my X1600 64 bit Win 7, good luck.

    ATI Catalyst™ Legacy Display Driver


    There seems to be a lot of confusion about the LEGACY drivers. The bottom line is, you cannot use the newer drivers posted on the main driver page of AMD for these older cards. The new drivers don't have the code for the older cards. They will never install correctly.

    You must use the LEGACY drivers for the older cards.

    Read this if still confused:  http://social.technet.microsoft.com/Forums/en-US/w7itprohardware/thread/243faae6-75c9-40f9-b946-100befe4b6f3
    Saturday, February 27, 2010 12:19 AM
  • Look peep, the legacy drivers are on the Windows DVD. IF you want the Catalyst drivers, 9.11 is the last one for legacy devices.

    Vote if answered or helpful, I am running for Office (joke)! IT/Developer, Windows/Linux/Mainframe RaidMax Smilodon, 680W, Asus M2NBP-VM CSM, AMD X2 4200+, 2GB DDR2-800, HD2400 Pro, more details on my site, need a new boot disk, existing one is 5 years old
    Saturday, February 27, 2010 2:40 PM
  • Actually, there is a new 10.2 legacy driver posted. I don't know if it changed/fixed anything but it installed fine for me. The driver date reads 2/10/2010 in system properties. The windows supplied driver doesn't have CCC which some people want so use the legacy drivers if you want CCC.

    I sure hope this is the end. We seem to be going in circles here.  : )
    Saturday, February 27, 2010 4:25 PM
  • I have tried the CCC with a range of drivers and that includes the built-in ones. After installing the CCC, let Windows pick the best driver from what is available. CCC will still work fine.

    Vote if answered or helpful, I am running for Office (joke)! IT/Developer, Windows/Linux/Mainframe RaidMax Smilodon, 680W, Asus M2NBP-VM CSM, AMD X2 4200+, 2GB DDR2-800, HD2400 Pro, more details on my site, need a new boot disk, existing one is 5 years old
    Saturday, February 27, 2010 4:28 PM
  • Vegan:
    OK! I give, let windows install what it wants. Just saying the 10.2 legacy shows a newer driver date. Probably the same 9.3 driver anyway just AMD's way of making us think they care.  You win, I quit! :)
    Saturday, February 27, 2010 7:14 PM
  • Hi folks,

    I've tried also the new 10.2 AMD driver package and it works very well on my Windows 7 64bit - don't be confused why it's a vista driver - the only things is that it's not supporting the windows display driver model (WDDM) 1.1, it's only supporting 1.0 - but as I said it works fine.

    -> http://support.amd.com/us/gpudownload/windows/Legacy/Pages/radeonaiw_vista64.aspx?type=2.4.1&product=2.4.1.3.9&lang=English

    cheer
    Andre
    Saturday, March 13, 2010 4:38 PM
  • Those drivers contain Vista and Windows 7 components, so do not worry.

    Vote if answered or helpful, I am running for Office (joke)! IT/Developer, Windows/Linux/Mainframe RaidMax Smilodon, 680W, Asus M2NBP-VM CSM, AMD X2 4200+, 2GB DDR2-800, HD2400 Pro, more details on my site, need a new boot disk, existing one is 5 years old
    Saturday, March 13, 2010 10:11 PM
  • I have a Benq P52 and I found a working driver for windows seven x64. I downloaded legacy driver 10.2 for motherboard and igp  and I modded it with mobility modder. Then I instaled the new driver and 'voila'. Aero enabled with  a score of 4.2 and 3d applications don't hang any more. I need to test this new driver in detail but I belive the x1600 isn't dead after all.

    here is the driver: http://support.amd.com/us/gpudownload/windows/Legacy/Pages/integrated_vista64.aspx
    Friday, May 14, 2010 12:37 PM
  • Hi there,

    I've just upgraded my OS from Vista Business to W7 Ultimate and haven't had any luck updating the driver. I'm still getting the windows default VGA driver displaying and my rating is still at 1.0. I downloaded the Legacy Driver from the above link then downloaded Mobility Modder and pointed it to the legacy directory. Any idea what could be going wrong here? Any suggestions would be great as my current resolution looks pretty fail! Help! 

     

    Thanks in advance!

    Saturday, August 13, 2011 2:35 AM
  • Portables are best off with the original OS, drivers are often proprietary.

     


    Windows MVP, XP, Vista, 7. Expanding into Windows Server 2008 R2, SQL Server, SharePoint etc.

    My page on Video Card Problems is now my most popular landing page. My Page on SSD is now #2. See my gaming site for game reviews etc.

    Developer | Windows IT | Chess | Economics | Hardcore Games | Vegan Advocate | PC Reviews

    Saturday, August 13, 2011 2:52 AM
  • Hi you all!! This is my story... I spent 2300 € on an Acer Ferrari 5005 4 years ago. I´ve just reinstall Windows 7 x64 and I could not install drivers for its Mobility X1600 grp. card, not even from Windows update (I don´t know why this driver didn't appear any longer on the list). I read this message (your message) and I just can say only one thing... you are GOD for me now, my friend. You saved my life. So, X1600 for a couple of years more. Why can't we download a driver like this from Acer Website? Why do they do this..?!!! Best regards. Mike.
    Saturday, August 20, 2011 11:37 PM