none
Unable to connect to share, Error code 0x80070005

    Question

  • One computer is running Vista Ultimate. The second is running Vista Home Premium. Both have Service Pack 1 installed. Both are running Windows Live OneCare. (Turning off the Firewall doesn't help). I've followed the directions shown in http://technet.microsoft.com/en-us/library/bb727037.aspx. I can see the network shares in Windows Explorer. I can connect to the Public share. When I try to access other shares, I get a Network Error dialog that states "Windows cannot access \\LOFT-HP\Documents. Check the spelling of the name. Otherwise, there might be a problem with your network. To try to identify and resolve network problems, click Diagnose.

     

    In the Details, it says Error code 0x80070005, Access is denied.

     

    On the LOFT-HP machine, I used Advanced Sharing, selected "Share this Folder", and set Permissions to Full Control for Everyone.

     

     

    When I press the Diagnose button on the Network Error dialog, I get these messages:

     

    "Documents" is available but the user account that you are logged on with was denied access. Windows cannot further diagnose the problem because network diagnostics does not know the user name and password that is required to connect to the shared folder.

     

    Make sure you typed the path correctly and you have permission to access the shared folder. If you are trying to access the shared folder with a user name and password that is different from what you used to log on to this computer, ensure that you have entered them correctly. Click for more information about permissions.

     

     

    I have this same problem with other folders that I've shared. I am so frustrated with Windows networking. Any help will be appreciated.

     

    --Jim

    Friday, May 16, 2008 1:30 AM

Answers

  • Hi Jim,

     

    Would you let me know where the folder “Documents” is stored? Is it in the same partition as the folder “Windows” or the known Documents folder under the user profile or other location?

     

    Additionally, please perform the following steps to check the result:

     

    1.    Create an account with the same user name and password on both Windows Vista machines.

    2.    Add this account to Administrators group on both Windows Vista machines.

    3.    Logon with this user account and access the share folder.

     

    Hope it helps.

     

    Monday, May 19, 2008 4:00 AM
    Moderator

All replies

  • Hi Jim,

     

    Would you let me know where the folder “Documents” is stored? Is it in the same partition as the folder “Windows” or the known Documents folder under the user profile or other location?

     

    Additionally, please perform the following steps to check the result:

     

    1.    Create an account with the same user name and password on both Windows Vista machines.

    2.    Add this account to Administrators group on both Windows Vista machines.

    3.    Logon with this user account and access the share folder.

     

    Hope it helps.

     

    Monday, May 19, 2008 4:00 AM
    Moderator
  • I just ran into this and the solution was much easier.  I was trying to share a subfolder of Program Files.  All I did was copy that subfolder to the root and share that instead and all problems went away.  Both machines are running Vista.  Hopefully this adds some insight.

    Wednesday, August 20, 2008 9:37 PM
  •  

    I have followed your steps but still have the same error. I have the same setup as the person who started this thred but i am trying to share a partition. any ideas?

     

    EDIT i think iv cracked it guys

     

    To give you unrestricted access across the network, make Everyone appear in
    the Security Tab. Go to the D drive in Disk Management, right-click it >
    Properties > Security Tab > Edit > Add then type ‘Everyone’ (not the quotes)
    and below it select your preferences, e.g. Read or Full Control. Now Apply,
    OK etc. to finish.

    • Proposed as answer by Ivan Ord Friday, February 27, 2009 5:19 PM
    Saturday, December 06, 2008 11:16 AM
  • I'm not sure if this will help you out, but this is the first forum which hasn't been stupid and rejected me posting on about this network problem.

    My desktop has XP Home, and laptop Vista basic.  I received the 0x80070005 problem lots and lots when I tried to connect to my desktop from the laptop, but I could connect to laptop from desktop.  SOOOO, after googling it intensively, and spending until 4.30am trying to fix it (I've just done it now, so sleep time soon :) ) I found a solution, or a workaround.  I went on the desktop, went into the public folder on the laptop, and right clicked and made a new shortcut TO \\KUDO\C (where KUDO is the computer name, which you can browse and find through going into MNP - MWN - Mshome (or whatever you called it) - Monica's Computer (or your computer name) - then select whichever hard drive to share.  And it actually works for me, I had been trying to fix this problem for a long time, since the past craptop stopped recognising how to get into this network.  Allor, c'est fini!
    • Proposed as answer by Ivan Ord Friday, February 27, 2009 5:20 PM
    Tuesday, December 16, 2008 4:49 AM
  • OK, same thing I came up with a while ago, but... can you see the desktop from the laptop using Windows Explorer, or can you only attach?
    Friday, January 16, 2009 4:26 AM
  • "EDIT i think iv cracked it guys

     

    To give you unrestricted access across the network, make Everyone appear in
    the Security Tab. Go to the D drive in Disk Management, right-click it >
    Properties > Security Tab > Edit > Add then type ‘Everyone’ (not the quotes)
    and below it select your preferences, e.g. Read or Full Control. Now Apply,
    OK etc. to finish."


    This worked great, and was exactly the problem I was having with my partition!  Thanks!
    Saturday, February 07, 2009 10:08 PM
  • Thanks a lo! You are a genius...   this really works

     

    Thanks

    Friday, February 27, 2009 5:18 PM
  • Gentlemen, while adding "Everyone" into the security tab as solved your current problem it creates another.  Anyone, and that is any one at all who gains ingress to your network can now access this share.  As long as there is nothing there that you need to
    A) maintain in a secure manner  

    Or 

    B) mind the whole world eventually having access to

    then your ok.  Please remember that the use of "Everyone" allows literally everyone to get into your partition or file structure.

    Just something to think about. 
    Thursday, March 05, 2009 12:25 AM
  • I have the same problems as all mentioned above.  I have tried all the solutions, but to no avail.  This issue is isolated to my HP Desktop running Vista Premium 64 bit and a HP laptop running Vista Premium 32 bit.  All other computers (manufacturers and operating systems) are able to see and access each other.  I even have a laptop with Vista Premium 64 bit from another manufacturer able to see and access all the other computers.  I am thinking this has something to do with my HP machines.  Does HP mess with the OS configurations in any way? 


    UPDATE .... I modified the directions from above and gained access. 


    On the Vista Premium computer with the file to be shared from Explorer Window ...

    1.  Right-click on the file to be shared
    2.  Select Properties option at the bottom of the pop-out list
    3.  New Window with title, "NameofFolder Properties" - Click on the "Sharing" tab
    4.  Under the Sharing tab -
         - Select Share button - new window pops up
    5.  In new window, type in the blank field "everyone" (without the "")
    6.  Click on Add button or press Enter
    7.  Look below the blank field to see Everyone added with Reader Permission Level.  Click on the word "Reader" to change the Permission Level to "Co-Owner"
    8.  Then click on the button at the bottome of the window titled "Share"
    9.  Let it do its work
    10.  Close the NameofFolder Properties window. 

    VOILA!
    • Proposed as answer by Tassiolc Thursday, May 27, 2010 4:37 PM
    Sunday, March 08, 2009 7:02 PM
  • Great!  Your fix worked, Atrotter!

    Much appreciated!
    Tuesday, June 16, 2009 3:55 AM
  • I am having the same problem. I have tryed the fixes above and still will not allow access. I can access the public but not the others. I have a vista 32 and a vista 64 machine that will not share( other than public). Any help

    Thursday, July 09, 2009 5:50 AM
  • What I finally got to work was to share the C:\ drive on the uncooperative machine.
    Friday, July 17, 2009 3:33 AM
  • This worked like a dream for me as well. It is super frustrating because in advanced sharing I had already set permissions up. windows SHOULD have made it an automatic feature that the root drive would have those permissions as well. Thank you sir. You just made my day.
    Wednesday, August 26, 2009 5:31 AM
  • OMG - how simple it was! I was Very Lazy with my home PC and ran it w/o a passphrase. Once I entered the passphrase all was smooth as silk.

    My MS does look after its errant children.
    Friday, October 09, 2009 9:21 PM
  • DUDE

    U r a genious!

    How did u figure that out? U must be Bill Gates's son!

    Thank you so much!!

    I Love You!

    rofl

    CYA!

    Thursday, May 27, 2010 4:40 PM
  • Thanks for sharing this clear and easy solution, Atrotter! Awesome!!

    I have been trying to hookup 2 HP desktops with Vista Home Premium 32 bit and could not gain access except through the Public folder. I can now easily share the Documents folder on each machine without placing things in the Public folder first.

    I wanted this for 2 years since I bought these Vista computers but could not figure it out (folder sharing was so easy with XP) and did not have the hours to spend on searching for solution. Decided to try searching again today. Found it here.

    Thanks again!!

     

     

    • Proposed as answer by fxexplorer Tuesday, October 19, 2010 8:45 PM
    Tuesday, October 19, 2010 8:44 PM
  • I ran into the same issue, but here is my problem..

    This is my Home Network...

    I have my File Server "FLIGHTSIM_PC" running Vista Ultimate 32 bit shared folders and shared HHDs - then I have

     "RACE_PC1" running Vista Home Premium 64 bit (identical to "RACE_PC2, in hardware and software)

     "RACE_PC2" running Vista Home Premium 64 bit 

     "LAPTOP" running Vista Home Premium 64 bit

     "BASEMENT" running Server 2000 64 bit

     "MINI" running XP 32 bit

     "GEN_3" running XP 32 bit

    I have network Discovery and Sharing enabled on every machine, they see each other and can access all shared folders, however on "FLIGHTSIM_PC" I have two shared HDDs, that I have full access from "RACE_PC2" and "LAPTOP" but I have the Error code: 0x80070005, Access is denied from "RACE_PC1". I have reset all the permissions for the shared HHDs but still no luck. Max connections for the shared HHDs are set at 10

    The each computer has an assigned Static IP Address, each has Password Log On, each Log On account has Administrator rights.

    I'm stumped...

    No, I can not run System Restore (I have no idea when this function was functional if ever), I have no inclination of doing an OS reinstall...

    I'm open to suggestions...

    UPDATE: After some consideration, I am under the impression it might be a OS related issue. I am wondering if I were to upgrade all the computers to say "Windows 7 Professional" or at least "Windows Vista Ultimate" it would resolve the Network Access issues.

    I just think it is odd that within the current OS configerations the HDDs allow 10 connections and yet, somewhere in the PERMISSIONS it is being denied to a few computers.



    • Edited by JABowders Wednesday, March 07, 2012 12:34 PM
    Monday, February 27, 2012 1:54 PM