Need help to enable WLAN Autoconfig.

    General discussion

  • Hi

    In short:

    It seems the "Wireless Autoconfig" service has a dependency on "ndis usermode" which prevents it from starting.  I cannot find such a service to enable or start it.

    Long version:

    I have a HP Probook 4720s Laptop, Window 7 Professional 64-bit.

    I acquired a USB dongle from Vodacom (our local VodaPhone supplier) to provide me 3G GPRS connections to the Internet.

    Their driver installation software failed by rolling back the install at a point when the user interface indicates it is starting services.

    - I googled Vodaphone support that suggested starting msconfig, stopping all non Microsoft services, reboot and re-install.

    I tried that, and got same issue.  

    - Then found post on other forum that indicated the issue is a dependency on the "Wireless Zero" service,  and I understand from yet more googling this is called "Wireless Autoconfig" in Windows 7. I noticed this service is not started on my computer, and if I try to start, it fails, indicating one of its dependencies does not start.

    I went to "Computer Management"->"Services", and I noticed 2 dependencies: "Remote procedure Call (RPC)" (I could verify this is started), and also "NDIS Usermode I/O Protocol". I cannot find a such service to check if it started.

    Even more googling landed me on someone mentioning a device that should exist in device manager, but I also do not see a ndis-like driver in my device manager.

    I also checked that ndisuio.sys exists in my drivers folder ( link below led me to believe it's related to the above), and if I click on it's properties, it indicates there's no previous versions for it installed that I can roll back to.  Although the link contains instructions on replacing that file, I did not try that.

    I also tried the advice below:

    I downloaded and installed the registry key. The post advised to check "Extensible Authentication Protocol" - I Cannot find it. The second one, "CNG Key Isolation", existed and could be started. However this did not make the ndis usermode service appear, and I opted for the upgrade install advice.

    My sysadmin provided me with a Windows 7 64-bit CD, but the install wizard never asks me "which type of install", where I could select  "Upgrade". It simply proceeds to start replacing the entire operating system, saying it will place my current operating system in a "Windows.old" folder. - I got scared and cancelled the install when it suddenly started copying files, as it appeared more like a full re-install, than an upgrade or repair. 

    What do I do now?


    Wednesday, May 16, 2012 11:03 AM

All replies

  • Hi,

    Based on my research, WLAN Autoconfig Service depends on Extensible Authentication Protocol Service. Please double check it again if it exists in Control Panel -> System and Security -> Administrative Tools -> Services.

    If it does not exist, I’m afraid that you have to perform an In-place Upgrade or reinstall your system.

    However, based on your description, I suggest checking the edition of Windows 7 Installation disk first, you can ask your system administrator; if Windows 7 on your computer comes from OEM, please contact the corresponding support.

    Hope this helps.

    Jeremy Wu

    TechNet Community Support

    Thursday, May 17, 2012 9:21 AM