none
Unable to turn on media streaming RRS feed

  • Question

  • Whenever I click on "Turn on media streaming" the button goes grey and the cursor show the system is busy but then nothing happens.  When I was first setting up the Windows 7 RC I tried this and I was able to access a list of devices which included my xbox360 but I have never been able to get to that menu again.  I have tried going through WMP12 and turning streaming on but that does not work either. 

    The only other odd thing that happens is about 50% of the time that I try to start WMP12 it will not load at all and I have to restart my system and try to open it again.
    Monday, July 27, 2009 6:24 AM

Answers

  • Ok I did up until a few seconds ago have the exact same problem as everyone else.

    Here is what I did to successfully fix the problem.

     

    Click Start and then run.

    In the run box type or past "%userprofile%\Local Settings\Application Data\Microsoft\Media Player " without the quotation marks.

    Now it is really this simple, delete all files that end in .wmdb (note  that you may have to untick "hide known file extensions for known file types" in order to see the file extensions).

    All you are doing is deleting the information about where media player can find the files you play.

     

    Now simply open up media play and manage your library again.

    Thats it your all done and can now turn streaming on.

    Sunday, April 25, 2010 3:13 AM
  • Hi,

     

    Please check if you can turn it on in a Clean Boot environment:

     

    Clean boot

    =================

    1)     Click the Start Button type "msconfig" (without quotation marks) in the Search box, and then press Enter.

    Note: If prompted, please click Continue on the User Account Control (UAC) window.

    2)   Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).

    3)   Click the "Startup" tab, click "Disable All" and click "OK".

     

    Then, restart the computer. When the "System Configuration Utility" window appears, please check the "Don't show this message or launch the System Configuration Utility when Windows starts" box and click OK.

     

    NOTE: we can go back to normal boot by running msconfig again and checking on Normal Startup in the General tab.

     

    In the Clean Boot Environment, the third party services and applications are disabled, please check if you can turn on media streaming at this time.

     

    If the problem does not occur, it indicates that the problem is related to one application or service we have disabled. You may use the MSCONFIG tool again to re-enable the disabled item one by one to find out the culprit.

     

    Thanks.


    Nicholas Li - MSFT
    Wednesday, July 29, 2009 1:37 AM
    Moderator

All replies

  • Hi,

     

    Thank you for posting.

     

    To turn on streaming, you may need to set up the proper equipment first. At this time, I would like to share the following with you:

     

    Getting started with media streaming

     

    Media Streaming with Windows 7

     

    Hope this helps. Thanks.


    Nicholas Li - MSFT
    Tuesday, July 28, 2009 10:16 AM
    Moderator
  • Thank you for your response, but Unfortunately those articles did not help in solving my problem.  My issue comes after step number 4, when I click OK nothing happens and I am left sitting at the same menu.  No matter how many times I click OK, I am unable to access the menu with the devices.

    Turn on streaming

    To turn on media streaming on your home network in Windows Media Player, do the following:

    1. Click the Start button Picture of the Start button , click All Programs , and then click Windows Media Player .

      If the Player is currently open and you’re in Now Playing mode, click the Switch to Library button Picture of the Switch to Library button in the upper-right corner of the Player.

    2. Click Stream , and then click Turn on home media streaming .

      Turn on home media streaming won't be available on the Stream menu if streaming is already turned on.

    3. On the Media streaming options page, click Turn on media streaming . Administrator permission required  If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

    4. Click OK .


    Tuesday, July 28, 2009 10:33 PM
  • Hi,

     

    Please check if you can turn it on in a Clean Boot environment:

     

    Clean boot

    =================

    1)     Click the Start Button type "msconfig" (without quotation marks) in the Search box, and then press Enter.

    Note: If prompted, please click Continue on the User Account Control (UAC) window.

    2)   Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).

    3)   Click the "Startup" tab, click "Disable All" and click "OK".

     

    Then, restart the computer. When the "System Configuration Utility" window appears, please check the "Don't show this message or launch the System Configuration Utility when Windows starts" box and click OK.

     

    NOTE: we can go back to normal boot by running msconfig again and checking on Normal Startup in the General tab.

     

    In the Clean Boot Environment, the third party services and applications are disabled, please check if you can turn on media streaming at this time.

     

    If the problem does not occur, it indicates that the problem is related to one application or service we have disabled. You may use the MSCONFIG tool again to re-enable the disabled item one by one to find out the culprit.

     

    Thanks.


    Nicholas Li - MSFT
    Wednesday, July 29, 2009 1:37 AM
    Moderator
  • I have exactly the same problem. I've tried the steps above but they didn't work for me. Any suggestions?
    Thursday, December 3, 2009 2:01 PM
  • I am also experiencing the exact same problem.  I booted into a clean environment as was suggested, and I still have the problem.  I click the button to turn on media sharing, and nothing happens.  The button still says the same thing. 
    • Proposed as answer by JWMutant Sunday, April 25, 2010 3:05 AM
    Wednesday, April 21, 2010 4:56 AM
  • Ok I did up until a few seconds ago have the exact same problem as everyone else.

    Here is what I did to successfully fix the problem.

     

    Click Start and then run.

    In the run box type or past "%userprofile%\Local Settings\Application Data\Microsoft\Media Player " without the quotation marks.

    Now it is really this simple, delete all files that end in .wmdb (note  that you may have to untick "hide known file extensions for known file types" in order to see the file extensions).

    All you are doing is deleting the information about where media player can find the files you play.

     

    Now simply open up media play and manage your library again.

    Thats it your all done and can now turn streaming on.

    Sunday, April 25, 2010 3:13 AM
  • Worked like a charm thank you.  :D  I have a few USB devices and things, guess it got all muddled.
    Tuesday, May 4, 2010 11:30 PM
  • Update for Windows 7:

    This worked for me as well, but the path to those WMDB files is:

     

    C:\Users\%userprofile%\AppData\Local\Microsoft\Media Player

    • Proposed as answer by jars99 Wednesday, June 16, 2010 6:34 PM
    Monday, June 7, 2010 3:20 PM
  • The files are in the location specified by Dichotomy10 in Windows 7

    For me, deleting the .wmdb files didn't work, so I renamed the Media Player folder to something else: "Media Player Old".  Then, media sharing would turn on, and then a new Media Player folder was created automatically.

    Wednesday, June 16, 2010 6:40 PM
  • Renaming the folder also worked for me after thing everything else (clean boot, deleting wmdb files) didnt.
    Tuesday, July 6, 2010 10:53 PM
  • I am having the same issue.  I have done everything on this page.  Clean boot... delete files... rename folder... I've even uninstaled and reinstalled WMP12 and WMC.  I get the same old grey flash and it's back.  Any other suggestions
    Friday, July 9, 2010 12:16 AM
  • I tried deleting the folder, and that didn't work... but what worked for me was going into Media Player, click the Stream dropdown menu, then selecting "Automatically allow devices to play my media...", which pops up a dialog box for confirmation, then I clicked "Automatically allow all computers and media devices.", then it chugged a bit altering various folders.  Then I was able to select "More streaming options..." and then "Turn on media streaming..." finally worked.
    Wednesday, October 20, 2010 4:57 AM
  • I have a laptop Steve-PC and a netbook Steve-NTBK, both running windows 7 home premium. I have created a home group on the laptop and am able to find and connect to the home group from Steve-NTBK to Steve PC,  but not the other way around.

    Even though the NTBK is connected to the homegroup created on Steve-PC, the PC shows 'no other homegroup computers are currently available'. Network discovery is turned on on the PC.

    When opening windows explorer on either machine, both machines appear under Network and I can stream from the netbook with its unfortunately smaller memory. On the laptop, when I select Steve-NTBK, I encounter a dialog box that says unable to connect, check the spelling, etc. The network diagnostic program is not helpful.

    On the laptop Steve-PC, I am unable to turn on media streaming, even in a clean boot environment as described above.

    Sunday, October 24, 2010 12:19 AM
  • I just noticed when I expand the Network Error Dialog box,  I see  'error code 080070035, Network path not found.
    Sunday, October 24, 2010 12:35 AM
  • folloed these instructions and did nothing what ever any different. My "turn on streaming" button does not grey out but it doesn't start or give me any info at all.
    Friday, November 5, 2010 6:01 PM
  • I did this and it make no differnece at all. my button does not grey out but nothing else happens either.
    Friday, November 5, 2010 6:03 PM
  • didn't work for me and neither did the link
    Friday, November 5, 2010 9:04 PM
  • I used this directory and found the same 4 or 5 files that had reappeared since I had tried windows media player . I erased those and it worked to start media streaming. The directories are actually the same files.
    Friday, November 5, 2010 9:13 PM
  • ** Not Tested **

    I just read it's because your libraries are broken.

    Remove everything and create a new Library, with files that actually exists...

    Hope the best!

    Sunday, November 21, 2010 1:08 PM
  • Forget Windows Media Player and its problems.  I downloaded Tversity (http://tversity.com/) and all works well between my PC and AV receiver.
    Sunday, November 21, 2010 5:13 PM
  • I deleted the files, renamed my folder and rebooted my system and it's all working now!  Thanks a lot everyone!

     

    Now tomorrow I have to go to a friends house and help them with their TV.

    • Proposed as answer by brunoland Friday, January 12, 2018 1:11 PM
    Saturday, December 4, 2010 2:43 AM
  • Hi to all,

    I just found this list of ideas and tried them all, but on my Win7 premium home, the button is still fading in/out when pressed, but media streaming is still not to be activated

    More ideas? Any Registry keys to manipulate?

    Despirate Media Player :-(

    Tuesday, December 21, 2010 7:32 PM
  • Brilliant, solved my streaming problem first time!
    Monday, February 7, 2011 11:41 AM
  • I had this exact problem as well but I found out how to fix it on my pc so here's my solution.  Hope it works for everyone else.

    My initial problem was that my xbox couldn't stream content from my Win7 pc.  Windows media center streaming worked however so I knew it was something wrong with Windows Media Player.  After lots of searching I found out that if I created a new User the streaming worked fine.  I used process of elimination to determine there is a set of files that need to be deleted in order to fix the problem.  Here's what to do:

     

    1) open services.msc and Disable "Windows Media Player Network Sharing Service"

    2) Go to the following hidden folder:

      C:\Users\<user>\AppData\Local\Microsoft\Media Player     (where <user> is the the account you're logged in as)

    3) Delete all the contents of this folder

    4) Open Windows Media Player 12 and head to Stream -> Turn on Media Streaming

    It should work now.

    So in short my problem had something to do with some application files that existed within Media Player itself.  Hope this fix works for others too.

     

    Tuesday, February 15, 2011 7:25 AM
  • what files exactly?
     
    On Tue, 15 Feb 2011 07:25:09 +0000, don_fraz wrote:
     
    >So in short my problem had something to do with some application files that existed within Media Player itself.
     

    Barb Bowman

    http://www.digitalmediaphile.com

    Tuesday, February 15, 2011 11:22 AM
  • I was unable to connect to my PS3 The problem was my firewall. I just restored my firewall to default and instantly i was connected. I checked my network sharing and it was already set where I wanted it to be. I didn't even have to turn on my media streaming. It was already done. I tried all that was posted above for the media player, none of it worked for me. IT WAS MY FIREWALL.
    Saturday, February 26, 2011 8:50 AM
  • Today I diagnosed and fixed this problem.  A few years ago I "optimised" my windows setup by turning off a load of services that I didn't need.  For media streaming, some of those services need to be switched back on.  The ones I had to switch on are Computer Browser, Workstation and SSDP discovery.   Once I did that, the Sharing button in WMP worked fine and I can now see my library through my Blue Ray player.

    To diagnose this as your problem, look at the Event Viewer (Control Panel->Administrative Tools->Event Viewer), particularly in the Windows Logs -> System folder, for error messages.

     

    Wednesday, March 9, 2011 2:23 PM
  • What i did was go on Administration tools, Services and Enable Windows Media Player Network Sharing Service and put it on Automatic :) 
    Monday, March 28, 2011 5:09 PM
  • Thanks for the tip! This worked like a charm for me. Deleting the WMV library database(s) allowed the 'turn streaming on' function to start working instantly! WMP began filling my library from files stored on my Windows Home Server and served them up to all my uPnP devices! Thanks again for the very simple fix!
    Friday, September 30, 2011 3:14 AM
  • Cheers vknightbd after trying everything out your advice worked and media streaming is on once again

     


    • Edited by dancool27 Monday, October 3, 2011 12:50 AM
    Monday, October 3, 2011 12:49 AM
  • This is ONLY thing that worked and simplest as well...THANKS!
    Wednesday, October 5, 2011 12:15 PM
  • I have tried all of the options proposed on this thread, before and after this entry.  None of them work.

    I cannot get media streaming to turn on.  The fields are grayed out.  I tried to delte the media files, it fif not work.  I looked in Administration - Services, and did not find the Window Media Player services anywhere.

    I can get media  to play from another Wi Fi connected device - an Android phone.

    Very frustrated - many hours spent trying to solve this

    Saturday, November 19, 2011 8:58 AM
  • what version of windows do you have?
    have you tried setting up a NEW user with administrative privileges and logging
    off current user and on to the new user and setting up your Media Library from
    the new user?
     
    please LIST what you have tried already.
     
    On Sat, 19 Nov 2011 08:58:09 +0000, Elaine and Mark wrote:
     
    >
    >
    >I have tried all of the options proposed on this thread, before and after this entry.  None of them work.
    >
    >I cannot get media streaming to turn on.  The fields are grayed out.  I tried to delte the media files, it fif not work.  I looked in Administration - Services, and did not find the Window Media Player services anywhere.
    >
    >I can get media  to play from another Wi Fi connected device - an Android phone.
    >
    >Very frustrated - many hours spent trying to solve this
     

    Barb Bowman

    http://www.digitalmediaphile.com

    Saturday, November 19, 2011 11:12 AM
  • You may try, from an elevated prompt: (change "D:\" for the drive letter where your media files resides)

    icacls D:\ /grant "NT Service\WMPNetworkSvc":(X)
    net stop WMPNetworkSvc
    net start WMPNetworkSvc

    Saturday, December 17, 2011 10:59 PM
  • I was able to correct this by doing the following:

    - click on start

    - in the "search program and files" box, type "policy" (without quotations)

    - click on "edit group policy"

    - go to Administrative Templates under COMPUTER Configuration

    - go to Windows Components

    - go to Windows Media Player

    - Disable "Prevent Media Sharing"

     

    My pc was provided by my job so this was probably turned in the base image.  It may not be everyone else's issue but definitely worth checking.

    Tuesday, December 27, 2011 4:02 PM
  • Hi,

     

    Thank you for posting.

     

    To turn on streaming, you may need to set up the proper equipment first. At this time, I would like to share the following with you:

     

    Getting started with media streaming

     

    Media Streaming with Windows 7

     

    Hope this helps. Thanks.


    Nicholas Li - MSFT

     

     

    Yeah Nick, THANKS A BUNCH for ignoring the actual problem.  Next time, instead of insulting our intelligence, just stay out of the conversation if you have nothing useful to offer. 

    The problem, which you seem to want to ignore, is that "Turn on media streaming" doesn't work for some of us.  The OK button is grey.  You respond with a bunch of pointless nonsense intended to waste our time.

    Friday, January 13, 2012 6:41 AM
  • I was able to correct this by doing the following:

    - click on start

    - in the "search program and files" box, type "policy" (without quotations)

    - click on "edit group policy"

    - go to Administrative Templates under COMPUTER Configuration

    - go to Windows Components

    - go to Windows Media Player

    - Disable "Prevent Media Sharing"

     

    My pc was provided by my job so this was probably turned in the base image.  It may not be everyone else's issue but definitely worth checking.


    ...except that typing "policy" doesn't return anything like you described on Windows 7 Pro.
    Friday, January 13, 2012 6:58 AM
  • Worked fine from the first try.

    Thanks

    Saturday, March 24, 2012 11:00 PM
  • Relocated user profile to D: drive. Probably caused my streaming issue. Elsewhere (http://blogger.ziesemer.com/2011/10/fixing-upnp-dlna-sharing-drive-windows.html#Solution) suggested security addition for WPMNetworkSvc rights at D: drive didn't solve, but rebuilding (rename original to ..... old and start MP {Jars99 June 16, 2010 6:40 PM}) the Media Player folder did. TYVM.

    • Edited by LexNL Wednesday, May 16, 2012 6:19 PM
    Wednesday, May 16, 2012 6:10 PM
  • i've tried all above method but none was successfull. moreover my wmp12 does not have stream button like it use to. im using win7 64bit ultimate.

    it should look like this right ?

    Allowing devices to share media from Media Player

    Saturday, June 9, 2012 12:30 PM
  • fendynpi: when was the last time the Stream button was there? If you use System Restore to go back to that point, does that help?

    Tim De Baets
    http://www.bm-productions.tk

    Wednesday, June 13, 2012 1:50 PM
  • This Solved my problem after everything on this page didn't work. I don't know that after doing something above allowed this to work or what. All I know is that I tried this and I was able to turn it on.

    1) Run "services.msc"

    2) Right click on "Windows Media Player Network Sharing Services"

    3) Click Properties. 

    4) Change "Startup Type" under the "General" tab to Automatic.

    5) Go back to "Turn on media streaming" and turn it on. 

    It should be able to be turned on.

    • Proposed as answer by Crissue Friday, June 5, 2015 11:41 PM
    Wednesday, July 25, 2012 7:12 PM
  • I finally got it fixed the following way:

    From start menu, open "view local services"

    Make sure that the following services are set to "automatic" (perhaps start them manually to be sure)

    *SSDP Discovery

    *UPNP Device Host

    *Windows Media Player Network Sharing Service

    Once those were enabled, I went to the Network and Sharing Centre, I created a homegroup and enabled streaming and filesharing under the "choose homegroup and sharing options" option

    this also fixed the problem that others were having, when the prompt  "Turn on media streaming"  appears and the OK button goes (stays) grey.

    Hope it will help someone in the future..... :)

    Wednesday, November 7, 2012 11:42 PM
  • Hi,

    I have this problem and I saw don_fraz's answer.. I followed it and when I clicked turn on media streaming, it said it was disabled, so this is what I did, I go to services.msc, click Windows Media Player Network Sharing Device and then right click, properties. Change the start up type into Automatic, it should be Automatic, not Automatic (Delayed)
    • Proposed as answer by Alpha Renegade Thursday, August 22, 2013 10:33 AM
    Thursday, August 22, 2013 10:33 AM
  • The firewall on your local network might be turned on. Try turning it off.
    Saturday, August 31, 2013 7:06 AM
  • I had the same problem. One of my security programs had disabled Windows Search in Services. I restored its Startup Type to Manual, and then started the service... manually.

    After that I was able to turn on Media streaming...

    • Proposed as answer by Robaye Monday, May 19, 2014 12:15 AM
    Tuesday, October 8, 2013 4:44 PM
  • This handy file fixed it for me, my firewall was broken from some malware, now everything is working again (and you can trust majorgeeks) http://www.majorgeeks.com/mg/getmirror/tweaking_com_repair_windows_firewall,2.html
    Saturday, November 9, 2013 3:09 PM
  • Ok I did up until a few seconds ago have the exact same problem as everyone else.

    Here is what I did to successfully fix the problem.

     

    Click Start and then run.

    In the run box type or past "%userprofile%\Local Settings\Application Data\Microsoft\Media Player " without the quotation marks.

    Now it is really this simple, delete all files that end in .wmdb (note  that you may have to untick "hide known file extensions for known file types" in order to see the file extensions).

    All you are doing is deleting the information about where media player can find the files you play.

     

    Now simply open up media play and manage your library again.

    Thats it your all done and can now turn streaming on.

    good one thanks it works great
    Saturday, March 8, 2014 2:45 PM
  • Although it's going back 2 years I had this problem with two of my computers running Windows 7. My Panasonic television couldn't connect to my computer.  This provided a complete cure.  As in many cases the solution is the simplest it's knowing what to do and where to look.

    Regards,

    David.

      
    Monday, May 12, 2014 9:08 AM
  • I have tried some of the various solution suggested below - but none of them results in the ability to go past the <Turn on media streaming> button - it just shows the "click"event and continues to just sit there.

    Here's the crazy thing: very often I am playing music stored on my Win 7 PC via my Ethernet network to my Amplifier in another room. I can start Music playing by Selecting Network on my Amp - then Media Player - MyMediaPC - Music (from the list of Music/Pictures/Playlists that appears) - then click on an album - click on a song that's displayed - and away we go listening to my PC stored music on my remote Ethernet connected Amp. I can do this from EITHER the Amp remote control OR from the iPhone DENON App.

    BUT this is NOT always possible. For example right now I went to choose another track from my amp remote and it did not respond. Neither did the Denon iPhone App. So I started the button sequence above again, but when I came to MyMediaPC list I could get no response at all from the Music item. And the other list items when clicked on now says "--empty".

    WHAT HAS NEVER WORKED from my PC is: Explorer > Selecting a track > Right click > Play to > myRemoteampAll that happens is a Play To mini-window opens, "wait - contacting network device" then after a second it shows myRemoteamp at the top, but in the list window "No media items in your list. To add, drag and drop here or "Play to" this device". So tried Drag and Drop into this list window. I get the little curvy arrow that indicates a shortcut is about to be dropped her, but nothing else happens.

    NEITHER HAS THE FOLLOWING WORKED EVER (yes I tried many of the 'successful' suggestions from this forum, not no go). Start - type Media Stream - click on Media Streaming options - click on <turn on media streaming> button, but as I said nothing happens.

    NEITHER HAS THE FOLLOWING WORKED EITHER. Start WMP - play a track (plays OK on the PC) - OR - select a track and right click - play to myRemoteamp - and the Media Streaming Options window open with the <turn on media streaming> button that does nothing when click.

    THEN SUDDENLY THIS WORKS: tried drag and drop again into the Play To window. This time a little + sign appeared and a track appeared in the list. Then a message "contacting media server". Then the track starts playing on the remote Amp!!!?? I am flummoxed!! 

    So leave this window running, but paused the track at my PC end. At the Remote Amp, retried by Network - then Media Player - MyMediaPC Music but no response.

    HELP!!

    thanks in advance

    Chris

    Tuesday, May 27, 2014 7:35 AM
  • Yes finally thank you so much!
    Thursday, July 10, 2014 10:58 PM
  • I must say thanks a million cause ive been getting the same issues and your solution worked perfectly. THANK UUU
    Friday, May 1, 2015 12:27 AM
  • This one is the only one that worked for me.
    Friday, June 5, 2015 11:41 PM
  • Thanks.   This worked for me!
    Wednesday, July 29, 2015 1:42 PM
  • OK, I had the exact same problem & I tried most of the answers listed below but didn't get anywhere. I gave up trying after a while & did some checking myself.

    So the first Logical thing I did  was to open "WINDOWS SERVICES" & scrolled down the list to find "Windows Media player Network Sharing Service"  & right clicked on it which brought up properties.

    Then I clicked on the dependencies tab at the top.

    Under dependencies you will see a list of "OTHER"services that also need to be enabled for Windows Media player Network Sharing Service to run.

    In my case "Windows Search" was disabled.

    So, I went back into the Services list and scrolled down the list a little & found the "Windows Search" service I then enabled it & started the service.

    Soon as I enabled the "Windows Search" service, I was able to start Windows Media player Network Sharing Service successfully.

    Problem solved for me, I hope it helps.

    Sunday, July 23, 2017 9:01 PM
  • Thank you for offering this solution.Worked for me when I went into services and turned Windows Search back on.
    Tuesday, September 12, 2017 1:03 AM