locked
Windows 7 x64 Quit Assigning Drive Letters Automatically RRS feed

  • Question

  • I have the exact same issue as this guy:

    http://www.sevenforums.com/hardware-devices/98798-windows-7-x64-quit-assigning-drive-letters-automatically.html

    So I'll just copy and paste his post:

    Alright, so my Windows 7 recently quit assigning drive letters automatically. I frequently plug in new hard drives to the system using various USB to IDE or SATA adapters and now when I plug in a new hard drive with any of these USB adapters, it does not get a drive letter assigned to the volumes on the drive. If I go to Disk Management, the drives show up, and so do their partitions, and I can manually assign a drive letter to it, but this gets rather tedious. Any idea why it quit doing it automatically and how to get it to automatically assign drive letters once again?? I figured maybe it ran out of letters, so I went in the registry to HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices and deleted all the remembered drive letter assignments in there, but that didn't help any. Any clues???

     

    Wednesday, September 1, 2010 6:15 PM

Answers

  • Hi,

     

    Thanks for posting in Microsoft TechNet forums.

     

    You may need to reinstall the USB controller and Storage Controller on your computer.

     

    To reinstall USB controller

    ================

     

    First, please disconnect all USB devices and then perform the following steps:

     

    1) Click "Start" button, type “devmgmt.msc” (without quotation marks) in the “Search” bar and press "Enter". Click “Continue” if necessary.

    2)  In Device Manager, double click to expand "Universal Serial Bus controllers", right click on the Host Controller, click "Uninstall" and click "OK".

    3)  Repeat the step 2 to uninstall all items under "Universal Serial Bus controllers".

     

    Then, restart your computer and Windows 7 will reinstall all USB controllers automatically.

     

    To uninstall the storage drivers and reinstall the latest version. Please download  the storage driver from the following link:

     

    Intel Matrix Storage Manager.

     

    Please note: we provide the third party link to download relevant driver for technical use only. There may be some changes without notice, Microsoft doesn’t guarantee any accuracy on contacting information.

     

    For your reference:

     

    Windows Server 2008 not assigning drive letter automatically

     

    disk management

     

    Best Regards

    Dale Qiao

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Dale Qiao Monday, September 6, 2010 1:12 AM
    Thursday, September 2, 2010 3:31 AM

All replies

  • have you got any drive emulation tools running such as daemon tools or power ISO running on your system?

    if you dod can you uninstall them, reboot your computer and test again.

     

    Thursday, September 2, 2010 2:03 AM
  • No drive emulation... haven't used Daemon tools since moving all my gaming needs to Steam a couple years ago.
    Thursday, September 2, 2010 2:35 AM
  • Hi,

     

    Thanks for posting in Microsoft TechNet forums.

     

    You may need to reinstall the USB controller and Storage Controller on your computer.

     

    To reinstall USB controller

    ================

     

    First, please disconnect all USB devices and then perform the following steps:

     

    1) Click "Start" button, type “devmgmt.msc” (without quotation marks) in the “Search” bar and press "Enter". Click “Continue” if necessary.

    2)  In Device Manager, double click to expand "Universal Serial Bus controllers", right click on the Host Controller, click "Uninstall" and click "OK".

    3)  Repeat the step 2 to uninstall all items under "Universal Serial Bus controllers".

     

    Then, restart your computer and Windows 7 will reinstall all USB controllers automatically.

     

    To uninstall the storage drivers and reinstall the latest version. Please download  the storage driver from the following link:

     

    Intel Matrix Storage Manager.

     

    Please note: we provide the third party link to download relevant driver for technical use only. There may be some changes without notice, Microsoft doesn’t guarantee any accuracy on contacting information.

     

    For your reference:

     

    Windows Server 2008 not assigning drive letter automatically

     

    disk management

     

    Best Regards

    Dale Qiao

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Dale Qiao Monday, September 6, 2010 1:12 AM
    Thursday, September 2, 2010 3:31 AM
  •  Hi,

    As this thread has been quiet for a while, we assume that the issue has been resolved. At this time, we will mark it as ‘Answered’ as the previous steps should be helpful for many similar scenarios. If the issue still persists, please feel free to  reply this post directly so we will be notified to follow it up. You can also choose to unmark the answer as you wish.
    BTW,  we’d love to hear your feedback about the solution. By sharing your experience you can help other community members facing similar problems. Thanks for your understanding and efforts.

    Best Regards

    Dale Qiao
    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, September 6, 2010 1:12 AM
  • Issue still exists, and not limited to USB. Also applies to eSATA.
    Thursday, October 21, 2010 11:22 PM
  • Don't you just hate those semi-automated MS replies which don't address your question properly?

    I had this issue too.  The following fixed it for me:

    Open up a command prompt.

    Enter the following:

    diskpart <enter> (takes a few seconds to load)

    automount enable <enter>

    Hope it works for you too.  Good luck.


    • Proposed as answer by Kadaki Friday, November 19, 2010 10:36 PM
    Thursday, November 18, 2010 9:46 PM
  • Hello,

     

    Yes Diskpart woudl work

    also should be able to do this using mountvol.exe.

    Mountvol.exe

    Creates, deletes, or lists a volume mount point.    

    /N          Disables automatic mounting of new volumes.                    

     /E          Re-enables automatic mounting of new volumes.               

     

    Registry: change

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MountMgr\NoAutoMount

    Value of 1 is disabled

    Value of 0 is enabled

    Noautomount value not present defaults to enabled.

     

                                                            

                                                 
                   
    Thanks, Darrell Gorter This posting is provided "AS IS" with no warranties, and confers no rights. VAMT - Volume Activation Management Tool - Download link http://www.microsoft.com/downloads/details.aspx?FamilyID=ec7156d2-2864-49ee-bfcb-777b898ad582&displaylang=en
    Saturday, November 20, 2010 2:04 AM
  • I have the EXACT SAME presenting problem as Nathan (and the guy he cut'n'pasted), i.e, "Windows 7 x64 Quit Assigning Drive Letters Automatically"

    When I run DISKPART as JC747 suggested, it tells me "Access is denied", although I am the Administrator of this PC.

    Likewise, when I run mountvol /e as Darrel Gorter suggested, I get "Access is denied" (I'm still the Administrator)

    When I attempt to follow Dale Qiao's advice and uninstall the USB drivers, on each attempt I'm told "Cannot uninstall this device because its descendants refused the request. This can happen if the device's decendants are required to boot up the computer."

    Also, my registry does not have a HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MountMgr\NoAutoMount value.

    So... any more ideas?... anybody?...  I'm SO TIRED of having to go assign a drive letter with Drive Manager every time I plug in another new USB drive !!!
    Thursday, February 3, 2011 11:29 PM

  •   it tells me "Access is denied", although I am the Administrator of this PC.

    You have standard user rights until you request them with "Run as administrator"

    http://windows.microsoft.com/en-US/windows7/How-do-I-run-an-application-once-with-a-full-administrator-access-token

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Friday, February 4, 2011 2:39 PM
  • Andre -

    THANX for the help on "Run as administrator"! 

    But how do I apply this to DISKPART and MOUNTVOL, which are run from the command prompt?... there's no way to right-click them to get to the Program Properties in order to set Run as Administrator...  Or am I overlooking something?

    OK - I went to the Windows/System32 folder and found DISPART and MOUNTVOL. Right-clicking DID get me to the permissions settings, but selecting my user name (Administrator...) and choosing Edit brings me to a Permissions for diskpart.exe window where all of my Allow check-boxes are grayed out. Likewise with Mountvol.exe. So... what now?
    Sunday, February 6, 2011 10:00 PM
  • you can put the commands into a cmd file and run this CMD as administrator:

    http://www.windows7news.com/2010/01/14/how-to-automatically-attach-vhd-images-in-windows-7/


    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Monday, February 7, 2011 2:02 PM
  • Thanks! Worked like a champ!!!
    Monday, April 25, 2011 6:27 PM
  • You rock.  This solved my problems perfectly and in about 2 seconds.  Their response reminds me of the "clean boot" days.  Remember that?  When the first answer out of every tech support rep's mouth was "You need to create a clean boot floppy."  I guess I'm showing my age, though.

    Thanks much!

    Monday, May 7, 2012 9:52 PM
  • Hi "JC747",

    Want to really thank you for your reply re "automount enable" ... worked like a charm in about 30 seconds.

    You're incredible, friend!

    Warm rgds,

    Dorian

    Sunday, March 17, 2013 11:28 AM
  • This worked right away for me. Thanks a lot!
    Saturday, December 21, 2013 12:27 PM
  • I am having the same problem.

    1-I have removed all USB drives at the "Universal Serial Bus Controllers",system re-installs it automatically when I started Windows.  But it did not worked.

    2- I tried running "Diskpart" and "Automount Enable" which it did not work.

    Signed letter becomes not accessible after starting windows.  So every time  I need to resign, I need to go through "Computer Management" menu.

    I am running Windows 7 64 Bit with SP:1, on HP ZBOOK 15 model.  So is there anyone who is able to solve the problem?

    Thanks

    Thursday, August 28, 2014 9:39 AM
  • Just say "turn on automatic volume mounting; type "mountvol /e" at the command prompt. 

    Good answer...thanks...uh...4 years late.  BUT, I know I created this problem myself...just couldn't remember where I turned OFF the automatic volume mounting...probably in the "services" menu?

    Wednesday, September 10, 2014 4:41 PM