none
Issue when trying to apply hotfix update KB3134725 for FIMService RRS feed

  • General discussion

  • Hi everyone,

    I have a problem when trying to apply the new hotfix, build 4.3.2195 (KB3134725) to the FIMService. I receive the following error event ID 1024:

    "Product: Microsoft Identity Manager Service and Portal - Update 'MIM Service & Portal Hotfix KB 3134725' could not be installed. Error code 1603. Windows Installer can create logs to help troubleshoot issues with installing software packages"

    I have created an install log file to check what the error might be and to try to correct it. I found this lines that might indicate the error: 

    MSI (c) (FC:08) [12:38:53:847]: Turning off patch optimization. {646356E3-7FF6-4923-85F6-15F413E95F5B} patch is not authored to support it.
    MSI (c) (FC:08) [12:38:53:847]: Looking for patch transform: EVAL.1
    DEBUG: Error 2746:  Transform EVAL.1 invalid for package C:\Windows\Installer\16b1950.msi. Expected product {AB9663A3-2B61-44C7-8A64-358EC72934E6}, found product {0782FB14-023A-430F-B0D5-4AE1D1CCFCAA}.
    1: 2746 2: EVAL.1 3: C:\Windows\Installer\16b1950.msi 4: {AB9663A3-2B61-44C7-8A64-358EC72934E6} 5: {0782FB14-023A-430F-B0D5-4AE1D1CCFCAA} 
    MSI (c) (FC:08) [12:38:53:847]: Skipping validation for patch transform #EVAL.1.  Will not apply because previous transform was invalid

    But I haven't found any suggestions as for how one could solve this. Has anyone experienced something similar? What could I do to solve it? The FIMSyncService.msp patch was installed without any error. So my FIMSyncService is now updated but my Fim portal is not. DIs it possible for the error to be related to SQL and access to the FIMService database?

    I would appreciate any help I can get!

    here is another part of the log that might imply the error:

    MSI (c) (FC:08) [12:38:54:832]: Transforming table Binary.
    
    MSI (c) (FC:08) [12:38:54:832]: Note: 1: 2262 2: Binary 3: -2147287038 
    MSI (c) (FC:74) [12:38:54:832]: Invoking remote custom action. DLL: C:\Users\ADMINI~1.DEM\AppData\Local\Temp\2\MSICFB.tmp, Entrypoint: DetectServiceAccount
    CustomAction DetectServiceAccount returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
    Action ended 12:38:54: DetectServiceAccount. Return value 3.
    MSI (c) (FC:08) [12:38:54:863]: Doing action: FatalError
    Action 12:38:54: FatalError. 
    Action start 12:38:54: FatalError.

    EDIT: Problem solved thanks to the following suggestion:

    "When that happened to me, it turned out that my login info that runs the services wasn't in the correct format.  The default install had it like:  servicename@domain.net, but it needed to be domain\servicename.

    It didn't make a lot of sense to me, but after changing it, it worked."

    made at this forum discussion:

    https://social.technet.microsoft.com/Forums/en-US/f4c94c42-901d-4fd2-a3e0-324d758d8619/error-installing-kb-978864-error-1603?forum=ilm2#3210f7bf-f389-46be-b84a-8b373e3d6704

    • Edited by SteffieD Thursday, September 15, 2016 9:19 AM
    Wednesday, September 14, 2016 3:01 PM