none
Install Hyper-V on Windows 8 RTM problem RRS feed

  • Question

  • I've tried to install Hyper-v on my Windows 8 RTM Pro. I got no message about anything going wrong. Couldn't find anything in the event log. Just everytime i tick the box next to Hyper-v, i get it removed after checking it once again. Found out that i should change Format country in Region settings to English. Then I was able to install Hyper-V and got it still working after changing Format to my local county.

    It must be fixed!


    • Edited by TRIUMF Saturday, September 8, 2012 3:33 PM
    Friday, September 7, 2012 1:24 PM

Answers

  • I've had the same issue using the German locale. When I changed to US (english) I was able to install. Switching back to German I was still able to run Hyper-V so it seems to only affect the installation/installation dialog.
    • Marked as answer by TRIUMF Wednesday, January 30, 2013 10:23 PM
    Tuesday, September 11, 2012 5:27 PM

All replies

  • Can you please post the screenshot of the dialogbox.

    Regards,
    prathaprabhu

    Friday, September 7, 2012 6:24 PM
  • Well, actually I have nothing to show. You can reproduce the problem setting regional settings to Lithuania for example and then try to add hyperv feature. I didn't check if it's just on fresh win8 or it may be reproduced after reinstalling hyperv feature(which was installed with English regional settings).
    Friday, September 7, 2012 7:23 PM
  • before you install the client hyper-v, open a command box and run "systeminfo". at the end of the screen you'll see the lines for your vm settings, you can copy and paste your output here. Hopefully it show:


    • Edited by devilgas Saturday, September 8, 2012 2:53 PM
    Saturday, September 8, 2012 2:49 PM
  • It shouldn't be the case cause it wouldn't be fixed with Format country change. But I've tried to reinstall Hyper-V with current Lithuanian Format settings. 

    Hyper-V uninstall went normally, but couldn't install it again. So the problem can be reproduced by changing Format every time you try to reinstall Hyper-v.

    Talking about Hyper-V requirements - they are met:

    Hyper-V Requirements: VM Monitor Mode Extensions: Yes
    Virtualization Enabled In Firmware: Yes
    Second Level Address Translation: Yes
    Data Execution Prevention Available: Yes


    • Edited by TRIUMF Saturday, September 8, 2012 3:44 PM
    Saturday, September 8, 2012 3:32 PM
  • I've had the same issue using the German locale. When I changed to US (english) I was able to install. Switching back to German I was still able to run Hyper-V so it seems to only affect the installation/installation dialog.
    • Marked as answer by TRIUMF Wednesday, January 30, 2013 10:23 PM
    Tuesday, September 11, 2012 5:27 PM