How do I mount back (give a drive letter to) an unallocated partition which used to be a bitlocker encrypted partition?


  • I accidentally deleted a bitlocker encrypted partition in Windows 7 Ultimate. Now it appears as "Unallocated" space in Disk Management. How do I mount it back or recreate the bitlocker encrypted partition table?
    Monday, November 19, 2012 2:15 AM


All replies

  • Have you got backup of the partition which was deleted?

    You will have to use some tools.

    check this:

    Manoj Sehgal

    Monday, November 19, 2012 2:52 AM
  • I read that thread before but it doesn't help because it didn't teach how to "edit the partition table manually and entered the exact partition type for a BitLocker encrypted partition". How do i use testDisk to edit the partition table and register this deleted partition?

    For your question, do you mean whether I have a backup of the partition table of the deleted bitlocker encrypted partition? Or do you mean whether I have a back up of the data in the partition? In either case, it is negative. If I have backup of the data, I won't be here trying to recover this deleted partition.

    I have been trying 2 approaches to recover my data. 1st, is as in my earlier question posted, how to retrieve back the deleted BitLocker encrypted partition i.e. how to get Windows 7 OS to recognize this "Unallocated" space as an ordinary drive or better still, as a BitLocker encrypted drive which I can simply key in my password to unlock it. Restore MBR???

    The 2nd approach is using the BitLocker Recovery tool - repair-bde.exe but the issue for this is the "Unallocated" space is not a Drive. I had used Efs Recovery - DiskInternals software to virtually mount (a feature in Efs Recovery - DiskInternals) this "Unallocated" space as Z: Drive and I could see, using Windows Explorer, a "FileSystem" folder and a single 50Gb file (which I suspect is all my data encrypted). I had tried repair-bde.exe on this virtually mounted partition Z:, it wasn't successful because the virtually mounted partition is not a valid Drive for repair-bde.exe. I have been tempted to use the Disk Management Tool in Windows to Create a Simple Volume on that "Unallocated" space for this recovery but I am wary of this action as it may write to the "Unallocated" space.

    Any solution on either approach is greatly appreciated, though 1st approach will be the easiest and faster way to get back my data. Thanks.

    Monday, November 19, 2012 8:07 AM
  • You have delete the partition so you could not give a drive letter to it, in this situation you could try Aomei Partition Assistant home (free) to recover your partition, see this tutorial:
    Wednesday, November 21, 2012 7:15 AM
  • Thanks sunnyjiongs for your reply. Is "Aomei Partition Assistant" software able to scan for deleted Bitlocker encrypted partition as well? I have tried many partition recovery softwares like TestDisk, Partition Find and Mount, EaseUS Partition Recovery and etc, all of them cannot detect the encrypted partition even after a deep scan. Only "Efs Recovery - DiskInternals" software list the "Unallocated" space as one of the partitions found but the software does not have an option to recover. That's when I read about and hopefully someone can advise me how to "edit the partition table manually and entered the exact partition type for a BitLocker encrypted partition".
    Thursday, November 22, 2012 8:39 AM
  • Can you help me, Manoj?
    Thursday, November 29, 2012 8:40 AM

    This is not a simple process and the above steps are valid for win7 also.

    It is best efforts since we are not data recovery company.

    Manoj Sehgal

    Friday, November 30, 2012 5:39 AM