none
How to turn off system protection/restore points in group policy RRS feed

  • Question

  • We are unable to disable the system protection on the local system disks under group policy. We have enabled "Turn off System Restore" under Computer Configuration \ Policies\ Administrative Templates\ System\ System Restore. All this does is gray out the options for you to configure, create or doing a system restore but it does not turn off the "protection" on the disk.

    Is there another way to do this in GP or is there a registry key that can be

     

    Thursday, November 18, 2010 10:22 PM

Answers

  • Hi,

     

    Thanks for posting in Microsoft TechNet forums.

     

    According to Process Monitor result, when turn on System Protection, this key was firstly changed:

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SPP\Clients

     

    Refer to

     

     

     

    This key (high-lightened)was only created when system protection was turned on.

     

    If you delete it, the System Protection will be turned off on UI.

     

    This change was not recommended for security reason. If you really want to delete it, please backup the key before you do that.

     

    Best Regards,

    Miya Yao

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com

     


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, November 19, 2010 4:59 AM
    Moderator

All replies

  • Hi,

     

    Thanks for posting in Microsoft TechNet forums.

     

    According to Process Monitor result, when turn on System Protection, this key was firstly changed:

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SPP\Clients

     

    Refer to

     

     

     

    This key (high-lightened)was only created when system protection was turned on.

     

    If you delete it, the System Protection will be turned off on UI.

     

    This change was not recommended for security reason. If you really want to delete it, please backup the key before you do that.

     

    Best Regards,

    Miya Yao

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com

     


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, November 19, 2010 4:59 AM
    Moderator
  • Hi,

     

    Did you solve the problem?

     

    Please feel free to give us any update.

     

    Best Regards,

    Miya Yao

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, November 23, 2010 3:15 AM
    Moderator
  • Hi,

     

    As this thread has been quiet for a while, we assume that the issue has been resolved. At this time, we will mark it as ‘Answered’ as the previous steps should be helpful for many similar scenarios. If the issue still persists, please feel free to  reply this post directly so we will be notified to follow it up. You can also choose to unmark the answer as you wish.

     

    BTW,  we’d love to hear your feedback about the solution. By sharing your experience you can help other community members facing similar problems. Thanks for your understanding and efforts.

     

    Best Regards,

    Miya Yao

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com

     


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, November 25, 2010 2:13 AM
    Moderator
  • I am working on this issue as well and have opened a separate request.

    With the above information one wonders how to remove this key in a domain GPO. In 2008R2 I am OK with adding keys, but seeing every protection key is different is there a way to push a key removal, allowing the disabling of the System Protection in Computer Configuration\Policies\Administrative Templates\System\System Restore?

    Thanks -BDP

    Wednesday, December 15, 2010 7:49 PM

  • You can configure the sample script below as a computer startup script to disable System Restore in GPO. 

    Disable Method of the SystemRestore Class
    http://msdn.microsoft.com/en-us/library/aa378852(v=VS.85).aspx

    Thanks. 


    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, December 16, 2010 7:47 AM
  • With a powershell cmdlet, to disable System Restore:

    disable-computerrestore "C:"

    To enable System Restore:

    enable-computerrestore "C:"

    Command to set diskpace used for previous files versions (example):

    vssadmin Resize ShadowStorage /For=C: /On=C: /Maxsize=5%

    or

    vssadmin Resize ShadowStorage /For=C: /On=C: /Maxsize=10GB

    Regards,

    • Proposed as answer by Larry.B.IT Tuesday, June 4, 2013 12:50 PM
    Friday, March 9, 2012 2:11 PM
  • Thank you, this powershell deployed via sccm combined with group policy worked perfect.
    Monday, March 26, 2018 1:00 PM