none
Remove network locations from "This PC" Permanently RRS feed

  • Question

  • M "This PC" view is just over loaded with some Windows Media Player Sharing devices from the neighboring network.  Problem for me is that we are a tech shop so every computer we attach to the network gets added to my tech system so after about a week I have close to 60 listed and cannot find "C:\" in the mess.  Is there a way to prevent Windows from automatically adding every computer it sees on the network? 

    This is very frustrating and is making me want to revert back to 7.  My computer; Libraries; and network locations should be kept separate to make navigation easier.

    Any help would be appreciated,

    Thank you.

    Monday, June 16, 2014 9:12 PM

Answers

  • After much trial and error with this issue I did find a solution that works without getting rid of the network discovery.  It was actually quite simple in the end.  Goto Network and Sharing Center, Select "Advanced sharing settings", then uncheck the "Turn on automatic setup of network connected devices.".  This allowed the network discovery to still work for adding printers and server shares but has stopped the media sharing devices from showing up in "My PC'.

    Thank you for all the help and suggestions everyone.

    • Marked as answer by Djice00 Wednesday, July 9, 2014 9:25 PM
    Wednesday, July 9, 2014 9:25 PM
  • Hi,

    If you turn on the network discovery, it‘s inevitable.

    I suggest you turn off the network discovery, access the sharing devices via \\IP or \\Name.

    Alternatively, you could map that device or drive for usage.


    Karen Hu
    TechNet Community Support

    Wednesday, June 18, 2014 3:02 AM
    Moderator

All replies

  • Hi,

    If you turn on the network discovery, it‘s inevitable.

    I suggest you turn off the network discovery, access the sharing devices via \\IP or \\Name.

    Alternatively, you could map that device or drive for usage.


    Karen Hu
    TechNet Community Support

    Wednesday, June 18, 2014 3:02 AM
    Moderator
  • Try collapsing the Network namespace root (i.e., click the little triangle to the left of the word Network) then closing your Explorer window.  Voila, it will be collapsed next time you open one and you will not have to see the many entries.  A bonus is that the Navigation pane won't jump when they're filled in.

    Of course, you have to try to remember to collapse Network after every time you actually expanded it to use a Network location.  But if you can make it a habit it's some small help.

    There are also ways to disable all the extraneous root namespaces you don't need, so that ideally Explorer windows have fairly clean Navigation panes.  To wit...
     

    Let me know if you'd like to hear more about that.

     

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options



    • Edited by Noel Carboni Wednesday, June 18, 2014 5:03 AM wording
    Wednesday, June 18, 2014 4:58 AM
  • I wanted to post an image of my Windows Explorer but apparently my account needs to be verified.  The network/media devices are listed under "This PC" not the network selection.  Disabling network discovery does not seem to be making a difference, all it did was hide the items under network in the left column, everything under This PC is still showing and new computers still get added.  Worst part is that even after the computer is no longer on the network it still shows in the list, my list is almost up to 50 in the last 2 weeks, and I have been removing computers when I get spare time.
    Wednesday, June 18, 2014 5:23 PM
  • Well, if it's things other than disk drives UNDER This PC that you're trying to get rid of, the removal of the root level namespaces may interest you:

    http://pricklytech.wordpress.com/2013/10/17/windows-8-1-x64-removing-the-folders-from-file-explorer/

    Note that I don't have any in the screen grab above.  In my usage I've not run across a long-term downside to doing this.

     

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    Thursday, June 19, 2014 3:52 PM
  • After much trial and error with this issue I did find a solution that works without getting rid of the network discovery.  It was actually quite simple in the end.  Goto Network and Sharing Center, Select "Advanced sharing settings", then uncheck the "Turn on automatic setup of network connected devices.".  This allowed the network discovery to still work for adding printers and server shares but has stopped the media sharing devices from showing up in "My PC'.

    Thank you for all the help and suggestions everyone.

    • Marked as answer by Djice00 Wednesday, July 9, 2014 9:25 PM
    Wednesday, July 9, 2014 9:25 PM