none
Unexpected error on server associating the workflow - Sharepoint Online RRS feed

  • Question

  • Hi All

    I'm using Sharepoint Online to publish some Sharepoint Deisnger 2010 Reusable Workflow. Until last week, I have no problems publishing the workflow. Now, when a try to publish the exact same workflow that was working last week (with no changes) i got the following error:

    "Unexpected error on server associating the workflow"

    I executed the powershell suggested here:

    http://www.sharepointpals.com/post/How-To-Identify-Complexity-of-SharePoint-2013-or-2010-Workflow-to-fix-errors-while-compilation

    and the return is 2580.

    These limits were changed recently ?

    Any help please !

    Tuesday, March 12, 2019 1:52 PM

All replies

  • I don't have a solution but I have this same problem. I haven't been able to execute the powershell command, but from what I've seen online that isn't always a solution anyway. 

    Update: This service advisory may have something to do with it: 

    SP175429 

    Status:
    Service degradation
    User impact:
    Users are unable to edit workflows or create new workflows in SharePoint 2010 using Designer and other protocols.
    Latest message:
    Title: Unable to edit existing workflows or create new workflows User Impact: Users are unable to edit workflows or create new workflows in SharePoint 2010 using Designer and other protocols. More info: Users may receive the error: "Unexpected error on server associating the workflow," and "Errors were found when compiling the workflow. The Workflow files were saved but cannot run." As a result of this problem, you may be unable to execute the following tasks: - Activating features that contain out-of-the-box or custom 2010 workflows - Provisioning out-of-the-box or custom site templates that contain 2010 workflows Current status: Our work to develop a mitigation solution is progressing as expected and is being treated at the highest priority. We'll provide a timeline for mitigation as soon as it becomes available. Scope of impact: Impact is specific to SharePoint 2010 workflows. Any user attempting to edit existing workflows or create new workflows may be affected by this event.

    Tuesday, March 12, 2019 7:58 PM
  • Hi Rafael,

    Since 3/7/2019, SharePoint Designer 2010 workflows stopped working on SharePoint Online sites, this issue is logged at Office 365 Admin Center->Health->Service Health->Advisories->SharePoint Online. Currently, it has not been fixed.

    Our work to develop a mitigation solution is progressing as expected and is being treated at the highest priority. We'll provide a timeline for mitigation as soon as it becomes available.

    For this issue, please check the service health frequently and wait for the update. Thank you for your understanding.

    Best Regards,

    Itch Sun



    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.


    Wednesday, March 13, 2019 1:45 AM
  • I am experiencing the same issue, but there is nothing posted about an incident in the health status for our tenant. I've opened a ticket with Microsoft but the issue is either more widespread than expected or the health status is also having issues reporting incidents accurately.
    Wednesday, March 13, 2019 2:15 PM
  • Hi amahloch,

    We will resolve this issue as soon as possible and we will provide a timetable immediately after the mitigation measures are available. Thank you for your understanding.

    Best regards

    Itch Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Thursday, March 14, 2019 1:33 AM
  • What is the update on this issue? I'm still having the same issue. 
    Monday, March 18, 2019 4:33 PM
  • Hi All

    You can pay attention to the information in service health.
    The next update will be on March 23.
    Thank you for your understanding and patience.

    Best regards

    Itch Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Tuesday, March 19, 2019 7:05 AM
  • Hi all,

    This issue has been fixed, now can be used normally, thank you for your understanding and patience.

    Best regards

    Itch Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Tuesday, March 26, 2019 1:43 AM
  • I am still recieving the same error.

    details : sp 2010 workflow to replace the sharepoint online list item permissions. one single line of code (maually trigger) to replace the list item settings. 

    please help me to fix the issue. i am struck with production list changes. 

    Error: 

    Error were found when compiling the workflow. The workflow files were savied but cannot be run

    Unexpected error on server associating the workflow

    Wednesday, November 6, 2019 2:43 AM
  • Hi All, 

    since yesterday i'm axperiencing tha same issue on newly created subsites (regardless of the site template):

    - spd 2013 workflows return "Error were found when compiling the workflow. The workflow files were saved but cannot be run - System.InvalidOperationException: Operation failed with error Microsoft.Workflow.Client.AuthenticationException: Authentication Failed. Valid credentials must be provided for one of the following protocols: Bearer. HTTP headers received from the server - ActivityId: ade7cecf-298f-41a2-b758-8a43f054cce1. NodeId: WFFE_IN_5. Scope: /spo/d2e6d93b-8ce5-4cdf-9dcd-4d1c9ac9b702/1f94f796-3235-4733-b367-3e45719cab51/cdf07f27-ef4f-4634-a242-1380aab913a2. WWW-Authenticate: Bearer realm="a2b6f772-f7c4-484d-b"

    - spd 2010 workflows return "Error were found when compiling the workflow. The workflow files were saved but cannot be run - Unexpected error on server associating the workflow"

    The issue is not present if I create and publish 2010/2013 spd workflows on existing subsites.

    At the moment I cannot access the admin console, is the issue come back?

    Thank you

    Fabio

    Wednesday, November 6, 2019 10:56 AM
  • [Update]

    A similar issue is back!!

    I see from my admin console since yesterday a problem on workflows is present.

    Fabio

    Wednesday, November 6, 2019 11:02 AM
  • Exact same issue has reappeared and is affecting users, see other posts here starting 11.5.19.

    Brought our workload to a stop.


    - Thank you. Respectfully, Janette M. Ricker

    Wednesday, November 6, 2019 1:59 PM
  • Same issue reported by a power user yesterday. on SPD 2013. Cannot publish or republish any old, current, or new workflows without receiving "Unexpected error on server associating the workflow".

    I duplicated it on my test SPO site using SPD 2013.

    Wednesday, November 6, 2019 6:29 PM
  • it's not working again since 06.11.2019, please respond to us ASAP. we are struck with production changes.
    Friday, November 8, 2019 11:46 AM
  • I am having this same problem and it is causing major issues.  Can you please let us know when this will be fixed?

    SharePoint Developer

    Friday, November 8, 2019 4:36 PM
  • Hi every one,

    Now issue is resolved.

    we are able to publish workflow.

    Thank you,

    Sowjanya.

    Monday, November 11, 2019 3:00 PM
  • This issue has returned!! Date is 11/14/2019 - I'm aware that there was a Service health advisory for this last week (on or about 11/6) and this was supposedly fixed, but it is STILL occurring. "Check for Errors" button in the ribbon indicates no errors in the workflow, but nonetheless this error appears whenever I try to publish ANY 2010 workflow in SPD to a SP Online site:

    

    A quick footnote - There was a maintenance outage this past Monday (11/11) when our site was read-only while you guys did some stuff. I noticed this started to occur almost immediately after that.

    I'm dead in the water if I can't modify and publish existing 2010 workflows!!

    • Edited by Minou325 Thursday, November 14, 2019 10:31 PM added more info
    Thursday, November 14, 2019 10:23 PM
  • Hi all,

    This issue has been fixed, now can be used normally, thank you for your understanding and patience.

    Best regards

    Itch Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Friday, November 15, 2019 6:34 AM