Disabling automatic folder refresh (and sorting)?


  • Howdy.

    Is it at all possible to somehow disable the automatic folder refresh when I view the folder?

    For example, I'm viewing a folder Temp at my D drive. I have two files on the clipboard, and I paste them into this Temp folder. As soon as they are pasted, the folder view automatically refreshes itself, and sorts the files. I don't want this automatic business. If I paste two files in to the folder, I expect them to remain the last files in the file list until I manually refresh the view or close and open it again.

    Anything I can do to make this stop?
    • Edited by Parsnip Monday, July 06, 2009 11:46 PM
    Monday, July 06, 2009 11:43 PM

All replies

  • I would love to get rid of this behaviour too. It´s annoying to have the files auto-sorted in the folder, and lost in middle of another ton of files.
    Why can´t we disable this not welcome "feature"? (looks more like a bug to me, but some disagree)
    Tuesday, July 07, 2009 11:40 AM
  • Another example: When you create a new folder and with the old behaviour you could instantly get in the folder because it's under your cursor. Now with the autorefresh it's instantly moved among the other folders and you have to move your mouse over there to get to it. It may seem like a minor thing, but this kind of useless extra move time piles up and disrupts my workflow.
    Tuesday, July 07, 2009 11:53 AM
  • Good point, Parsnip. It disrupts my concentration too. Specialy when working in a large folder, with lots of other files / folders inside.
    Tuesday, July 07, 2009 1:08 PM
  • glad i'm not the only one that hates this.  when trying put some music files in a certain order or trying to watch a set of mpegs i am forced to go through and rename the files so that they will sort themselves in an order i want to watch/listen to them in...extremely annoying.
    Sunday, July 12, 2009 6:04 PM
  • Based on the lack of replies that would help us out, I presume that there just isn't a way to turn this off.

    Well I've moved back to XP for the time being, and find it very unlikely that I'll move to Win7 when the time comes unless they add an option to turn this off.
    Wednesday, July 15, 2009 9:37 AM
  • Yes, I work in directories containing 1000's of files.  I don't want -moved files-  or  -renamed files-   to cause a refresh until I want the directory refreshed.  

    I moved 50 files to another directory and had to wait until the old directory refreshed FIFTY times before I could work with other files!   What a pain.
    Sunday, August 02, 2009 9:12 AM
  • Howdy,
     I have been looking for an answer to this total pi$$-me-off-er for a while now. I'll keep looking and post if I find an answer. If anyone ever does find the answer, post it here pa-leeeeez  ;^)

    thanks !

    Tuesday, October 06, 2009 10:09 PM
  • I would also like to see this resolved. There has been mention on other forums that it is not possible due to the design of Windows Vista/7, but there must be a workaround for something as straight forward as this.

    I would be interested in finding out what the official word of Microsoft is on this one.........
    Tuesday, October 06, 2009 11:43 PM
  • I would be interested in finding out what the official word of Microsoft is on this one.........
    Good luck with that. :)

    I haven't found a solution to this problem in this time, and haven't heard anything even semi-official from anyone. Kind of makes me sad.

    I mean, I will eventually move to Win7 when I upgrade my gaming comp, so I guess when that happens I'm just going to have to get used to it. A total bummer.
    Wednesday, October 07, 2009 11:36 AM
  • You are all absolutely correct! I've seen this refered to as a "convenience" feature, but I would like to know who the moron at MS who decided that there would not be any way to turn this off. It drives me nuts! It shouldn't be hard for them to write a simple update that allows the user to disable that "feature".
    Wednesday, October 07, 2009 5:16 PM
  • Hi guys,

    I have been searching for an answer to this myself and I HAVE FOUND THE ANSWER!!!!

    As far as I know, you can not do it using windows explorer.  I have searched and searched and can't find an answer.  So what I found was a program called Xplorer2.  Google it.  It works WAY better than windows explorer and THERE IS A SETTING THAT YOU CAN TURN OFF THE STUPID AUTOSORT.  YEAH.  It works great in XP, Vista, and Windows 7.  Best of all they have a FREE version that will do everything windows explorer will do and much more.

    When Microsoft creates a problem, look elsewhere for the answer.
    Wednesday, October 14, 2009 11:58 PM
  • This "feature" needs to go away.
    Friday, October 23, 2009 12:36 PM
  • Where abouts in xplorer2 is this turn off autosort located?   I've looked and can't find it.
    Friday, November 27, 2009 5:18 AM
  • Windows 7 has nothing so essential that XP doesn't with 3rd party apps. As much as I would have loved to upgrade, auto sort forces me back to XP. Maybe Windows 8 will fix this crapfest.
    Saturday, January 02, 2010 10:13 AM
  • Wow. No way to turn off this annoying refresh... so SAD. MS please please please please please allow us to turn off auto-refresh. I know Directory Opus has this option. I guess I'm off to buy it - something actually user-friendly.
    Saturday, March 20, 2010 5:50 AM
  • Add my vote for a registry setting to revert this behavior back to the way it was in XP.
    Tuesday, March 23, 2010 10:22 PM
  • Here are the registry settings to disabling automatic sorting.

    And here is a batch file that does all necessary changes in one step.

    Thursday, June 24, 2010 9:41 AM
  • Here are the registry settings to disabling automatic sorting.

    And here is a batch file that does all necessary changes in one step.

    Before I get my hopes up too much, does this really give the same behaviour as XP? As in: you can manually refresh and it sorts alphabetically, but it doesn't do it automatically when you didn't want it to happen?

    And hopefully somebody with Win7 or Vista can try this out and report back.

    If this works I love you, obv.

    Thursday, June 24, 2010 12:49 PM
  • Before I get my hopes up too much, does this really give the same behaviour as XP?
    As in: you can manually refresh and it sorts alphabetically,
    but it doesn't do it automatically when you didn't want it to happen?
    And hopefully somebody with Win7 or Vista can try this out and report back.
    Why not test it yourself ? Install the free of charge virtual machine "VMware Player 3". Install your Windows 7 or Vista – you don't need a license key within the 30 day activation period. Then test it.
    Friday, June 25, 2010 9:17 AM
  • I tried it on my Windows Vista Business box. It unfortunately, didn't worked. If anyone finds a solution for this I'd like to know.
    Friday, June 25, 2010 9:07 PM
  • Thanks for the update !


    Unfortunately, the page linked to claims it does not work when folders are set to LIST view and, of course, this is how ALL my folders are set. Wet Chicken Nugget suggests Xplorer2, which does work but is not a satisfactory solution for me. I know someone will come up with something. Meanwhile I’m back to XP.

    What I would REALLY like is for Microsoft to come up with something like “Windows Anorexic” … stable and fast with absolutely NOTHING added on … let me add on what I want to, you just make the OS fast and stable, and I will make it safe and suited to my needs.


    Saturday, June 26, 2010 1:37 PM
  • Well Service Pack 1 Release Candidate is out and I don't see this blocking problem fixed in it. Working with files is impossible without auto sort and auto arrange turned off. I have formatted and gone back to Windows XP SP3. No problem with that OS.

    Microsoft can't take any action or notice but I definitely can.
    Thursday, October 28, 2010 8:20 AM
  • The solution mentioned by Konst-33 disables Auto Arrange, not Auto sort/Auto refresh in List View and Details view which seems impossible to disable in the horrible Windows 7/Vista OSes. So much for "productive UI". This kind of design is what drives me nuts and MS doesn't care about providing a hotfix right away to fix it.
    Thursday, December 09, 2010 7:23 AM
  • xplorer2 - How to turn off Autosort

    Top Menu Bar - Tools\Options\

    Select the Window Tab

    4 Lines down - Uncheck Automatically re-sort-contents after moving/copying etc.

    Also, I usually uncheck Full Row Select

    checkmark Allow slow double-click to rename items

    And on the Advanced tab

    Checkmark Highlight active pane's titlebar as in 2xExplorer

    Checkmark Automatically resize Name column in detailed view


    After I get it displaying the way I want it, I choose Actions\Save settings Now

    and then Actions\Export Settings (and save them to a file in case I screw up later)

    Also on the Main View Menu, I usually uncheck the Mini Scrap item which closes the

    scrap window on the bottom left panel.

    I also usually set it to Single Pane - uncheck View  Dual Pane

    When it's running, I right-click on it's icon in the Task Bar and Pin it to the Task Bar

    then you can run it from there.  If you have it open and want another copy to open

    just right-click on the taskbar icon and left-click xp2 and a new window will open.


     If you want to see the total size of the subfolders, click Tools and checkmark Subfolder size

    or press Ctrl-D to turn this option on or off quickly.


    Overall this is one of the best file managers I have ever used !!

     The Pro version also lets you change the keyboard functions which I like because the

     default key for refresh is Ctrl-R instead of F5

















    Monday, January 10, 2011 4:47 AM
  • I guess it's never going to be fixed because even the Windows 8 Developer Preview doesn't have it fixed. The issue cropped up in Vista, wasn't fixed for some reason in Windows 7 (probably getting a working stable OS out was more important) but you'd think surely now Windows 8 would fix this but apparently Microsoft doesn't care nor does it understand how this is an issue. They had several opportunities to fix this problem for good in service packs, hotfixes or new Windows versions. So much for all the $$$ spent on user interface research and development, they still don't get usability, they still don't get ease of use and making users' lives easier, not harder. Just have to accept Windows 8 won't be fixing this issus either. I am moving over to Debian Linux.

    Sunday, September 18, 2011 12:30 PM
    • Edited by xpclient Thursday, May 10, 2012 12:39 PM
    Wednesday, September 21, 2011 7:47 AM
  • If you have it open and want another copy to open just right-click on the taskbar icon and left-click xp2 and a new window will open.

    Just a tip: Hold Shift when clicking a pinned program on the Taskbar to open another instance of it.
    • Edited by SP1R1TM4N Tuesday, May 07, 2013 3:57 PM minor edit
    Tuesday, May 07, 2013 3:56 PM
  • No update on this from Microsoft clowns. It's been what 8 years since Vista came out with this auto sorting monstrosity. Even in Windows 7/8, there is NO WAY TO TURN OFF THIS ALWAYS-SCATTER-MY-FILES-ALL-OVER-THE-FOLDER-AND-MAKE-ME-LOSE-TRACK-OF-THEM MODE
    Sunday, April 13, 2014 8:36 AM
  • I have put up with this unbelievable annoying problem for far too long. Guess what? I now have a Macbook Air. It will run FOUR Windows virtual machines at one time without slowing down much- - with a 1.7 GHz CPU! People more and more are going to Mac and Microsoft is gradually losing ground because they simply don't give a d**n about us and our preferences. Sure, there's a learning curve that admittedly has been a little frustrating for me, but all in all, the Mac is the best computer I own - and I own six servers, three desktops, two laptops besides the Mac, CCNA, A+, Network+, Fiber, and Cat5 certs as well as two certs for Windows Server 2003. SO, I know what I'm talking about.

    Microsoft seems to think that no one should be using keyboards anymore. How often after exiting a program have you had to wait a few seconds before Windows will respond to keypresses? Notepad seems to be a common culprit. There are a few others - SFV Checker is another. For crying out loud, the Commodore 64 back in 1984 had a keyboard buffer so keystrokes wouldn't be lost if the hard-working CPU just got a little behind. You could even change the size of the keyboard buffer if you wanted!

    I'm frequently keyboarding around in explorer windows, and suddenly the window refreshes, my place is lost and the cursor is at the upper-left corner. It's infuriating - and MS calls this a "FEATURE"?!?

    Oh, gotta go, my Mac is calling...

    Friday, April 10, 2015 4:28 AM