TFTP Download Failed (WDS)


  •  Hello

    Uppgraded my RIS server (Windows Server 2003 sp1) to WDS (mixed mode) and trying to send out some images. Worked fine with RIS earlier but now when i press F12 i get the message:

    "TFTP Download Failed"

    I have installed a boot-image. Tried boot.wim and a winPE light touch image.

    Any ideas.


    Best Regards


    Friday, July 14, 2006 12:55 PM

All replies

  • Hi Per,

    Did you add the boot.wim image to your WDS image store using the WDS management utilities, or did you drop it in the Remote Install folder manually?

    Also, are you running DHCP on the same computer as WDS? If so, have you set WDS not to listen to port 67, and set DHCP option 60 to "PXEClient"?



    Tuesday, July 18, 2006 5:52 PM
  • Hello


    I used the WDS management utility to add the image. And DHCP is not running at the same server.

    I don´t get the TFTP download error any longer.


    Now i get another error:

    File: \Boot\BCD

    Status: 0xc00000098

    Info: The windows boot configuration data file does not contain a valid os entry




    Wednesday, July 19, 2006 7:34 AM
  • There´s something with the \boot\x86\bootmgr.exe file

    If i rename it i get TFTP DOWNLOAD FAILED.

    If don´t rename it i get the \boot\bcd error.

    Any Ideas?


    Wednesday, July 19, 2006 2:13 PM
  • Hello,
    useful help is available on the 'wdsoobstepbystep.doc' paper (Published: August 2006) in section 'Known issues with PXE-booting a client to install Windows'.

     Maybe help you this cmd:
    WDSUTIL /set-server /architecturediscovery:yes


    Thursday, October 05, 2006 11:22 AM
  • I have this same problem trying to image some servers, they are all new servers using 2 x Quad-core processors.  The problem seems to be with EMT64 capable Intel processors, they negotiate themselves to the WDS servers as 64-bit capable (no problem there, it works every time) via the WDSNBP.COM file (after having run wdsutil /set-server architecturediscovery:Yes anyway).  The problem is at the point where it attempts to download the file, I then -almost immediately - receive a 'TFTP Download Failed <CR/LF> Press any key to restart...' message.  Now, this is where it becomes interesting, twice (out of roughly 150 attempts) - on consecutive attempts - the Vista bootmanager file downloaded and ran successfully, however, when selecting the RIS mode from the list of options, I then receive the 'TFTP Download failed; message (please note, it is a different message) without the 'Press any key to...' message.


    If I try an old machine, 32-bit capable only - in this case a Dell GX240 - against the same machine, it works correctly.  I have un-installed & re-installed the WDS services, this has not solved the problem, I have been forced to unitialize the server, then re-run the WDS Legacy app to re-add an image and create the required reminst share, etc...  The 64-bit capable servers now work correctly - interestingly using the file which provides the 'TFTP Download Failed' message above.


    I am at a complete loss with this problem now, I have tried different switches, different modes on our ProCurve switches (IGMP Snooping on/off, STP on/off), I've even plugged it into an old hub that we have hanging around, all to no avail.  I then tried turning the multi-core functionality off for the processors, this made no difference either.  I saw no option to disable the EMT64 extensions in BIOS, this wouldn't of been a fix anyway as it is a 64-bit version of Windows 2003 Enterprise server I am trying to install.


    You might see this and think it's ok as I am able to deploy the OS now, but it's only working in legacy mode, not mixed mode or native mode, I need to be thinking ahead towards Vista deployment in the very near future, so I need this problem solved ASAP.  Please help if you can, I am willing to provide any type of log file I can to help, even NetMon 3.1 capture's have been studied!!  The only thing I haven't been able to try is editing the IP Helper tables on our routers as these machines are currently on a test network and are routed via MS RRAS servers, I'm not sure if you can or how to make these edits in the IP Helper tables in RRAS.  I have however tried the DHCP options - 066, 067, 060 - all to no avail.  There is no routing between the WDS server & the servers to be RIS'd (WDS'd!!) so this isn't a problem either.


    I eagerly await help :-)


    I forgot to mention that I have both the 32-bit & 64-bit boot files from vista boot.wim files on the server, in the correct place and that the path to the file presented in the PXE boot screen is \boot\x64\

    • Proposed as answer by xiong huang Monday, November 07, 2011 8:00 AM
    • Unproposed as answer by xiong huang Wednesday, November 09, 2011 1:35 AM
    Friday, January 18, 2008 3:42 PM
  • This issue is still outstanding, can anybody help?  a bump so to speak, but this is and was urgent 11 days ago...

    Tuesday, January 29, 2008 2:17 PM


    I have a DHCP, TFTP server and I want to restore a Server 2003 R2 by using ASR with an PXE installation. The server I want to restore takes the IP address but in the moment that it is looking for the TFTP file, it can not by found. And then shows and error PXE-E32 TFTP open Time Out.

    Wednesday, September 03, 2008 8:53 PM
  • Hi,CuppaT,I have to say Thanks to you. After read your amazing install-notes, I give up to use WDS on Windows 2003 server R2, and upgrading my server to windows 2008.

    Does anyone solve this problem?

    Thursday, June 17, 2010 7:31 PM
  • If you're still experiencing this issue, please enable WDS tracing logs (, reproduce the issue, and paste the contents of wdsserver.log here.
    Monday, June 21, 2010 10:44 PM
  • hi, I have to tell you that provided by microsfot contains a serious bug.

    one function does not initialize (zero out) a temp-var (16bit), which low 8bit is written by a subsequent funcion call.

    but the other function uses its whole 16bit value (as an option tag size).


    both 2006 and 2009 version of have the same bug.

    • Proposed as answer by Johny Francis Saturday, October 27, 2012 4:53 AM
    Monday, November 07, 2011 8:05 AM
  • What function do you suspect has this bug, or which option tag are you seeing this error with?
    Monday, November 07, 2011 6:40 PM
  • Hi Aaron

        I haven't the source code of, but I did de-assemble the binary file, and found a function is to get a level-2 option tag from the

    cached packet of DHCP reply ACK which is returned by the PXE UNDI driver.  I guess the function type is:

        char* get_option(char main_tag, char sub_tag, char* buf, int buf_len, *option_len);

    the bug exist in this function.


    the Option tag is 0xFC (=252)




    Wednesday, November 09, 2011 1:33 AM
  • has anyone resolved this? I am trying to look for a solution. Thanks! 


    Sunday, November 13, 2011 2:47 AM
  • Fov_D007 - in your screenshot, on the line that says "Contacting Server:", is that a valid IP address for your PXE server? It looks like that address should be 


    A network capture of this process would be useful, but this may be a bug in whatever VM solutions you're using. 


    The version number from would also be useful.

    Wednesday, November 16, 2011 8:33 PM
  • Aaron,

    I see the previous poster did not respond to you; I'm suffering the same result...only the referral server IP is correct.  But I get the same TFTP restart failed... error.

    What do you recommend?

    I'm also using virtualbox with a host-only network adapter.  I'd greatly appreciate any insight or suggestions to get this project going forward.

    Very Respectfully,


    Wednesday, April 04, 2012 6:12 AM
  • Hi,

    I spent days to resolve the issue TFTP download failed! but no luck

    I reconfigured the server and images, I have checked the DHCP configuration 060-PXEClient is enabled, 067-Bootfile Name string value is set boot\x86\

    I also ran WDSUTIL /set-server /architecturediscovery:yes, no luck whatsoever.

    I'm running a Vitualbox(4.1.10) PXE-enabled windows 7 machine, I can see the machine IP address on my DHCP server .

    I read almost all articles and documents regarding this issue.

    would someone please help us with this!

    Many Thanks!

    • Edited by saedz Monday, April 09, 2012 6:22 PM
    Monday, April 09, 2012 6:05 PM
  • I was finally able to get this to work by following all the tech guide instructions and then:

    Using TFTPD32 (not wds), set it to use instead of in the DHCP settings, then set "Option Negotion" on.

    Using C:\Output as the TFTP root dir:

    Copied C:\Program Files\Windows AIK\Tools\PETools\x86\boot to c:\Output

    Copied C:\winpe_x86\mount\Windows\Boot\PXE to c:\Output

    I didn't bother using my own BCD fileb that the instructions wanted me to make (which caused error after error), just used the one from C:\Program Files\Windows AIK\Tools\PETools\x86\boot

    Next, I moved the .wim file to c:\Output\Sources, and renamed it: c:\Output\Sources\boot.wim

    Then, I made a copy of the whole mess to c:\Output\Boot (sometimes I saw from the logs it looked for files there, sometimes not, depending on the file).

    By the time I was done, I had copies of these files all over the place. So, to recap:

    Watch the log from TFTPD for any missing files, and keep moving them around until the damn thing loads.

    Crappy experiance all the way around... Hope this helps!!

    Friday, April 20, 2012 5:01 AM

    Apart from using VMWare Player and setting it to NAT which will make it work.

    With Orical VM Player, you need to download the extension pack located here:

    Then you need to make sure Network settings are the following.

    Attached to = Host-Only Adapter.

    Name = VirtualBox Host-Only Ethernet adapter.

    Promiscuous Mode = Deny.

    Cable connected = Checked.

    Thursday, May 03, 2012 9:09 AM
  • I'm not sure how you guys are preparing authorizaiton for your WDS clients (i.e. precreating machine accounts or if your WDS servers are open to all client requests for PXE images).

    I eventually got it working using VirtualBox and do recall that there is a host limit to how many times a particular machine can query the WDS server in a given period and be authorized to download the image.  *I think it's 24 hours.  I was able to get around this by recreating the machine account (delete/recreate).  So there's something with cached service request counts and an associated limit for authorization.  Be mindful of that issue, it will produce the same results as stated above...TFTP timing out.  Ensure that you have WDS logging enabled and check the logs--THEY'RE SUPER HELPFUL!!!

    I was trying to get creative and use Windows Routing and Remote Access Servers, with RIP between two physical machines to simulate two distinct networks (across boundaries for future provisioning of a forest and multi-domain architecture), connected via crossover cable, and I couldn't establish success with port-forwarding rules but once I eliminated the fancy network factor and just did host-only networking, I was able to successfully push an image (minus the above issue with the validity period for servicing a request).

    Hope that might help you avoid any problems.



    Wednesday, September 19, 2012 10:43 AM