Getting a printer driver from Windows Update


  • I'm trying to install an HP LaserJet 1300 on a Windows 7 x64 system.  The printer is currently shared on an XP Pro sp3 system but eventually will be directly connected (USB) to the Win 7 machine.

    If I try to install it normally, Windows locates the printer share over the network but can't find a driver for it.  (I get error 0x00004005).

    In the past, I was able to install this same printer on another Win 7 x64 system by installing it as a local printer, getting to the list of drivers and selecting "Windows Update."  After the update, a driver for this printer appeared in the list of printers and I could complete the installation.  Once the driver was installed, I then changed the port to a TCP/IP port and all was well.

    When I tried to follow this same procedure today, I get to the "Choose your printer from the list" screen and click the Windows Update button.  The window shows "Windows is updating the list of devices from Windows Update. This may take a a few minutes."  After a varying amount of time, I get the following:  "Windows was unable to get a list of devices from Windows Update. Please try again later."  This has happened repeatedly for the last 8 hours or so.  This happens no matter what printer manufacturer I select -- it seems to be a problem with Windows Update.

    HP says

    You do not need to download drivers for this product. Print drivers for your product are available within the Windows 7 operating system

    And I know the driver was at WU as of October 2009.

    I went to but it's very difficult to determine which of the many packages is the appropriate driver (I think "AMD64" is the type I want, but that still leaves over a hundred or so different packages). 

    I picked "Microsoft driver update for HP LaserJet 1300 PCL 5" for AMD64 architecture and downloaded it.  I used the expand command to extract the contents of the cab file, but when I pointed the Add Printer wizard at the inf file, it didn't like it.

    So ...

    Why isn't Windows Update updating the list of devices?

    If I have to do things manually, how can I tell which item in the catalog might work, and then how do I use that cab file to install the printer?

    Thursday, June 07, 2012 3:51 AM


All replies

  • Have you tried to plug the printer directly into the Win7 machine and have it get a driver from Win Update that way?  If not, give that a shot and let us know if it works.  If it doesn't, we can address the next step then.

    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, June 07, 2012 3:15 PM
  • I am having the EXACT same trouble. Our printer is a office network printer, cannot try to plug it in usb Obujuwami. It seems that the root error is the Windows Update module. 
    Thursday, June 07, 2012 9:23 PM
  • I've been having the same problem. Maybe Windows messed up an update? This is the first time I've had a problem with it
    Thursday, June 07, 2012 9:23 PM
  • I had a thread going on this topic in the Answers forum:  Although I never got to the bottom of why Windows Update could not "update the list of devices," I was able to manually install the printer using the following method (and to Obujuwami -- now that the driver is installed, I hope I will be able to install the printer directly connected to the Win 7 box without too much struggle).

    1. Went to, downloaded what appeared to be the correct "driver package" for Windows 7 x64 ("AMD64 Architecture")
    2. Extracted the contents of the cab file using the Expand command in a command prompt window
    3. Added the driver package to the driver store using pnputil.exe -a <inf from the expanded cab file>
    4. Went back to Add a printer and selected "Add a local printer"
    5. Selected "Create a new port" and selected "Local Port" (this had me stumped for a while; I kept trying to use a Standard TCP/IP port, but you can't use \\computername\sharename as an IP address -- you can only use that form in "Local Port")
    6. Got to the list of printer drivers where now the driver for the LaserJet 1300 PCL 5 is listed, so it can be selected
    7. Finished the install, sent a test page, and it works!

    • Edited by Pete999 Friday, June 08, 2012 12:07 PM
    Friday, June 08, 2012 12:02 PM
  • @iamwpj --

    See my reply above.  That method is intended for use by "network administrators," so it should work fine for you.  From a Command Prompt, you can type pnputil.exe -? for syntax help or see pkginstall.doc from here -->

    Friday, June 08, 2012 12:10 PM
  • Solution: it seems that the Windows Update has corrupted files, this refreshes the Software Distribution folder.

    Essentially what you will be doing is deleting the Software Distribution Folder. Then after it renews itself, WU should be functional.

    1. Open Task Manager (Ctrl-Alt-Del)

    2. Click Services Tab

    3. Under Name find "wuauserv"

    4. Right click on "wuauserv" and click on Stop Service. do not close

    5. Open Window Explorer and browse to C:\Windows

    6. Delete the Folder "SoftwareDistribution"

    7. Go back to the Task Manager, Right click on  "wuauserv" and click on Start Service.

    Pete, we tried your suggestion, but our .inf file kept getting marked as invalid. We were unable to get past this error. 

    • Marked as answer by Pete999 Friday, June 08, 2012 9:57 PM
    Friday, June 08, 2012 4:32 PM
  • I don't know why your inf file was marked as invalid.  The "package" I downloaded EXPANDed into 3 files (,, and prnhp001.inf) and a folder (Amd64).  I used the pnputil command with prnhp001.inf.

    In any case, however, deleting the SoftwareDistribution folder did indeed fix the problem.  Thanks for finding that.

    Friday, June 08, 2012 10:03 PM
  • At first we thought that this was a problem that could just be with Enterprise, but I went home and this is also an issue on my computer and on a friend's computer. So whatever the problem is, it is a problem on Microsoft's end. This solution works for installing one printer though, because if you go to install a second you have to go through the steps all over again.
    Tuesday, June 12, 2012 9:00 PM
  • There is an update to the Windows update. Its supposed to improve some certs and such.

    Looks like Windows had temporarily created an issue before pushing this update.

    gone fishing;you can find me on the internet

    Friday, June 15, 2012 8:43 PM
  • Hi, iamwpj,

    When I click "Stop Service" on wuauserv, I get an error message that reads, "The operation could not be completed.  Access is denied."  I own this machine and am the only user (it's a new machine), and assume I have administrative rights.

    I would appreciate any thoughts you have.

    • Proposed as answer by indyfx Sunday, June 17, 2012 10:15 AM
    • Unproposed as answer by indyfx Sunday, June 17, 2012 10:16 AM
    Saturday, June 16, 2012 1:54 PM
  • Hi, iamwpj,

    When I click "Stop Service" on wuauserv, I get an error message that reads, "The operation could not be completed.  Access is denied."  I own this machine and am the only user (it's a new machine), and assume I have administrative rights.

    I would appreciate any thoughts you have.

    Hi RGriffin28

    I had a similar problem.  However this is how I overcame it.  When you open task manager rather than clicking on the services tab, click on the services button in the bottom right corner.  If you scroll down to Windows Updates and stop it there it also stops it under the "wuauserv" file in the services tab.  You then follow the instructions suggested by iamwpj.  It is now working fine.  I must stress that I am no IT expert so I do not know if stopping Windows Updates running using this method has any other implications

    • Edited by indyfx Sunday, June 17, 2012 10:22 AM
    Sunday, June 17, 2012 10:21 AM
  • This worked for me

    I kept trying several other Microsoft "solutions" including Mr Fix It, but nothing worked

    Thank you!

    Thursday, August 30, 2012 3:48 AM