none
Can't use stored RDP files after upgrade to Windows 10 1607 RRS feed

  • Question

  • After upgrading to the Windows 10 Anniversary Version (1607) I am not longer able to use my stored RDP files on the desktop. (Or anywhere else on the disk)

    I either get no reaction or a message box with an error stating that the device or path can't be accessed. This message is thrown from the explorer process.

    The same behavior is also present for the "edit" verb. Using "procmon" I can see MSTSC.exe staring and loading some DLLs, but the command line given RDP file is never even accessed. 

    My computer is a 64 Bit "Pro" system that was upgraded from Windows 7 to Windows 10 to Windows 10 1607 which is part of a domain.

    My domain user has full rights on the local domain profile, so I even do not understand the "Can't be accessed" error from explorer.

    Just before the upgrade everything works just fine. Starting the mstsc.exe directly and specifying the target interactively also works without any hassle. A "sfc" scan does not report any problem.

    I would be happy if you can give me some tips what I might have missed.

    Greetings
    Peter

    Friday, August 19, 2016 4:27 PM

Answers

  • .RDP files won't open (remote desktop) after Win10 Anniversary Update issue reported by others, has a know work-around.

    WORKING FIX   --  I have received reports that this works:

    If you are experiencing this issue, you should be able to work around it by removing the custom scale factors you have set (a custom scale factor applies across all monitors).

    1. Hit the Windows key and then type "display".

    2. Tap on the "display settings" link that is found.

    You should see the following text in red: "A custom scale factor is set".

    3. Click on the text underneath which states "Turn off custom scaling and sign out". 

    4. Sign back in.

    MSTSC should now work with an RDP file passed as a parameter.


    Microsoft still needs to address this bug:  RDP Files do not run with custom display font scaling.

    Friday, August 19, 2016 5:16 PM