none
slow large file network copy. win7 to win7

    Question

  • can someone else with access to two win7 computers try this out because i'm yanking my teeth with 2MB/s transfers on gigabit. and this is with a fresh install on both computers too so no tweaks or anything.

    1. copy a large file (1-10gig in size) from computer 1 to computer 2 using windows share not homegroup. note speed.
    2. go to computer 2 and copy large file to computer 1. note speed.

    here's what i'm getting. it starts fast (50MB/s) but then starts to drop every few seconds until it hits 1-2MB/s about 30 seconds into the copy.

    this part is important. you have to copy a fresh file over otherwise it acts as if the file was cached or something. i've tested this numerous times. if you copy a file the first time it'll be slow. delete that file on the 2nd computer and copy it over again and it'll be fast to copy. you can do this as many times as you want and the copy will be fast, but as soon as you try to copy over a new large file the speed drops down to 1-2MB/s again!

    p.s. i tried this both on a gigaswitch and through a crossover cable and the results are the same. if it matters one of my nic's is a realtek and the other is nforce.

    Wednesday, May 13, 2009 4:03 PM

All replies

  • What speeds do you get on smaller files? Do you ever get full speed? Can you try setting your NIC speed to 1000Mbps Full duplex (on both machines) instead of auto and see if that helps?
    Thursday, June 25, 2009 3:16 PM
  • also same problem! Win7 - Win7 copying a 700MB video from Homegroup share. Can get up to 1MB/s, but usually less across G wireless.

    Has anyone tried wireless file copy speed across homegroup? This is horribly slow!
    Friday, October 30, 2009 6:52 AM
  • Slow as a dog on both copy and delete.  I can watch the files being transferred and deleted.  What is win7 doing?  Logging and journaling each byte?  I also get about 1MB max on transfers.  Driving me crazy.  Have not yet tried DOS copy to see if it's any faster.
    Monday, November 23, 2009 3:54 AM
  • I use an external hard drive and I get 30-40 migabytes a second both from computer to HDD drive (LaCie 750 GB, nothing to fancy here) and samething from LaCie to computer. I have it plugged in through a USB, try that. As for home sharing and wireless routers it will be slower but slowest I experience with an N router was 3Mbit/s. Unless you guys are using NAS servers then speed is going to be slow (with exception of HDD drive being plugged in through USB).
    Monday, November 23, 2009 6:04 AM
  • Not really a helpful response there Genericuser, unfortunatelly for a gig ethernet connection you should be seeing speeds on most systems of around 70meg for transfer rates as that is the limitation of the bus between harddrive and ethernet adaptor, so im sorry your incorrect in your assesment of the situation. Im also trawling many many posts in regards to these slow transfer speeds looking for an answer, which there seem to be 100's of ideas but no solid solution as yet. Google searching is throwing up countless results. On this site alone there appears to be 100's seeking answers to this solution and they are only the ones that have posted, Many many more would have got to a stage like I have and seen microsoft respond with basic tool tips for the unknowing as far as networking is concerned and not suggesting a correct solution.

    I have seen posts that blame peoples routers, their inability to produce a functioning  network, faulty hardware, bad drivers, loads of things suggested by microsoft just to see the same people respond with tried and didnt work. This is clearly some sort of programming issue with Microsoft but true to most large coorporations they do not wish to admit there is an issue, and probably are not paying any serious attention to the issues people are having. You never know we may get some random KB******* update in a couple of years fixing the problem.

    Tuesday, October 19, 2010 4:51 AM
  • I know this won't help your situation, but I consistently get 65MB/s or better, machine to machine.  My only pain point in the entire network is my WD WorldBook "NAS" that can't seem to go any faster than 16.6MB/s for a short time at the beginning of a transfer, then slowly works it's way down to 14-15MB/s.

    So, it's not a Win7 limitation or glitch, otherwise I'd be having the same problems you are.

    My network is based on Cisco SB RVS-4000, a Cisco SB EG0008W 8 port 1Gb switch,  Cisco SB EG005W 5 port 1Gb switch, and a Linksys WAP54G for wireless.  I get the same reasonable 65MB/s while going from a machine direct connected to the RVS-4000 to another machine direct connected to that same device, as I do to a machine downstream behind both the switches mentioned.

    I did nothing special to acheive this, but I'd be glad to learn more about your setup and perhaps dig a bit deeper.  If you want some help, I'll do what I can, we can compare settings and whatnot, whatever it takes to get you going. 

    DAS

    Tuesday, October 19, 2010 5:46 PM
  • Have you tried to disable Remote Differential Compression? : 

    1. Click Start – Control Panel – Programs – Turn Windows features on or off.

     2. Uncheck "Remote Differential Compression" and click OK.

     3. Restart the computer and you should see an improved performance with copying files.

    That worked for me.

    Tuesday, March 01, 2011 1:30 PM
  • Found it.  Windows 7 64bits freezing while copiyng files over network.

    Symantech Endpoint Protection ! as soon as it was disabled I was able once again to copy files over network.

    Please try disabling Anti-virus it could be root of your problem. 

     

    Good Luck

    Tuesday, July 26, 2011 2:51 PM
  • Wednesday, December 28, 2011 9:37 PM
  • There is couple of things that you can try.

    http://answers.microsoft.com/en-us/windows/forum/windows_7-networking/very-slow-200kbsec-file-copy-between-win7-machines/b8736b1b-0a91-4567-ba33-215084ffc906

    1. Running as Administrator in Command Prompt, type: "netsh int tcp set heuristics disabled"

    2. Next, follow the instructions that Amrita wrote above.

                      First enter: "netsh int tcp set global autotuninglevel=disabled" and reboot.

                      Then enter: "netsh int tcp set global autotuninglevel=normal" to restore it to the typical setting.

    3. Finally, go to Control Panel > Programs > Turn Windows Features on or off > and check "Simple TCPIP services (i.e. echo, daytime, etc.) so that it is enabled.

    4. Reboot your system again, and the file transfer rates should be excellent.

     

    Under wireless adapter properties
    Transmit Power (5-highest)

    Under your ehtnernet adapter properties
    Link Spped & Duplex (100 mb halfduplex)
    Try each of the values and see which will give you best transfer rate.


    Disable your antivirus program on the computer that's hosting the file.

    Wednesday, December 28, 2011 10:01 PM
  • Autotuning, RDC, duplex, etc didn't make a difference for me.

    What it turned out to be was power managment.

    I disabled power management from the configure button for the NIC.

    From the "advanced" tab, I disabled "energy star" option.  Network copies went from 4-5MBps to 60-118MBps.  This was a Marvell NIC

    On a 2nd computer, with a Realtek NIC, the "green ethernet" and "energy efficient ethernet" that needed to be disabled.

    On a 3rd, with an Intel NIC, it was "energy efficient ethernet", "reduce link speed during standby" and "reduce link speed during system idle"

    Jumbo frames didn't make a difference until the power management options were changed.

    Sunday, March 11, 2012 8:28 PM
  • Remove IPv6 from network properties.

    If your internal or external networks do not  require  IPv6 protocol, better remove it under network connection properties. Keeping IPv6 in your computer sometimes slows down network by trying to register IPv6 addresses, or trying to get IPv6 address, or trying to resolve IPv6. Better remove it if it’s not required.

    Monday, February 25, 2013 3:23 PM