none
new window opens behind existing window - how to modify?

    Question

  • Sometimes when I select another program or function, the new window opens up behind an existing window on the screen.  I know there are ways of getting to the new window, but how can I make W7 operate like earlier Windows in this respect - i.e. always open a new window in the foreground?
    Monday, March 22, 2010 10:00 AM

All replies

  • Windows 7 should default to placing new windows in the foreground.  Does this issue remain after installing all available updates and rebooting?

     

     


    If this was helpful, please vote by clicking the green triangle. If it solves the issue, click Propose as Answer. Thanks!
    Monday, March 22, 2010 10:43 PM
  • Yes it does.  I have automatic updating set up, and reboot daily.  This has been happening for weeks, but is not predictable - i.e. if I try to create this effect, it will (of course) bring up a window in the foreground.  However, I am often mystified when I select another program and cannot see the window, only to find that it is hidden behind an existing window.
    Tuesday, March 23, 2010 12:14 AM
  • I've had this problem for ages (Windows 7 Ultimate). Example: using Revo Unistaller, an uninstall program starts, the unnistall window stays hidden behind the Revo active window. Many other instances too.
    theWeissGuy
    Tuesday, March 23, 2010 1:07 AM
  • When did the issue first occur? Did it occur after installing some software?

    Does the issue occur in all applications you are trying to open?

     

    As Shawn mentioned, the newly opened window should pop up in the foreground by default. This issue can be caused by certain program installed. You can first access Clean Boot to check the issue. If the issue disappears in the Clean Boot environment, you can continue to narrow down which entry is causing the issue.

     

    Also, does the issue occur in all user accounts? You can create a new user account to test the result.

    • Marked as answer by Linda Yan Monday, March 29, 2010 2:10 AM
    • Unmarked as answer by rattlingroger Thursday, March 24, 2011 3:10 PM
    Wednesday, March 24, 2010 5:47 AM
  • As I reported in my earlier post, unfortunately this behaviour is not predictable - it happens whenever it feels like it!  However, when I can find some reliable sequence which will reproduce the problem I will examine using the Clean Boot process, and try creating a new user account.
    Thursday, March 25, 2010 9:31 AM
  • It seems that this thread has gone into the no response zone.  I have the same problem and it occur's with a Clean Boot to Safe Mode.  Any other suggestions would be appreciated...
    Monday, September 13, 2010 4:00 AM
  • Same issue. Everything opens up behind. THis is a brand new computer. It has been this way from the very begening. I'm not running objectdoc which I've read people have had luck with unistalling, or firefox, or have dowloaded any new programs recently. From the moment the computer was set up and turned on it has done this.
    Sunday, October 31, 2010 12:29 AM
  • Same issue for me.  Almost all windows open behind existing applications.  I feel it more likely to happen with "windows 7" system windows.  Example when opening a file with no application associated with it's extension, the chose an application dialog box is behind.  But it also happens with ms works, openoffice, and other applications.  I am amazed there isn't a simple setting to manage this.
    Thursday, January 6, 2011 7:14 PM
  • Same issue. 5-2011 .  Windows 7 & on new machine with all Win updates.
    Wednesday, May 25, 2011 10:21 PM
  • Same issue...Is there a way to file a bug with microsoft?
    Friday, July 22, 2011 5:24 PM
  • Yep, me, too. Just bought a new computer with Windows 7 (yay, bye bye Vista). I've been going along and all of a sudden tonight, my stupid windows are opening behind. So for example, I'm in Windows Mail and click new email. The new email window comes up behind the mail program. This is crazy! How do I fix it?

    Nothing has changed except I've been having problems with IE today...browsers hanging and not opening. I've been running this computer for TWO WEEKS.
    Friday, September 23, 2011 9:14 AM
  • Same issue here, anybody find a solution?
    Manning
    Wednesday, October 19, 2011 3:19 PM
  • Many people with this specific problem have had the ForegroundLockTimeout registry setting help them out.  This fix generally is most helpful to people who have the problem occur all the time.  It's a bit less likely to help those who have the problem only some of the time, but definitely still worth a try.

    Here's one post on that topic: http://answers.microsoft.com/en-us/windows/forum/windows_7-performance/windows-7-explorer-window-does-not-appear-in-front/1199682e-2415-4a7a-bf21-f57a972122ee or do a web search, "foregroundlocktimeout site:microsoft.com" to fine one of many different articles about it.

    • Proposed as answer by Bob32256 Thursday, May 19, 2016 2:32 PM
    Saturday, October 22, 2011 6:40 PM
  • I've dealt with this issue quite frequently over the last 5 years or so.  The following will often fix the problem but probably not always.  Go to Windows Explorer and select Tools>Folder Options>View> and check the "Launch folder windows in a separate process" check box.

    Hope this helps.

    • Proposed as answer by DaniBy Thursday, March 20, 2014 8:29 PM
    • Unproposed as answer by DaniBy Thursday, March 20, 2014 8:30 PM
    • Proposed as answer by BillFbna Thursday, October 19, 2017 10:55 AM
    Wednesday, December 14, 2011 2:41 AM
  • @Terry I followed your instructions and it worked perfectly for me.  I have Windows XP so not sure about those running Windows 7.  Thank you. 
    Friday, December 16, 2011 4:18 PM
  • This is a relatively easy process make sure that go into the theme properties, reapply the theme and also you could set the window to foreground.
    Professional In Computing - Please Contact for Help. Please remember to click “Mark as Answer” on the post that helps you This can be beneficial to other community members reading the thread.
    Wednesday, December 21, 2011 4:00 AM
  • I had this problem happening in Outlook.

    If I tried to open an email, it would open behind the main Outlook window.

    The same happened if I opened a link in the email - it would open behind the mail.

    The fix that was suggested to me was so simple that I still don't believe it.

    Right click on the task bar and unlock the taskbar, then lock it again.

    Close down OUtlook and re-start it.

    Problem solved! JUst dont know how  or why.

    Monday, January 30, 2012 4:54 PM
  • That worked!!!!! You ROCK!

    I email xml files and pdf files to the office all the time. I would right click on the file and click on send to email recipient and the new email window would pop up behind all my other windows. The Foreground Flash Count was set to 7 and I changed it to 3. Worked like a charm. Thank you so much. This little nuisance has been a thorn in my side for months!

     

    Monday, February 6, 2012 11:07 AM
  • It would seem that this is a closely related issue:

    http://superuser.com/questions/269415/show-desktop-sometimes-sets-a-window-to-always-on-top

    It seems some folks that have posted here are actually having the "Always-on-top" issue as opposed to the "Always-on-bottom" issue.

    BTW. We could really use a solution for the win+d always-on-top problem linked above.

    Wednesday, May 16, 2012 4:04 PM
  • This is an OLD POST, but I think I need to contribute my two cents!

    In Windows 7, window pop-ups are control by FOREGROUNDFLASHCOUNT and FOREGROUNDLOCKTIMEOUT in the REGISTRY (You need to CLICK ON the START ICON at the leftest of your TASKBAR, and type REGEDIT in the SEARCH PROGRAMS and FILES field).  Go to the REGISTRY EDITOR and it is at this path:

    HKEY_CURRENT_USER\CONTROL PANEL\DESKTOP.

    One click on the DESKTOP (Manual Display), and your will see the detail populate at the right side of the REGISTRY EDITOR window.  Go to fine the FOREGROUNDLOCKTIMEOUT, and double click on it.  

    The EDIT DWORD small window will pop-up.  Change the VALUE DATA to ZERO.  

    Yes, you must restart your PC in order for the change to apply.

    Here is what is telling us in the Windows 7 manual:  http://technet.microsoft.com/en-us/library/cc957205.aspx

    ForegroundFlashCount

    2 out of 6 rated this helpful Rate this topic

    HKCU\Control Panel\Desktop

    Data type

    Range

    Default value

    REG_DWORD

    Number of flashes in decimal

    3

    Description

    Specifies the number of times the taskbar button flashes to notify the user that the system has activated a background window. If the time elapsed since the last user input exceeds the value of the ForegroundLockTimeout entry, the window will automatically be brought to the foreground.

    Related Entries

    Yes, if the DOWNLOAD timer in the FOREGROUNDLOCKTIMEOUT (SHOWING 30D40 Hexadecimal) is longer than the 3 FLASH(Default), then you will see the new WINDOW pop-up behind your mother window or your application.  Set the VALUE DATA to ZERO, sooner than the 3 FLASH of the FOREGROUNDFLASHCOUT, the the DESCRIPTION above is applied.

    Good luck

    Leng


    Wednesday, August 22, 2012 1:58 AM
  • This, bizarrely enough, worked for me too.  God, these little glitches will be the death of me.

    Thanks. Peace.

    Tuesday, January 8, 2013 4:53 PM
  • This also has reared its head in my new Windows 8 Pro installation. Bizarrely the fix for win 7 (foregroundcount reg entry) fixed it.
    Saturday, February 9, 2013 9:48 PM
  • This is an OLD POST, but I think I need to contribute my two cents!

    In Windows 7, window pop-ups are control by FOREGROUNDFLASHCOUNT and FOREGROUNDLOCKTIMEOUT in the REGISTRY (You need to CLICK ON the START ICON at the leftest of your TASKBAR, and type REGEDIT in the SEARCH PROGRAMS and FILES field).  Go to the REGISTRY EDITOR and it is at this path:

    HKEY_CURRENT_USER\CONTROL PANEL\DESKTOP.

    One click on the DESKTOP (Manual Display), and your will see the detail populate at the right side of the REGISTRY EDITOR window.  Go to fine the FOREGROUNDLOCKTIMEOUT, and double click on it.  

    The EDIT DWORD small window will pop-up.  Change the VALUE DATA to ZERO.  

    Yes, you must restart your PC in order for the change to apply.

    ForegroundFlashCount

    HKCU\Control Panel\Desktop

    Data type

    Range

    Default value

    REG_DWORD

    Number of flashes in decimal

    3

    ...

    ...

    Good luck

    Leng


    This has saved me a year of frustration. All it took was the number 3. It was so hard to find a fix for this because Googling, "Why the heck is the freaking save window behind the gosh dang browser window!?" Doesn't really query a fix. Thanks a ton.
    Tuesday, July 9, 2013 9:07 PM
  • I tick this box and then untick the same setting and viola, all is back to normal.
    Tuesday, December 3, 2013 8:08 AM
  • Hi All,

    even i had the same issue and thank you that is resolved by changing the FOREGROUNDLOCKTIMEOUT key Value to Zero.

    But that is solved for only my account, what about other user accounts. i tried with different account and issue still exist for that account.

    please let me know how to reflect this reg change for all user accounts.

    Thursday, January 2, 2014 5:29 AM
  • Terry this worked great for me too - thanks.

    • Edited by DaniBy Thursday, March 20, 2014 8:31 PM
    Thursday, March 20, 2014 8:29 PM
  • UK_Dragon - absolutely remarkable - this worked for me too!  I have been plagued by background opening windows for about a year now (in Windows 8), never knowing how to fix them.

    I don't like the ForegroundLockTimeout solution because a. it sometimes doesn't work anyway and b. it forces windows to pop up in front at other times when they want to, not just when *I* open a window.

    Unlocking the taskbar, then locking it again, has fixed all my issues.  How bizarre, easy, annoying yet wonderful all at the same time. :)

    m


    Tuesday, October 28, 2014 8:24 AM
  • Hi All,

    I have a similar problem . Please help me.

    I have created OutLook AddIn for Outlook 2013. Where add in has got Hidden windows.form.web browser control within it . SO on button click it launches the IE with the given data (xml file converted to bytes). In debugger mode, When I attached this ADDIn to OUTLOOK.EXE process , IE windows comes in the foreground . if i detach the debugger or install the AddIn in machine then on button click IE opens in the background .

    Dont know why this is happening , sometimes after restarting machine it works fine. But this problem comes back ..

    I am using Windows 7 64 bit machine .

    Thursday, April 2, 2015 11:42 AM
  • Your instructions worked - my problem* is now resolved.  Thanks so much for posting this solution.

    *PROBLEM: New windows (documents, files, Search, etc.) all of a sudden started opening only in the background, so until I caught on to this glitch, I thought my taskbar wasn't functioning properly.  Using Firefox.  I tried opening files from Task Bar on Internet Explorer (MS owned and operated...) and did not encounter the problem, but because I use only Firefox, I needed to resolve the problem.  I'm guessing it has to do with an MS update yesterday that affected Firefox.  GRRR.

    I never, ever touch the inner working of my computer as I'm capable of making grave errors that will send me running to the computer repairman $$$ (lesson learned), but BillGateFollower's instructions were very clearcut and I took the dare.  Thanks,BGF - you've saved the day.

    Saturday, June 13, 2015 9:32 AM
  • Thanks Terry, this worked for me. Annoying as h___.
    Thursday, December 31, 2015 5:15 PM
  • I have this issue often when Alt-tabbing to another application. I Alt-Tab to another application and it stays in the background.

    I found a useful workaround in the meantime. If you have a Win key, press Win-Down and then Win-Up and the application comes to the foreground.

    I just checked my ForegroundFlashCount setting as described by @johnqflorida. Mine was at 7 instead of 3. Too early to say if setting it to 3 helps.


    • Edited by F. Kist Friday, February 12, 2016 9:15 AM
    Friday, February 12, 2016 9:14 AM
  • I know this is an old thread, but johnqflorida's suggestion fixed this annoying problem for me in Windows 10. Thanks!
    Thursday, May 19, 2016 2:33 PM
  • The fix that was suggested to me was so simple that I still don't believe it.

    Right click on the task bar and unlock the taskbar, then lock it again.

    This one worked for me except I didn't relock it.  Just a "kick" was sufficient.  Yet another years old, apparently ignored, windows bug worked around by frustrated user community.

    Monday, June 20, 2016 3:00 PM
  • This problem frustrated me for weeks and then I stumbled across the solution.

    See http://winaero.com/blog/turn-on-xmouse-active-window-tracking-focus-follows-mouse-pointer-feature-in-windows-8-1-windows-8-and-windows-7/

    Uncheck the option that forces windows to become active upon mouse over.

    Wednesday, August 17, 2016 12:46 AM
  • This problem frustrated me for weeks and then I stumbled across the solution.

    See http://winaero.com/blog/turn-on-xmouse-active-window-tracking-focus-follows-mouse-pointer-feature-in-windows-8-1-windows-8-and-windows-7/

    Uncheck the option that forces windows to become active upon mouse over.

    This was driving me nuts!! I tried this solution and it works!! You don't have to mess with the registry. A really simple solution.
    Friday, September 23, 2016 10:23 AM
  • God bless you dear Johnfrog ! It worked fine for me on WIndows 10 ! Have a very nice year !!!

    jbcv1957@gmail.com

    Saturday, January 7, 2017 11:25 PM
  • Wow Shawn, 70% of your answer was campaigning to get an upvote/points, while 30% of your answer was actual answer.  And as far as your answer goes, that's the laziest piece of crap answer I've ever heard.  You might as well have said "did you try restarting your computer? If this was helpful, please vote..."  You're a disgrace.
    Wednesday, March 22, 2017 6:54 PM
  • My system is a fresh install of Windows 10 Anniversary Release.  I have been having the same new window in background problem.   I found the ForegroundFlashCount set to 7.  I changed it to 3 per link below and it seems to have fixed the problem.

    https://answers.microsoft.com/en-us/windows/forum/windows_7-performance/windows-7-explorer-window-does-not-appear-in-front/1199682e-2415-4a7a-bf21-f57a972122ee

    Wednesday, May 3, 2017 6:44 PM
  • Perfect! Having this problem on Windows 10, never on Windows 7, worked first time. Thanks Terry, that was really bugging me.
    Wednesday, July 12, 2017 7:57 AM
  • This did the trick for me/my computer. Thank you for taking the time to post this helpful information!
    Wednesday, August 23, 2017 8:39 PM
  • This worked for me.
    Thursday, March 29, 2018 12:06 AM