Windows Easy Transfer and SaveData.MIG file not transferring!!!


  • My windows was bogging down so I decided to re-install.  I used windows easy transfer.  I actually got my windows easy transfer to create a SaveData.MIG file from my old hard drive.  I then erased the original hard drive to re-install windows and deleted all the original files in doing so (thinking the easy transfer backed everything up).  I then re-installed windows and attempted to transfer all my files through WET.  It makes it through the whole process, even shows me the files that are going to be transferred.  As soon as the transfer starts, it goes for about a minute and then "Migration Failed: WET is now closing".  I cannot get any further than this.  When I look under C:/users I can see where it starts to create the files from the old users from the old installation.  It fails somewhere. 

    I was hoping that we could somehow access this savedata.mig file PLEASE!!!!! It has everything in it!!!!  Pictures, music, contacts, EVERYTHING!!!!!  I read that you folks at MS have an internal tool to access this file.  Please help.  Oh, and by the way the SaveData.MIG file is 672gb big.


    (if anyone has any suggestions please e-mail me at

    Monday, August 25, 2008 3:13 PM

All replies

  • Hi Bruno,


    Yes, Microsoft has developed an internal tool to extract SaveData.MIG files. However, as your file is too big so that I have no way to receive it due to our forum support limitations. In addition, I can only use this internal tool but have no permission to provide it to you. Thank you for your understanding.


    Now I suggest performing a Clean Boot to test the issue


    Clean Boot


    1. Click Start, type "MSCONFIG" (without the quotations) in the Search Bar and Press "Enter" to start the System Configuration Utility.


    Note: Please click Continue if the "User Account Control" window pops up.


    2. Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).

    3. Click the "Startup" tab, click "Disable All" and click "OK".

    4. Restart the computer and test the issue.


    Note: Clean Boot is a troubleshooting step. If some programs have been disabled, we can re-enable them later. If you see the System Configuration Utility, check the box of "Don't show this message" and then click "OK".


    Please test this issue in the Clean Boot environment.


    If the issue persists, do you have another computer running Windows Vista? If so, please test whether we can restore the SaveData.MIG file to that computer.


    If it cannot restore either, I suggest contacting Microsoft Customer Service and Support (CSS) via telephone so that a dedicated Support Professional can assist with your request. Please be advised that contacting phone support will be a charged call.


    To obtain the phone numbers for specific technology request please take a look at the web site listed below:;EN-US;OfferProPhone#faq607


    I hope the problem will be resolved soon.


    Tim Quan - MSFT


    Wednesday, August 27, 2008 3:12 AM
  • I will try a clean boot.  Thanks for the tip.

    I was curious if you are on the Microsoft campus in Redmond, Tim?  I live just over the bridge in Seattle and would love it if I could drop off my hard drive to you.  That way you could access the file and hopefully restore some of my file.  I am most interested in my pics as they are irreplaceable.  I can always get my music collection built up again.  Let me know. 

    I will call support as my last resort.  I don't see it right I pay for a $500 OS and have to pay more to get it to work correctly.  Micro$oft owes me one in my opinion.  Thanks Tim

    Wednesday, August 27, 2008 11:03 PM
  • i have since been in contact with windows support.  It took about a month to discover something as wrong with the WET program and the .mig tool was released to me from a microsoft support person.  I am willing to share with whomever needs it.  Please email me at  I will be happy to help without a $60 support fee.
    Sunday, September 21, 2008 10:07 AM
  • Hi, can somebody please help. I've been trying to help my mother sort out a problem with her computer but unfortunately the only option was to reset it to the factory settings, i used the so called easy file transfer program saved everything, it told me it completed the save fine onto an external source reset the computer but the easy file transfer will not reload the files. They contain pictures of my dad before his accident, my late Grandmother and my kids when they were born, so as i hope you can understand my mother is devastated and i feel terrible because i put my trust in a program that just does not work :-( i need to extract the files from this .MIG file can someone please please help?
    its a standard vista home os.

    I checked out the link above but as I am in the UK and redundant i just cannot afford windows support fee's and quite frankly I dont see why i should have to since by the look of it its a common fault with this program designed to get more money from trusting people (sorry for the comment but between this and the so cxalled restore point that hardly ever works) I'm getting quite dissapointed in trusting microsoft with important things.
    P.s. Sorry about the essay ;-) 

    Sunday, September 27, 2009 1:37 PM
  • Hello, I have a story which is strikingly similar to that of Daveyoung_666 although the family implications are bit different.

    My father's HP laptop with Vista Home Premium needed to be returned to factory settings, so we created a data-set (about 10 Gb) with Windows Easy Transfer. The data is split in three file fragments img00001.mig, img00002.mig and img00003.mig. I suppose this is due to a limited max file size on the USB-stick we used.

    I have copied the fragments to 3 DVD's and to the hard drive in a folder on the desktop.

    When I initiate the load back with Windows Easy Transfer using the DVD's, the laptop starts to read dvd #1 while it counts up to 100%. Immediately thereafter it says something like " Error reading all parts of the media - Windows Easy Transfer will be terminated".

    If I initiate the load back using the before-mentioned files on the hard disk, Windows Easy Transfer does not recognise the files, and asks me to select valid files.

    I have tried renaming the files to .dat - no luck
    I have tried running Windows Easy Transfer load back in safe mode - cannot be done

    I suspect that it is one of Vista's own processes that is the cause.

    Tuesday, September 29, 2009 12:26 PM
  • Thank you for that Spanner64.  Sounds exactly the same as me.
    I've been passed around 3-4 er threads i think the term is but no-one really willing to help so far :-(
    If i find out anything i'll let you know.

    Wednesday, September 30, 2009 3:47 AM
  • Hi again Spanner64
    Still waiting for response on this issue there's a few more of us now on this link
    trying to get a response as we are not alone mate.

    Wednesday, October 28, 2009 4:12 PM
  • Hello everyone, you should be able to get it here: It worked for me at least to get serially named files with no extension. Apparently the file header was corrupt. But at the end I renamed all into JPG and the ones which were not showing as picture thumbnails I tried to change them into WMV. This is how I recuperated about 3000 items... (mostly photos and videos) I hope that helps!!!
    Gabriel Nesmerak MS Pre-Sales Engineer
    • Proposed as answer by GabrielN Tuesday, December 01, 2009 10:24 PM
    Tuesday, December 01, 2009 10:23 PM

  • You can can try to get the MIGRECOVER tool from here:

    I had some unexpected success to recover 3000 files (mostly pictures and WMVs) and renamed them after, while apparently the header of the MIG files were corrupted.

    I hope that helps!,

    Gabriel N.

    Gabriel Nesmerak MS Pre-Sales Engineer
    Tuesday, December 01, 2009 10:26 PM
  • Hi All,

    I am a Microsoft employee and this issue came to my attention when a family member recently thought he lost about 100 GB of personal files using Windows Easy Transfer (WET) while upgrading from Vista to Windows 7.  WET doesn't give any error message--it just won't open the file.

    The MigRecover utility posted at the link above appears to be an older version of the tool meant for accessing USMT3 files.  The newer WET tool uses a different (USMT4) format, which requires a more recent version of MigRecover to access.  I verified that I receive the same "c:\" prefix error many have mentioned above when using the old USMT3 tool.  Using the newer WET tool resolved that issue and worked great for the 100 GB store I was trying to recover.

    Unfortunately for legal reasons I am prohibited from distributing the tool outside of Microsoft, and just to be clear I am not on the team who made the tool (or that supports Windows or WET).  However, the tool may be made available in individual cases where the technical support engineer deems it an appropriate solution for specific scenarios.



    • Edited by ScotBrat Friday, December 18, 2009 5:55 AM
    Tuesday, December 15, 2009 11:46 PM
  • Hi Scott,

    I commented to another similar post of yours on this site where you provide similar information.

    In my case I successfully used WET to transfer files from my Widows 7 64bit OS to an external hard drive.  I then reinstalled Win 7 with a clean install thus deleting all files from the former install.  I naturally assumed that WET would work to transfer all files back to the new install of Win 7 64bit.  I repeatedly receive the same msg: Windows Easy transfer coudn't open this file.  WET cannot open its own file that it created.  I do not understand that.  It is over 150GB of important personal data.  It should be simple but it is not.  Every time I try to open the MIG file, I receive the exact same results.  Nothing but the msg.

    If you find out anything, I surely look forward to your response.

    Sincerely grateful.
    Thursday, December 17, 2009 8:29 AM
  • Thanks, Scott.  I will try it out and let you know.  I have little time at the moment, but I will likely approach this late tonight or tomorrow.  Thanks.
    Thursday, December 17, 2009 5:14 PM

    This process worked for me.  I recovered my files.

    Thank you.
    Friday, December 18, 2009 8:11 AM
  • What is the largest file you can recieve?   I have a 5+ gig MIG file ( encrypted) that I'd really like to recover...

    and or have things changed and now the mig tool has been released..!!!!!


    thanks in advance


    Saturday, August 06, 2011 4:04 AM

    This process worked for me.  I recovered my files.

    Thank you.

    This tool doesn't work with encrypted .Mig files. I've made .MIG 1000 Mbytes archive and 100% sure with the password but this utility didn't help me: all the files extracted are  marked as <filename>(corrupt)
    Friday, May 18, 2012 11:49 AM