none
Can't Install IIS

    Question

  •  

    I have SP3 and all updates installed. When I tried to install IIS, I get the error message "Setup cannot copy the file staxmem.dll" It then asks me to insert the Windows XP Service Pack 3 CD and points to the following location to copy files from - "c:\windows\ServicePackFiles\i386"

     

    I have no SP3 CD, so I downloaded and installed and a new staxmem.dll file but I still get the same error message when I try to install IIS. How do I get IIS to install?

     

    Gary Phillips

    E-mail: garyp@marketinginformationtechnology.net

    Mobile Phone: 412-215-9076

    Monday, August 25, 2008 1:56 AM

All replies

  • If SP3 has installed correctly, there should be a staxmem.dll in c:\windows\ServicePackFiles\i386

    Do you in fact have one there?  If not, if you search your entire system for staxmem.*, where do you find any?

    Monday, August 25, 2008 10:40 AM
  • Yes, The staxmem.dll is in the C:\Windows\ServicePackFiles\I386 folder. Again, as I stated previously, this is where I installed a new staxmem.dll file. IIS still will not install, Now what?

    Tuesday, August 26, 2008 11:50 PM
  • You can't use just any old staxmem.dll that you found on the internet.  It must be the one installed there by SP3.  If you have overwritten it with a different version, then you will not be able to install IIS.

     

    Wednesday, August 27, 2008 9:18 AM
  • OOPS! The reason that I did downlad a new staxmem.dll file was that I was getting the error message. Is the fix to unistall and reinstall SP3? If so, what is a safe procedure to use to do this?

     

    Wednesday, August 27, 2008 8:38 PM
  • Go to Start > Run and type CMD
    In the Command Prompt box type in the following;

    esentutl /p %windir%/security/database
    /secedit.sdb

    Then try the install again
    Thursday, September 4, 2008 4:47 PM
  • I had exactly the same problem and fixed it by follow choon3's advice. Thanks guy. Great Advice.

    Jethro Arenz

    Thursday, October 11, 2012 10:19 AM