locked
WINDOWS 7 BUG: Explorer Locks "thumbs.db" in most recently viewed folder

    General discussion

  • I have been able to recreate this error a number of times, but I can't seem to figure out the exact scenario need to do it. But basically here is what happens.

    I'm browsing a folder on the network and viewing different sub folders within it. If I browse into a folder contain images and then immediately back out of the folder, and then follow that with an attempt to delete the folder, I will have the following problem:

    "The action can't be completed because the file is open in Windows Explorer. Close the file and try again."

    "Thumbs.db" ... etc



    I can recreate this only with folders that contain images immediately within the folder. Basically, I think Explorer is creating the thumbs.db file or accessing it and it is locking that file so when you back out of it and then attempt to delete the folder, "thumbs.db" is still locked and so the folder can't be removed. Keep in mind that all the other files STILL get deleted, it's just struggling with the final system file "thumbs.db" that Explorer is locking. I assume that the bug is in the fact that Explorer doesn't close the file down or unlock it once you back out of the directory.

    NOTE: When you do the same thing as above (browse into a folder with images, then back out) but then browse into another folder with images and backout again, you can't delete any of the two folders without the error happening once.
    Wednesday, November 18, 2009 5:35 PM

All replies

  • Hi Britton,

    Coulc you please try to take the following steps to troubleshoot this issue?

    1. Run gpedit.msc
    2. Navigate to Local Computer Policy->User Configuration->Windows Components->Windows Explorer
    3. Set "Turn off the display of thumbnails and only display icons on network folders" to Enable.

    Then, try to test this issue again.

    Does it work?
    Friday, November 20, 2009 7:58 AM
  • Robinson,

    The workaround you suggested seems to fix the issue.  Additionally, you can:

    * Press Alt + F, from the Windows 7 Explorer interface
    * Select Tools
    * Select Folder Options
    * Select the View tab
    * Check the box that says "Always show icons, never thumbnails"

    This seems to fix the issue as well.  So it seems this feature is causing issues and this feature is enabled by default.  So, any idea when this will be fixed as it's a handy feature, but no sense in leaving on if it doesn't actually work.

    Nathan

    Tuesday, November 24, 2009 3:30 PM
  • Sorry, I don't have a solution, but as far as the two "solutions" provided so far, they are not solutions, but rather a work around with sacrificing of the OS features.
    These solutions are not acceptable as a concept. It's like offering using DOS instead of explorer...

    MS should address this as a bug...
    Monday, December 21, 2009 2:20 PM
  • This is a major bug - I recreate it all the time being a web designer - its quite annoying when you copy and paste a folder, try and change its name only to be given this error saying its 'in use'.. So you end up with multiple copies of folders that you cant delete...

    As vanowm said - the above ISNT a solution - its a workaround.

    Fix it.
    Sunday, January 24, 2010 11:42 PM
  • I agree this problem and its various affects are all over the internet and at the end of every thread there are no Microsoft solutions.  This has been a problem from the beginning and either they can't fix it or they are ignoring it.  I have to remote desktop into my server everytime I am modifying or moving folders so I can kill the open file connection so that it will actually let me delete or rename the folders.  I hate to say it but I think XP was the last great OS Microsoft is going to put out, they keep adding features I don't use that break basic features that I do use (renaming folders).  Sorry to rant but I have struggled with this problem for 4 months and am sick of waiting for a fix.
    Sunday, February 07, 2010 8:54 AM
  • Hi,

    I experience the same issue with my Win7 install and it's extremely annoying.

    I am quite surprised actually that "disabling thumbnails" is the first suggestion by the Microsoft moderator. So is it common practice when someone has trouble with a feature, to simply disable the feature? Disabling thumbnails, of course, causes all pictures to look like basic icons unless they are explicitly previewed. This is certainly not a fix. It's like trying to suggest someone turn off the screen saver if they are having problems with the screen saver. Why not just tell the users to turn off their computer? Problem solved right? LOL You should just admit it's a bug! It sure looks and smells like one.

    BTW - I dual boot with Vista64 and Vista doesn't have this problem. I have a huge music collection that I've been sorting for the last few months. I installed Win7 shortly after it was released and noticed this issue immediately, I can even delete the entire contents of the folder first but Win7 can't delete the empty folder because it says thumbs.db is open (I'm wondering why a thumbs.db file exists when there are no files left to cache?). I eventually noticed if I wait a few minutes or so after viewing the folder I am then allowed to delete the folder, but the fact I have to do this is ridiculous. I've been booting into Vista to sort my music so I don't have to go through this little dance every time.

    I certainly hope Microsoft will realize this is a HUGE annoyance regarding a very basic feature of their flagship OS and start addressing the issue. Most people don't know enough about their computer to have any idea why this is happening. I had assumed a patch would come out relatively soon because the issue is ubiquitous, but no luck so far. Come on guys, get on it! This thread was opened nearly 4 months ago, so you've had PLENTY of time.

    Thanks and happy debugging :)

    Kelly
    • Edited by KelJow Saturday, April 03, 2010 4:03 PM
    Wednesday, March 03, 2010 7:40 PM
  • I might have found a better work around but would need someone to confirm.  I found that Adobe reader was the culprit for this issue for me.  I installed Foxit PDF and made that the default for PDF's.  It doesn't quite add up because in theory excel and word shouldn't have anything to do with Adobe, but it solved the issue for me.  Let us know whether this works or not for you.  It still allows you to use the preview and gets the response time you'd expect. 
    Thursday, March 04, 2010 3:48 PM
  • YES!!! Good job Geigerdi!!

    I uninstalled Acrobat, restarted, and now have NO problems with deleting folders in any of my network locations. I made sure I tested this with about 10 folders, both full and recently emptied. I received no errors and in each case the folder deleted immediately.

    That's about the weirdest thing, why on earth would Adobe Acrobat have anything to do with explorer releasing the thumbs.db file?

    Microsoft dev's: Do you have any idea how this could be possible? I did not have Adobe running at startup, so purely it's existence as an installed application seems to cause this issue.
    Friday, March 05, 2010 12:11 AM
  • I just found another very interesting tidbit of information.

    I thought I'd try to re-install Adobe reader to see if the issue could be reproduced. Using Firefox, I went to the adobe download site, installed Adobe reader and the issue did not return. I restarted my computer, opened a pdf from the internet and the issue did not return. I opened IE and found a pdf document, with a pdf open in Firefox and IE the issue did not return.

    So, now I've got Adobe reader installed and the issue has completely disappeared... just by uninstalling and re-installing Adobe reader.

    I'm absolutely dumbfounded that this has solved my problem, and also quite ecstatic that I no longer have to boot Vista for any reason whatsoever.

    THANK YOU!!!
    Friday, March 05, 2010 6:47 AM
  • That is great news.  So the new fix is to remove Adobe reader and re-install it. How bizarre. 
    Friday, March 05, 2010 3:35 PM
  • what if you dont have reader but acrobat?
    Saturday, March 27, 2010 2:47 AM
  • Are you asking this because you are also experiencing the problem?

    From my experience this issue seems to be related to Adobe updates, so it may easily affect other Adobe products. I have uninstalled and re-installed Adobe about 3 times since my first post to resolve the issue, because the issue keeps coming back after Adobe updates. Luckily it's not that huge of a pain and it doesn't happen often enough to really annoy me.

    It would be nice if the "Microsoft developers" would check into WHY this is actually happening because it may not be isolated to Adobe. The fact that this changes the function of the O/S beyond the function of the application should be a clue that there is something fundamentally wrong.

    Sure, it's a small issue. But still, it's an issue with Win7 and Win7 only.

    Tuesday, March 30, 2010 3:45 AM
  • I don't have *any* of Adobe's dreadful bloatware installed on my Win 7 machine (never have) and still have this problem. This is a brand new (64 bit Ultimate) Win 7 install. So I don't think it's directly related to Acrobat.

    As the original poster said, this problem is specific to folders that have images and build a thumbs.db file. Under some circumstances, that file stays locked even when there are no folders open. Process Explorer specifically shows the thumbs.db file STILL OPEN even when there are no explorer file folder windows open on the entire system.

    THIS IS CLEARLY A BUG. It would be nice if one of the Dev's or someone at MS would comment on this rather obvious problem?

    In fairness to MS, Win 7 is still relatively new, so these sorts of problems probably are a fact of life. But the right thing to do is acknowledge the problem, get in on the list, and get a fix out in a reasonable amount of time.

    There is another workaround while still keeping thumbnails. If you simply re-boot, or just log off your user account (if applicable), the file is released and you can delete the folder. But when you have dozens of windows/apps open, and are the middle of work, this is hardly an acceptable solution.

    So how about it MS? Is this a known problem? Is a fix in the works?

     

    PS - To you Acrobat users, dump Acrobat for PDF XChange. You'll be *very* glad you did! It takes a small fraction of the resources, is faster, works perfectly and doesn't mess up other parts of your system. Acrobat has gone down hill since about Version 6.

    Wednesday, March 31, 2010 9:03 PM
  • So, if you're not using "any" of Adobe's products, does that include Flash and Shockwave? I'm honestly surprised by your aversion for Adobe products. Although Adobe reader takes up a couple hundred megs on the drive (not unusual for any modern software), it rarely uses more than 10MB of memory (I have 3 large PDFs open at the moment and the app is using only 8MB of RAM). Also, I've never noticed any performance problems with the software on any modern (P4+) computer with a decent amount of RAM. It seems to work great on all my machines, I have no complaints.

    Assuming you are using Flash or Shockwave, the updates still may have caused this issue on your system, it's worth speculation anyhow. We're still not 100% clear on how this is possible, but it's worth a try removing and re-installing them.

    The original poster did not say the problem is "specific" to folders with pictures, he was simply giving an example of his experience. The issue is certainly not isolated to that example. I have been experiencing the issue with folders on a network share containing only music, with no images whatsoever. As I said before, it's strange that thumbs are created for music files in the first place, since the icon looks no different if you turn the thumbnail preview feature off. It seems Windows 7 is generating thumbnail files on network locations regardless of the need to create them, which is why this issue is especially annoying to me.

    Instead of logging out or restarting, you can also wait a few minutes and the file will be released. Just don't view the contents of the folder before you delete it or else you are re-opening the thumbs.db file and putting it back into use. I've found on average the thumbs file is released after about 3 minutes.

    Saturday, April 03, 2010 3:56 PM
  • FWIW, I accidentally came across a slightly easier fix for this bug.  Instead of setting "Turn off the display of thumbnails and only display icons on network folders" to Enable, I simply changed the Windows Explorer display setting from "Details" to "Content".  Then I was able to delete my Thumbs.db files without any complaints from Windows 7, even though I have thumbnails enabled.  After deleting the offending file(s), I just restore the display to "Details" again.
    Monday, April 05, 2010 7:32 PM
  • Easiest fix for local folders (I have no idea on network folders) is simply to right click computer click properties go to advanced system settings and then advanced click settings under performance and click adjust for best performance. It takes two seconds and once your done playing with your folders just turn it back to "let windows choose" It's still annoying but it works.
    Monday, April 12, 2010 7:18 PM
  • It would be nice if one of the Dev's or someone at MS would comment on this rather obvious problem?

    That's so true in general, yet is simply not the way Microsoft works.

    I think the best workaround to this bug is to disable the use of Thumbs.db files entirely.  For those of you with Windows 7 versions that contain the Group
    Policy Editor, here's how:

    ·    Click the Start orb

    ·    Enter gpedit.msc in the search box and hit Enter.

    ·    Expand User Configuration - Administrative Templates - Windows Components.

    ·    Click on Windows Explorer.

    ·    Right-click the entry "Turn off the caching of thumbnails in hidden thumbs.db files" and choose Edit.

    ·    Enable the setting.

    -Noel

    Monday, April 12, 2010 7:38 PM
  • I am having this same problem, but with an .mkv file.  I have tried everything suggested here and I still can not delete the file.  Any suggestions?  I have also tried unlocking the file, and tried taking ownership of it, running in safe mode, etc.  Nothing is working to get this file off my Win 7 64 bit system.

     

    Alli


    MS Beta Butterfly
    Tuesday, May 04, 2010 12:56 AM
  • I am having this same problem, but with an .mkv file.  I have tried everything suggested here and I still can not delete the file.  Any suggestions?  I have also tried unlocking the file, and tried taking ownership of it, running in safe mode, etc.  Nothing is working to get this file off my Win 7 64 bit system.

     

    Alli


    MS Beta Butterfly
    Try opening up the task manager and ending explorer.exe. Then open up command prompt and browse to the file and delete it from there. When you're done just re-open your task manager and run "explorer.exe" again. That usually works for .mkv files though I have had it not work before.
    Monday, May 31, 2010 5:16 PM
  • Could you be more specific about what you've tried? It is difficult to believe you have tried "everything suggested," because if you have, your issue would actually be different than anyone else on here. We have all been able to workaround this error somehow.

    At the very least, turning off thumbnail caching (using the post just above yours) should stop the machine from using the thumbs.db file completely. If you are still experiencing the issue after doing that, I would imagine there is something more fundamentally wrong with your o/s.

    Can you cut and paste the file somewhere else? Can you rename the file? What happens when you select "Always show icons, never thumbnails" in folder options, view tab?

    Nonetheless, this shouldn't be happening at all. Everyone should be able to delete folders and files without running into this problem. Unfortunately, workarounds are all we have at this point; even from the Microsoft folks :(

    Tuesday, June 01, 2010 4:14 PM
  • I just found another very interesting tidbit of information.

    I thought I'd try to re-install Adobe reader to see if the issue could be reproduced. Using Firefox, I went to the adobe download site, installed Adobe reader and the issue did not return. I restarted my computer, opened a pdf from the internet and the issue did not return. I opened IE and found a pdf document, with a pdf open in Firefox and IE the issue did not return.

    So, now I've got Adobe reader installed and the issue has completely disappeared... just by uninstalling and re-installing Adobe reader.

    I'm absolutely dumbfounded that this has solved my problem, and also quite ecstatic that I no longer have to boot Vista for any reason whatsoever.

    THANK YOU!!!
    I cannot reproduce this fix. I have tried a fresh Win7 install, never installed Acrobat Reader but went straight for Foxit (my preferred anyway), but still have the lock problem. Guess i just have to turn of the thumbs.db caching as mentioned but someone else
    Sunday, July 11, 2010 7:17 AM
  • Robinson Zhang.  How exactly is this 'troubleshooting' the problem?  By turning off the feature that should work in the first place?
    Wednesday, August 04, 2010 3:07 PM
  • This did not work for me.  
    Saturday, August 14, 2010 7:33 PM
  • I got a fix that works for me now.  Background, I am deleting video folders from a shared network drive on my WHS from a Windows 7 x64 client machine.  

     

    My fix:

    1. Right-click on the top folder

    2. Select Properties

    3. Click on the Customize tab

    4. Select Optimize this folder for: Videos.  

    5. Check the box next to "also apply this template to all subfolders."  

    I still get the warning box when deleting the thumbs.db file within the folder, but hitting "Yes" results in successful deletion.  Yay! 

    Added benefit, I can still see the picture when in the videos folder, so I'm not just staring at a list of text.

    I hope this helps others.

    Saturday, August 14, 2010 7:49 PM
  • To delete the thumbs.db file change the view to icons and then Windows will allow you to delete it.

     

     

    Tuesday, August 17, 2010 5:22 PM
  • Zelda: Thanks - that seemed to work well enough and I didn't have to play around with the settings. One note, it didn't work with the "small icons" but worked with the "medium icons".

     

    Wednesday, September 08, 2010 6:56 PM
  • And what exactly does your recommendation have to do with this thread and a possible solution? I suggest everyone avoid the above link as it was a spam/attack site.
    Wednesday, December 08, 2010 12:48 PM
  • That's a good tip Zelda...

     

    this is still a bug though.. I've tried all the combinations of size or format/delete and the only ones I found to work were

    Display formats that DO work - ICON in size Med, Lg, XLg only, and the Content option

    Display formats that do NOT work - Details, list, Tiles, and Sm icons

     

    These little thumbs.db are extremely annoying. They're like little turds MS drops along the way, taking up storage, messing up file counts and folder sizes when doing compares, they stick to files/folders even when not wanted, and until now, they have been problematic to remove.

    My solution up until now has been going to an XP box, searching for these little turdlets, and deleting them all "en masse". I was unable to flush the bowl in Win7, because even after searching for all instances, it would always refuse to destroy the last one no matter what I did.

    In my tesing today, I found that even in the search results, if you change the display format to a "deletable format" - must be something other than the default (details?) - you can eliminate all the turdlets..

     

    N.B. - Adobe used to leave multiple Bridge turdlets in every folder it touched. They ultimately reduced it to one file, but they have always been "deletable"  when desired, regardless of explorer's viewing format. Take a lesson MS, there is a bug here...

    Wednesday, December 08, 2010 1:16 PM
  • That solution worked for me. I had problems with mkv files on my desktop...

     

    http://mintywhite.com/windows-7/7maintenance/delete-file-command-prompt/

    Thursday, December 09, 2010 5:30 PM
  • All the workarounds on this page basically involve having Explorer stop paying attention to thumbnails temporarily.  They're not fixes, but workarounds, and until MS actually fixes this, the solution is to find the least annoying workaround.  For me, robster8192 is the best - works (so far), and takes two clicks without having to leave the view or navigate any dialog boxes.
    Sunday, December 12, 2010 4:01 PM
  • Temporarily?  I think not.

    The real solution is to stop using Thumbs.db files entirely and permanently.  I've shown how above.

    They're only needed for compatibility with old stuff.  Windows 7 doesn't use them to manage its thumbnails any more.  That's done with a central thumbnail cache.

    -Noel

    Monday, December 13, 2010 10:19 PM
  • non of the above fix resolve my issue with .mkv files...damn annoying!
    Wednesday, December 15, 2010 10:44 AM
  • Removing all of my adobe installs did the trick for sure- i was having an issue deleting files on my work network. I am running Win7 at home too with a network drive and having the same issue. It has been driving me mad so I am glad I found a fix here. I was doing side work at home and backing up user data to the drive and couldn't delete all the files so I have all kinds of folders cluttered up! Thanks.
    Monday, December 20, 2010 5:27 PM
  • Hi there! I got the same problem several hours ago and I found the solution!

    http://lockhunter.com/

    This tool did the trick!

    Saturday, January 01, 2011 4:30 PM
  • That will work but it's not a solution it's a work around.

     

    MS REALLY need to fix this annoying issue.

    Friday, January 14, 2011 2:41 PM
  • Here's another work around solution.  All I had to do was click the button that hides the preview pane.  Once explorer is no longer looking to preview your file, it doesn't have to start thinking that thumbs.db is going to be locked.  Easily turned off and on.
    Wednesday, January 19, 2011 7:38 PM
  • I see there have been a number of replies on how to workaround this bug. Sadly none of them actually worked for me. Additionally, none of them seem to work 100% for all users.

    This solution works 100%, regardless of what actual process has the file locked.

    If you are trying to move or delete a folder, and thumbs.db is locked by another process, you need to first find out which process has that file locked:

    1. Install Process Explorer from SysInternals if you do not already have it installed (Process Explorer is a free app distributed by Microsoft, you can download it here: http://technet.microsoft.com/en-us/sysinternals/bb896653

    2. Run ProcessExplorer and go to Find > Find Handle or Dll...

    3. Search for the name of the folder you are trying to manipulate. It will take a couple seconds, but Process Explorer will eventually find the culprit or culprits.

    4. Click on the result in the Find window. On the main Process Explorer window the Process and handle will be highlighted. 

    5. Try to right-click on the handle and "close handle" This will likely not work. 

    6. If step 5 works, you can now go and manipulate the folder as you wanted. If step 5 did not work, right-click on the process itself on the top pane of ProcessExplorer and choose "Kill Process."

    7. If step 6 does not work (if you cannot kill the process) then you will likely need to reboot. If step 6 kills Explorer.exe and Explorer.exe does not restart on its own in a couple seconds, you can restart explorer.exe yourself by going to File > Run, and typing in Explorer.exe.

     

    These steps will close any program that may have your folder locked. In my case, it was Picasa which had my files locked.

     

    Additionally, the process outlined above will work for *any* file which is locked, not just thumbs.db.

     

    Note: please upvote this answer, as it is the only one I've seen on this thread which will actually solve the problem regardless of which application has a lock on that file.  Thanks.

     

    Wednesday, February 02, 2011 5:59 PM
  • Patrick, that solves the symptom, but the problem of a program locking thumbs.db (in your case Picasa) remains.  However, identifying the players could help lead more directly to a solution (e.g., getting a new version of Picasa, or just stopping using it).

    And regarding no other proposed solution fixing the problem, I'd dare say stopping the use of thumbs.db files entirely cuts rather more to the core than your proposal.

    -Noel

    Thursday, February 03, 2011 9:31 PM
  • Your solution is great Noel, and correct, save for the fact that it leaves out anyone who utilizes Windows 7 Home edition (which is the version pre-loaded on a lot of machines)...
    Friday, February 04, 2011 3:59 AM
  • Your solution is great Noel, and correct, save for the fact that it leaves out anyone who utilizes Windows 7 Home edition (which is the version pre-loaded on a lot of machines)...
    I posted the .reg file equivalent of that group policy workaround here: Thumbs.db being accessed by Windows Explorer - folder cannot be deleted

    Can you see if it works on the Home edition?
    Friday, February 04, 2011 4:37 AM
  • Works on Home edition like a charm! Like most of the fixes on MS, it needs a surgery to remove the cancer.

    Win7 has been a major disappointment so far, the too-shiny task-bar is terrible I have to install an application not to have tabs stick together on task-bar, a simple task such as changing the background to solid balck caused a bug to fire, ...!

    No wonder apple is taking their position

    Friday, February 04, 2011 11:03 PM
  • Nice job ferreting out that setting, JoeBoxer.

    -Noel

    Saturday, February 05, 2011 12:54 AM
  • Glad to hear it's working. And thanks, Noel.
    Monday, February 07, 2011 6:51 PM
  • When I was trying to delete a folder (auto-created by my scanner for my scanned images which I then moved) it didnt mention anything about thumbs.db just said the file or folder was being used by another program.

    How I stopped it;

    Try to permanently delete the folder (shift+delete)

    This then tells you what file is being used and what is using it (in my case, thumbs.db & Desktop Gadgets)

    Go close that program and then delete

     

    I have no idea why Desktop Gadgets was using anything in that folder but once I unchecked view gadgets the folder was deletable.
    Just my experience, plus I'm the kind of person that doesnt like to install programs or mess with settings.
    I like my thumbnails and would like to see this fixed by microsoft

    Friday, February 11, 2011 2:05 AM
  • Hi Everyone, I have done almost everything people have suggested, that includes the following:

    - Remove thumbnails

    - Use Unlocker - Un-install then re-install Adobe Reader

    - I have tried Patrick Burrows Method

    - I ended Windows Explorer process (However I can not open my download folder because my tool bar disappears)

    You Name it I have done it. Here is the low down I have a MKV Video file(s) that are locked in my download folder, they work fine as in when I play them they play. However every time I try and rename, delete or move the file it says "the action cannot be completed because the file is open in windows explorer" am at the end of the road, can't figure out why it's happening. Just wanted to tell you with Patrick's Method I can see that when I delete the file it seems like the file opens up by it's self, opening 2-4 files at a time. Is there anyone that knows how to fix my problem? If so please write back ASAP!!!

    Sunday, March 13, 2011 11:08 PM
  • I was able to get rid of this issue by right click the lower preview pane in explorer as mentioned and changing it to Size -> Medium instead of Size -> Small. I haven't had this issue ever on my laptop and it just recently occurred. I did recently update from Adobe 9 to Adobe X. Come on Windows, this is stupid. We shouldn't have to Google search your site to find out how to delete folders on our own computers to which we have administrator accounts.

     

    For those curious and looking at this issue:

    Windows 7 Home Premium SP1 (x64).

    I install all relevant optional updates and all required updates on a daily basis through Windows Update. 

     

    Can we really not just put out a fix for this bug?

    Tuesday, March 29, 2011 6:41 PM
  • Disappointed that SP1 hasn't even fixed this annoying issue.
    Tuesday, March 29, 2011 8:28 PM
  • Only consider doing this if you are at your wit's end!

    I had a problem that started with an MKV file and shortly thereafter it happened, again, with a 2011 Family Tree file with an FTM extension. I resolved my problem with a draconian solution.  Rebooting the Win7 machine DIDNOT free the files. I booted the computer with the Try-me feature of Ubutu 10.10 (linux-GUI) and I did a CUT of the files to my flashdrive. I retarted the computer and allowed Win7 to boot and did a cut/paste from the flashdrive of the files back to the original location on my hard drive. 

    Very, very draconian; but, it worked. I will admit that the problem first started when I attempted, unsuccessfully, to rename an MKV file.  I have Adobe Reader and Win7 Home Premium SP1 and haven't had any issues in more than two weeks. 

    Wednesday, April 13, 2011 1:18 AM
  • The very same thing happened to me when dealing with large MKV file (1.49 GB to be precise). Anyway what I wanted to do is to move it into another folder after witch that error came up. Half an hour later, totally mad, i tried to delete it but an error keep coming up. And then half an hour after that I came to a conclusion:

     

    1. Started TC UP(Total Commander)

    2. Opened Windows Explorer Task Manager

    3. Killed explorer.exe process

    4. Switched back to TC and moved that damn file

    5. Started explorer.exe process again

    Monday, April 18, 2011 7:36 PM
  • Can we really not just put out a fix for this bug?


    You do realize the fix is in this very thread.  Just turn off generation of thumbs.db and you won't see this problem.

    It's only there for compatibility with old shell extensions or apps that expect thumbs.db files, and most folks don't have such apps.

    -Noel

    Tuesday, April 19, 2011 3:44 AM
  • The steps I normally take to work around this issue:

      1.  Copy the folder.

      2.  Delete the contents of the original folder location, excluding thumbs.db

      3.  Delete the original folder.

    Haven't had a situation where this doesn't work (yet!)... but gee I'd love MS to fix this problem.

    HTHs

     - Brad

    Tuesday, April 19, 2011 4:23 AM
  • but gee I'd love MS to fix this problem.


    Y'know, I'm starting to understand why Microsoft thinks of their users in the way they show in their moronic commercials.  Brad, did you even READ what was *just above* what you posted?

    -Noel

    Tuesday, April 19, 2011 3:08 PM
  • No it's not.  As only Windows 7 Pro upwards has GPEDIT.  What are others suppose to do?
    Tuesday, April 19, 2011 6:27 PM
  • Did you happen to notice the registry tweak listed above as well?  Look for the post by joeboxer.  Even though you didn't pay for a version of Windows with the capability of turning off Thumbs.db generation, it can be accomplished.

    -Noel


    Tuesday, April 19, 2011 6:49 PM

  • Y'know, I'm starting to understand why Microsoft thinks of their users in the way they show in their moronic commercials.  Brad, did you even READ what was *just above* what you posted?

    -Noel

    Hey Noel.  I'm a software designer for my company (and can read).  Do you want to guess what every user calls it when my software throws an error, even when there is a workaround? A workaround does not stop a bug from being a bug... it just lowers it severity.  If it walks like a duck and quacks like a duck... then it is a duck.

    And whilst I'm competent enough to edit the registry, not everyone who is experiencing this issue is.  Many people work for organisations that lock down their registry access.  Other organisations have to put Group Policy changes through a change management process that may take months.  A registry hack is not a solution for many people.

    Lastly, where did you get your information from that thumbs.db is only used for compatibility with old shell extensions?  Me thinks you need to do a little more research before making such assertions...

     - Brad

     

    Wednesday, April 20, 2011 12:16 AM
  • Lastly, where did you get your information from that thumbs.db is only used for compatibility with old shell extensions?  Me thinks you need to do a little more research before making such assertions... 


    I'm speaking practically, from actual experience.

    I have had Thumbs.db generation disabled since running the Windows 7 RC back in '09, then going to the RTM.  Absolutely everything works without Thumbs.db files present, and my thumbnail views come up nice and fast.  As far as I'm concerned, there's no practical downside to this configuration change.

    Here's some research for you:

    Windows 7 stores its thumbnails in a centralized database.  This is a design change from Windows versions prior to Vista, which DID have a design bug that sometimes caused interference with user operations, especially with file deletions.  The cache in the recent versions of Windows is stored at %userprofile%\AppData\Local\Microsoft\Windows\Explorer as a number of files with the label thumbcache_xxx.db (numbered by size); as well as an index used to find thumbnails in each sized database.

    From the wording of the Group Policy setting:

    "If you enable this policy setting, Windows Explorer does not create, read from, or write to thumbs.db files".

    If it wouldn't work, you think Microsoft would give you a setting with which to disable it?  Clearly they realized it was a bug way back, and have already provided a way to configure it to work properly.  They just don't make it the default for compatibility reasons.

     

    And here's a suggestion:

    If your IT department won't allow you to set that GPO entry, or edit your registry, write up a memo to your boss outlining how much time each day you could save from doing workarounds if IT would allow (or make for you) the simplest registry change.  I've worked in some pretty bad places, but it was always possible to get people to sit up and listen if management was told what they were forcing you to do was costing extra money.

    -Noel





    Wednesday, April 20, 2011 7:05 PM
  • Thank you Patrick!

    I tried the other options mentioned here, but as a Home Premium user, I do not have access to gpedit.

    It was also Picasa that locked my folders. In fact, it locked a completely empty folder for no apparent reason.
    I have been using the sysInternals suite for a while, but have not found all the strengths yet I see :)


    Wednesday, April 27, 2011 11:26 AM
  • I couldnt delete the files. but using task manager and ending the process "explorer.exe" and using MS DOS (start,run, cmd) to delete the files. This worked for me!:D
    Sunday, May 01, 2011 11:36 AM
  • I am an architect and graphic designer. I was just moved from XP to Windows 7 by our IT people and am seriously dismayed that I can no longer show a file in a window as a flat image, that is as the thumbnail picture that sat on the flat folder in Windows XP. Being visually and spatially  oriented, I counted on seeing the array of selected images representing files (of files of files...) to be the most useful and vivid means for me to organize my data. Now that thumbnails are not even a primary option, as they were in XP, I not only have to suffer from the idiosyncratic ways folders, files, icons, and thumbnails seem to take on a life of their own,as this thread has been discussing, but in addition have to wade through the visual garbage of these half-opened folder icons that hide a good part of the thumbnail I used to look at completely.

    So, (a) is there any way at all to view files as Thumbnails only, (b) is there any way to eliminate the folder icon that obscures the image I get when I "customize" the folder, and (c) is there any way to make this image flat,m rather than as an angled stand-up cardboard version of itself?

    I cannot understand why this was all eliminated from any user-friendly mode in Windows 7, when it was so easy to manage and use in XP. It would have been nice to have been able to simply choose thumbnails in View directly, and see both files and folders in that mode, as it was in XP. Is there no way to restore that capability?

    Monday, May 02, 2011 10:51 PM
  • Sadly, no, you can't have it the old way.  I think it's been changed primarily because it's easier to change the way things look to give a "new and improved" impression than it is to change the way they work and accomplish the same thing.

    I'm a little confused what you mean by "Now that thumbnails are not even a primary option, as they were in XP" though...  Have you tried "Large Icons" view?

    -Noel

    Tuesday, May 03, 2011 3:51 AM
  • Thank you Noel for your quick response. Yep it is sad.

    The new improved seems to have overlooked a lot of visual ordering options that were available on XP< or at least I can't find them. For example, in the File Organize and File View options, I have not been able to find a way to have NO sorting criteria applied, so I can move the icons and file images around within that file's window, as I used to. This may not make sense to someone who is thinking about content options in terms of titles, dates, and so on, but is very useful to someone who wants to organize things by how their visual qualities group-- for example in your selection to put the 10DSky, Moon Mosa, 2,20 Gamma items next to each other in the set, without any Amigos or Sebrings between them. In other words, is there anyway to turn off what used to be called "auto-arrange"?


    Yes I am familiar with the Large Icon option. Regarding thumbnails in XP what I meant was that XP allowed you to choose an image as a cover for the file folder, which would lie flat (rather than being opened at an angle, as in Vette Prints, Wild Bird Contest, etc in your example.) This allowed the entire window to be composed of frontal images. In a way, it made file management for me more visually compact, since I would find a single image that triggered my sense of the order of the subset of folders and files within. It may be a small thing to some, but I was able to compose each level as a nine-square grid of vivid but distinct images.It was like arranging rooms in a floor plan, and it worked very well for me. That spacial way of ordering memory has a venerable history-- see Frances Yates The Art of Memory 1966, and more recently Moonwalking with Einstein by Joshua Foer, not to mention the old MIT study Spacial Data Management.

    I'll have to get XP restored on this computer to get you a screen shot of what I mean, but at the moment I fear doing that since everything may well be scrambled again. In my case, the way things look is also the way things work.


    Jonathan Friedman
    Thursday, May 05, 2011 2:40 AM
  • Nope, you can't disable "auto arrange".  That's been discussed many times, and Microsoft has simply decided we'll have it their way or go buy another OS.  Fortunately (for me) I never got used to arranging things visually in folders, so the loss of "manual arrangement" didn't bite me hard. 

    Funny thing...  It DOES work on the desktop still, which I use.

    I've run across a (registry?) hack somewhere online that makes it possible once again to manually arrange your icons in folders, if you want to take that approach.  I don't know how well it works, but I'm 100% sure I've seen it documented.

    Regarding your being able to use XP...  I kind of misspoke before about "having it the old way"...

    Rather than restoring XP on the system, consider getting Windows Virtual PC and XP Mode (free downloads from Microsoft).  Then you can boot up XP as a virtual machine inside your Windows environment and have XP functions, including Explorer from XP.  It may not be a very efficient way to do it, but having a virtual machine on hand can be useful in many, many ways.

    -Noel



    Saturday, May 14, 2011 7:20 PM
  • I've been having the same issue as you.  I've tried to delete a file only to be told that it is use by Windows Explorer.

    I tried the "Show Icons only" resolution but it did not work.

    Then I saw the Adobe problem.  I have Adobe Reader installed but not Acrobat.

    I took a look at MSCONFIG and found that one of the Services running is Adobe Active File Monitor V8.  This is installed with Adobe Elements 8.

    I went into Services in Computer Manager, set it for manual and turned it off.

    Then I went back to delete the thumbs.db that I've been trying to delete and it deleted.

    I'll just reset Adobe Active File Monitor V8 back to automatic and whenever I have this issue turn the Service off and delete the file.

    Anyways, that's what worked for me.

    Thanks

    Wednesday, May 18, 2011 5:28 PM
  • I was having this problem with my EPS files (Adobe Illustrator) and I tried everything mentioned above but none of them helped me... Here is something that I tired and it helped me out...

    1. The file you are trying to delete, right click on it and click "open with" then click on other programs and select notepad and also check the box with "always use the selected program to open this kind of files".

    2. when you click ok then notepad will try to open the file but stop it and end program...

    3. with this the file association will be changed and after restart, you will be able to rename, move or delete any file of that type... 

    4. after doing all your actions.. reverse the file associations by following the point nr. 1 to its original program...

    It worked for me after all that is why I thought to share it with you all....

     

    Thanks

    Tuesday, May 31, 2011 5:54 PM
  • Murtaza Sharif,

    Thank you, it seems that one of the simplest answers did the trick for me. I reassociated the file to Notepad, reboot, and was able to successfully remove the directory. Thanks so much, this was getting on my nerves!

    Knight42

    Wednesday, June 01, 2011 11:53 PM
  • Having read this whole thread and tried some but not all of the solutions suggested, I found another solution but am leery of generalizing. I leave it to the developers to rule on whether or how this is helpful. I had a folder with one Word file in it. I tried to delete the folder. Got the error under discussion. Deleted the Word file successfully. Now the folder is empty but the folder won't delete. The folder never ever had anything but the one file in it. And it never had thumbs.db in it. I have Windows 7 Home Premium I tried: 1-disabling the thumbnails display in folder options 2-uninstalling Adobe Reader...which didn't work...after launching the uninstall it seemed to just die. 3-waiting for a while. Then going back and trying to delete it. Then, to eliminate extraneous factors, I decided to close everything on my desktop, which included Excel 2007 with a new yet unsaved file and Quickbooks 2011. I closed QB. I went to save the new file I had going in Excel and the Save As box defaulted to the folder I am trying to delete!! No rhyme or reason to that...it is several layers down in the documents folder and I never had an Excel file in the folder I wanted to delete. Now, I did one of the following and I honestly can't remember which: 1-renavigate to a different save as folder, saved and closed in Excel. Go back to the directory window, and deleted the folder, or 2-renavigated in Excel to the save as folder I wanted but didn't save yet, after which the folder deleted ok. So does this mean that having an application open with its default Save As directory happening to be the folder you want to delete, even though you haven't and are not now trying to save anything there and can't even tell that's the default, is sufficient to lock the folder??? (rhetorical question) Wierd.
    Monday, June 20, 2011 10:00 AM
  • I posted the .reg file equivalent of that group policy workaround here: Thumbs.db being accessed by Windows Explorer - folder cannot be deleted

    Can you see if it works on the Home edition?


    Thank you, Joe!  It seems to have solved the problem for me. 

    What makes this most irritating to me is that if the thumbs.db file is only needed for bass-ackward compatibility - like maybe running an XP VM - then the generation of the thumbs.db file should be off by default, unless you actually set up such a VM.  Equally annoying, however, is the simple fact that the file stays locked after you leave the folder - or for that matter, even when you're still in the folder, and the file has been successfully created.  I don't recall ever having this type of problem when using XP.

    And of course, the gripe that trumps all the others is the fact that this has obviously been a well-documented major bug since the release of Windows 7, and MicroLimp still hasn't solved it.  I mean, c'mon people!  It can't possibly take two years to fix the process that generates the thumbs.db file so that it releases it after it's been created or updated.

    Tuesday, June 21, 2011 9:54 AM
  • @Murtaza Sharif

    That's an interesting workaround, and I'm glad you like it.  However, it is 1. Impractical, because of all the steps, including a reboot, necessary to simply delete one file; and 2. Mildly dangerous, because of the way that reassociating a filetype affects the Registry.  It is rare, but possible, that changing the association to Notepad (or anything else, for that matter) and then back to the original program, will not restore the original functionality of double-clicking or right-clicking on files of that type.  To truly reset the file association to its former state, you would have to do a system restore, but that could quite possibly also restore the file you just deleted, and then you'd have to delete it again, which of course you couldn't do, because of the restored file association.

    Moreover, your post is concerned with Adobe Illustrator files (.eps), and since this thread is concerned with the thumbs.db file being locked, it's no surprise that none of the solutions presented here would help you, because the two problems are not at all related.  It is generally unwise to apply solutions for one problem to try to fix another.  It's kind of like putting a bandage on your finger to address a broken leg.  Before long you'll have a bunch of fingers cluttered with bandages, and you'll still have a broken leg.

    Tuesday, June 21, 2011 10:29 AM
  • @karenzipser

    If you have not enabled viewing protected operating system files, you would not see the thumbs.db file, and if only system files are in the folder in question, then hovering over that folder in Explorer would give you the "empty folder" tooltip balloon.  Right-click the folder, and click on Properties.  If the folder truly is empty, it will show 0 bytes and 0 files.  If it shows any number of files other than zero, then they would be hidden and/or system files, in which case it could very well be the thumbs.db file that is giving you trouble.

    Simply disabling thumbnail display in folder options does not disable the generation of the thumbs.db file.  And conversely, disabling generation of the thumbs.db file does not require you to turn off thumbnail display.  Go back up and follow the link from joeboxer to get the registry tweak you need you disable generation of the thumbs.db file.  I also have Win 7 Home Premium, and it worked beautifully for me.

    Hope it helps.

    Tuesday, June 21, 2011 10:48 AM
  • wow this thread started 2009. my problem is when i try to move a video file from one folder to another this error will pop up. i was reading the thread and got tired. i go back to my explorer and tried to move again the files. i didn't try to click the "try again" button until today and it actually worked. i just need to click try again for 2-3 times to move a file. is there really a fix to this problem? thanks!
    Saturday, June 25, 2011 7:00 PM
  • I tried two of the suggested fixes.  By far the easiest is changing the view in the explorer window from detail to large icon.  I could delete the thumb, then swich back to detail view.  It has worked every time I tried it.

    But now I need help.

    Unfortunately, I tried Steve's fix first.  It worked as far as getting rid of thumbs.  But when I changed the computer setting back, to "let windows choose" not everything went back to the way it was.  I now have triangles instead of plus signs in explorer.  And I have little three dimensional lighted things when I hover over a button.  How do I go back to the standard view?

    Tuesday, June 28, 2011 8:29 PM
  • I had this same problem that nothing reaslly worked until now, Whe I found the program that is actully easier than everything else I tried. And its called (Lock Hunter) and you can find it here (http://lockhunter.com/?ver=&vertype=pro&sm=main_window_64 ) Let me know what you think about it. I like it a lot compared to everything else so far.
    Sunday, July 03, 2011 2:07 AM
  • If you choose to use an application that forces a bypass of basic file system operations, you are simply asking for trouble.  You ARE going to break your system and corrupt your disk by forcing "unlocking" of files.  It's just a matter of when.

    It's like calling for a tow truck any time you press the gas pedal in your car and it doesn't go...  Maybe it just needs to be started or shifted into the proper gear.  But winching up the front and dragging the car to a new destination chances breaking stuff in the drive train.

    In short, a little operator education moots the need to force a workaround.

    So figure out what's going wrong and correct it (in this case, stop Windows from generating Thumbs.db files, as listed in the thread above).  Then you won't have the problem in the first place and won't need any kind of "force unlock" workaround.

    It simply isn't a given that strange and unexpected things will happen to your folders - it just doesn't happen when things are set up right.  I never have any unexpected inabilities to manipulate my files and folders.

    -Noel




    Tuesday, July 05, 2011 10:36 PM
  • If you choose to use an application that forces a bypass of basic file system operations, you are simply asking for trouble.  You ARE going to break your system and corrupt your disk by forcing "unlocking" of files.  It's just a matter of when.

    It's like calling for a tow truck any time you press the gas pedal in your car and it doesn't go...  Maybe it just needs to be started or shifted into the proper gear.  But winching up the front and dragging the car to a new destination chances breaking stuff in the drive train.


    The analogy isn't quite so applicable in this case. You're taking a case where there are many unknowns and yes, it would perhaps be hazardous in that case. however, a flatbed tow would not damage anything in the drivetrain =). In this case, we're talking about a specific media file which we probably put there, like a movie or picture. The operating system is not going to miss that. I don't see how something is going to "break" down the line just because a picture or movie that isn't essential to OS operation was deleted. Quite frankly, I don't see the level of danger you suggest. If we were to start randomly unlocking and deleting system files, then yes, I'd agree with you. However, my movies of cats jumping into cardboard boxes are not essential to my system, although they are probably an essential part of the internet as a whole.
    I had this same problem that nothing reaslly worked until now, Whe I found the program that is actully easier than everything else I tried. And its called (Lock Hunter) and you can find it here (http://lockhunter.com/?ver=&vertype=pro&sm=main_window_64 ) Let me know what you think about it. I like it a lot compared to everything else so far.

    Thanks man - this worked for me! I had a .mkv file on my desktop that I had been trying to delete. I remember I ran into this problem with a previous 7 x64 install, but not on the desktop. I believe a command window with admin privileges managed to delete it (using the del command). However, that didn't work this time. The program worked and I was able to delete the file, although Windows was almost in denial that I had actually deleted the file. I guess Windows was angry and in disbelief it had been defeated, heh (j/k). Had to refresh the desktop and recycle bin to get it to finally go away.

     

    Nothing else (with the exception of disabling the buggy service) listed in this thread worked, although many of them were good ideas.

    In short, a little operator education moots the need to force a workaround.


    Mr. Carboni, I'm curious to know whether you read the rest of the thread. This is not an issue of user error; this is a bug in Windows 7 that Microsoft refuses to address, or is really dragging their feet on a fix.

     

    It simply isn't a given that strange and unexpected things will happen to your folders - it just doesn't happen when things are set up right. 

    -Noel




    Right - if they were set up right by Microsoft, we wouldn't have this problem.





    Wednesday, July 06, 2011 2:58 PM
  • This is not an issue of user error; this is a bug in Windows 7 that Microsoft refuses to address, or is really dragging their feet on a fix.

    Microsoft actually has addressed it - that's why there's a policy for preventing the creation of Thumbs.db.  Windows 7 itself runs just fine without Thumbs.db files. 

    Now, you may have some other software that looks at those files, and which may be mucking up your folder access - I don't know.  I DO know that I have never seen this problem, either before or after I disabled the generation of Thumbs.db files (as well as disabling that damnable indexing).

    If Microsoft had just ceased creating these files (or configured the policy not to generate the files), then no doubt some [non-Microsoft] applications that rely upon them would have suddenly been broken, and people would be complaining about that instead.  They probably figured this was the lesser of the two evils.

    I'm guessing that in a future version of Windows the Thumbs.db files just won't be generated, or the policy will be set to not generate them by default.

    I never said Microsoft was perfect, nor that they haven't got bugs (or design flaws).  Just that knowing why something's happening and preventing it is better than applying workarounds to recover from problems that have already occurred.

    -Noel

    Wednesday, July 06, 2011 4:10 PM
    • Hi thanks for the program name is really easy much easy then i tried many ways but not successfully worked for me, but now all come back to normal.    Thanks again.    
    Thursday, July 07, 2011 3:05 PM
  • I don't think any of these so called solutions are working i have tried them all ..... the thing i ignored in this was the link to lockhunter ...that thing raly deletes what u want it to delete and even tells u what process is blocking the pocess :)
    Monday, July 11, 2011 6:25 AM
  • This is not an issue of user error; this is a bug in Windows 7 that Microsoft refuses to address, or is really dragging their feet on a fix.

    Microsoft actually has addressed it - that's why there's a policy for preventing the creation of Thumbs.db.  Windows 7 itself runs just fine without Thumbs.db files. 

    Now, you may have some other software that looks at those files, and which may be mucking up your folder access - I don't know.  I DO know that I have never seen this problem, either before or after I disabled the generation of Thumbs.db files (as well as disabling that damnable indexing).

    If Microsoft had just ceased creating these files (or configured the policy not to generate the files), then no doubt some [non-Microsoft] applications that rely upon them would have suddenly been broken, and people would be complaining about that instead.  They probably figured this was the lesser of the two evils.

    I'm guessing that in a future version of Windows the Thumbs.db files just won't be generated, or the policy will be set to not generate them by default.

    I never said Microsoft was perfect, nor that they haven't got bugs (or design flaws).  Just that knowing why something's happening and preventing it is better than applying workarounds to recover from problems that have already occurred.

    -Noel


    Bah. I just ran into this issue and it had been driving me insane for an hour. Unluckily I ended up at this forum to find that people have been complaining about this for a year and a half. I have Windows 7 64 bit Ultimate, fully legal, fully updated, fully unable to delete network folders that used to have pictures or videos in them. I have to use an XP machine to do it. This is called "addressing" the situation? I got so confused trying all the workarounds, trying again and again to delete certain folders (a task I was given by my boss) that I accidentally deleted the wrong folder! And guess what? It had a bunch of valuable videos in it! GONE FOREVER! So I can delete folders WITH VIDEO, but cannot delete (seemingly) empty folders WITHOUT VIDEO. Brilliant, just brilliant. So, I'm going back to the old XP machine down the hall so I can complete my task, leaving my $2,000.00 Windows 7 machine to run the fans and pretty up the dual monitors with pretty window dressings. I have no hope that this will ever be "addressed" and "fixed," seeing how the first post was back in 2009. Same old Microsoft, same old Windows.
    Tuesday, July 19, 2011 2:59 PM
  • This is not an issue of user error; this is a bug in Windows 7 that Microsoft refuses to address, or is really dragging their feet on a fix.

    Microsoft actually has addressed it - that's why there's a policy for preventing the creation of Thumbs.db.  Windows 7 itself runs just fine without Thumbs.db files. 

    Now, you may have some other software that looks at those files, and which may be mucking up your folder access - I don't know.  I DO know that I have never seen this problem, either before or after I disabled the generation of Thumbs.db files (as well as disabling that damnable indexing).

    If Microsoft had just ceased creating these files (or configured the policy not to generate the files), then no doubt some [non-Microsoft] applications that rely upon them would have suddenly been broken, and people would be complaining about that instead.  They probably figured this was the lesser of the two evils.

    I'm guessing that in a future version of Windows the Thumbs.db files just won't be generated, or the policy will be set to not generate them by default.

    I never said Microsoft was perfect, nor that they haven't got bugs (or design flaws).  Just that knowing why something's happening and preventing it is better than applying workarounds to recover from problems that have already occurred.

    -Noel


    Bah. I just ran into this issue and it had been driving me insane for an hour. Unluckily I ended up at this forum to find that people have been complaining about this for a year and a half. I have Windows 7 64 bit Ultimate, fully legal, fully updated, fully unable to delete network folders that used to have pictures or videos in them. I have to use an XP machine to do it. This is called "addressing" the situation? I got so confused trying all the workarounds, trying again and again to delete certain folders (a task I was given by my boss) that I accidentally deleted the wrong folder! And guess what? It had a bunch of valuable videos in it! GONE FOREVER! So I can delete folders WITH VIDEO, but cannot delete (seemingly) empty folders WITHOUT VIDEO. Brilliant, just brilliant. So, I'm going back to the old XP machine down the hall so I can complete my task, leaving my $2,000.00 Windows 7 machine to run the fans and pretty up the dual monitors with pretty window dressings. I have no hope that this will ever be "addressed" and "fixed," seeing how the first post was back in 2009. Same old Microsoft, same old Windows.
    Hear hear!
    Monday, July 25, 2011 8:56 AM
  • If you choose to use an application that forces a bypass of basic file system operations, you are simply asking for trouble.  You ARE going to break your system and corrupt your disk by forcing "unlocking" of files.  It's just a matter of when.

    It's like calling for a tow truck any time you press the gas pedal in your car and it doesn't go...  Maybe it just needs to be started or shifted into the proper gear.  But winching up the front and dragging the car to a new destination chances breaking stuff in the drive train.

    In short, a little operator education moots the need to force a workaround.

    So figure out what's going wrong and correct it (in this case, stop Windows from generating Thumbs.db files, as listed in the thread above).  Then you won't have the problem in the first place and won't need any kind of "force unlock" workaround.

    It simply isn't a given that strange and unexpected things will happen to your folders - it just doesn't happen when things are set up right.  I never have any unexpected inabilities to manipulate my files and folders.

    -Noel




    Another drinker of the Microsoft Kool-Aid speaks!

    Despite more than 30 years dealing with MS induced headaches, each iteration of the perpetual Beta software that MS calls "Windows" continues to introduce new challenges to my career. Being the lesser of one evil, MS Windows is here to stay, and I heartfully thank the folks in Redmond for providing solid job security as I am called upon to address the plethora of issues guaranteed to arise with each generation of new and improved bugs.

    My Linux machines provide absolutely no enjoyment; they are abysmally boring as they just sit there year after year, just doing what they always do. But booting Windows brings a certain aura of baited anticipation every time I allow it to re-update the updated updates it updated eight other times since the last SP release... And the rush it brings if it successfully boots is my drug of choice!

    As I used to say before modding parts of my automobiles actually became illegal: "I love working on cars, that's why I drive a Ford!"

    Operator education? Operator education will only lead a user to realize what a kludge he or she is actually working with. Who is MS kidding? The uninformed, that's who, because underneath it all is much of the same code that has evolved into the chimera that constitutes each generation of the Windows OS.

    Having said that, I must honestly admit that the OS has improved vastly since the days of '95. After all, if you beat a yard full of cats for long enough, you will eventually be able to lay their bodies out in some kind of order. 

    Wednesday, July 27, 2011 4:19 PM
  • Hey Noel I just wanted to say thanks for the original solution you posted back in April last year. And for continuing in your attempt to educate :)

     

    Neal

    Saturday, August 20, 2011 2:36 AM
  • Thank you Neal.  I'm glad it worked for you.

    Off to drink more Kool Aid.  But not to worry, Mark, unlike you I have an iron stomach.  ;)

    -Noel



    Saturday, August 20, 2011 6:19 PM
  • it simply worked for me after copying the original file to another location; deleting all contents; logging in as safe mode and deleting the offensive folder. Windows 7, 64 bit
    Monday, August 22, 2011 5:39 AM
  • Robster8192 - you rock! Keeping it simple.
    Friday, August 26, 2011 5:38 PM
  • Noel if you would read the whole thread you would realize the "fix" you are talking about is not working for everyone.  You are the moron, disabling a feature is not a fix it is a work around.
    Wednesday, August 31, 2011 8:34 PM
  • Noel if you would read the whole thread you would realize the "fix" you are talking about is not working for everyone. You are the moron, disabling a feature is not a fix it is a work around.

    Thank you for your comment, Whosurpappy, and especially for the name-calling. I shall treasure your opinion.

    Just what feature is it you think I've disabled? Please tell us all just what won't work with that policy change.

    Perhaps you should try to stick to commenting on subjects for which you actually have at least some knowledge.

    -Noel

    Wednesday, August 31, 2011 10:00 PM
  • Robinson,

    The workaround you suggested seems to fix the issue.  Additionally, you can:

    * Press Alt + F, from the Windows 7 Explorer interface
    * Select Tools
    * Select Folder Options
    * Select the View tab
    * Check the box that says "Always show icons, never thumbnails"

    This seems to fix the issue as well.  So it seems this feature is causing issues and this feature is enabled by default.  So, any idea when this will be fixed as it's a handy feature, but no sense in leaving on if it doesn't actually work.

    Nathan

    thank you so much for this info! this fixed my problem (which is different than the original posters issue). i was having trouble handling an mkv file (couldn't open, delete, move without windows explorer restarting). i am wondering if there is some issue, in general with the preview/thumbnail stuff & windows explorer (i'm using windows 7 btw). thanks again for the help!!
    Thursday, September 08, 2011 3:24 PM
  • Rosie211, I invite you to actually READ this thread.  A method for disabling the Thumbs.db generation has been provided.

    -Noel

    Thursday, September 08, 2011 3:48 PM
  • Disabling "Show thumbnails instead of icons" in System Properties / Peformance Options / Visual Effects seems to have fixed this problem for me.

    Glad too cuz this was getting way too annoying. Mine were getting locked just by clicking once on the folder. Didn't even have to go into the folder and view the files for it to become locked.

    Wednesday, September 14, 2011 11:51 AM
  • ·    Click the Start orb

    ·    Enter gpedit.msc in the search box and hit Enter.

    ·    Expand User Configuration - Administrative Templates - Windows Components.

    ·    Click on Windows Explorer.

    ·    Right-click the entry "Turn off the caching of thumbnails in hidden thumbs.db files" and choose Edit.

    ·    Enable the setting. Sorry started reading above and didn't quite finish but tried above and same thing, but changed to "Turn off the display of thumbnails and only display icons" as with above which I read, choose enable and I can live with it, am actually quite pleased. I accused someone of giving me a video virus, if you are reading this I am sorry.Thanks guys for the fix,until next time.Microsoft fix this if you can or give us a small refund,pleeze, you have billions of $$$$$$$$$$ we are poor.

    Tuesday, September 20, 2011 11:32 PM
  • Noel- Is it possible your fixis not working for some because Explorer needs to be restarted? I used the group policy change to stop usign thumbs.db files on network shares and the problem continued to occur. I then stopped and restarted Explorer (in task manager) and the problem went away.

    It seems like it just works for some...,and not for others. Maybe the explorer restart would help.

    Steve

    Thursday, September 29, 2011 2:48 PM
  • If you are having this problem with MKV files and have DivX player installed, try removing it. As soon as I did that, voila, I was able to delete and rename the MKV files.
    Thursday, September 29, 2011 3:55 PM
  • I probably should have added the step at the end "Log off and back onto Windows", yes.

    -Noel

    Thursday, September 29, 2011 6:08 PM
  • Thanks Robster8192 your information seemed the simplest and safest so i gave it a go.  Viola, when displaying Content the thumbs.db is deleted.
    Friday, October 07, 2011 6:11 PM
  • ***I can't believe that everybody is going for the most complex ridiculous ideas or system changes to accomplish this.  ***

    ****Answer is here and SUPER SIMPLE****

    I just had this problem happen, network drive, deleting stuff, viewed an image in a folder to make sure it was garbage and it was, went to delete the whole bunch of folders and this same thing happened, "The action can't be completed because the file is open in Windows Explorer. Close the file and try again."  I then checked google and found this thread then thought "oh hay maybe this will work..." and it did!

    Windows sometimes locks the file  (Thumbs.db) in the last folder you have viewed an image in.  To unlock that other one, just go your my pictures folder or some other folder with images in it and open one of the pictures.  Now, go back to the network folder or local folder with the locked Thumbs.db file and try to delete it again. 

    This has worked for me every time now.  I'm cleaning up a bunch of space off of my networked drive at work for typical house cleaning.  So far I'm 15 for 15 with my method.  Give it a shot!  Seriously!

     

    Good luck.

    Monday, October 24, 2011 6:00 PM
  • Why would you think that reconfiguring your system once to not generate Thumbs.db in the first place is somehow ridiculous, but your having to do a workaround 15 times is not?  Seriously?

    -Noel

    Tuesday, October 25, 2011 3:15 AM
  • Does these setting have any impact on your case?

    http://technet.microsoft.com/en-us/library/ff686200(WS.10).aspx

    I am unable to reproduce the issue even after several retries to debug further, but i do remember seeing this issue earlier.

    I will pass on this issue feedback at the next oppurtunity.

     


    Sumesh P - Microsoft Online Community Support
    Wednesday, October 26, 2011 9:25 AM
    Moderator
  • I am unable to delete Thumbs.db from network drivers. I get the message that " the action can't be completed because the file is open in another program.  Close the file and try again "
    I have to delete few foleder and I am unable to do that. I am using win 7 X64 bit. I have used unlocker and few other programs to unlock the file  but i still get the same issues.
    I have also tried to delete the file from the command prompt and close the explorer  from the task manager and fet the same issue.
    In View -> folder options I have also unckecked the option " Display file icon on thumbsnail "
    Also I went to gpedit.msc -. user config -> admin templates -. windows components -> windows explorer -> enabled
    1. turn off the display of thumbsnail and only display icons
    2. turn off the display of thumbsnail and only display icons on network folder
    3. Turn off the caching of thumbsnail ain hidden thumbs.db files.

    Also as some one suggest I uninstalled Adobe reader and still unable to delete the files.
    Any help ?

    Wednesday, November 02, 2011 3:12 PM
  • To delete the thumbs.db file change the view to icons and then Windows will allow you to delete it.

     

     

    This WORKS and is also the most secure,most feasible of all methods to instantly remedy the problem which needs no changes to the system,no loss of features and takes a maximum of TWO mouse clicks in explorer pane. proves that often the most simple approach is the best...none of the complicated steps described by others were necessary to instantly release the folder this file resided in (mapped network drive on streaming box) from being locked.
    • Edited by Br33zer Tuesday, November 29, 2011 11:20 PM
    Tuesday, November 29, 2011 11:13 PM
  • I've been using LockHunter to deal with this annoyance, and just found this thread.

    Noel, I tried your solution but it didn't work on my Win7 system.

    ·    Click the Start orb

    ·    Enter gpedit.msc in the search box and hit Enter.

    ·    Expand User Configuration - Administrative Templates - Windows Components.

    ·    Click on Windows Explorer.

    ·    Right-click the entry "Turn off the caching of thumbnails in hidden thumbs.db files" and choose Edit.

    ·    Enable the setting.

    -Noel


    So I tried Nathan.Grist's solution and it worked:


    * Press Alt + F, from the Windows 7 Explorer interface
    * Select Tools
    * Select Folder Options
    * Select the View tab
    * Check the box that says "Always show icons, never thumbnails"

    This seems to fix the issue as well.  So it seems this feature is causing issues and this feature is enabled by default.  So, any idea when this will be fixed as it's a handy feature, but no sense in leaving on if it doesn't actually work.

    Nathan

    -- Robert
    Monday, December 12, 2011 7:41 PM
  • I wonder, did you log off and back on again after making the changes?  I'm sorry I didn't make that obvious.

    -Noel

    Monday, December 12, 2011 9:57 PM
  • Noel,

    No, I didn't try logging off.  The other approach worked instantly, though.  But if it stops working or causes other problems I'll try yours again (and log off).

    Robert

    I wonder, did you log off and back on again after making the changes?  I'm sorry I didn't make that obvious.

    -Noel


    Monday, December 12, 2011 10:27 PM
  • The point behind my suggestion is that Explorer won't any longer try to generate Thumbs.db files, which (unless you're running very specific old software that requires Thumbs.db files to be present) are no longer needed by Windows.  But after making that change ("Turn off the caching of thumbnails in hidden thumbs.db files") you need to log off/on or reboot to ensure it takes effect.  It should prevent the problem from recurring from then on.

    -Noel

    Tuesday, December 13, 2011 7:31 PM
  • I found a downside to setting Windows Explorer to "Always show icons, never thumbnails" -- folders with photos and pictures wouldn't show them as thumbnails when viewing them as large icons -- Explorer showed them as generic icons. So I tried Noel's approach using gpedit.msc to "Turn off the caching of thumbnails in hidden thumbs.db files" (and rebooted after making the change). That worked -- I can delete and move folders, and I see thumbnails for photos. Thanks! Robert
    Tuesday, December 13, 2011 10:04 PM
  • Glad to hear you got it worked out, Robert.

    -Noel

    Thursday, December 15, 2011 1:41 AM
  • i got a few .mkv files on my comp almost all of them work fine but a couple says its open in another program when there clearly not is that the windows 7 bug or is that a problem with the file? btw the file plays fine but to move or delete it takes a while because an error message keeps popping up and i have to click try again like 5 times or more before i can delete or move the file....

     

    Noel i am using windows 7 home premium and when i click on the start orb and search gpedit.msc in the search box it says no item matches ur search so i searched my whole computer for it and 4 files with the name gpedit.msc came up i opened all of them but then it says MMC could not create plug-in could any1 help me plz?  




    • Edited by xflash27 Sunday, December 25, 2011 6:12 AM
    Saturday, December 24, 2011 3:06 AM
  • Noel if you would read the whole thread you would realize the "fix" you are talking about is not working for everyone. You are the moron, disabling a feature is not a fix it is a work around.

    Thank you for your comment, Whosurpappy, and especially for the name-calling. I shall treasure your opinion.

    Just what feature is it you think I've disabled? Please tell us all just what won't work with that policy change.

    Perhaps you should try to stick to commenting on subjects for which you actually have at least some knowledge.

    -Noel

    Noel, I think you are coming across as arrogant and people are responding to that.  I don't agree with the name calling but there must be a better fix. Your solution to this problem is indeed a workaround and not a true fix. You have stated that some older programs may not function correctly with this feature disabled. Personally I think MS should have disabled the use of thumbs.db by default and let the old software struggle. Chalk it up to backwards compatibility issues.

    For the record it is probably the best solution for most people, but just the fact that this thread is still active does suggest that this problem has not been adequately addressed by Microsoft. Also the fact that Windows explorer itself can be the cause of the locking means MS should be able to patch it to release the file more aggressively.

    Also for the record, disabling the creation and reading of the thumbs.db file worked for me. I am a power user and this was a simple change for me. The problem is that it should not even be an issue any more because many casual users may struggle and potentially damage their systems while trying workarounds.

    -Down



    Wednesday, January 04, 2012 7:34 PM
  • just the fact that this thread is still active does suggest that this problem has not been adequately addressed by Microsoft.
    I have to agree with that.
     
    If your definition of "fix" is that it should work perfectly for folks out of the box, then it's not fixed.  But I tend to extend the term "fix" to embody gray areas in which reconfiguring Windows corrects an issue.

    I don't know whether there is still the potential for conflict in Windows 8 Explorer, but it seems that the "Turn off the caching of thumbnails in hidden thumbs.db files" policy is still available and it's not enabled in the Windows 8 Developer Preview.

    That said, I've only ever found one Thumbs.db file on the disk on a Windows 8 system, and it might have been put there by Microsoft before making the release, not by the running Windows 8 system itself:

     
    C:\TEMP>dir c:\Thumbs.db /s /ah
     Volume in drive C has no label.
     Volume Serial Number is 5425-06AF
     Directory of c:\Windows\System32\oobe\info

    08/25/2011  11:32 AM            27,136 Thumbs.db
                  1 File(s)         27,136 bytes
     
     
    I'd be interested to hear whether any Thumbs.db files are being generated on anyone's Windows 8 system.
     
     
    -Noel

    Detailed how-to in my new eBook: Configure The Windows 7 "To Work" Options


    • Edited by Noel Carboni Wednesday, January 04, 2012 10:35 PM
    Wednesday, January 04, 2012 10:33 PM
  • Having experienced the same problem with Windows Explorer - I examined the file types causing problems and discovered it related ONLY to me being unable to delete, move or rename .MKV files. (Media files)

    In many cases Windows Explorer would crash when you just selected the .MKV file, (as scrolled down to that file even with clicking on it for action)

    I went and tried the various suggestions on websites to delete the files or eliminate the thumbs issue, and found that many of them worked.    Deleting the files, or disabling the THUMBS issue, does not resolve the entire problem.  SO I thought about what caused it.

    I found that in my case the UNDERLYING cause of the problem, was the latest version of DIV/X that I had installed recently.  Apparently DIV/X causes problems with the Thumb nail images and size/length of MKV formats, and your system gets hung. 

    I therefore uninstalled DIV/X  (and went back to VLC as the main player)   -      The entire Problem was solved IMMEDIATELY.     

    I can now move, delete, rename .MKV files again.    and Windows Explorer no longer crashes like this. 

     If you have this problem and you have DIV/X installed, I suggest that you try uninstalling DIV/X and see if the problem goes away immediately after you reboot your machine.  

    It certainly did for me.  If that doesnt fix it, you can always reinstall DivX again.

    For the more technically minded, you can achieve the same result by deleting the DIV/X Codecs, without total uninstall. 

    good luck....... 

    Tuesday, January 17, 2012 4:03 AM
  • Hi Britton,

    Coulc you please try to take the following steps to troubleshoot this issue?

    1. Run gpedit.msc
    2. Navigate to Local Computer Policy->User Configuration->Windows Components->Windows Explorer
    3. Set "Turn off the display of thumbnails and only display icons on network folders" to Enable.

    Then, try to test this issue again.

    Does it work?

    This only works if you're running Professional or above. Local Group polices are not availble in Premium & below.

    I tried the Folder view option suggestion on my version of Home Premium version & it worked just fine.

    Friday, March 02, 2012 3:10 PM
  • Just use the free tool to unlock

    http://lockhunter.com/

    Sunday, March 11, 2012 7:51 PM
  • Robinson,

    The workaround you suggested seems to fix the issue.  Additionally, you can:

    * Press Alt + F, from the Windows 7 Explorer interface
    * Select Tools
    * Select Folder Options
    * Select the View tab
    * Check the box that says "Always show icons, never thumbnails"

    This seems to fix the issue as well.  So it seems this feature is causing issues and this feature is enabled by default.  So, any idea when this will be fixed as it's a handy feature, but no sense in leaving on if it doesn't actually work.

    Nathan

    This seems to have fixed this annoying issue for me.  Thank you.  Although, I must say, epic FAIL on Micro$oft's part for pushing out a feature that does nothing but cause issues.  WTG.
    Friday, March 23, 2012 2:05 AM
  • Nice, this worked on my end... easy fix until a SP release (i hope) resolved this.

    Tuesday, March 27, 2012 2:10 PM
  • thanks mate this got to the root of my problem also,in my opinion this is definately the best way to solve this problem by fixing the cause in the first place,in my case it was an application called my winlocker that had gone rogue and needed addressing,not a bug caused by windows 7
    Sunday, April 08, 2012 10:33 AM
  • It seems this (now 2 years!) workaround you've posted solved the issue for me. Win7 Ultimate. Thank you. I was stumbbling upon this annoyance since... forever. Tx.
    Sunday, April 08, 2012 7:21 PM
  • Hi All,

    I have the same problem, has a dilemma to be exact.

    If I tick Always show icons, never thumbnails, renaming file or sub-folder on the server would be locked.

    If I don't tick Always show icons, never thumbnails,  the preview for some documents are not showing properly

    It should be a fix from Microsoft, we always up to date with Windows Security Updates on both win 7 workstations and SBS 2011

    Wednesday, April 18, 2012 3:12 PM
  • Hi Noel

    I just have to say that your original solution of disabling thumbs.db works perfectly. And I apologise for the rest of the ding bats in this thread that don't appreciate the simplicity which is your solution and instead keep focusing on "omg I can't delete this file, NO MATTER HOW MANY TIME I TELL IT TO DELETE ASDFASDFASD".

    Anyway, keep it up!

    P.S I made an account just to say that
    • Edited by deeeeno Wednesday, May 09, 2012 2:23 PM PS
    Wednesday, May 09, 2012 2:23 PM
  • An alternative is to install a small program called Unlocker (from emptyloop.com). It works for me.
    Anytime you can't move or delete a folder or a file just right click it and run Unlocker. It will analyse what is locking it and present you with some options.
    "Simples"
    :)

    Like Deeno said, Thank you Noel.
    Thursday, May 24, 2012 1:13 AM
  • You're welcome, guys, thank you in return for the feedback.

    -Noel

    Saturday, May 26, 2012 1:03 AM
  • Reconfiguring the system to not generate thumbs.ds is not a solution for the many of us who often need large or small thumbnails displayed in explorer when working with images. It's the bug that should be fixed, not the feature disabled.

    It's quite extraordinary that Microsoft has not fixed this bug since it was reported two and a half years ago. Windows 7 is the worst Windows version ever when it comes to locking files or folders that should not be locked. I think my next ''Windows' will be a Mac because there are so many of these little annoying problems in Windows, Office, and other MS software, and Microsoft simply don't solve them.

    Monday, June 11, 2012 1:30 PM
  • Read more carefully.

    Windows no longer uses Thumbs.db.

    They're only generated for compatibility with certain older applications, which almost no one uses.

    Disabling generation of the Thumbs.db files via the policy editor does NOT affect the ability to use thumbnailed views in Explorer. 

    It is a solution to the problem with almost no downside.

     

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    Monday, June 11, 2012 3:27 PM
  • Thanks for your reply, but how exactly is this done? You do realise how long time it would take to read this forum through from start to finish for a problem MS should have fixed themselves? Solutions are presented only for others to say they don't work.

    I have two GPEDIT.MSC on my system, one for 64-bit and one x86. Both of them display the message "MMC could not create the snap-in" if I run them. 

    Then I tried

    * Press Alt + F, from the Windows 7 Explorer interface
    * Select Tools
    * Select Folder Options
    * Select the View tab
    * Check the box that says "Always show icons, never thumbnails"

    but the result is that thumbnails are no longer displayed in explorer when I choose 'large icons' or 'extra large icons', just as that configuration description says. That seems to contradict what you say, so is there any way to get rid of the thumbs.db files without disabling thumbnail views, given that GPEDIT doesn't work?

    Monday, June 11, 2012 3:59 PM
  • The detailed instructions for using the policy editor are listed above in my first post in this thread.  They have NOTHING to do with the settings you listed. 

    One last step I neglected to list was that you should log off and on again after going through them.

    Try running gpedit.msc as administrator.

    If you cannot run gpedit.msc, then you have a fundamental system problem - or a lower version of Windows that does not support the use of the policy editor (though in the latter case I'm not sure where you would have gotten a gpedit.msc file).  You might want to start a new thread and ask why it is you can't run the Local Group Policy Editor.

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options




    Monday, June 11, 2012 4:17 PM
  • Thanks again for replying, but I'm still confused.

    Your first post in this thread says: "Rosie211, I invite you to actually READ this thread.  A method for disabling the Thumbs.db generation has been provided.-Noel". No detailed instructions. In a much later post, you said:

    Policy Editor, here's how:

    ·    Click the Start orb

    ·    Enter gpedit.msc in the search box and hit Enter.

    ·    Expand User Configuration - Administrative Templates Windows Components.

    ·    Click on Windows Explorer.

    ·    Right-click the entry "Turn off the caching of thumbnails in hidden thumbs.db files" and choose Edit.

    ·    Enable the setting.

    I had first tried to click the Windows button, orb if you want, then type gpedit.msc, but it was not found.

    I did a file search in the Windows folder, and it actually gave me four matches in

    C:\Windows\winsxs\amd64_microsoft-windows-g..admin-gpedit-snapin_31bf3856ad364e35_6.1.7600.16385_none_ccd7905990f3c9d2

    C:\Windows\winsxs\x86_microsoft-windows-g..admin-gpedit-snapin_31bf3856ad364e35_6.1.7600.16385_none_70b8f4d5d896589c

    C:\Windows\winsxs\x86_microsoft-windows-g..it-snapin.resources_31bf3856ad364e35_6.1.7600.16385_en-us_aab602c931a89371

    C:\Windows\winsxs\amd64_microsoft-windows-g..it-snapin.resources_31bf3856ad364e35_6.1.7600.16385_en-us_06d49e4cea0604a7

    I tried again "run as administrator" for each one (from the context menu), and they all gave the same message:  "MMC could not create the snap-in"

    Hence, I can't get your instructions to work.

    My Windows 7 64-bit is entirely up to date with Windowsupdate.

    There may be another forum somewhere that explains why gpedit doesn't work, but it's a lot of trouble to go through for each Windows user for a small problem that ought to have been dealt with better than this. I wonder if it wouldn't have been better to have some old applications malfunction than to disturb all Windows users with this annoying problem that prevents deletion and moving of files.

    Monday, June 11, 2012 4:45 PM
  • "Finn Skovgaard" wrote in message news:7669f471-d670-4bf5-aa36-3069be29c3f8...

    Thanks again for replying, but I'm still confused.

    .

     
    GPEDIT is only available in Pro, Ultimate and Enterprise editions.

    Noel Paton | Nil Carborundum Illegitemi | CrashFixPC | The Three-toed Sloth
    Monday, June 11, 2012 5:31 PM
  • My first response to this thread was the description of how to use gpedit to disable the use of thumbs.db.  Look at the dates if you don't believe me.  I suspect you're using threaded view, which is impossible to follow in my opinion.

    If you do not have gpedit installed, chances are you are using a version of Windows that does not support it.  I believe only Windows 7 Pro and above provide the local group policy editor.  This is why you should not try to save a few bucks on lower versions of Windows.

    However, I have researched what registry entry that policy editor setting affects.  Are you up to doing direct registry edits?  If so this is the registry value you that enabling that setting changes:

    [HKEY_CURRENT_USER \ Software \ Policies \ Microsoft \ Windows \ Explorer]

    DisableThumbsDBOnNetworkFolders  REG_DWORD  0x00000001 (1)

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options


    • Edited by Noel Carboni Monday, June 11, 2012 5:35 PM spelling typo
    Monday, June 11, 2012 5:34 PM
  • It was Windows 7 64-bit Home Premium that was pre-installed when I bought the computer, so that is what I use. It wasn't a choice. I just supposed that when MS sells a Windows version, then it is able to handle basic operating system tasks such as deleting, renaming and moving files without blocking the actions with awkward error messages because of old files one doesn't need anymore. Apparently, Windows versions below Pro are a bit like buying a car and discovering that you need to reprogram its computer if you want to use fifth gear. When I do choose software, I choose according to what I need it to do, but something like this problem never appears in the overview. There is no way of knowing in advance if even a more expensive version will have the same bug too. Why does MS release software versions incapable of accomplishing basic tasks? One can only guess in vain, but MS seems more and more disorganised and inefficient internally.

    Anyway, the regedit finally seems to have solved the problem, so many thanks for explaining it. The solution is so simple that it's inexcusable that it's not included in Windows as a normal user interface function.

    I use thread view because when someone replies to a post, it's difficult to figure out what he is replying to if it's not in thread view.

    Monday, June 11, 2012 7:20 PM
  • Glad you got it worked out.

    Your point about Microsoft avoiding these problems by defaulting the setting to not generate Thumbs.db files was right on the money, but they have chosen not to do so - possibly out of an imperative to treat compatibility as a high priority (which is in itself a Good Thing).  What's surprising is that they have chosen not to disable the creation of Thumbs.db files in Windows 8 as well.

    This site seems to have a pretty good tabular overview of what is and isn't in the various Windows editions:  http://en.wikipedia.org/wiki/Windows_7_editions

    Not that you're in any mood to send Microsoft more money, but just for reference there is a way to upgrade a particular edition of Windows to a higher level (e.g., Home Premium to Ultimate).  It's called a "Windows Anytime Upgrade".  http://www.microsoftstore.com/store/msstore/en_US/pd/Windows-Anytime-Upgrade-Windows-7-Home-Premium-to-Ultimate/productID.216649800

     

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    Monday, June 11, 2012 8:19 PM
  • Ok,

    It's been almost 3 years. 3 years! Why is this bug still not fixed?

    No, I'm not going to disable network thumbnails. That's ridiculous, and it makes things worse for me. I use a network drive as a storage device.. Disabling thumbnails is absolutely not an option..

    It is not a solution to the problem at all.

    Please fix the issue. I don't want to have to end-task explorer every time I want to delete thumbs..

    Saturday, June 23, 2012 9:04 PM
  • It is fixed, folks.  Clearly we have a reading comprehension problem here.  Just make the policy setting and be done with it.

    The fix is to disable Explorer ever attempting to generate those hidden files, which were a terrible idea to begin with.

    It's impossible to fix and to work compatibly with ancient software.  Chances are none of you are running such software.

     

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    Sunday, June 24, 2012 4:29 AM
  • It isn't fixed. As you know very well, because you said it yourself, only some versions of Windows 7, Pro for exemple, allows the policy settings. Windows 7 for ordinary mortals doesn't.

    I got rid of the useless thumbs.db file generation by updating the registry according to your instructions, but that is only for people who know what they are doing in the registry.

    The user interface for many Windows versions simply offers no solution.

    Another solution, apart from stopping the generation, would be to stop locking these files when it isn't necessary. That's another bug.

    It's obvious for everybody that Microsoft simply doesn't care about ordinary users' ordinary problems with bugs. They manage to sell Windows and other software without fixing the problems, so why waste money making it a good product? There is no real competition to Windows, unless one has dosh enough to buy Macs that are 2-3 times as expensive. It's like having the choice between a Russian Lada and a German Mercedes. Most people can't afford the Mercedes.

    Sunday, June 24, 2012 10:26 AM