You need permission to perform this action


  • We are starting to roll out Vista to our end users and running into a problem with network drives. I have a logon script that maps several drives for the end-users. Users with a Dell Latitude D830 are unable to rename any files or folders located on the mapped drives. They get the following error - You need permission to perform this action. The only options are Try Again or Cancel. When the same users log into a PC that is also running Vista they can change the names without a problem (also works on XP). If I log into the laptops as the Domain Administrator, I can rename the files without a problem. The laptops came pre-installed with Vista and the workstation was upgraded to Vista if that makes a difference. There isn’t anything being reported in the Event Viewer and is happing on all the laptops. Is anyone else having the problem and know of a solution?

    Friday, September 21, 2007 4:48 PM

All replies

  • I have a Dell XPS 710 and have encountered this problem, too.  Vista came pre-loaded and my account is the administrator account, but I still frequently get this message.  Also, if I try to delete or rename some files I get the same message.  I know of no solution yet.


    MTA: I just found this


    Simply right click the folder and assign your profile full permissions and if they're already there assign users full permissions at least for the time you use to remove the folder. Or you could try going to msconfig in run box>Tools>turn off UAC ***temporarily in order to remove the folder.

    This usually works to take permissions of files and folders in Vista:

    To take ownership of a folder, follow these steps:

    Right-click the folder that you want to take ownership of, and then click Properties. Click the Security tab, and then click OK on the Security message (if one appears). Click Advanced, and then click the Owner tab. In the Name list, click your user name, or click Administrator if you are logged in as Administrator, or click the Administrators group. If you want to  take ownership of the contents of that folder, select the Replace owner on subcontainers and objects check box. Click OK, and then click Yes when you receive the following message: You do not have permission to read the contents of directory folder name. Do you want to replace the directory permissions with permissions granting you full Control? All permissions will be replaced if you press Yes.

    where folder name is the name of the folder that you want to take ownership of.

    Click OK, and then reapply the permissions and security settings that you want for the folder and its contents.

    To take ownership of a file, follow these steps:

    Right-click the file that you want to take ownership of, and then click Properties. Click the Security tab, and then click OK on the Security message (if one appears). Click Advanced, and then click the Owner tab. In the Name list, click Administrator, or click the Administrators group, and then click OK. The administrator or the Administrators group now owns the file.

    Alternatively (and temporarily assign permission to users for that folder): Rt. click folder>properties>security tab>highlight your profile>add>type users in the object box>OK button>put checks in all boxes>apply>close dialogue box.

    It worked on another forum, but didn's solve my problem.

    Sunday, September 23, 2007 2:56 PM
  • I'm trying to copy files from a network share (XP machine) to my new Vista laptop (cloning various directories of data) and I get this message. I can not figure out how to copy these directory trees over, this is nuts.  In some cases, if I create  a directory by the name of the destination, into the destination tree, it suddenly starts copying till the next missing directory.  Then, certain files will not copy (due to suspect extensions I suppose).

    This is just completely a barrier to making progress.  Any hints would be appreciated.

    Tuesday, December 11, 2007 10:54 PM
  • I have just had the same problem...


    I was logged in as administrator, and I had ownership of all of the files and sub folders folders. But I could not copy the folders or rename them. Folder general properties showed an attribute of read-only and even if I took the read-only away it still came back again when I went to check the properties.


    My problem turned out to be he fact that I had a sql server 2005 database nestled somewhere deep within the folder structure that I was trying to copy. As soon as I stopped SQL server, folder copied over and renamed OK. Of course pointing SQL server 2005 to the new database location is another issue...



    Saturday, December 29, 2007 1:04 PM
  • Follow the below steps when you get the error message stating : you need permission to perform this action when trying to move the files:

    1. Click on the start button and then click on the All Programs.
    2. Click on the Accessories  and then right Click command prompt and select run as Administrator.
    3. Type in  "net user administrator /active:yes and Press on Enter.
    4. Restart your computer.


    To get more instructions on this refer:

    Monday, March 15, 2010 8:50 AM
  • Please help.  I am having this same problem on my Dell Studio 17.  I have tried all of the proposed solutions in this forum, and none have been successful.  I even tried Sals Omni's, but all that did was create a new administrator account, and the administrator account was a fresh slate, with none of the files listed under my user account ... which incidentally is also labeled as an Administrator account ... yet, for some reason, I'm not allowed to rewrite my file.  I've gone through the Security tab as well as the Ownership tab.  I've changed some access to my files in that I can change them from read-only, but I also have the same problem as stephengraham in that when I go back to the Properties, the read-only setting is changed back.

    The only thing I don't understand is this sql server 2005 you've mentioned.  I tried googling it elsewhere to see if that's my problem, but I haven't found anything helpful. What is this?  How can I find out if that's my problem?  What do I need to do to discover if it's present?

    Hoping you can help me figure this out!


    Sunday, September 05, 2010 7:58 AM
  • SQL Server 2005 refers to the fact that SQL Server 2005 was installed on the server and there was a related service that had the files open - so they could not be deleted/renamed etc. But that probably isn't the case in your enviornment.

    As far as the base problem - well I'm looking into that myself now as well :(. There is a new computer in our home environment and I'm experiencing the same symptoms with it.

    Saturday, October 23, 2010 9:28 PM