none
Can't connect to RDP on Windows Server 2016 RRS feed

  • General discussion

  • Hi,

    We have a Server 2016 with Remote Desktop Services enable but we can't connect to it anymore (it worked before).

    We tried a lot of things already but not solved it yet. It seems the RDS isn't accepting connections on port 3389.

    - telnet to it on port 3389 not working

    - ping does work

    - verified the port setting in registry

    - rebooted the server

    - added a separate rule to allow 3389 always

    - netstat -an doesn't show an listening port on 3389

    Someone an idea?

    Kr Kevin



    • Edited by Quasten Wednesday, April 25, 2018 9:54 AM
    • Changed type Quasten Thursday, July 18, 2019 3:00 PM I can't check anymore because i'm not working for that company anymore. It was not a ping issue as the last repy suggested anyhow :)
    Wednesday, April 25, 2018 9:52 AM

All replies

  • Hi,

    1. In services.msc, please verify that the Remote Desktop Services service is Running.

    2. You may try disabling and re-enabling Remote Desktop in System Properties -- Remote tab and check again if the service is listening on port 3389 using netstat -ano .  One thing you can do is to check the process id of TermService service using Task Manager, then compare the output of netstat -ano and see which ports, if any, the service is listening on.

    Thanks.

    -TP

    Thursday, April 26, 2018 3:50 AM
    Moderator
  • Hi,

    If possible, please try to disable Windows Firewall, and 3rd party protection/antivirus software on Windows Server 2016 temporarily and check the result. 

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, April 26, 2018 8:01 AM
    Moderator
  • Hi,

    1) I restarted the service multiple times already. I did it again now.

    2) I also disabled RDS and re-enabled it, without luck. The process termsvcs is running, but no listening port 3389 in netstat.

    Kr Kevin

    Thursday, April 26, 2018 8:25 AM
  • Hi, 

    I disabled Windows firewall already without luck. Tremdmicro AV is also uninstalled to solve this issue.

    Kr Kevin

    Thursday, April 26, 2018 8:36 AM
  • Hi,

    Please confirm that if there is "Remote Desktop Security Filter Driver" in Device Manager - Hidden Devices - Non Plug and Play.

    Besides, please confirm that group policy “Allow users to connect remotely using Remote Desktop Services” is enabled:
    Computer Configuration – Administrative Templates – Windows Components – Remote Desktop Services – Remote Desktop Session Host – Connections

    If problem persists, please post the result of CMD command “netstat -ano” on Windows Server 2016.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, April 26, 2018 10:02 AM
    Moderator
  • Hi,

    I don't see Non Plug and Play section in device manager with hidden devices (I think it doesn't exist anymore in Windows Server 2016?). I also don't find Remote Desktop Security Filter Driver in any section.

    Here's the output of netstat

    Active Connections

      Proto  Local Address          Foreign Address        State           PID
      TCP    0.0.0.0:135            0.0.0.0:0              LISTENING       788
      TCP    0.0.0.0:383            0.0.0.0:0              LISTENING       1492
      TCP    0.0.0.0:445            0.0.0.0:0              LISTENING       4
      TCP    0.0.0.0:1002           0.0.0.0:0              LISTENING       2156
      TCP    0.0.0.0:4600           0.0.0.0:0              LISTENING       3192
      TCP    0.0.0.0:27194          0.0.0.0:0              LISTENING       2300
      TCP    0.0.0.0:49664          0.0.0.0:0              LISTENING       540
      TCP    0.0.0.0:49665          0.0.0.0:0              LISTENING       448
      TCP    0.0.0.0:49668          0.0.0.0:0              LISTENING       660
      TCP    0.0.0.0:49670          0.0.0.0:0              LISTENING       660
      TCP    0.0.0.0:49689          0.0.0.0:0              LISTENING       1000
      TCP    0.0.0.0:49749          0.0.0.0:0              LISTENING       4172
      TCP    0.0.0.0:49751          0.0.0.0:0              LISTENING       644
      TCP    10.24.195.98:139       0.0.0.0:0              LISTENING       4
      TCP    10.24.195.98:445       10.1.2.109:33397       ESTABLISHED     4
      TCP    10.24.195.98:52976     10.24.63.194:80        CLOSE_WAIT      2076
      TCP    10.24.195.98:53003     10.24.63.194:80        CLOSE_WAIT      2076
      TCP    10.24.195.98:53762     10.24.63.194:80        CLOSE_WAIT      2076
      TCP    10.24.195.98:53763     10.24.63.194:80        CLOSE_WAIT      2076
      TCP    10.24.195.98:53832     10.24.63.194:80        CLOSE_WAIT      2076
      TCP    10.24.195.98:53833     10.24.63.194:80        CLOSE_WAIT      2076
      TCP    10.24.195.98:53949     131.253.61.96:443      SYN_SENT        1000
      TCP    [::]:135               [::]:0                 LISTENING       788
      TCP    [::]:383               [::]:0                 LISTENING       1492
      TCP    [::]:445               [::]:0                 LISTENING       4
      TCP    [::]:1002              [::]:0                 LISTENING       2156
      TCP    [::]:4600              [::]:0                 LISTENING       3192
      TCP    [::]:27194             [::]:0                 LISTENING       2300
      TCP    [::]:49664             [::]:0                 LISTENING       540
      TCP    [::]:49665             [::]:0                 LISTENING       448
      TCP    [::]:49668             [::]:0                 LISTENING       660
      TCP    [::]:49670             [::]:0                 LISTENING       660
      TCP    [::]:49689             [::]:0                 LISTENING       1000
      TCP    [::]:49749             [::]:0                 LISTENING       4172
      TCP    [::]:49751             [::]:0                 LISTENING       644
      TCP    [::1]:383              [::1]:49822            ESTABLISHED     1492
      TCP    [::1]:49711            [::]:0                 LISTENING       2020
      TCP    [::1]:49711            [::1]:49869            ESTABLISHED     2020
      TCP    [::1]:49715            [::]:0                 LISTENING       2020
      TCP    [::1]:49715            [::1]:49866            ESTABLISHED     2020
      TCP    [::1]:49717            [::]:0                 LISTENING       3984
      TCP    [::1]:49731            [::]:0                 LISTENING       4036
      TCP    [::1]:49731            [::1]:49867            ESTABLISHED     4036
      TCP    [::1]:49737            [::]:0                 LISTENING       4036
      TCP    [::1]:49737            [::1]:53937            ESTABLISHED     4036
      TCP    [::1]:49743            [::]:0                 LISTENING       4964
      TCP    [::1]:49743            [::1]:53934            ESTABLISHED     4964
      TCP    [::1]:49745            [::]:0                 LISTENING       4964
      TCP    [::1]:49755            [::]:0                 LISTENING       4152
      TCP    [::1]:49755            [::1]:53936            ESTABLISHED     4152
      TCP    [::1]:49760            [::]:0                 LISTENING       4484
      TCP    [::1]:49760            [::1]:53938            ESTABLISHED     4484
      TCP    [::1]:49776            [::]:0                 LISTENING       4832
      TCP    [::1]:49776            [::1]:53935            ESTABLISHED     4832
      TCP    [::1]:49783            [::]:0                 LISTENING       4532
      TCP    [::1]:49786            [::]:0                 LISTENING       4532
      TCP    [::1]:49786            [::1]:53933            ESTABLISHED     4532
      TCP    [::1]:49788            [::]:0                 LISTENING       4532
      TCP    [::1]:49800            [::]:0                 LISTENING       4532
      TCP    [::1]:49800            [::1]:49823            ESTABLISHED     4532
      TCP    [::1]:49818            [::]:0                 LISTENING       4532
      TCP    [::1]:49822            [::1]:383              ESTABLISHED     2512
      TCP    [::1]:49823            [::1]:49800            ESTABLISHED     1492
      TCP    [::1]:49866            [::1]:49715            ESTABLISHED     1492
      TCP    [::1]:49867            [::1]:49731            ESTABLISHED     1492
      TCP    [::1]:49869            [::1]:49711            ESTABLISHED     1492
      TCP    [::1]:53930            [::1]:383              TIME_WAIT       0
      TCP    [::1]:53931            [::1]:383              TIME_WAIT       0
      TCP    [::1]:53932            [::1]:383              TIME_WAIT       0
      TCP    [::1]:53933            [::1]:49786            ESTABLISHED     1492
      TCP    [::1]:53934            [::1]:49743            ESTABLISHED     1492
      TCP    [::1]:53935            [::1]:49776            ESTABLISHED     1492
      TCP    [::1]:53936            [::1]:49755            ESTABLISHED     1492
      TCP    [::1]:53937            [::1]:49737            ESTABLISHED     1492
      TCP    [::1]:53938            [::1]:49760            ESTABLISHED     1492
      TCP    [::1]:53939            [::1]:383              TIME_WAIT       0
      TCP    [::1]:53940            [::1]:383              TIME_WAIT       0
      TCP    [::1]:53941            [::1]:383              TIME_WAIT       0
      TCP    [::1]:53942            [::1]:383              TIME_WAIT       0
      TCP    [::1]:53943            [::1]:383              TIME_WAIT       0
      UDP    0.0.0.0:123            *:*                                    452
      UDP    0.0.0.0:162            *:*                                    1984
      UDP    0.0.0.0:500            *:*                                    1000
      UDP    0.0.0.0:4500           *:*                                    1000
      UDP    0.0.0.0:5050           *:*                                    452
      UDP    0.0.0.0:5353           *:*                                    836
      UDP    0.0.0.0:5355           *:*                                    836
      UDP    10.24.195.98:137       *:*                                    4
      UDP    10.24.195.98:138       *:*                                    4
      UDP    127.0.0.1:52245        *:*                                    1000
      UDP    127.0.0.1:52246        *:*                                    3192
      UDP    127.0.0.1:58173        *:*                                    2300
      UDP    127.0.0.1:60574        *:*                                    836
      UDP    127.0.0.1:60854        *:*                                    4720
      UDP    127.0.0.1:62233        *:*                                    660
      UDP    [::]:123               *:*                                    452
      UDP    [::]:162               *:*                                    1984
      UDP    [::]:500               *:*                                    1000
      UDP    [::]:4500              *:*                                    1000
      UDP    [::]:5353              *:*                                    836
      UDP    [::]:5355              *:*                                    836

    Thursday, April 26, 2018 10:43 AM
  • Hi,

    Please check group policy configuration on problematic remote system.

    Open Run, type “rsop.msc” and end with enter to check local group policy.

    Or, open CMD and type “gpresult /r” to list applied domain group policy. 

    Confirm that if there is any remote desktop connection relate group policy.

    Besides, as far as I know, default port 3389 can be changed via registry, please check the configuration and make sure that default port is not changed, reference “How to change the listening port for Remote Desktop” for detail steps:
    https://support.microsoft.com/en-us/help/306759/how-to-change-the-listening-port-for-remote-desktop

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, April 27, 2018 8:46 AM
    Moderator
  • Hi,

    How things are going there on this issue?

    Please let me know if you would like further assistance.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, April 30, 2018 1:58 AM
    Moderator
  • Hi,

    Sorry for the late respons, I was off work.

    All servers use same group policies so that can't be the issue. Changing the port in registry, I also tested that.

    Very weird issue. We have 770 Windows Servers (also a bunch of Windows Server 2016) and never had any similar problem we couldn't solve.

    Kr Kevin

    Monday, April 30, 2018 7:21 AM
  • Hi,

    If possible, try “sfc /scannow” and check the result. also, please re-start system in Clean Boot and check the result.

    Perform a clean startup to determine whether background programs are interfering with your game or program:
    https://support.microsoft.com/en-us/help/331796/perform-a-clean-startup-to-determine-whether-background-programs-are-i

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, May 1, 2018 8:33 AM
    Moderator
  • Hmmm... weird because from your netstat output of your Windows 2016, i don't see any listening on the TCP 3389

    Can you run this reg query to see if the fDenyTSConnections is set to 1 or 0

    reg query "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server" /v fDenyTSConnections

    hth


    This posting is provided AS IS without warranty of any kind

    Tuesday, May 1, 2018 3:51 PM
  • Hi,

    I found some corrupted files sfc scan, but it's not solved after the repair (and service restart). Clean boot I already tested.

    This is the output of the reg query

    C:\Windows\system32>reg query "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server" /v fDenyTSConnections

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server
        fDenyTSConnections    REG_DWORD    0x0

    Wednesday, May 2, 2018 12:29 PM
  • Thanks for the output...

    Can you run the following command ?

    netstat -anob

    This should give you the listening port for the TermService.  The "b" from the anob will give you the process associated with the port.

    You should see something like this...

      TCP    0.0.0.0:3389           0.0.0.0:0              LISTENING       2844
      TermService

    Thanks!


    This posting is provided AS IS without warranty of any kind

    Wednesday, May 2, 2018 7:18 PM
  • Active Connections

      Proto  Local Address          Foreign Address        State           PID
      TCP    0.0.0.0:135            0.0.0.0:0              LISTENING       788
      RpcSs
     [svchost.exe]
      TCP    0.0.0.0:383            0.0.0.0:0              LISTENING       1492
     [ovbbccb.exe]
      TCP    0.0.0.0:445            0.0.0.0:0              LISTENING       4
     Can not obtain ownership information
      TCP    0.0.0.0:1002           0.0.0.0:0              LISTENING       2156
     [python.exe]
      TCP    0.0.0.0:4600           0.0.0.0:0              LISTENING       3192
     [Agpm.exe]
      TCP    0.0.0.0:27194          0.0.0.0:0              LISTENING       2300
     [tmlisten.exe]
      TCP    0.0.0.0:49664          0.0.0.0:0              LISTENING       540
     Can not obtain ownership information
      TCP    0.0.0.0:49665          0.0.0.0:0              LISTENING       448
      EventLog
     [svchost.exe]
      TCP    0.0.0.0:49668          0.0.0.0:0              LISTENING       660
     [lsass.exe]
      TCP    0.0.0.0:49670          0.0.0.0:0              LISTENING       660
     [lsass.exe]
      TCP    0.0.0.0:49689          0.0.0.0:0              LISTENING       1000
      Schedule
     [svchost.exe]
      TCP    0.0.0.0:49749          0.0.0.0:0              LISTENING       4172
     [hpsensor.exe]
      TCP    0.0.0.0:49751          0.0.0.0:0              LISTENING       644
     Can not obtain ownership information
      TCP    10.24.195.98:139       0.0.0.0:0              LISTENING       4
     Can not obtain ownership information
      TCP    10.24.195.98:445       10.1.2.109:50635       ESTABLISHED     4
     Can not obtain ownership information
      TCP    10.24.195.98:54662     10.24.63.193:80        CLOSE_WAIT      2076
     [ntrtscan.exe]
      TCP    10.24.195.98:54663     10.24.63.193:80        CLOSE_WAIT      2076
     [ntrtscan.exe]
      TCP    10.24.195.98:54664     10.24.63.193:80        CLOSE_WAIT      2076
     [ntrtscan.exe]
      TCP    10.24.195.98:64108     10.24.63.191:80        CLOSE_WAIT      2076
     [ntrtscan.exe]
      TCP    10.24.195.98:64338     10.24.63.191:80        CLOSE_WAIT      2076
     [ntrtscan.exe]
      TCP    10.24.195.98:64346     10.24.63.191:80        CLOSE_WAIT      2076
     [ntrtscan.exe]
      TCP    10.24.195.98:64408     131.253.61.102:443     SYN_SENT        1000
      wlidsvc
     [svchost.exe]
      TCP    [::]:135               [::]:0                 LISTENING       788
      RpcSs
     [svchost.exe]
      TCP    [::]:383               [::]:0                 LISTENING       1492
     [ovbbccb.exe]
      TCP    [::]:445               [::]:0                 LISTENING       4
     Can not obtain ownership information
      TCP    [::]:1002              [::]:0                 LISTENING       2156
     [python.exe]
      TCP    [::]:4600              [::]:0                 LISTENING       3192
     [Agpm.exe]
      TCP    [::]:27194             [::]:0                 LISTENING       2300
     [tmlisten.exe]
      TCP    [::]:49664             [::]:0                 LISTENING       540
     Can not obtain ownership information
      TCP    [::]:49665             [::]:0                 LISTENING       448
      EventLog
     [svchost.exe]
      TCP    [::]:49668             [::]:0                 LISTENING       660
     [lsass.exe]
      TCP    [::]:49670             [::]:0                 LISTENING       660
     [lsass.exe]
      TCP    [::]:49689             [::]:0                 LISTENING       1000
      Schedule
     [svchost.exe]
      TCP    [::]:49749             [::]:0                 LISTENING       4172
     [hpsensor.exe]
      TCP    [::]:49751             [::]:0                 LISTENING       644
     Can not obtain ownership information
      TCP    [::1]:383              [::1]:49822            ESTABLISHED     1492
     [ovbbccb.exe]
      TCP    [::1]:49711            [::]:0                 LISTENING       2020
     [ovcd.exe]
      TCP    [::1]:49711            [::1]:49869            ESTABLISHED     2020
     [ovcd.exe]
      TCP    [::1]:49715            [::]:0                 LISTENING       2020
     [ovcd.exe]
      TCP    [::1]:49715            [::1]:49866            ESTABLISHED     2020
     [ovcd.exe]
      TCP    [::1]:49717            [::]:0                 LISTENING       3984
     [ovconfd.exe]
      TCP    [::1]:49717            [::1]:57187            ESTABLISHED     3984
     [ovconfd.exe]
      TCP    [::1]:49731            [::]:0                 LISTENING       4036
     [opcmsga.exe]
      TCP    [::1]:49731            [::1]:49867            ESTABLISHED     4036
     [opcmsga.exe]
      TCP    [::1]:49737            [::]:0                 LISTENING       4036
     [opcmsga.exe]
      TCP    [::1]:49737            [::1]:64386            ESTABLISHED     4036
     [opcmsga.exe]
      TCP    [::1]:49743            [::]:0                 LISTENING       4964
     [opcacta.exe]
      TCP    [::1]:49743            [::1]:64383            ESTABLISHED     4964
     [opcacta.exe]
      TCP    [::1]:49745            [::]:0                 LISTENING       4964
     [opcacta.exe]
      TCP    [::1]:49755            [::]:0                 LISTENING       4152
     [opcmona.exe]
      TCP    [::1]:49755            [::1]:64385            ESTABLISHED     4152
     [opcmona.exe]
      TCP    [::1]:49760            [::]:0                 LISTENING       4484
     [opcmsgi.exe]
      TCP    [::1]:49760            [::1]:64387            ESTABLISHED     4484
     [opcmsgi.exe]
      TCP    [::1]:49776            [::]:0                 LISTENING       4832
     [opcle.exe]
      TCP    [::1]:49776            [::1]:64384            ESTABLISHED     4832
     [opcle.exe]
      TCP    [::1]:49783            [::]:0                 LISTENING       4532
     [oacore.exe]
      TCP    [::1]:49786            [::]:0                 LISTENING       4532
     [oacore.exe]
      TCP    [::1]:49786            [::1]:64382            ESTABLISHED     4532
     [oacore.exe]
      TCP    [::1]:49788            [::]:0                 LISTENING       4532
     [oacore.exe]
      TCP    [::1]:49800            [::]:0                 LISTENING       4532
     [oacore.exe]
      TCP    [::1]:49800            [::1]:60139            ESTABLISHED     4532
     [oacore.exe]
      TCP    [::1]:49818            [::]:0                 LISTENING       4532
     [oacore.exe]
      TCP    [::1]:49822            [::1]:383              ESTABLISHED     2512
     [perfalarm.exe]
      TCP    [::1]:49866            [::1]:49715            ESTABLISHED     1492
     [ovbbccb.exe]
      TCP    [::1]:49867            [::1]:49731            ESTABLISHED     1492
     [ovbbccb.exe]
      TCP    [::1]:49869            [::1]:49711            ESTABLISHED     1492
     [ovbbccb.exe]
      TCP    [::1]:57187            [::1]:49717            ESTABLISHED     1492
     [ovbbccb.exe]
      TCP    [::1]:60139            [::1]:49800            ESTABLISHED     1492
     [ovbbccb.exe]
      TCP    [::1]:64382            [::1]:49786            ESTABLISHED     1492
     [ovbbccb.exe]
      TCP    [::1]:64383            [::1]:49743            ESTABLISHED     1492
     [ovbbccb.exe]
      TCP    [::1]:64384            [::1]:49776            ESTABLISHED     1492
     [ovbbccb.exe]
      TCP    [::1]:64385            [::1]:49755            ESTABLISHED     1492
     [ovbbccb.exe]
      TCP    [::1]:64386            [::1]:49737            ESTABLISHED     1492
     [ovbbccb.exe]
      TCP    [::1]:64387            [::1]:49760            ESTABLISHED     1492
     [ovbbccb.exe]
      UDP    0.0.0.0:123            *:*                                    452
      W32Time
     [svchost.exe]
      UDP    0.0.0.0:162            *:*                                    1984
     [snmptrap.exe]
      UDP    0.0.0.0:500            *:*                                    1000
      IKEEXT
     [svchost.exe]
      UDP    0.0.0.0:4500           *:*                                    1000
      IKEEXT
     [svchost.exe]
      UDP    0.0.0.0:5050           *:*                                    452
     [svchost.exe]
      UDP    0.0.0.0:5353           *:*                                    836
      Dnscache
     [svchost.exe]
      UDP    0.0.0.0:5355           *:*                                    836
      Dnscache
     [svchost.exe]
      UDP    10.24.195.98:137       *:*                                    4
     Can not obtain ownership information
      UDP    10.24.195.98:138       *:*                                    4
     Can not obtain ownership information
      UDP    127.0.0.1:49577        *:*                                    5520
     [PccNTMon.exe]
      UDP    127.0.0.1:52245        *:*                                    1000
      gpsvc
     [svchost.exe]
      UDP    127.0.0.1:52246        *:*                                    3192
     [Agpm.exe]
      UDP    127.0.0.1:58173        *:*                                    2300
     [tmlisten.exe]
      UDP    127.0.0.1:60574        *:*                                    836
      NlaSvc
     [svchost.exe]
      UDP    127.0.0.1:61081        *:*                                    3776
     [wmiprvse.exe]
      UDP    127.0.0.1:62233        *:*                                    660
     [lsass.exe]
      UDP    [::]:123               *:*                                    452
      W32Time
     [svchost.exe]
      UDP    [::]:162               *:*                                    1984
     [snmptrap.exe]
      UDP    [::]:500               *:*                                    1000
      IKEEXT
     [svchost.exe]
      UDP    [::]:4500              *:*                                    1000
      IKEEXT
     [svchost.exe]
      UDP    [::]:5353              *:*                                    836
      Dnscache
     [svchost.exe]
      UDP    [::]:5355              *:*                                    836
      Dnscache
     [svchost.exe]

    • Edited by Quasten Thursday, May 3, 2018 8:28 AM
    Thursday, May 3, 2018 8:26 AM
  • It seems that TermService is not listening on any port...

    Is the service is started?

    Also, please validate that you have both lines in the file "C:\Windows\System32\drivers\etc\services"

    ms-wbt-server    3389/tcp                           #MS WBT Server
    ms-wbt-server    3389/udp                           #MS WBT Server

    hth


    This posting is provided AS IS without warranty of any kind


    • Edited by cthivierge Thursday, May 3, 2018 1:01 PM Adding content
    Thursday, May 3, 2018 12:17 PM
  • Hi,

    Yes the service is started and restarted many times. Also rebooted it and clean start. I checked the services file and the 2 lines are there.

    It worked perfectly for months.

    I tried every fix I found related on technet/google of course before posting this thread.

    I really hope somebody can help us. But getting desperate :(

    Thursday, May 3, 2018 1:42 PM
  • Hi,

    >I found some corrupted files sfc scan, but it's not solved after the repair (and service restart). Clean boot I already tested.
    Please run “sfc /scannow” again and make sure there is no error reported.

    Best Regards,
    Eve Wang



    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, May 4, 2018 6:34 AM
    Moderator
  • C:\Windows\system32>sfc /scannow

    Beginning system scan.  This process will take some time.

    Beginning verification phase of system scan.
    Verification 100% complete.

    Windows Resource Protection did not find any integrity violations.
    Friday, May 4, 2018 10:48 AM
  • Can you validate that the service "Remote Desktop Services" or "TermService" is running ?

    you can also use the sc query TermService command line.


    This posting is provided AS IS without warranty of any kind

    Friday, May 4, 2018 3:09 PM
  • SERVICE_NAME: termservice
            TYPE               : 20  WIN32_SHARE_PROCESS  
            STATE              : 4  RUNNING
                                    (STOPPABLE, NOT_PAUSABLE, ACCEPTS_SHUTDOWN)
            WIN32_EXIT_CODE    : 0  (0x0)
            SERVICE_EXIT_CODE  : 0  (0x0)
            CHECKPOINT         : 0x0
            WAIT_HINT          : 0x0
    Monday, May 7, 2018 7:52 AM
  • Nobody any suggestion anymore?
    Monday, May 14, 2018 8:59 AM
  • I had the same problem after a migration of Windows Server 2008R2 (p2v), my reslution may work for you:

    The problem occurs because the RDP service tries to use the old network adapter. 

    After some hours of google, I found this option in registry:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp

    Change the "LanAdapter" value from "1" to "0", to allow RDP in all network adapters.

    Reboot the system and test.

    I hope it helps.


    • Edited by Canove Sunday, May 20, 2018 4:30 PM
    Sunday, May 20, 2018 4:30 PM
  • Hi,

    Thanks for the advice, but didn't help. Value was already set to 0.


    Tuesday, May 22, 2018 12:59 PM
  • I had the same issue. For me, we used a product called Trend Micro Deep Security. A Policy inside of there enabled it's own Software Firewall that was independent of Windows Firewall. By Disabling the firewall within Trend Micro, it solved the issue for me and things got back to normal. 
    Tuesday, July 10, 2018 5:29 PM
  • I also just encounter the problem. It was after i run the command:

    tasklist /FI "imagename eq cmd.exe " /V

    Then when i tried Remote Desktop Connection, I was unable to connect anymore.

    Then I restarted the server, still was not able to connect.

    Remote Connection enabled, also have TCP    0.0.0.0:3389           0.0.0.0:0              LISTENING       ###
      TermService

    Any idea how to solve this?

    Friday, August 31, 2018 2:00 AM
  • Ok, I change the Computer from IP address to the server name, then i work again. However, not sure why previously it works using IP address.
    Friday, August 31, 2018 2:09 AM
  • Hi sir, I had this same issue. Not sure if you resolved it or not. What fixed it for me was, I stopped the "Remote Desktop Services" and then navigated to this folder (You will have to show hidden folders) "C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys". Give everyone and your service account you logged in as full permissions on the folder (I'm sure you can narrow down security later), now go in to the MachineKey folder and delete this key "f686aace6942fb7f7ceb231212eef4a4_17ea43a5-71ef-4a6a-bb14-53484f1a536c". Once you have deleted this key, start Remote Desktop Services and try RDP again. This should resolve your issue

    -CY

    Tuesday, September 18, 2018 12:57 PM
  • I have exact same issue, but i do not have the MachineKey listed above.
    Wednesday, January 30, 2019 5:54 PM
  • Hi,

    Any luck on this issue, we have a server with all the settings enabled for LanAdapter, rdp service listening on port 3389 and so on. We tried resizing, restarting and redeploying the machine as well but the RDP doesn't work and gives general error when tried to connect to. Please help with any ideas.

    Regards,

    Mamidi Vasavi

    Monday, February 11, 2019 3:23 PM
  • It could be caused by multiple issues no single cause. can you run Procmon, restart the remote desktop services along with remote desktop configuration ?

    Do you see any access denied results in Procmon capture ? if so, to what RegKey / File / folder is it ?

    Do you see any related events under System / Application / RemoteDesktopServices-RdpCoreTS  or TerminalServices-RemoteConnectionManager ? can you share them ?

    What is the status of the RDP certificate under MMC > Certificates > Local > remote Desktop Services ?

    Is it expired or valid ?

    RDP Private Key prefixed with : f686aace6942fb7f7ceb231212eef4a4

    The default permissions are:
    Network service / read , local admins / read and System / full NTFS Permissions.

    Check the permissions on the MachineKeys folder, by default only Everyone and Local Administrators have NTFS permissions on it

    And make sure the private key does not have "inherited permissions" enabled

    Wednesday, February 20, 2019 11:14 PM
  • I know this is old BUT... on

    rootusers how-to-enable-ping-in-windows-server-2016-firewall

    I found how to enable ping then I checked the "Remote Desktop - X" they were all off so i enabled them and RDP started working correctly..

    NOTE: Even when firewall was off the pings and rdp would not work... IDKW...

    Thursday, July 18, 2019 2:45 PM
  • I had the same Problem after Hardening the Server.

    My Resolution was, after i deactivate the Service, was to activate the Service "Remote Desktop Services UserMode Port Redirector" and to restrict the rdp protocol by GroupPolicy.

    Found here: "https://docs.microsoft.com/en-us/windows-server/remote/remote-desktop-services/clients/troubleshoot-remote-desktop-connections"

    Monday, September 16, 2019 2:18 PM
  • After much troubleshooting and trying every short of reinstalling Windows Server 2016, turned out to be port 3389 was being blocked. During troubleshooting I even tried to connect with the firewall turned off and had no success. So here is what I did:

    1. Click the “Windows” button on your taskbar and then click “Settings.” Type “Control Panel” into the Windows Settings search bar and press the “Enter” key to open the Control Panel.

    2. Click the “System and Security” option and then click “Windows Firewall.” Click “Advanced Settings.”

    3. Click the “Inbound Rules” option on the sidebar of the Windows Firewall window and then click the “New Rule” option under the “Actions” sidebar.

    4. Click the “Port” option under “What type of rule would you like to create?” and then click “Next.”

    5. Click “TCP” for the port type and then click “Specific local ports.” Type in 3389 to the textbox next to “Specific local ports” and then click “Next.”

    6. Click “Allow the connection” and then click “Next.” Select all options for connection types (Public and Private networks) on the next screen regarding when to apply the rule, then click “Next” again.

    7. Type in a name for the rule such as "TCP 3389," then click “Finish” to allow the 3389 port in Windows Firewall.



    • Edited by jonsnow85 Thursday, September 19, 2019 2:26 AM
    Thursday, September 19, 2019 2:24 AM