none
Sleep Button Grayed out RRS feed

  • Question

  • I have Windows 7 Professional on my laptop and the sleep option is grayed out. Please help me get it restored.
    Monday, May 9, 2016 5:10 AM

Answers

  • Hi,

    I found several users who had the similar issue as yours, they gave the advices may help you, please refer to the link:

    https://social.technet.microsoft.com/Forums/windows/en-US/f2c22cfe-968e-4933-9f0b-2edfb8a84d87/windows-7-shutdown-restart-sleep-and-hibernate-buttons-greyed-out?forum=w7itproui

    https://social.technet.microsoft.com/Forums/windows/en-US/05fa4693-8b01-47eb-8a9a-027b5b8b8c06/vista-disabled-sleep-mode-sleep-mode-grayed-out?forum=itprovistahardware

    Best Regards,

    Tao


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, May 10, 2016 11:47 AM
    Moderator

All replies

  • Hello!

    You don't mention what, if anything, you tried so far, so this is sort of tricky.

    For example, you don't mention if your PC will go into sleep mode on its own or not. Have you tried this when running on battery? I mention this because the answer you give will help clarify the diagnostic picture. Meaning, if your laptop *does* go into sleep mode on its own, but you cannot invoke it from the menu, then that suggests the Power Settings are in working order, and that the problem lies in the mechanisms that control what you can and cannot use on the start menu.

    Next, is this a work or home PC? If it is a work PC, your IT department may have removed Sleep as part of the overall configuration chosen by your IT leadership. In this case, I do not suggest making changes through the Microsoft website; rather, call your company service desk and ask them for assistance.

    I do not think the Power settings in control panel are the place to begin looking, because the fact that the option is greyed out suggests policy changes.

    If it's a home PC try this:

    Click START, then use either the search or run boxes and type "gpedit.msc" press the ENTER key

    then navigate to:

    Computer Configuration >

    Administrative Templates >

    System >

    Power Management >

    Sleep Settings

    After you select "Sleep Settings", you will see content on the right side with 3 columns, SETTING, STATE and COMMENT.

    Everything under STATE should read "Not Configured", and if it does not just double click on each one and set them to "Not Configured".

    Again, this will NOT work for a work PC...in fact on a work PC if you have admin rights to even launch gpedit.msc you will see a slightly different layout, one that shows you the LOCAL settings and the settings chosen via GROUP POLICY.

    If you see anything for GROUP POLICY, you will not be able to make this change without breaking something (either the PC or a company policy).

    If you have further details after trying these steps, please post back here

    thanks!



    thanks, bob

    Monday, May 9, 2016 7:12 AM
  • Hi,

    I found several users who had the similar issue as yours, they gave the advices may help you, please refer to the link:

    https://social.technet.microsoft.com/Forums/windows/en-US/f2c22cfe-968e-4933-9f0b-2edfb8a84d87/windows-7-shutdown-restart-sleep-and-hibernate-buttons-greyed-out?forum=w7itproui

    https://social.technet.microsoft.com/Forums/windows/en-US/05fa4693-8b01-47eb-8a9a-027b5b8b8c06/vista-disabled-sleep-mode-sleep-mode-grayed-out?forum=itprovistahardware

    Best Regards,

    Tao


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, May 10, 2016 11:47 AM
    Moderator
  • Hello,

    I'm having the same problem - sleep and hibernate greyed out. Laptop does not sleep or hibernate on its own (if I close laptop, battery drains and laptop shuts down).

    I followed your advice:

    If it's a home PC try this:

    Click START, then use either the search or run boxes and type "gpedit.msc" press the ENTER key

    then navigate to:

    Computer Configuration >

    Administrative Templates >

    System >

    Power Management >

    Sleep Settings

    After you select "Sleep Settings", you will see content on the right side with 3 columns, SETTING, STATE and COMMENT.

    Everything under STATE should read "Not Configured", and if it does not just double click on each one and set them to "Not Configured".

    ........ All are listed as "Not Configured"

    ??? What next ???

    Thank you,

    Jennifer

    Thursday, March 30, 2017 1:42 PM
  • The following I sent as Feedback to MS.

    I am having problem with with Sleep in grayed out mode. I see in this forum lot others have the same problem. And none working. My question, why MS has to make this fix so difficult? Was it necessary to make it difficult? or MS made it purposely?  I guarantee there is no technical reason (as a technical person, I can say that) to make this so difficult. This should be as easy as right click on Sleep mode and check "Enable" or "Disable" .  I challenge MS that I can give MS such simple system level solution if MS disagrees with my assertion.

    Saturday, June 29, 2019 4:11 PM
  • I did exactly the way said. ALL were "Not Configured". So no change was warranted and so I am stuck with my "Sleep" grayed out state. BTW, it is a home PC. 

    Saturday, June 29, 2019 4:57 PM