Vostro 200, Intel 82562V-2 ethernet adapter does not initialize correctly

    General discussion

  • Hello, when Seven (x64) boots on my Dell Vostro 200, sometimes (1 out of 5?) the network shows as "limited connectivity".

    The NIC is up, and the router led shows activity on the Vostro port, but I can't even ping the router. ssh'd into the router, and tcpdump showed no traffic.

    It is not a DHCP problem, since my IP is fixed (and the network properties does show my fixed configuration at this point).

    Then I go to "Network Connections", disable and enable the "Local Area Connection", and it starts working.

    Same PC boots Vista (x86) and Linux Debian kernel 2.6.24 (x86), and the NIC works always right on both. Very intriguing is that I get the exact same problem if I update the Linux kernel from 2.6.24 to 2.6.26 or 2.6.28 (that's why I'm stuck with 2.6.24). Others have reported the same case with Linux for the Vostro 200:

    Could it be that the same change introduced (by intel?) from kernel 2.6.24 to 2.6.25 was introduced from Vista to Seven (x64), and is causing the same glitch on this ethernet hardware?

    Is someone else trying Seven x64 on the Vostro 200 with this NIC? I know that I'm not alone with the Linux problem. Am I with the Seven problem?


    Joao S Veiga

    Saturday, January 24, 2009 5:21 PM

All replies

  • If the computer goes into sleep mode, when it wakes up sometimes the problem also appears.
    Saturday, January 24, 2009 11:15 PM
  • jsveiga said:

    If the computer goes into sleep mode, when it wakes up sometimes the problem also appears.

    Use the PRO/1000 Gigabit /PRO/10GbE - Version 13.5.1 from here.

    Disable Power Management (specifically the 'Allow to power down') on the device properties of the NIC to avoid sleep/wake issues.

   - - If you find my post helpful, please click on the "Post was helpful" option inside my post.
    Sunday, January 25, 2009 8:23 PM
  • Thank you Aaron, but I'm really not comfortable downloading/installing a driver not downloaded from Intel/Dell/Microsoft.

    I went to the Intel Download Center instead and downloaded the Vista 64 driver for the 82562 Ethernet controller (closest I could find to my controller description). It is version 13.5, but it won't install on Windows 7 64 ("The program is not supported on this platform"); I did try "Vista compatibility mode". 

    The site you linked to has a driver newer (Dec 18) than the Intel site (Nov 6), but the only difference on the release notes is:

    - - Support for the Intel(R) 82598EB 10 Gigabit KX4 Network Connection

    + - Support for the Intel(R) 82598EB 10 Gigabit BX Network Connection

    None of which is my controller.

    I had already disabled the power save mode when I found that sleeping also triggered the problem sometimes, but there's still the problem when booting up.

    Monday, January 26, 2009 10:31 PM
  • Either it is a big coincidence, or someone at Microsoft is really listening; I just ran Windows Update, and voilà, there is a

    "Microsoft driver update for Intel(R) 82562V-2 10/100 Network Connection" (released just yesterday)

    Just installed, and will observe if the problem went away...




    Monday, January 26, 2009 10:43 PM
  • :-/ didn't take long.

    I shut down, disconnected the Vostro 200 power cable, and pressed the power button (I do this to discharge the power supply faster - before this, although the computer is off, the router activity LED for its connection is still on, so I suppose the NIC is still powered).

    Reconnected the power cable, booted Windows 7, and got no networking. Disabled/Re-enabled the connection, and got it up and running.

    On device manager, although the driver update was released yesterday, the actual driver version and date shows as:

    Microsoft, 9-Oct-2008, (unfortunately I didn't take note of what it was before).


    Monday, January 26, 2009 11:01 PM
  • Hello,

    I have a Dell Inspiron 530s which has an 82562V-2 network card. I have Windows 7, installed about a month ago. The network was very unreliable.

    I noticed that it kept saying that the cable was unplugged as well as that I had an invalid IP address - doubtless due to failure to find the DHCP host. I went to the network card in device manager. It has a tab 'Link Speed' in its 'Properties' (right click on the card name for that for the uninitiated). On that tab is a diagnostics button and in the diagnostics page a 'cable' tab. I found when I ran the cable diagnostic the network came up immediately  (mostly, sometimes the hardware diagnostic had to be run as well).

    I am old enough to remember that when 10/100 cards came out about 15 years ago they had trouble detecting the network speed, so I changed the card from 'Auto-detect' in the 'Speed and Duplex' setting in the 'Link Speed' section to '100Mbps full duplex' because I know my network will support that. It has been reliable for several days since

    I have no idea why this should be a problem with Windows 7, it certainly was not a problem at all under Vista

    I am using the driver from Intel which I loaded in anearlier attept to resolve this.
    Friday, January 29, 2010 1:14 PM
  • I also have this problem with a Vostro 200 / 82562v network card. I've tried 32bit and 64bit versions of Windows 7 and both have the problem. The machine was working fine with Vista for a couple of years. Currently I have a wireless USB dongle attached to work around the problem but I'd like to get the card functioning again if possible. Any ideas?
    Saturday, January 30, 2010 2:09 AM
  • Thank you, Clive. I have the same hardware and Intel driver, except that I have a Dell Vostro 200, and a similar problem after I installed Win 7: the network was stable until I woke the computer from sleep or restarted it, when I often got the error message " Local Area Network doesn't have a valid IP configuration", and I would have to restart the router/modem. I tried your solution and it worked for me.

    Saturday, February 06, 2010 4:42 PM
  • Clive,

    You diagnosis was dead on.  I ran into exactly the same problem w/the built-in mb adaptor on a Dell Vostro 400 w/a Intel 82562V-2 Network adaptor.  Everything lit up, but didn't consistently receive an IP in Win7.

    I set the connection speed to 100 Full, and it all started working!
    Monday, March 01, 2010 7:09 PM
  • Thank you, Clive.

    I recently upgraded my Dell Inspiron 530 from Vista 32 bit to Windows 7 64 bit. I had the same intermittent connection problem with its 82562V-2 network card.

    I replaced the Windows driver with a newer Intel driver from the Intel driver download website but that did not fix the problem. I also tried to use a Vista driver but Windows 7 wouldn't let me install it because it said I already had a newer driver. So, no luck with drivers.

    After much googling, I came across your suggestion. I set Speed and Duplex to '100Mbps full duplex' and my 82562V-2 network card now works flawlessly. I am using the default Microsoft driver.

     I wish I had found your solution earlier. It would have saved me hours of frustration.

    Saturday, August 27, 2011 12:59 PM
  • Hi Clive

    Many thanks; I had a Dell Vostro that would just slow right down to almost frozen when browsing, but your suggestion has everything right back up to expected speeds. I always browse with cache disabled - I am a web developer - but pages now load very quickly. Thank you :-)


    • Edited by ultrageoff Saturday, September 02, 2017 9:40 PM
    Saturday, September 02, 2017 9:39 PM