none
Server 2019 poor network performance RRS feed

  • Question

  • We are having major performance issues with Server 2019. Read and write performance is very poor compared to Server 2016. we installed a number of servers on customer sites to replace old servers and all customers have complained about opening files from the server being slow.

    We have set up a test server in our office and measured some read and write speeds and found a vast difference between 2019 and 2016.

    We installed a 2016 and a 2019 VM on a 2019 host using Hyper V and used Lan Speed test to measure Read\write speeds to the VMs and the Host

    The server is a Dell PowerEdge with 8x 15K disks configured RAID 10 using Intel quad port network card.

    The 2016 VM the read\write speeds are 600 Mbps write and 780 Mbps read.

    The 2019 VM the read\write speeds are 220 Mbps write and 115 Mbps read.

    Both VMs are using the same virtual switch, are configured exactly the same, and are on the same virtual disk, the only difference is the operating system which is fully patched on both VMs.

    We have now tested this on various specs of servers at customer sites and found the same results everywhere, 2019 is much slower than 2016.

    All BIOS and drivers are the latest available from Dell.

    This is not isolated to one server it is happening on a number of servers, some of which replaced old SBS 2011 servers and yet run slower that the old SBS boxes.

    Has anyone else found this issue?

    Monday, July 22, 2019 12:09 PM

All replies

  • you state all drivers and bios are latest from dell.  have you raised this issue with dell to ensure configuration according to dell?  what you are seeing is not expected behavior, so i would check configurations.


    tim

    Monday, July 22, 2019 1:02 PM
  • Yes all has been checked with Dell and they see no issues, this is happening with multiple servers.
    Monday, July 22, 2019 5:48 PM