none
Wi-fi hotspot connected successfully but no Internet Connection

    Question

  • I've created the Hotspot and it's successfully connected to my phone, but I couldn't use the Internet.  I'm pretty sure that my phone works fine. I've even tried to Rollback my wifi driver but ended up in nothing. Even I couldn't find new update for my wifi Driver. I even tried the Third party software to create Hotspot (Connectify Dispatch), Despite it connected successfully to my phone, I couldn't access the Internet.
    (Note: I use Windows 8.1)
    Wednesday, November 20, 2013 10:48 AM

Answers

  • Hi,

    It seems like there was some problem with this blog, may be you couldn't open it, you can follow the steps below to troubleshoot this problem.

    1. Try to use network troubleshooter to identify and fix this problem.

    2. Reinstall wireless adapter driver for test.

    3. Try resetting  TCP/IP.
     
    Reset TCPIP and check  if it works.
     
    Follow the steps

    a) Boot to the desktop view.

    b) Open command prompt, right click in the left corner when the Start window appear and select command prompt (admin).

    c) At the command prompt, copy and paste (or type) the following command and then press ENTER:
    netsh int ip reset c:\resetlog.txt

    Note: If you do not want to specify a directory path for the log file, use the following command:
    netsh int ip reset resetlog.txt

    d) Reboot the computer.
     
    Let us know the status.


    Roger Lu
    TechNet Community Support

    Thursday, November 28, 2013 2:43 AM
    Moderator

All replies

  • Hi,

    I'm a bit confused by your description, Did you mean that you create a hotspot on your computer, while your phone connected but couldn't connect to the internet? or you create a hotspot on your phone, while your computer connected but couldn't connect to the internet?

    For computer WIFI connection problem, You can refer to the link below to resolve this problem for test.

    Windows 8.1 Wifi showing "limited" or "No Internet Access":

    http://blogs.technet.com/b/dennis_schnell/archive/2013/08/31/windows-8-1-wifi-showing-quot-limitied-quot-or-quot-no-internet-access-quot.aspx


    Roger Lu
    TechNet Community Support

    Monday, November 25, 2013 9:24 AM
    Moderator
  • Hi,

    It seems like there was some problem with this blog, may be you couldn't open it, you can follow the steps below to troubleshoot this problem.

    1. Try to use network troubleshooter to identify and fix this problem.

    2. Reinstall wireless adapter driver for test.

    3. Try resetting  TCP/IP.
     
    Reset TCPIP and check  if it works.
     
    Follow the steps

    a) Boot to the desktop view.

    b) Open command prompt, right click in the left corner when the Start window appear and select command prompt (admin).

    c) At the command prompt, copy and paste (or type) the following command and then press ENTER:
    netsh int ip reset c:\resetlog.txt

    Note: If you do not want to specify a directory path for the log file, use the following command:
    netsh int ip reset resetlog.txt

    d) Reboot the computer.
     
    Let us know the status.


    Roger Lu
    TechNet Community Support

    Thursday, November 28, 2013 2:43 AM
    Moderator
  • Thank you Roger. It worked! Sorry, it took little bit later to comment here. Thanks again

    Con Amore, Andrew James A


    Tuesday, January 28, 2014 9:30 AM
  • Dear Roger,

    I tried it but not worked i am using windows 8. mobile showing connected to hot spot wifi but network is still not there.

    Please suggest if you have any solution for this.

    Thanks.

    • Proposed as answer by Rakshith Rohan Tuesday, April 22, 2014 5:53 AM
    • Unproposed as answer by Rakshith Rohan Tuesday, April 22, 2014 5:53 AM
    Saturday, March 01, 2014 8:35 PM
  • Hi

    Did you share your WiFi Network with the configured HotSpot?

    Saturday, March 01, 2014 9:38 PM
  • I faced the same problem in Windows 8.1 . After several unsuccessful attempts at updating the network adapters , I changed the internet sharing settings in my anti virus which was by default set to OFF. This caused me to successfully establish Wi-Fi connection but without a working internet connection. Also check the windows firewall if you have set the private connection containing the virtual network to be blocked. Enjoy. :)
    Friday, April 11, 2014 10:50 AM
  • Hi,               (SOLUTIONS)

         Turn off windows firewall, Antivirus as well as Windows defender then try it..and dont forget to share your LAN connection/dongle  to Virtual wifi hotspot..(go to LAN properties select share tab and click allow sharing)

    NEXT:

        Run cmd as an administrator then type two commands as mentioned below:

                  1. netsh wlan set hostednetwork mode=allow ssid=mywifi key=12345678 (8 char must) Press enter

                   2.netsh wlan start hostednetwork (Press enter)

      

      Thanks

      Rohan Rakshith


    • Proposed as answer by Rakshith Rohan Tuesday, April 22, 2014 5:54 AM
    Tuesday, April 22, 2014 5:53 AM
  • HI,

    DID U TRY THESE SETTINGS ?

    IF NOT THEN TRY AND I HOPE U'LL GET IT THIS TIME

    CONTROL PANEL>NETWORK AND INTERNET>NETWORK CONNECTIONS 

    RIGHT CLICK ON WIFI ADAPTER AND CHOOSE PROPERTIES

    IN PROPERTIES DIALOG BOX GO TO SHARING AND ENABLE " ALLOW OTHER NETWORK USERS TO CONNECT THROUGH THIS COMPUTER'S INTERNET CONNECTION" 

    Thursday, June 12, 2014 8:41 AM
  • Done as you mentioned.still facing problem.pls help me out

    Thursday, June 19, 2014 4:42 PM
  • done

    Thursday, June 19, 2014 4:42 PM
  • Hi dear...

    thanks a lot, I have 3 days without internet on my computer, but his show me connect on WIFI.

    I used you steps to repair this problems, now all browsers a connect to networking.

    Friday, July 25, 2014 7:10 AM
  • POSSIBLE FIX FOUND........................

    Look at this page

    http://adamralph.com/2014/01/24/continuously-losing-internet-connectivity-in-windows-8-1/

    The fix may be as simple as running

    netsh winsock reset

    and reboot.
    Wednesday, August 20, 2014 6:47 PM
  • This worked for me.Thanks
    Sunday, December 07, 2014 12:25 PM
  • Hi, this has been bugging me ever since i have windows8. I have an iPhone6 and when i enable personal hotpsot i can connect with the iphone from any laptop running linux or windows7. But my windows8 laptop failed. It did make a wifi connection, and the iphone counted 1 connected device. But i could not access any internet address. Reading this site and trying some of the mentioned solutions i stumbled upon the trick that worked for me. When i access the wifi network with my right mouse button (enter connection center or something like it) and pressed the The Change Adaptor settings I saw that my Bluetooth Network Connection was not active. When i double clicked it i did see my iPhone but it was not connected somehow (while wifi did show me a connection). After i selected my iphone and pressed Connect Using: Access point, i did have internet!!

    I did not find the solution to connect permanently but this workaround is good enough for me. Thanks for all your tips.

    Friday, January 30, 2015 6:53 PM
  • I did not find the solution to connect permanently

    See if this gives you any clues (command pipeline for a cmd window):

    netsh wlan sh in | findstr /i "conn stat"

    (I.e., enter that before using your workaround.)

     

    HTH



    Robert Aldwinckle
    ---

    Friday, January 30, 2015 9:55 PM
  • Thank you for taking the time to help with this. I did what you suggested (without the pipesymbol). This is the result (i changed some IDs en addresses):

    C:\Users\Leon>netsh wlan sh in

    There is 1 interface on the system:

        Name                   : WiFi
        Description            : Intel(R) Dual Band Wireless-AC 7260
        GUID                   : xxxx
        Physical address       : xxxx
        State                  : connected
        SSID                   : iPhone6-leon
        BSSID                  : xxxx
        Network type           : Infrastructure
        Radio type             : 802.11n
        Authentication         : WPA2-Personal
        Cipher                 : CCMP
        Connection mode        : Auto Connect
        Channel                : 1
        Receive rate (Mbps)    : 72
        Transmit rate (Mbps)   : 72
        Signal                 : 99%
        Profile                : iPhone6-leon

        Hosted network status  : Not available

    C:\Users\Leon>ping www.google.com
    Ping request could not find host www.google.com. Please check the name and try
    gain.

    THIS IS WHERE I DID THE CONNECT WITH BLUETOOTH DEVICE (as mentioned in my solution)

    C:\Users\Leon>netsh wlan sh in

    There is 1 interface on the system:

        Name                   : WiFi
        Description            : Intel(R) Dual Band Wireless-AC 7260
        GUID                   : xxxx
        Physical address       : xxxx
        State                  : connected
        SSID                   : iPhone6-leon
        BSSID                  : xxxx
        Network type           : Infrastructure
        Radio type             : 802.11n
        Authentication         : WPA2-Personal
        Cipher                 : CCMP
        Connection mode        : Auto Connect
        Channel                : 1
        Receive rate (Mbps)    : 72
        Transmit rate (Mbps)   : 72
        Signal                 : 99%
        Profile                : iPhone6-leon

        Hosted network status  : Not available

    C:\Users\Leon>ping www.google.com

    Pinging www.google.com [74.125.136.103] with 32 bytes of data:
    Reply from 74.125.136.103: bytes=32 time=90ms TTL=45

    I am no network expert but I don't see any differences. There might be a way to let the Bluetooth device connect automatically, but I wouldn't know how.

    Saturday, January 31, 2015 3:36 PM
  • I am no network expert but I don't see any differences.

    Ditto.  I was hoping the Connection mode  would provide the clue.

    There might be a way to let the Bluetooth device connect automatically, but I wouldn't know how.

    That's what I would like too.  Between my Surface RT and Surface Pro.  I even called my SSID for my HostedNetwork BT in hopes that would give it the idea.  Somehow they get connected but I don't know if it is because of BT or not.  But I don't need it that often so I just use the netsh wlan sta ho on both sides when I need it.  So then when I go Win-w Bl Enter (all that I need to identify MUF Bluetooth Settings) in each I can see that they are paired.  Why?  I have no idea.   ; )

    But all that I was trying to help you find was a better workaround than your current procedure.  So, perhaps you can use a modification of the one that I use?

     

    Good luck



    Robert Aldwinckle
    ---

    Saturday, January 31, 2015 4:50 PM
  • Thank you for your help. I also do not use the connection between my laptop and my iPhone all that often. What i read somewhere was to create a shortcut on my desktop that will bring me directly to my Bluetooth devices. So i can connect the device manually with a minimum of mouse clicks. That is good enough for me.

    Thanks again!

    Monday, February 02, 2015 10:51 AM
  • when I go Win-w Bl Enter (all that I need to identify MUF Bluetooth Settings) in each I can see that they are paired.  Why?  I have no idea.   ; )

    Now I know.  I decided to unpair them and see what the actual UX was for pairing them again.  What a horrible experience!  They mention Passkey (or Passcode) and can't seem to decide which side is going to say what.  Mostly they just say "That didn't work."  Whatever the results are from the experience I can say, definitely stay away from the MUF Bluetooth Settings dialog, as temptingly simple as it may appear because I think it is correspondingly ineffective.  The procedure that I think finally worked was first using the Control Panel's procedure on the Pro side. That finally gave a quirky prompt on the RT side with both showing the same Passkey.  Good grief.



    Robert Aldwinckle
    ---

    Monday, February 02, 2015 4:33 PM
  • my phn shoing connected bt not connecting to internet.

    bt my laptop is working with internet.

     
    Monday, April 06, 2015 7:10 PM