none
Multicast Windows 8.1 deployment

    Question

  • Hello,

    We use a WDS to Deploy our Windows images. This by itself is working.

    I have enabled Multicast on the Image, and enabled IGMP and setup Multicast on the network. I used Wsend and Wlisten to test the Multicast and I can get the Multicast traffic to flow between the server and my computer. 

    But when I connect a computer in the same range as my computer (same VLAN) and start deployment, it starts and then skips the multicast transmission and goes back to SMB based connection. 

    My Multicast range is 239.192.0.2 and 239.192.0.252 and UDP Port Policy is 640001 and 65000

    TFTP Maximum Block Size is set as 1432

    What could be possibly wrong? Do I need to edit the default.bcd file manually?

    Regards,

    Ramu


    Ramu V Ramanan

    Wednesday, August 27, 2014 5:56 AM

Answers

  • See Wade, the IGMP settings when in place, I can get multicast to work. But not through WDS, but from a third party tool and I can confirm the muticast packets through the router interface stats as well as through the applicatiion. I am pretty positive the muticast itself is working and network is fine. 

    I have already referred to the KB2582106  and the packet sizes have been switched and tested. But those articles are not referring to 2012 and there are no reference or blogs to 2012 settings for WDS/MDT. 

    I have given up and started using normal SBM connections. 


    Ramu V Ramanan

    Saturday, September 06, 2014 1:42 AM

All replies

  • Hi  Ramu,

    I am afraid there is no need to edit the default.bcd file.

    After you configure Windows Deployment Services server, if you modify the Multicast IP Address, the UDP port range, or the RPC port number, you must restart the service before the changes will take effect. If you do not restart the service, the server will use the old values and may not answer clients. Perhaps that’s why this situation happens. I suggest to restart the service to see the result. To restart the service, right-click the server in the MMC snap-in, click All Tasks, and then click Restart.

    You can follow the article below to see the detail, pay attention to the “known issues in creating a multicast transmission” part:

    http://technet.microsoft.com/en-us/library/dd637994(v=ws.10).aspx

    Regards


    Wade Liu
    TechNet Community Support


    Thursday, August 28, 2014 11:07 AM
  • Hello Wade,

    I have restarted the services and the server itself and that has made not changes.

    I have read the article and known issues section doesn't match my situation. As I mentioned earlier, I can create a Multicast stream using WSend and use Wlisten to join the same stream. This rules out network as the Multicast itself works. Just that WDS doesn't use Multicast for some reason over the same network. In the WSend and Wlisten, the only different we create a Muticast stream and we have the option to configure a address. With WDS I believe its random. Also with WDS when I look at the router, I can see attempts from WDS but the actual data stream is dropping. I am inclined to feel its some setting, like TTL, but not sure how to troubleshoot.

    Regards,

    Ramu


    Ramu V Ramanan

    Thursday, August 28, 2014 12:04 PM
  • Hi  Ramu,

    I would suggest to use the default IP range for multicast, the one as below:

    Or you just choose to use the IP address from the DHCP. I don’t know what’s the DHCP range in your network environment, but as in your description, the  multicast goes back to SMB connection, this might be a IP conflict.

    Any further issues, you can post it back.

    Regards


    Wade Liu
    TechNet Community Support


    Sunday, August 31, 2014 5:15 AM
  • Will try that and let you know.

    The reason for the change was : Ref: http://support.microsoft.com/kb/2582106 : 'The default Multicast range in WDS is 239.0.0.1 to 239.0.0.254.  Depending on the network this may not work.  Change the range to 239.192.0.2 to 239.192.0.250 or check with your network administrator for a unused range' : 

    Regards,

    Ramu


    Ramu V Ramanan

    Sunday, August 31, 2014 10:24 AM
  • That didn't make any difference unfortunately.

    Regards,

    Ramu


    Ramu V Ramanan

    Tuesday, September 02, 2014 4:32 AM
  • Hi  Ramu,

     I want to know what is the Windows server edition of the WDS server?

    There are many possible causes for a multicast deployment to fail, One possible reason is that the network router/switches do not handle IP fragmentation properly.

    If you are using a Windows server 2008 series, you can follow the article below to solve this.

    http://support.microsoft.com/kb/2582106 

    Regards


    Wade Liu
    TechNet Community Support

    Wednesday, September 03, 2014 9:30 AM
  • The server is now Server 2012 R2 Standard. 

    The article applies to 2008R2, is that the same values for 2012 R2?


    Ramu V Ramanan

    Wednesday, September 03, 2014 10:19 AM
  • Hi  Ramu,

    That's why I asked the Windows server edition at first, it is not the same for Windows server 2012R2, but at least, it gives a right direction, this happens normally because the network fails to forward multicast because of the switch settings.

    For instance, on some switches the default value for ip igmp query-interval is 60 seconds, which means that the switch will stop forwarding multicast traffic to the port after 3 * 60 = 180 seconds if it doesn’t seen any IGMP traffic.  Contact your switch vendor for how to configure these timeouts.

    Regards



    Wade Liu
    TechNet Community Support

    Friday, September 05, 2014 2:09 AM
  • See Wade, the IGMP settings when in place, I can get multicast to work. But not through WDS, but from a third party tool and I can confirm the muticast packets through the router interface stats as well as through the applicatiion. I am pretty positive the muticast itself is working and network is fine. 

    I have already referred to the KB2582106  and the packet sizes have been switched and tested. But those articles are not referring to 2012 and there are no reference or blogs to 2012 settings for WDS/MDT. 

    I have given up and started using normal SBM connections. 


    Ramu V Ramanan

    Saturday, September 06, 2014 1:42 AM
  • Hi  Ramu,

     It's good that there is a workaround available for now, if you have any other clue or background information provided, you can post it back or create a new thread at this forum.

    Regards


    Wade Liu
    TechNet Community Support

    Tuesday, September 09, 2014 3:16 AM