Visual C++ Runtime error with wmplayer.exe



    I have Vista Ultimate 64 with wmplayer 11.0.6001.7000. Automatic updates run. For the last month or so (I can't link it to any new installations), I have started getting the delightful:


    | Microsoft Visual C++ Runtime Library                              |X|


    | Runtime Error!                                                      |

    | Program: C:\Program Files (x86)\Windows Media Player\wmplayer.exe   |

    |                                                                     |

    | This application has requested the Runtime to terminate it in an    |

    | unusal way.                                                         |

    | Please contact the application's support team for more information. |


    |                                                             | OK |  |



    message box. I have an up to date version of Trend Micro PC-cilling Internet Security 2007 running all the time.


    I have seen discussion of this problem in relation to internet explorer and windows explorer, but not with wmplayer.


    Despite the message, the player runs fine so long as you don't tell it <OK>.


    Any ideas?



    Friday, October 10, 2008 10:12 AM

All replies

  • u cud try reinstalling media player. the installation of ur pprevious installation probably got corrupted or it was the incorect version for ur architechture. male sure u downlaod the x86 version n not the x64. alo temporarily close n stop ur virus protection when installing since these prevent certain scripts from executing. ur player may seem to work fine but certain features might act erractic, especially if ur encoding r decoding. lemme kno if it works.

    having trouble fnding the right one visit

    Sunday, October 12, 2008 3:28 AM
  • Okay, I will try it. Why the x86 version and not the 64-bit (I am running Vista Ultimate 64-bit on a Q6600)?



    Sunday, October 12, 2008 6:40 PM
  • in that case, download the x64 version of the player. most ppl use a 32-bit version of vista so i recommended the x86 version. lemme know if any joy.

    Thursday, October 16, 2008 9:23 PM
  • Ah! I can't :-( Vista will not allow me to install it because it is older than the version already installed. I also cannot uninstall it - there is no mentio of it in the installed software list, or in the Windows components list. <Sigh!>



    Friday, October 17, 2008 2:37 PM
  • Windows Media Player (WMP) is part of the basic installation of Windows Vista so there is no option to remove it from Control Panel -> Programs or to run a stand alone re-installation of the Windows Media Player for Vista.

    The easiest way to solve problem with the Windows Media Player 11 for Vista is by using System Restore to restore your system to a date where Windows Media Player was still working without problems. To do so:

    1. Go to Start-menu -> Search-bar -> type in RESTORE and press Enter on your keyboard. This will open the System Restore program.
    2. Select a restore point after clicking on Next.

    Select a date before the issue first occured to get the system repaired. If you have installed additional applications after the 24th February it will be necessary to reinstall the software of course.



    Friday, October 17, 2008 11:28 PM
  • I have the same error  Visual C++ Runtime error with wmplayer.exe. Media player keeps running without problem until I click "OK" on the error message. I'm running Vista Business 32bit.



    Thursday, December 04, 2008 4:37 PM
  • Oh! Sorry - I fixed mine. I should have said... Perhaps this will help you and others if they have the same problem. I had deleted/moved some media files to a different location in my PC and had not rescanned the HDD for media. The broken links in the library were the cause of the problem. This is really a bug that could be fixed with a proper error message when the links do not resolve correctly.


    I did a rescan of my HDDs for media and when the library had sync'ed up, the problem went away...





    Thursday, December 04, 2008 7:40 PM
  • I was having the same error and appear to have fixed it with your suggestion.  Only problem I had was finding how to rescan.  I went into more options, then advanced and advanced again.  When I close that window, it did a scan of the drive.  Only problem was, it found over 9000 items.  Not sure what they are or where it put them because they are not showing up in my library.  But again, the problem seems to be resolved.

    Thanks for the help.

    Saturday, December 13, 2008 12:44 AM
  • Sorry, missed a step.  Went into "more options", then "monitor folders", then "advanced" and "advanced" again.

    Saturday, December 13, 2008 12:48 AM