Windows 7 clock is running very fast


  • I'm running Windows 7 64bit RC, not as a Virtual Machine. (only OS on this box).
    Athlon II X2 250 processor, 780V chipset. (Asus M3A78-CM motherboard).

    If I bring up the clock on-screen the second hand is moving ridiculously fast (1 minute takes about 2.5 seconds).

    Things I've tried:
    I updated my BIOS to the latest version.
    Note: It doesn't appear to be a hardware issue (at least with the CMOS clock), as when I'm in the BIOS the clock takes 60 seconds for 1 minute.
    I had heard that the problem was possibly related to the high precision event timer, but I don't appear to have a way to disable that from the BIOS, and disabling it in the Device manager didn't do anything.
    The other possibility was supposedly Cool N Quiet (which I have tried disabling from the BIOS, again with no luck).

    Any idea what to try next?

    Note: It was not doing this when I originally installed the OS. but Defender and my Anti-Virus find nothing so it doesn't appear to be malware... I'm not exactly sure when it started as I only noticed when I was on a web forum and animated gifs on some adverts were changing very quickly.
    Sunday, November 08, 2009 7:02 AM


  • I found a solution for my system.  I switched the computer off at the wall and waited a few seconds, turned it back on, then waited a few more seconds before pressing the power button.  Its working ok now.   It hasn't repeated the problem having turned it off and on again a couple of times now.
    • Marked as answer by MLeiper Thursday, November 19, 2009 9:45 AM
    Wednesday, November 18, 2009 10:23 PM

All replies

  • Hi Mleiper,

    Mostly, this issue is caused by Windows Time service corrupt. You can try to take following steps to troubleshoot this issue.

    Run the following command in a elevate privileges cmd window.

    net stop w32time
    w32tm /unregister
    w32tm /register
    net start w32time

    Then, please restart the computer to test the issue again.

    If any error message was received when trying to take my suggestion, please let me know.

    Hope it helps.

    Tuesday, November 10, 2009 6:06 AM
  • Thanks, for the suggestion.
    Unfortunately, it doesn't seem to be the answer.

    i.e. when I ran net stop w32time, it told me it wasn't running.
    I've run the other commands, got an error on the unregister (probably because it wasn't registered), and then registered and started w32time. But a minute is still passing in 2½ seconds after a reboot.
    Tuesday, November 10, 2009 10:30 AM
  • Hi Mleiper,

    I noticed you said "when I ran net stop w32time, it told me it wasn't running", maybe we found the culprit.

    Could you please check following settings?

    1. Click Start, type services.msc and press Enter.
    2. Please locate a service named Windows Time and double click it.
    3. Does the service status is Start? If not, please try to start it.
    4. Please try to change the startup type to Automatic.
    5. Restart the computer to check the issue still persist.
    6. If the issue still persists, please let me know this service status.

    Thank you for your cooperation.
    Wednesday, November 11, 2009 8:15 AM
  • There is no Windows Time service running when I bring up services.msc. (My clock is re-syncing to internet time periodically)

    Today when I tried the net start w32time, I get an error message (which I didn't get yesterday).

    C:\Windows\system32>net start w32time
    System error 1290 has occurred.

    The service start failed since one or more services in the same process have an
    incompatible service SID type setting. A service with restricted service SID typ
    e can only coexist in the same process with other services with a restricted SID
     type. If the service SID type for this service was just configured, the hosting
     process must be restarted in order to start this service.

    I've just gone through the steps at (although the entry was already there, will try a reboot, and come back...)
    Wednesday, November 11, 2009 10:30 AM
  • OK - When I first went into services.msc, Windows Time wasn't there at all.

    Tried to start it, and got error 1290, so I re-entered the registry entry as per to re-enter my HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TapiSrv entry (which didn't appear to be any different, but when I rebooted, Windows Time was now in services.)

    It was already flagged as automatic, but not started. I started it, and rebooted.
    Again, if I go into services.msc after the reboot, it's not started, but still flagged automatic.

    I changed it to automatic (delayed start), and rebooted. It now shows as started, but I still have a clock that goes forward a minute every 2½ seconds.
    Wednesday, November 11, 2009 10:55 AM
  • Hi Mleiper,

    Glad to hear the Windows Time sevice is back. Given the current stage, I have following suggestion;

    Suggestion 1: Register dll file and reset SNTP.
    Please run the following command in a elevate privileges cmd window.

    net stop w32time
    w32tm /unregister
    w32tm /register
    regsvr32 c:\windows\system32\w32time.dll
    w32tm /config /,0x4 /syncfromflags:MANUAL
    net start w32time

    Then, please test the issue again. If the issue still persists, please take the following suggestions.

    Suggestion 2: Reset Windows Time Service related group policy
    1.  Click Start, click Run, type gpedit.msc , and then click OK. 
    2.  In the Group Policy Object Editor MMC snap-in, expand Computer Configuration, expand Administrative Templates, expand System, and then click Windows Time Service. 
    3.  In the right pane, right-click Global Configuration Settings, and then click Properties. 
    4.  In the Global Configuration Settings Properties dialog box, click Not Configured, and then click OK. 
    5.  Expand Windows Time Service, click Time Providers, and then set all the objects in this node to Not Configured. To do this, follow these steps: a.  In the right pane, double-click Enable Windows NTP Client, click Not Configured, and then click OK. 
    b.  In the right pane, double-click Configure Windows NTP Client, click Not Configured, and then click OK. 
    c.  In the right pane, double-click Enable Windows NTP Server, click Not Configured, and then click OK. 

    Does it work?

    Hope it helps.

    Thursday, November 12, 2009 9:33 AM
  • Robinson, Thanks again, Tried that, but still no luck - rebooted after each of the two options, but clock is still going very fast. On the second option, all the items were already flagged as not configured. Is there some sort of diagnostic info you might want? - even something as simple as the list of services running, or the processes listed in Task Manager? MLeiper
    Friday, November 13, 2009 10:10 AM
  • I've got exactly the same issue.   The clock is spinning like crazy, the hourglass spins like crazy.  The cursor blinks fast, videos and music play fast, the windows splash screen flashes quickly.   The screensaver even kicks in very quickly.

    When I'm in the bios, the clock is normal, it just goes crazy when windows is running.  I can boot of a xp pe disk and its all normal.  It ran fine for quite a few weeks and now this.

    My hardware is Phenom 905e with Asus m4a785td-v evo.  Slightly similar to yours.

    I'm keen to get this sorted out because I need this thing working.   Any further ideas would be appreciated.
    Wednesday, November 18, 2009 5:40 AM
  • I found a solution for my system.  I switched the computer off at the wall and waited a few seconds, turned it back on, then waited a few more seconds before pressing the power button.  Its working ok now.   It hasn't repeated the problem having turned it off and on again a couple of times now.
    • Marked as answer by MLeiper Thursday, November 19, 2009 9:45 AM
    Wednesday, November 18, 2009 10:23 PM
  • OK - that worked for me too.

    Must mean there's some motherboard circuitry that still gets power even when the PC is switched off, that's not powered from the CMOS battery, but needs a physical power disconnect rather than just a shutdown to reset it... (i.e. Must be somehow linked to something like wake on lan, wake on keyboard, where I know power tends to be there after shutdown.) - but that is somehow tied into the timing circuitry (but not the CMOS clock)?
    Thursday, November 19, 2009 9:45 AM
  • I have same mainboard with you and same issue as well. Even when I try to re-install the windows and boot from Windows CD, the installation goes very fast too.

    It appears only happening on AMD chipset?
    Tuesday, November 24, 2009 12:52 AM
  • I also had the same problem with a M4A785TD-V mobo and Windows 7/ 64 bit, and my experience supports MLeiper's hypothesis above.  In my case the timing went haywire from the first restart of the Windows installation.  The keyboard was unusable - 20-30 duplicated characters from a momentary key press (this makes installing Windows interesting !), and no doubleclick function from the mouse.  No USB devices were recognised and the monitor kept going dark after just  seconds of inactivity. 

    After 2 days of fiddling around (changing power supplies, resetting BIOS and CMOS, etc, all to no effect) the problem has gone away this evening, after I followed the steps outlined above (thanks guys) and

    1. Persevered with a basic Windows install until I could reset the parameters of Windows Time Service as described above by Robinson to Started/ Automatic
    2. Shut down the PC, and unplugged all power cables and other cables to powered devices eg monitor, printer  (this must allow the mobo hardware powering Windows Time to initialise properly)
    3. Plugged cables etc back in and restarted

    Windows started up OK and has remained OK through 4 subsequent restarts while I installed PC software.  It will be interesting to see whether it still works tomorrow.

    Next time I upgrade my PC I'll probably go for a Mac instead ...
    Tuesday, November 24, 2009 10:56 PM
  • having the same problem on win 7 64 with m4a785td-v evo
    what's goin on here
    problem started when i installed a pcie 600 tuner card...uninstalled, system restore ,drivers everything
    still same problem ,,,will try power cord suggestion

    thinkin it was that asus turbo key button? on mobo
    Saturday, December 26, 2009 6:48 PM
  • My problems are very similar. Motherboard M4A785D-M PRO, Processor Athlon 64 X2 5000+ Black Edition, 2x2gb RAM, and Windows 7 Ulitimate 32 bit.
    When I unplugged, working normaly, but I always shutdown my PC, and sometime when it started again, these problems with clock running, are back.
    I think that phrase "Windows 7 Ready" from ASUS is a problem.
    Tuesday, January 12, 2010 8:46 AM
  • I have a very very similiar hardware/OS set up. My computer was shut down unexpectedly due to a momentary power intruption. Computer was connected to a simple surge protector. The computer would not turn back on. But the USB remote receiver and keyboard still had power. Switching the power supply's switch off then on let the computer burn back on. The four color dots forming the MS logo blinking very fast. (the rest of the problems were described as above). I was kind of lucky to solve the problem in a very short time by unplugging the power supply and without making any changes at all. When I call tech support at work, I always get an advise to disconnect, wait then reconnect. It still work for this problem.
    Sunday, February 07, 2010 6:50 AM
  • Had/Have exactly the same issue on my Asus M4A785TD-V Evo board. Dual boots with Ubuntu Linux and BIOS and Linux clocks are always OK, yet Windows clock run 30x too fast. Tried Windows XP 32/64bit, Windows 7 32/64bit and Windows Server 2008R2 64bit and had same issue on all of them. Tried the power cord thing and that worked first time.
    However after a power-cut I had same problem and disconnecting poer didn't help. After playing with the BIOS settings I found that disabling the SVD (Secure virtualisation mode on processors) all was fine again.
    It seems that the virtualistion option screws the clock in Windows. THis may be because I installed the OSes with it off then turned it on (Therefore installing with it on won't cause an issue.....still to be verified!)
    Will update you all when I have more information.

    Sunday, March 07, 2010 5:23 PM
  • hi ,

    one of the most simple ways to prevent the clock from running to fast or to slow is two fold , first click on ' change date and time settings ' , go to the tab

    ' internet time ' , click ' change settings ' and flag ' synchro with internet server ' from ** **

    if that fails open your comp , you will see a small flat battery somewhere on the mother board ( note some cheap models dont have this ) , remove it and replace it 

    with the same type , make sure your comp is remove from the electricity and you have rubber soles on your shoes (!!) while doing this !

    in some comps it can be fixed with a simple update , some older dell's and HP's are missing in the bios and OS the right software code

    have a nice day
    Scan with OneCare + 50 Windows 7even Tips + Plagued by the Privacy Center? REMOVE IT + Threat Research & Response Blog + Sysinternals Live tools + TRANSLATOR+ Photosynth + Microsoft Security + Microsoft SUPPORT + PIVOT from Live Labs + Microsoft Live Labs + Get OFFICE 2010 FREE ! + Get Windows LIVE! +
    - Had same problem, clock ran 1 minute every 2 sec or so
    - The context was a brand new out of the box HP TX2 tablet PC with Vista 64

    - HP support helped me run some diags and recommended reseating memory chips
    - That appeared to fix it, it rebooted and ran ok several days
    - However, the problem reappeared a few days later
    - HP support then sent me 2 brand new 2gig memory simms
    - Problem is gone (that was several weeks ago) 

    - This was apparently an intermittent hardware problem (bad memory simm)
    - It apparently had nothing to do with Windows Vista (which was on it originally)
    - It apparently had nothing to do with Windows 7 (which is on it now and working fine)
    Wednesday, March 10, 2010 6:38 PM
  • Not a synchronisation issue. Clock runs 15 to 20 times too fast. Synchronising that is not solving the problem, just resetting the fault count back to zero. Also this doesn;t help when you're trying to double-click on items.

    Beg to differ with some of you guys and gals, but the BIOS clock on this board is fine. The clock in Linux OSes is also fine so the issue is not the hardware. The issue only occurs when using Windows 7 or Server 2008R2.  There is a workaround for Server 2008R2. That is to turn off the Virtualisation on the processors or turn off the clock adjustment if you have VM on. This does not work on 7.

    This tells me that it is the way these OSes read the clock frequency. I would normally say thats a board issue with the OS drivers, but if it works on XP then it must be something in the OS that causing the problem right?

    I mean, you don't buy a new car if you have a flat tyre? (Tire)

    Saturday, May 01, 2010 9:20 PM
  • I have marked this as the answer, but it seems to be a combination of doing the w32time settings (including making sure it starts up after a reboot), and THEN shutting down and turning off the power externally for a while.

    (It's happened a couple of times on longer power cuts, after my UPS has given up... - Unfortunately the UPS is covering a couple of PCs, so it's the work one that is hooked up to it, rather than this one...)

    But each time, if I go through the w32time updates, then reboot and confirm that w32time is starting after the reboot, then shut down for a while (with power switched off at the plug), it then comes back and works...

    Tuesday, November 30, 2010 12:54 PM
  • I tried this rough style and worked very welll


    Shutdown Ur system


    switch off power supply


    Remove the RAM


    Wait for 30 seconds


    power on the system


    then put back the DIMMs


    Back to Normal.....

    • Edited by azam-shaik Saturday, January 14, 2012 2:33 PM
    Saturday, January 14, 2012 2:32 PM
  • I might be a little late with responding,

    but i also ran into this problem with my new pc:

    Asus M4A78

    AMD Phenom x3 2.3 Ghz

    4 gb ddr2 667Mhz

    1GB GDDR5 ATI radeon HD 4870

    Windows 8 pro x64

    and i tried the last option to remove my ram etc..

    it didn't work but when i accedentially touched my northbridge i fried my finger.

    so i left the switch on my psu off and waited a few mins untill my pc cooled down (i got this problem after a whitescreen)

    it cooled off and i started my pc up again and my problem was gone.

    so another solution:

    shut down, cool off, fire up, buy new coolers 

    i hope this might help some others

    Monday, April 29, 2013 1:45 AM