none
Can see some, but not all computers in network RRS feed

  • Question

  • I've just installed a Windows 10 computer in an Active Directory domain. This is the first Windows 10 workstation. When I use Windows Explorer and go to 'Network', I can see 4 of the 14 network workstations and servers. All other Windows 7 workstations can see all 14 network computers. I've tried things recommended in various Internet postings, but nothing works. I cannot determine what is different between the 4 computers that do show and the 10 that don't. Of the computers visible on the Network from a Window 7 workstation, 8 are Windows 7 computers, 1 is Windows 10, 1 is a Windows 7 Virtual Machine hosted on Linux, 2 are Linux, 2 are Mac. On the troublesome Windows 10 computer, 3 visible on the Network are Windows 7 and 1 is the WIndows 7 Virtual Machine. The other 5 Windows 7 workstations do not show, nor do any of the Linux or Mac workstations.

    Yes, I have 'Turn on Network Discovery' and 'Turn on file and printer sharing' set for Private, Guest or Public, and Domain (current profile).


    • Edited by jmarkfoley Thursday, August 15, 2019 7:45 PM
    Thursday, August 15, 2019 7:40 PM

Answers

  • I've finally found the solution. As mentioned, this problem is all over the Net, but no Windows forums or sites seem to have the answer. I was directed to the correct solution from Linuxquestions.org. Here's how to get the Network Neighborhood working with Windows 7/10 without resorting back to using SMB 1.0, note that these settings can be done on both Windows 7 and Windows 10, and need to be done on Windows 7 in order for the Windows 10 computers to see them without SMB 1.0:

    1. Verify that SMB1.0 is disabled: Control Panel > Programs and Features > Turn Windows features on or off. Scroll down to SMB 1.0/CIFS File Sharing Support and verify that all sub-features are un-checked.
    2. Set the following in the registry (regedit):
      [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\mrxsmb10] "Start"=dword:00000004 [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters] "SMB1"=dword:00000000

      or, at the cmd command prompt (run as Administrator):

    sc config mrxsmb10 start=disabled
    reg add HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters /v SMB1 /t REG_DWORD /d 0 /f
    
    1. Note that I have found these command line commands to not actually work if the registry key does not already exist. So, either use regedit to add/modify the keys explicitly, or at least check after rebooting that the setting have “taken.”

    2. Next, ensure the services that WSD rely on are run automatically. Their full names are “Function Discovery Provider Host” and “Function Discovery Resource Publication”. The registry edits/commands are either of these, as you prefer:
      [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\fdPHost] "Start"=dword:00000002 [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\FDResPub] "Start"=dword:00000002

      or, at the cmd command prompt (run as Administrator):

    sc config fdPHost start=auto
    sc config FDResPub start=auto

    Reboot the computer for these settings to take effect. After the reboot, the Windows Explorer Network Neighborhood should show all hosts in the domain which are likewise set to not use SMB 1.0.

    Vielen Dank to Stilez, the author of the first link reference below and intrepid researcher and discoverer of the correct solution.

    Note that the same link references the use of wsdd.py Python script which will enable Linux computers to likewise be discoverable without SMB 1.0. I'll not post that here as this is a Windows forum, but interest users, and admins of mixed environments, can reference the below link for that addition info.

    References:
    How to kill off SMB1, NetBIOS, WINS and still have Windows' Network Neighbourhood better than ever

    What protocol does Windows 10 use to discover network hosts?




    • Marked as answer by jmarkfoley Saturday, November 9, 2019 8:52 PM
    • Edited by jmarkfoley Saturday, November 9, 2019 8:55 PM
    Saturday, November 9, 2019 8:47 PM

All replies

  • In Start Search type Services.msc and press the Enter Key.

    Now locate the service named Function Discovery Provider Host.

    Right click on it and click on Properties.

    If the service is already running, stop it.

    Then change the Startup Type to Automatic (Delayed Start) and then Start the service.

    Click on Apply and then click on OK to save the changes.

    Reboot the computer for the changes to take an effect.


    S.Sengupta,Microsoft MVP Windows and Devices for IT, Windows Insider MVP

    Friday, August 16, 2019 3:46 AM
  • Hello,

    Make sure you've also enabled Turn on automatic setup of network connected devices option, provided next to Turn on Network Discovery option. 

    Regards.


    Microsoft MVP (Windows and Devices for IT)

    Windows Insider MVP

    Windows Help & Support [www.kapilarya.com]

    Friday, August 16, 2019 5:24 AM
  • And please do their suggestions on all the machines.

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, August 16, 2019 8:31 AM
  • Nope, still only see the same 4 workstations. I've verified that the Function Discovery Provider Host service is running, however it always reverts to Manual startup even though I've set it to Automatic (Delayed Start), twice.

    Turn on automatic setup of network connected devices is checked.

    Later ...

    I've managed to find a work-around. Instead of using the Network icon to navigate to my desired target host\Path, if I type the path directly into the Windows Explorer path box, I can access the folders/files on the remote host, e.g. \\DBSERVER\QuickBooks\myfile. Thus it's clear that this computer can access the remote computer, but the Network explorer does not show this computer.

    Friday, August 16, 2019 3:52 PM
  •   That is not uncommon. After a while (when you have searched for and found all of the missing machines) you will have all of them in the dropdown list of the search bar. I use just the name of the device, not individual files, to keep the search list simpler.

     

    Bill

    Sunday, August 18, 2019 2:33 AM
  • Bill: Not sure what you mean. How long is "after a while"? Nor am I sure how I would "search for" the missing machines. This computer has been running a week and still only the 4 computers originally visible in the Network are the ones still visible. There are 3 other essentially identical Windows 7 computers in the office not showing up. These other computers have Network Discovery and File/Printer sharing turned on. Not to mention Mac and Linux computers visible on all the Windows 7 computers. Turning off the firewall on these other computers doesn't help. Is there some communication protocol I could test for?
    Wednesday, August 28, 2019 2:32 PM
  • I've just installed a new Windows 10 Pro computer on the domain. Still showing only 4 of the Windows workstations: 3 Win7, 1 Win10 (the Win7 virtual machine has been removed). None of the other 4 Win7 workstations show up. None of the 3 Mac workstations show. None of the 3 Linux servers show. All of these computers show on all Windows 7 workstations.

    No further ideas on this? Is this simply a bug in Windows 10?


    • Edited by markFoley Sunday, September 8, 2019 5:01 AM
    Sunday, September 8, 2019 4:58 AM
  • This problem is all over the Internet including a rather lengthy thread on this forum: https://social.technet.microsoft.com/Forums/en-US/1e223ed7-e65d-466e-b7de-a3735c467967/windows-10-cannot-see-or-connect-to-network-computers?forum=win10itpronetworking. That thread dates back to 2017 and Microsoft apparently has no plans on solving this problem.  I tried a number of suggestions on that thread including:

    turn off ivp6
    netcfg -d
    Set Function Discovery Provider Host service to Auto and restart

    None of those ideas worked. What did work (also from that thread) was to enable SMB 1.0:

    Control Panel > Programs and Features > Turn Windows Features on or off > SMB 1.0/CIFS File Sharing Support > (expand), check: SMB 1.0/CIFS Client and SMB 1.0/CIFS Server

    After doing that on one of the Windows 10 computers all hosts, including Windows 10, Windows 7, Linux and Mac, appeared on the Network list!

    Not sure what to think at this point. Before doing this setting I had only 2 of the remaining 4 Windows 7 workstations, only 1 of the 6 new Windows 10 workstations and none of the Linux or Mac computers showing on the network list. Interestingly, still none of 3 the Mac workstations show.

    I will do some more experimentation with these computers to see what SMB protocol they are set to or default to.

    If Microsoft is wanting to move away from SMB 1.0, they're not doing a very good job of taking up the slack. Nor do they seem particularly responsive to complaints on this. I have two clients who are completely stuck trying to access resources on other LAN hosts.

    Monday, October 21, 2019 9:57 PM
  • Well, I spoke too soon. After rebooting my network is back to showing 1 of the 6 new Windows 10 computers and 2 of the 4 Windows 7 workstations; no Linux and no Mac. Yet, the SMB 1.0/CIFS Client and SMB 1.0/CIFS Server are still checked in "Windows Features"!

    Any ideas at all?

    Later ...

    Well, now all the computers are once again showing in the Network. Maybe I didn't wait long enough after rebooting for the system to re-discover all the hosts.


    • Edited by jmarkfoley Tuesday, October 22, 2019 3:05 PM
    Tuesday, October 22, 2019 5:00 AM
  • I have posted this question to a Linux forum: https://www.linuxquestions.org/questions/linux-networking-3/what-protocol-does-windows-10-use-to-discover-network-hosts-4175663365/, to see if there is something on that end which can be configured to use the SMB2.0 protocol for "discovering" it's presence. I'll post findings here.

    Is there something that can be set on the Windows 7 hosts to permit their discovery using SMB 2.0? That might be a first step to resolving this issue.

    Wednesday, October 30, 2019 5:26 PM
  • Question, if anyone knows: How does Windows discover hosts on the network? Does it poll IPs individually on the subnet? Does it query the DHCP server?
    Thursday, October 31, 2019 12:18 PM
  • I've finally found the solution. As mentioned, this problem is all over the Net, but no Windows forums or sites seem to have the answer. I was directed to the correct solution from Linuxquestions.org. Here's how to get the Network Neighborhood working with Windows 7/10 without resorting back to using SMB 1.0, note that these settings can be done on both Windows 7 and Windows 10, and need to be done on Windows 7 in order for the Windows 10 computers to see them without SMB 1.0:

    1. Verify that SMB1.0 is disabled: Control Panel > Programs and Features > Turn Windows features on or off. Scroll down to SMB 1.0/CIFS File Sharing Support and verify that all sub-features are un-checked.
    2. Set the following in the registry (regedit):
      [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\mrxsmb10] "Start"=dword:00000004 [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters] "SMB1"=dword:00000000

      or, at the cmd command prompt (run as Administrator):

    sc config mrxsmb10 start=disabled
    reg add HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters /v SMB1 /t REG_DWORD /d 0 /f
    
    1. Note that I have found these command line commands to not actually work if the registry key does not already exist. So, either use regedit to add/modify the keys explicitly, or at least check after rebooting that the setting have “taken.”

    2. Next, ensure the services that WSD rely on are run automatically. Their full names are “Function Discovery Provider Host” and “Function Discovery Resource Publication”. The registry edits/commands are either of these, as you prefer:
      [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\fdPHost] "Start"=dword:00000002 [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\FDResPub] "Start"=dword:00000002

      or, at the cmd command prompt (run as Administrator):

    sc config fdPHost start=auto
    sc config FDResPub start=auto

    Reboot the computer for these settings to take effect. After the reboot, the Windows Explorer Network Neighborhood should show all hosts in the domain which are likewise set to not use SMB 1.0.

    Vielen Dank to Stilez, the author of the first link reference below and intrepid researcher and discoverer of the correct solution.

    Note that the same link references the use of wsdd.py Python script which will enable Linux computers to likewise be discoverable without SMB 1.0. I'll not post that here as this is a Windows forum, but interest users, and admins of mixed environments, can reference the below link for that addition info.

    References:
    How to kill off SMB1, NetBIOS, WINS and still have Windows' Network Neighbourhood better than ever

    What protocol does Windows 10 use to discover network hosts?




    • Marked as answer by jmarkfoley Saturday, November 9, 2019 8:52 PM
    • Edited by jmarkfoley Saturday, November 9, 2019 8:55 PM
    Saturday, November 9, 2019 8:47 PM