Offer Remote Assistance - Not working from windows 7 to windows 7



    I have been unsuccessful in getting Offer RA to work from one Windows 7 box to another Windows 7 box. I have however been able to get Solicited RA to work, and I can use Offer RA to our Windows XP machines. My company is setup on a domain with 2003 servers, and we are about to roll out Windows 7 on the client machines.

    I have tried many suggested solutions to this problem including:

    • Enabling Solicited Remote Assistance & Offer Remote Assistance under domain policy and local policy alike
    •  - Under Offer Remote Assistance Helpers I have included (domain\user, domain\group, user, and group) to no avail
    • I have changed the DCOM permissions settings under raserver to include my domain administrator group
    • I have included user and domain group under the local group "Offer Remote Assistance Helpers"
    • I have verified there is no firewall active, and I am on the same subnet as the novice machine
    • I have tried both hostname and IP address to connect to
    • Under remote settings I have verified that Allow Remote Assistance is enabled and Allow this computer to be controlled is also enabled
    • I have verified this registry key is correct [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Ole]      "EnableDCOM"="Y"

    I am at a loss, and could use some suggestions. Thanks for your time.


    Friday, September 17, 2010 5:33 PM

All replies

  • Using wireshark, I can see the incoming request on the novice computer. It's almost as though I do not have permission, even though I should.
    Monday, September 20, 2010 5:56 PM
  • Hi,


    Please let me know how does the issue occur, right after you click “Invite someone you trust to help you”, or when you select any option to send an invitation. Are there any errors received?


    I suggest you log on with a local user account but not a domain account on both computers, verify the related policy and then try to launch Remote Assistance. If it works, check GPOs on your domain controller, find the GPO that changes this policy.


    More information, please refer to Windows Remote Assistance: frequently asked questions






    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by Sabrina Shen Friday, September 24, 2010 3:40 AM
    • Unmarked as answer by Wadz Friday, October 01, 2010 4:27 PM
    Tuesday, September 21, 2010 7:53 AM
  • This is using Offer Remote Assistance. I can use solicited remote assist, but this is counter productive for users that are not very computer savvy. I need Offer RA to work.

    When I open Offer RA on my computer and type in the computer name, it pops up an error that says:


    Your offer to help could not be sent -
    please check the following:
     * Do you have the correct permissions on the remote computer?
     * Is the remote computer turned on, and is it connected to the network?
     * Is there a network problem?

    Now I know that I'm connected to the computer with \\computername\c$
    It's visible and I have full permission on it. This also verifies that it is on the network, and there is no network problem.

    You can open Offer RA by using the following link: %windir%\system32\msra.exe /offerra

    Also as a side note. I use offer ra on windows XP machines all the time on this same network. There is no issue with this, and it connects to the computers right away.

    Friday, October 01, 2010 4:25 PM
  • Wadz,

    I am experiencing a similar issue and am unable to offer remote assistance from any Windows 7 Enterprise machine.  However, I can offer remote assistance from an XP or Vista box and connect to XP, Vista, and Win 7 clients, just not from my Windows 7 machine.  It is very perplexing and thus far the only solution that provides any explanation is this:

    Unfortunately it is going to big a herculean task to have our systems group agree to install this patch on our domain controllers...especially since I don't know with certainty that this is the issue.  I guess it would be possible to create a test environment, but it would be helpful to know if others are experiencing these issues as well.



    Friday, November 19, 2010 10:14 PM
  • I have the same scenario.

    Using offer remote assistance - MSRA /OFFERRA <ip_address>

    I get the error:

    Your offer to help could not be sent.


    However, if I try an invitation with file, this works fine.


    I have done everything as described by Wadz in the first post.

    Any ideas?

    Thursday, January 20, 2011 3:24 PM
  • My boss and I now have a work around for this issue. It appears as though you can not connect through offerra like this unless your computer is part of the domain. We see this issue because we use laptops for multiple clients not always on location. Our work around is to install remote assistance to a win2k8 server and rdp into that first then use offerra from there. This seems to work for xp and win7 on our clients.

    Not the best solution, but it works. I'd still like to be able to run directly from my laptop if anyone has a better idea.

    Tuesday, March 01, 2011 5:54 PM
  • You CAN offer Unsolicited Remote Assistance to Domain Users/Machines from NON-domain machines.

    1 Down load ShellRunas from:

    2 Extract the files then run:
     C:\*pathToFiles*\shellrunas.exe /reg /quiet
    C:\*pathToFiles*\shellrunas.exe/regnetonly /quiet

    3 Create a txt file named “OfferRemoteAssistance” containing:

    runas /netonly /user:DOMAIN\USER "C:\Windows\System32\msra.exe /offerra"

    5 Rename the txt file “OfferRemoteAssistance.BAT”

    6 Open the ‘User Account’ control panel, and change the ‘User Account Control’ settings slider to ‘Never notify’.
    (It won’t tell you but a restart is required)

    7 VPN to the Domain you want to offer Unsolicited Remote Assistance

     8 Then Run “OfferRemoteAssistance.BAT”

    Hope this helps!

    • Proposed as answer by bkps Saturday, July 23, 2011 11:56 PM
    Wednesday, May 18, 2011 12:31 AM