locked
A Home Group icon has appeared on my desktop, why?

    Question

  • I noticed today that there is a new icon on my desktop, called Home Group(or something like that, because my operation system is in Dutch, so it appears as Thuisgroep). I cannot remove this icon because it's not like the other shortcuts and I don't know how it appeared there. Is it because of an update of the system? I don't use the home group for now so ... I don't really need it there. Any ideas? Thanks!

    Alexandra.
    • Edited by Alexandra N Sunday, March 14, 2010 8:24 PM spelling
    Sunday, March 14, 2010 8:23 PM

Answers

  • Hello,

    To remove the Home desktop Group icon, you need to manually modify some registry key:

    1. Open notepad and then copy the following text (without ===) into it.

    ================================
    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\NewStartPanel]
    "{B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}"=dword:00000001

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\ClassicStartMenu]
    "{B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}"=dword:00000001

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\NewStartPanel]
    "{B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}"=dword:00000001

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\ClassicStartMenu]
    "{B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}"=dword:00000001
    ===========================================
    2. Save the txt file and rename to xxx.reg. Then double click xxx.reg to import the registry key.

     


    Thomas77
    • Marked as answer by Novak Wu Thursday, March 18, 2010 7:45 AM
    Monday, March 15, 2010 7:17 AM

All replies

  • Hello,

    To remove the Home desktop Group icon, you need to manually modify some registry key:

    1. Open notepad and then copy the following text (without ===) into it.

    ================================
    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\NewStartPanel]
    "{B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}"=dword:00000001

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\ClassicStartMenu]
    "{B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}"=dword:00000001

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\NewStartPanel]
    "{B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}"=dword:00000001

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\ClassicStartMenu]
    "{B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}"=dword:00000001
    ===========================================
    2. Save the txt file and rename to xxx.reg. Then double click xxx.reg to import the registry key.

     


    Thomas77
    • Marked as answer by Novak Wu Thursday, March 18, 2010 7:45 AM
    Monday, March 15, 2010 7:17 AM
  • Hiya,

     

    It's far easier to do the following. Right click home group (or in your case thuisgroep) select homegroup settings, then select leave homegroup.

    Icon vanishes, and no registry hacking in sight... :)

     

    zzark

    Save the Hive

    • Proposed as answer by ElGrillo Wednesday, October 17, 2012 6:19 AM
    Friday, August 06, 2010 5:18 AM
  • Thanks!!!!
    Thursday, March 15, 2012 7:10 PM
  • Thanks.  Most annoying that HomeGroup icon mysteriously appears on the Desktop and there is no option to remove it in Desktop Settings where you can choose other icons like Computer, Network, User.  Microsoft should get its act together.
    Friday, March 29, 2013 10:15 PM
  • Unexpected "Homegroup" icon is a hot topic. We see that "just click on leave homegroup" solution in several dot com forums. Unfortunately, for most forum visitors there is no "leave homegroup" while there is the desktop "Homegroup" icon. IMPORTANTLY, this Homegroup 'icon' is very misbehaved! Try and move it and it goes nowhere: it is locked in place, regardless of desktop settings, and it cannot be deleted.

    Perhaps enlightening, Media Center 'black screens' and otherwise corrupts Windows 8 desktops and display adapter handles (and concurrently hangs dxdiag.exe on large-memory boards). Homegroup may simply be another NOT READY Microsoft feature (fortunately not hawked at $10 a crack, like the MC).

    Back to topic, Intel.com forum posters mostly do not see any Leave Homegroup anywhere in the simple Homegroup Open dialog, nor in Control Panel\All Control Panel Items\Homegroup and all its 'offshoots [sic]'. 

    Further enlightenment, it is a fact that a joint Pentagon-FBI task force asserts that 1 in 3 computers has been maliciously attacked by "unfriendly alien governments". Now, only yesterday we tasked a Microsoft.com driver download page that had hoaxed over 180,000 'drivers-NOT' onto unsuspecting regional desktops. Is the same thing happening for every other Microsoft Hardware download item? Well, it could be this misbehaving Homegroup icon is an "unfriendly" feature, something one might intelligently expect in a nation that has been constantly at war for almost 70 years. This protracted colonial war effort has now conscripted Microsoft to program murder technology (sorry if the 'm' word is overly sensitizing, but universally massive doses of murder may explain 'unfriendly' in an 'expected' context). Tuit, these general matters may be slipping beyond the scope of civil forum enquiry.

    Back to topic one last time for this post, THIS ISSUE IS NOT RESOLVED! It seems to be hooking into the edge of compounding systemic OS flaws. FYI, we haven't got past Microsoft Help Desk (usually a receptionist in a friendly Asian state) to any Microsoft development team for over two months. So there's some hard facts for you to chew on... but what would be really nice is a Microsoft sponsored 1-2-3 method to lose the obviously corrupt icon repeatedly installed by Microsoft Windows Update on this posting stand-alone (aka NOT groupie) machine.


    Oh as I was young and easy in the mercy of his means, Time held me green and dying Though I sang in my chains like the sea.


    Sunday, April 07, 2013 11:24 AM
  • burb take note that as in other previous Windows 8 install-and-update Homegroup bug incidents, this early AM Homegroup just crawled into the woodwork somewhere, but was no longer on the desktop.

    ysk that is not always the case and in still other Windows 8 installs indeterminate things happen and the installation lasts a few minutes: that's the fun-and-exciting part of systems management lol

    just for windows 8 we've started planking each thus dedicated machine stream as nnn ... 999 should do ... we all hope ... (help) (as usual)


    Oh as I was young and easy in the mercy of his means, Time held me green and dying Though I sang in my chains like the sea.

    Sunday, April 07, 2013 12:09 PM
  • This worked for me. I was not a member of any home group and had never created one. Home-Group Icon just appeared today.

    Go To control Panel, Administrative tools, Services. Home-group listener and Home-group Provider. Right click and Stop both services.

    Then right click and select properties on each of the Home-Group Services Listener and Provider and select "disabled" from the drop down.

    Mine was set to manual and obviously that didn't work because it automatically showed up on desktop so manual setting is faulty, I disabled mine.  

    • Proposed as answer by nemmite Monday, May 06, 2013 5:34 PM
    Monday, May 06, 2013 5:34 PM
  • quote

    Go To control Panel, Administrative tools, Services. Home-group listener and Home-group Provider. Right click and Stop both services.

    well that worked fine and without all the messing around..thanks

    Question????

    Why no option to "select as an answer???


    Jetgriff

    • Proposed as answer by jetgriff Wednesday, June 26, 2013 12:56 AM
    Wednesday, June 26, 2013 12:56 AM
  • This worked for me. I was not a member of any home group and had never created one. Home-Group Icon just appeared today.

    Go To control Panel, Administrative tools, Services. Home-group listener and Home-group Provider. Right click and Stop both services.

    Then right click and select properties on each of the Home-Group Services Listener and Provider and select "disabled" from the drop down.

    Mine was set to manual and obviously that didn't work because it automatically showed up on desktop so manual setting is faulty, I disabled mine.  

    This worked perfect for me, thanks :)
    Saturday, August 17, 2013 10:08 AM
  • That's a simple and effective solution. Thanks a lot.
    Monday, October 21, 2013 12:27 PM
  • check those services that nemmite mentioned - it worked for me. 

    The home-group listener was not running but the provider was. soon as i turned it off the icon was removed automatically from my desktop

    thanks Nemmite

    Monday, December 16, 2013 4:43 PM
  • It did not work for me. Happy New Year!
    Thursday, January 02, 2014 1:30 AM
  • It worked for me. Thank you and Happy New Year!
    Thursday, January 02, 2014 1:30 AM
  • easy fix, it worked for me, thanks!
    Wednesday, January 15, 2014 7:54 PM
  • Just right click your desktop. Select "Personalize" then "Change desktop icons." Check (turn on) the "Network" icon and click "apply" (the homegroup icon will change into a network icon) then UN-check the network icon and click "apply." The unwanted icon will disappear.
    • Proposed as answer by codyrt Tuesday, February 11, 2014 12:49 AM
    Friday, January 17, 2014 1:55 PM
  • It worked. Thank you.
    Saturday, January 18, 2014 2:16 AM
  • it worked
    Saturday, January 18, 2014 4:11 AM
  • Just right click your desktop. Select "Personalize" then "Change desktop icons." Check (turn on) the "Network" icon and click "apply" (the homegroup icon will change into a network icon) then UN-check the network icon and click "apply." The unwanted icon will disappear.
    This worked for me, this is much simpler than stopping services or changing the registry, especially if you want to use HomeGroups in the future. 
    Tuesday, February 11, 2014 12:51 AM
  • it worked. thanks!!!!!!!!
    Friday, February 21, 2014 8:05 PM
  • Just right click your desktop. Select "Personalize" then "Change desktop icons." Check (turn on) the "Network" icon and click "apply" (the homegroup icon will change into a network icon) then UN-check the network icon and click "apply." The unwanted icon will disappear.

    This seems to have worked for me too. I already had the "Network" icon checked and turned on. But unchecking it got rid of the pesky "Homegroup" icon and rechecking it has not brought the "Homegroup" icon back (yet--touch wood).

    I notice there's also an "Allow themes to change desktop icons" option under "Change desktop icons". I wonder if that could be somehow causing the "Homegroup" icon's misbehavior by interacting with themes in unexpected ways?

    --

    Bob

    • Proposed as answer by Opinicus34973 Thursday, February 27, 2014 7:45 AM
    Thursday, February 27, 2014 6:04 AM
  • The question was "WHY" a HomeGroup icon has appeared on my Desktop, not how to remove it.

    I still don't know how it suddenly appeared, and why? I can't find any explanation anywhere.... and, NO, I did not drag it to my desktop, and I did not change any settings. It just appeared!

    Saturday, March 01, 2014 3:00 PM