none
Access denied installing drivers as Admin

    Question

  • Hello, when I go to install any device driver, I receive an "Access Denied" failure message. I checked the permissions on the source files and the existing files being replaced, and I have full control (logged in as local admin). I then removed it from its OU(<ou#1>) and restarted to see if it was the group policy, and I was able to install the same source driver files. I did a gpresult on <ou#1> and looked through the group policy being applied, but could not find anything related to driver installation. I'll gladly upload/share the group policy to be looked at, but I can't seem to post it with this message. 

    After putting it back in <ou#1>, I found that the driver store files at C:\windows\system32\driverstore\*.dat only had permissions for SYSTEM(but the admin group owned the files). Using SubInAcl, I added full control to these files for the admin group, which then allowed me to install/update drivers. But when I restart the computer, the permissions for those 5 driver store files are reset back to SYSTEM=full control, owner=admin group. 

    How can I stop the permissions from being reset on these 5 files when the system is restarted? *Note that this is in an Enterprise environment

    Tuesday, August 14, 2012 3:39 PM

Answers

  • Hey, I just wanted to say thanks for the very relevant help, but I've figured out the problem. After sifting through my group policy, I found that it was the point and print restrictions in the group policy that was preventing me from installing drivers.
    • Marked as answer by tuxOnWindows Friday, August 17, 2012 8:54 PM
    Friday, August 17, 2012 8:54 PM

All replies

  • Have you install with elevated rights (Run as Administrator)?

    M.

    Wednesday, August 15, 2012 4:06 PM
  • yes, I've tried installing drivers as both the local administrator and the domain administrator
    Wednesday, August 15, 2012 4:11 PM
  • Once again. Have you installed with elevated (priviledged) rights?
    Wednesday, August 15, 2012 5:50 PM
  • as stated before, yes. see picture for proof (and yes I know this isn't a pic of installing drivers, but DISM uses the same 5 driver index files)

    

    Wednesday, August 15, 2012 6:06 PM
  • Hi,


    Based on your screenshots, I’m afraid that you did not run command prompt as administrator.


    Due to User Account Control is enabled, applications and tasks always run in the security context of a non-administrator account, unless an administrator specifically authorizes administrator-level access to the computer.


    More details in User Account Control Overview for IT Professionals.


    Therefore, you can do the following:


    Method 1:


    Right click applications or command prompt and run them as administrator.




    Method 2:


    Turn off User Account Control. However, it is not recommended.


    More information:

    User Account Control

    What is User Account Control?


    Hope this helps.


    Jeremy Wu

    TechNet Community Support

    Thursday, August 16, 2012 2:44 AM
    Moderator
  • Thanks for the refresher on the basics of Windows, but I am running the command prompt with elevated permissions and Windows UAC is already turned off.  (you can see the full psr on my public skydrive)

    Note the same window title for every command prompt screenshot I've posted, signifying that they've all been "Run as administrator". If you test opening a command prompt as a standard user and as an administrator on your computer, you'll notice that the window title for each prompt is different. You should take a look at this Microsoft Technet topic to get a better understanding of running programs with different permissions than that of the logged in user.

    Thursday, August 16, 2012 2:00 PM
  • I think your reply is unrespectful with Jeremy, that was only trying to help you...


    Colobora con el foro:
    Si la respuesta es de utilidad para resolver tu duda/problema, usa la opción "Marcar como repuesta". Otros usuarios con dudas similares -en un futuro- lo agradecerán.

    Thursday, August 16, 2012 5:15 PM
  • It wasn't meant to be disrespectful, but rather to clearly demonstrate my point that he was not understanding, so that we could move past this troubleshooting step. Because I have already stated it twice and Jeremy still disbelieved me, I wanted to show without any doubt that I am running command prompt as administrator with elevated privileges. 

     
    Thursday, August 16, 2012 5:38 PM
  • Hi,


    Thanks for the reply.


    The reason I would like you to check this is that I noticed “C:\Users\Administrator>”. However, a privileged command prompt should be “C:\windows\system32>”.


    Anyway, let’s try others:


    1. Turn on UAC, run as administrator and see how it works.


    2. Create a new user administrator account and test the issue again.


    3. Run command

    whoami /all >C:\whoami.txt

    and let us know the result in C:\whoami.txt.


    In addition, please let us know the following:


    1. Is the user account a domain or a local account?

    2. Is it the build-in administrator account or just a user account named as administrator.

    3. Does any other computer in the same domain has the same issue?


    Hope this helps.


    Jeremy Wu

    TechNet Community Support

    Friday, August 17, 2012 6:33 AM
    Moderator
  • Hey, I just wanted to say thanks for the very relevant help, but I've figured out the problem. After sifting through my group policy, I found that it was the point and print restrictions in the group policy that was preventing me from installing drivers.
    • Marked as answer by tuxOnWindows Friday, August 17, 2012 8:54 PM
    Friday, August 17, 2012 8:54 PM
  • Hey, would you be kind enough to point me in the right direction for the gpo settings?

    I seem to be having the same problem.

    thanks

    R

    Monday, November 26, 2012 1:23 PM
  • Thanks very much, I guess I have a slightly different issue, as I am running windows 8, but not on a domain, it has never joined a domain.

    It was upgraded from Windows 7.

    Windows update gets access denied with error code 80070005

    installing the driver thru device manager "Update drivers" gets the same error "access denied"

    manually selecting a device driver from a list gets the same error.

    any one have any suggestions?

    thanks 

    Wednesday, November 28, 2012 3:18 PM
  • This actually solved my driver installation problem with AMD Radeon HD8570M gpu, on windows 10 and Lenovo G500 brand laptop, which was giving this error upon trial of installation: error 1603
    • Edited by malipetek Saturday, October 21, 2017 10:50 PM additional info
    Saturday, October 21, 2017 10:49 PM
  • I've troubleshooting this for 2 days now, disabling all GPOs and similar. We have this problem with NVidia Graphics drivers both in Windows 7 and Windows 10. Also some other drivers (seemingly random) that refuses to install with Exception 0x80070005 - Access is Denied.

    Finally I unloaded Trend Antivirus and it works just fine now. Not verified WHAT in Trend that causes this yet.

    Friday, March 2, 2018 8:29 AM
  • Hi Mattias,

    Thanks, unloading trend worked for us as well. We're you able to find what exception you needed to apply on trend in order proceeded with future installs without having to unload Trend ?

    Any information would help. My email is below.

    emontenegro@heat.com 

    Thanks,

    Ezequiel 

    Monday, March 19, 2018 7:53 PM
  • I found another solution. Try rebooting in safe mode and install driver. Worked as a charm for me.
    Thursday, May 24, 2018 3:29 PM