none
Clear data from prod-global-autodetect.acompli.net

    Question

  • Hi there,

    Despite setting up an autodiscover domain as per the deployment guides for moving to Exchange Online, and AutoDisover tests succeeded as expected, Outlook appears to pull old mail settings from prod-global-autodetect.acompli.net that points to our old email servers (confirmed with Fiddler).

    I've read forums posts here that indicate I need to ask for someone to clear the cache for the domain. Would appreciate it the appropriate person could clear the mail settings information for rkfes.com.

    Kind regards,
    Ben

    Tuesday, July 17, 2018 8:51 AM

All replies

  • Hi Ben,

    From the description, this issue is more related with Exchange server. I'll help move this case to Exchange Server forum to get a better response.

    Thank you for your understanding and support.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Wednesday, July 18, 2018 6:18 AM
  • Ben, what did you find here? I too am seeing an issue where the Outlook App wants to setup a Gmail account, despite AutoDiscover being configured properly, pointing to Office 365.

    Similarly, I confirmed this with fiddler.

    http://prod-global-autodetect.acompli.net:443

    I saw a few other threads with the same problem, but without resolutions, including those claiming to be working with Office 365 support.

    EDIT 1: In one of the above threads, they say to open an in-app support case and request they clear the cache for the domain with the issue. This seems like a silly solution, but I'll try it and post back.

    EDit 2: I can reproduce the problem with PowerShell. It is clear the service is returning bad info:

    $headers = @{
        "Accept-Encoding" = 'gzip'
        "User-Agent"      = 'Outlook-Android'
        "X-Email"         = 'mike@MyDomain.com'       
    }
    $Response = Invoke-WebRequest  "https://prod-global-autodetect.acompli.net/autodetect/detect" -Headers $headers
    $Response.Content | ConvertFrom-Json | select -ExpandProperty protocols


    {
    "email": "mike@myDomain.com",
    "services": [
      {
    "service": "google"
    }
    ],
    "protocols": [
      {
    "protocol": "imap",
    "hostname": "imap.gmail.com",
    "port": 993,
    "encryption": "ssl",
    "username": "mike@myDomain.com",
    "validated": false
    },
      {
    "protocol": "smtp",
    "hostname": "smtp.gmail.com",
    "port": 465,
    "encryption": "ssl",
    "username": "mike@myDomain.com",
    "validated": false
    }
    ],
    }

    Final Edit / Resolution:

    In the end, our customer updated the MX record and 12-14 hours later, the service started feeding the correct data into the app. I opened an in-app support case, and after a week of trying to explain the situation to them, I gave up. I did however hear from a colleague that you should be able to open a case in the Office 365 portal and ask them to look up an article called:  "How to file an endpoint change request for the Outlook AutoDetect service" (KB: 4052171).

    Hopefully Microsoft will realize we took the time to publish AutoDiscover for a reason, and if they want to use MX as a factor, great, but it should be BEHIND the AutoDiscover logic.


    Mike Crowley
    My Blog -- Baseline Technologies





    Thursday, November 22, 2018 6:24 AM
  • Hi Ben,

    From the description, this issue is more related with Exchange server. I'll help move this case to Exchange Server forum to get a better response.

    Thank you for your understanding and support.

    Regards,

    Perry



    Good Morning,

    I have a problem, I have configured auto discovery in my domains, but after the implementation of microsoft autodetect in the "16.0.6769.2015" version, the Outlook 2016 and mobile Outlook clients have started to return the incorrect SMTP data, returning:
    host mail.mx.domain.com
    door 25

    The correct thing was to return:

    host smtp.domain.com

    door 587

    I've already applied the solution to disable autodetect on the client and by discovery, it returns the correct data. But as many customers are, it is impossible to apply this solution at all.

    https://support.microsoft.com/en-us/help/3189194/how-to-disable-simplified-account-creation-in-outlook

    Using the fiddler, I saw that a request is made for https://prod15-files.acompli.net/, it seems to be an api of them, and making the request for them returns wrong:
    Request

    curl "https://prod15-files.acompli.net/autodetect/detect?services=office365,outlook,yahoo,google,icloud&protocols=eas,imap,smtp,rest-cloud" -H "X-Email: test @ domain .com.br "

    PS: I already made a knock to disable autodetect, but even so it becomes unfeasible to disable everyone.
    Return from webservice:

    PS2:
    This happens for all domains in my database, because even when configured, when there is a connection difficulty, Outlook tries to reconfigure and pick up the incorrect data.

    {"email": "test@dominio.com.br", "services": [], "protocols": [{"username": "test@dominio.com.br", "protocol": "eas", "autodiscover": "autoconfig.dominio.com.br", "validated": false}, {"protocol": "imap", "hostname": "imap.domain.com", "port": 993, "encryption": "ssl", "insecure": "invalid_certificate", "validated": false}, {"protocol": "smtp", "hostname": "mail.mx.domain.com", "port ": 25," encryption ":" none "," insecure ":" plain "," validated ": false}]}

    Could someone give me a light?
    Thank you very much in advance!
    Wednesday, March 6, 2019 7:45 PM
  • Good Morning,

    I have a problem, I have configured auto discovery in my domains, but after the implementation of microsoft autodetect in the "16.0.6769.2015" version, the Outlook 2016 and mobile Outlook clients have started to return the incorrect SMTP data, returning:
    host mail.mx.domain.com
    door 25

    The correct thing was to return:

    host smtp.domain.com

    door 587

    I've already applied the solution to disable autodetect on the client and by discovery, it returns the correct data. But as many customers are, it is impossible to apply this solution at all.

    https://support.microsoft.com/en-us/help/3189194/how-to-disable-simplified-account-creation-in-outlook

    Using the fiddler, I saw that a request is made for https://prod15-files.acompli.net/, it seems to be an api of them, and making the request for them returns wrong:
    Request

    curl "https://prod15-files.acompli.net/autodetect/detect?services=office365,outlook,yahoo,google,icloud&protocols=eas,imap,smtp,rest-cloud" -H "X-Email: test @ domain .com.br "

    PS: I already made a knock to disable autodetect, but even so it becomes unfeasible to disable everyone.
    Return from webservice:

    PS2:
    This happens for all domains in my database, because even when configured, when there is a connection difficulty, Outlook tries to reconfigure and pick up the incorrect data.

    {"email": "test@dominio.com.br", "services": [], "protocols": [{"username": "test@dominio.com.br", "protocol": "eas", "autodiscover": "autoconfig.dominio.com.br", "validated": false}, {"protocol": "imap", "hostname": "imap.domain.com", "port": 993, "encryption": "ssl", "insecure": "invalid_certificate", "validated": false}, {"protocol": "smtp", "hostname": "mail.mx.domain.com", "port ": 25," encryption ":" none "," insecure ":" plain "," validated ": false}]}

    Could someone give me a light?
    Thank you very much in advance!
    Wednesday, March 6, 2019 7:45 PM