none
Realtek® RTL8201CL LAN PHY Fast Ethernet LAN controller - 64bit Windows 7

    Question

  • Realtek® RTL8201CL LAN PHY Fast Ethernet LAN controller - 64bit Windows 7

    I can't get the driver to load.  Which drivers are best to use?  The controller is integrated in the sr1010z

    http://h10025.www1.hp.com/ewfrf/wc/document?docname=c00257657&cc=us&lc=en&dlc=en&product=461226 

    Motherboard Specifications, K8S-LA (Salmon)

    Form factor Micro-ATX form factor: 9.6 in x 9.6 in
    System BIOS Supplier Award
    Processor AMD Athlon 64 processor with HyperTransport support
    Processor socket type Socket 754
    Processor front side bus frequency 1600 MT/s @ 800 MHz
    Maximum approved processor
    • Athlon64 3700+
    • AMD Athlon64 3400+
    Chipset "North Bridge" SiS760
    Chipset "South Bridge" SiS964
    Memory type PC 2700 or PC 3200 DDR
    Memory sockets 2 x 184-pin DDR DIMM
    Maximum Memory 2.0 GB
    Graphics None
    Graphics configuration Up
    Graphics connector (AGP) 1 AGP 8x
    Audio Integrated AC97
    AC'97 CODEC Device Realtek ALC658C 6-channel CODEC
    Audio Jacks ( Legend below ) 2M (1F+1B), 2LI (1F+1B), LO, Headphone connector
    Ethernet 10/100 LAN supplier Realtek® RTL8201CL LAN PHY Fast Ethernet LAN controller
    Ethernet configuration Integrated, Down
    IEE 1394 VIA VT6307
    IEE 1394 Front/Back Options 1F + 1B
    SATA connectors 2 SATA connectors (supports a total of 2 drives, 1 serial ATA-150 disk drive on each connector)
    IDE UDMA modes 2 x UDMA 100/66/33
    Expansion slots (AGP/PCI/Exten) 1 AGP, 3 PCI
    USB ports Up to 6
    USB Front/Back Options Up to 2F + 4B
    Serial, parallel, floppy, PS2 keyboard and mouse 1S,1P,1F,PS2 K+M
    Available manufacturing options ( Legend below ) ULE6

    • Moved by OthorvathMVP, Moderator Saturday, January 17, 2009 2:49 PM (Moved from Windows 7 Networking to Windows 7 Hardware Compatibility)
    Monday, January 12, 2009 11:42 PM

Answers

  • Gave up after I tried SIS, Realtek drivers a variety of ways.  Installed a Netgear 311B (Broadcom based) and got wireless up and running.  I'll keep monitoring the thread to see if anyone replies with similar hardware that is working.
    Wednesday, January 14, 2009 3:09 PM

All replies

  • I run my Uli rt8201 driver install program in XP SP2 compatibility mode and it loads in windows 7.
    Tuesday, January 13, 2009 12:15 AM
  • I was trying to update the drivers.  Where is a site to download the driver package you speak of?  Also, how in Winows 7 do you run the package or the driver in XPsp2 compatibilty mode?  Is it each time or just the initial install?

    Tuesday, January 13, 2009 1:43 AM
  • I got my driver installer from the asrock site, which is my mobo manufacturer.  Here's the link to the website:  http://www.asrock.com/support/download.asp?Model=&Socket=939&Product=939Dual-SATA2&OS=XP64 and I used the Lan Driver version 3.5.  I can't guarantee the driver will load for your motherboard since this seems to look for a uli version of the rt8201 chip.  I right clicked on the executable and selected the compatibility tab.
    Tuesday, January 13, 2009 2:01 AM
  • Also, try the ASUS website, www.asus.com.  They have an xp64 bit driver for a k8s-mx board.  It might be similar to yours.
    Tuesday, January 13, 2009 2:29 AM
  • Gave up after I tried SIS, Realtek drivers a variety of ways.  Installed a Netgear 311B (Broadcom based) and got wireless up and running.  I'll keep monitoring the thread to see if anyone replies with similar hardware that is working.
    Wednesday, January 14, 2009 3:09 PM
  • Solved the problem!

    Have an Asrock 939 Dual. Installed Windows7 en got 64bit drivers from Asrock site! (actually for XP 64 bit version)

    Windows7 didn't want to load the "Lan_XP64_MCE_XP_2K_ME_98(3.50)"

    Then I saw here the "compatibility mode", tried again and now it works perfectly!

    Saturday, October 16, 2010 2:17 PM