Running regedit as admin


  • Hi all,

    Ran into a problem trying to launch regedit using the "Run as Administrator" option available from a right click of the mouse while logged in as a regular user.  When you click on run as administrator it tells you that you do not have permissions.  We do have group policy set to not allow users to edit the registry, but the run as administrator function should bypass that and it does not.  Any advice or ideas would be greatly appreciated. 



    Thursday, October 25, 2012 4:38 PM

All replies

  • You have set group policy in wrong way. Run resulting set of policy.

    Better forum for your problem is Windows Server Group Policy



    Thursday, October 25, 2012 8:59 PM
  • Milos,

    Thanks for your help.  I would agree but, it doesn't happen like this on every Windows 7 machine.  Odd I know.  GP was the first thing that came to mind for me.

    Thursday, October 25, 2012 9:17 PM
  • Hi,

    Please let us know which account you run as, the local administrator account or the domain administrator account?

    Also, please make sure that UAC is turned on and run

    Icacls C:\Windows\regedit.exe

    to check if the right permissions are set.

    In addition, please check if there is any related trace in Event Viewer.

    Hope this helps.

    Jeremy Wu

    TechNet Community Support

    Monday, October 29, 2012 4:49 PM
  • Jeremy,

    I will take a look at UAC and run icacls to see what happens.  This happens on local or domain admin accounts.  I will let you know.



    Wednesday, October 31, 2012 1:38 PM
  • Jeremy,

    Here is what I get when icacls c:\windows\regedit.exe is ran

    NT Service\TrustedInstaller:(F)


    NT Authority\System:(RX)




    Wednesday, October 31, 2012 2:34 PM
  • Hi,

    Which group policy setting do you use to lock down the registry? Does it also block the access to administrator? You can try to disable the UAC feature on Win7 client.



    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Monday, November 05, 2012 9:44 AM
  • Denny,

    We are using the "Prevent access to registry editing tools" policy.  It is set under User Configuration --> Admin Templates --> System

    We do have a non group policy users org that does not have the limitations.  All administrative accounts are in this group.  UAC has been completely turned off on the machines in question, and still not able to do a right click and "run as" on the regedit.exe

    Very odd.....I have been working on this problem as I can, still not sure why it is doing this....What I did do was move the user that needed registry access to the non group policy users org.  It was a temporary solution to the problem at least.

    Tuesday, November 06, 2012 8:52 PM