none
Volume buttons not working on Sony VAIO VGN-FW351J. Suggestions?

    General discussion

  •  The volume buttons (as well as the S1 button) above my keyboard no longer work after I installed W7. Previously had Windows Vista Premium. Tried re-installing the drivers from the Sony support page and no dice. Any suggestions? Do I need to downgrade back to Vista in order to have that luxury? I will miss the amazing new task bar the most. Thanks.
    Wednesday, February 11, 2009 3:35 AM

All replies

  • Did you install the 64bit version?
    I got the same problem on a FW11s (european version, but almost the same).
    Also Fn keys don't work. It seems sony didn't release a 64 bit version of the drivers, on their site I found some 'unofficial' drivers (for vista 64)
    http://www.vaio-link.com/os/vista/64bit/
    but no one for the volume keys...
    I just wanted to try the 32bit version (well I paid 4giga RAM and I want to use them all :-P).
    Wednesday, February 11, 2009 9:49 PM

  • Got the same problem with my VGN-FZ21M.

    If I well remember :
    - Installed from scratch the Vista supplied with my VAIO
    - Installed 7 RC
    - Installed last drivers from Sony
    - Was OK during a time
    - Got not OK (can't tell why)
    - Installed last drivers from Sony (again)
    - Got OK again

    Sunday, May 17, 2009 4:42 PM
  • Only solved this for a clean install with xp, but there is a library and a service you need to install. You need to install the library first.  The links to the xp version are:

    Sony® Shared Library for Microsoft® Windows® XP   (http://esupport.sony.com/US/perl/swu-download.pl?mdl=VGNTX670P&upd_id=1846&os_id=7)

    and the service: ftp://download.sony.com/US/pc/SOOOTH-32500000-US.EXE

    These may work on 7, my xp libs and services are kind of touch and go on vista and 7... haven't tried these.  Sony may have a 7 version of these in the works too.
    Thursday, July 23, 2009 2:49 PM
  •  The volume buttons (as well as the S1 button) above my keyboard no longer work after I installed W7. Previously had Windows Vista Premium. Tried re-installing the drivers from the Sony support page and no dice. Any suggestions? Do I need to downgrade back to Vista in order to have that luxury? I will miss the amazing new task bar the most. Thanks.
    You need to install the shared Lib and event services from your sony model support page . use the vista drivers and they will all work . including the s1 and Fn buttons etc
    Friday, July 31, 2009 1:15 PM
  • If installing the drivers etc. doesn't fix your issue try this.  Go to Run and type in Services.msc.  Scroll down to Human Interface Device Access, right click and choose Properties.  Change the Start Up type to Automatic.  Click OK, close all windows and reboot.  This should fix your problem.
    Monday, March 08, 2010 10:41 PM
  • I have same problem, (s1 button and fn functions) which occurred after upgrading to windows 8.  So my system is Sony VAIO VGN-FW351J with Windows 8 OS.
    I followed your instructions and turned Human Interface Device Access to automatic, but that did not resolved my problem. Any other suggestions?

    12-31-12:  Anyone who has same problem should follow these steps:

    Download and install the following Sony VAIO utilities (for windows 7, it works for windows 8); Please restart after each download. It should work. It worked for me and all special buttons and keys including Fn keys work great:

    • Sony Firmware Extension Parser Device Driver
    • Sony Shared Library
    • Setting Utility Series
    • VAIO Event Service

    For VAIO Event Service I asked Sony support techs (live chat) and they gave me the link to this utility.

     
    • Edited by AJ3450 Tuesday, January 01, 2013 3:02 AM
    Thursday, December 20, 2012 8:48 PM
  • Hello :) 

    I have the same issue but no luck ... >< I have a question where can I find the

    (Sony Firmware Extension Parser Device Driver) I looked up into sony support website but there is no such thing ... 

    thaaaaanks very much 

    Monday, September 02, 2013 1:17 PM