Win 8.1 Pro dism /Online /Cleanup-Image /RestoreHealth returns Error: 14098 RRS feed

  • Question

  • I am running Windows 8.1 Pro and have recently been experiencing some odd behavior.  This has lead me to discover that my component store is corrupt.

    I have attempted to use sfc with no luck and have posted that on a separate thread.

    When I attempt to use dism /online /cleanup-image /retorehealth, dism quickly comes back with Error: 14098.

    Event the dism log looks corrupt. Below is just the beginning of the file. the not English character portion continues and is quite large:

    [2580] Caller did not request sparse mount
    [2580] Mounting new image.
    Wim:         [\\?\GLOBALROOT\device\harddisk1\partition1\Recovery\WindowsRE\Winre.wim]
    Image Index: [1]
    Mount Path:  [C:\WINDOWS\TEMP\c18ce950-f10f-4afc-a811-28b1ffe5b733]
    [2580] Wimserv process started for guid b3e8550e-9dd9-4246-855b-f0ac5d1c531f.  Id is 956
    [956] ImageUnmarshallHandle: Reconstituting wim at \\?\GLOBALROOT\device\harddisk1\partition1\Recovery\WindowsRE\Winre.wim.
    [956] Mounted image at C:\WINDOWS\TEMP\c18ce950-f10f-4afc-a811-28b1ffe5b733.
    [2580] [0x8007007b] FIOReadFileIntoBuffer:(1415): The filename, directory name, or volume label syntax is incorrect.
    [2580] [0xc142011c] UnmarshallImageHandleFromDirectory:(511)
    [2580] [0xc142011c] WIMGetMountedImageHandle:(2568)
    [2580] [0x8007007b] FIOReadFileIntoBuffer:(1415): The filename, directory name, or volume label syntax is incorrect.
    [2580] [0xc142011c] UnmarshallImageHandleFromDirectory:(511)
    [2580] [0xc142011c] WIMGetMountedImageHandle:(2568)
    [2580] ImageUnmarshallHandle: Reconstituting wim at \\?\GLOBALROOT\device\harddisk1\partition1\Recovery\WindowsRE\Winre.wim.
    [2580] ImageUnmarshallHandle: Reconstituting wim at \\?\GLOBALROOT\device\harddisk1\partition1\Recovery\WindowsRE\Winre.wim.

    Is partition1 the "System Reserved" partition?  Could it be corrupted and if so, can it be repaired or rebuilt?

    Any ideas or help would be greatly appreciated.



    Tuesday, January 21, 2014 5:36 PM


  • I gave up and had to reload windows which is a TOTAL pain, not the reloading Windows part, but having to reinstall all of my applications.  It is horrible that these files cannot be rebuilt without basically doing a fresh install.  I would hope that this can be addressed in the future.


    Wednesday, February 19, 2014 10:03 PM

All replies

  • Hi,

    When you use command "dism /online /cleanup-image /retorehealth" but not specify a /Source for the repair files, the default location for Features on Demand is used. That to say, this command would use default Winre.wim which locate at C:\Recovery\WindowsRE\Winre.wim.

    According to the error message, [956] Mounted image at C:\WINDOWS\TEMP\c18ce950-f10f-4afc-a811-28b1ffe5b733. the Winre.wim path was error.

    Please check your Winre.wim location. In addition, you also can use other Windows 8.1 pro Winre.wim file to fix your system, for more information, please refer to the link below:

    Repair a Windows Image:

    C drive should had a drive value problem. Please check your current system drive location.

    Roger Lu
    TechNet Community Support

    Wednesday, January 22, 2014 9:40 AM
  • Honestly this is something MS should check into. There should be an easier way for users to implement this command rather then a complete dictionary to fix broken windows files. This is a Microsoft windows problem. I know for myself I had to use this command quite often because I installed something windows did not like. Because of that window files became unusable. It would make practical sense for Microsoft to incorporate a feature that runs these commands in administration tools.


    Dism /Online /Cleanup-image/ScanHealth

    if that runs an error then run

    Dism /Online /Cleanup-Image /StartComponentCleanup

    then run

    dism /online /cleanup-image /retorehealth

    Edit: Microsoft has to make a serious decision. During setup, Metro, or desktop. Installing items in desktop mode is creating errors in Metro or windows store items. In future upgrades consider the flavors of OS, implement a users choice. Desktop, Metro, or classic. Face the facts if you follow Linux method of desktop, and the install process. There is no confusion between desktops and we have a choice. This makes common sense. I like the feature of gnome or Ubunto it gives the user a choice and a better picture for Microsoft. Lets face it, Bill Gates choose to hand over his business to people. This gave Bill Gates time to help other people that need help. How about Microsoft do the same and give people the choice between desktops during install. Follow Bill Gates important roll in his life now. Bring some fairness and happiness to people that like Microsoft and what to help users get what they want and the best support they need. Doing this allows Microsoft the glory to help people feel good about themselves. Sure MS can live in a dictatorship roll and continue to bully users to use the product, there is a consequence to this. Good young developers are working on a better OS and this is going to happen. It is better to help people then to fight people.

    • Edited by colakid Wednesday, January 22, 2014 11:52 AM
    Wednesday, January 22, 2014 10:06 AM
  • Roger,

    Thank you for your reply.  Neither my troubled machine or another Win 8.1 Pro machine have C:\Recovery directories.  A search of both machines finds no Winre.wim or any .wim files, although on my 2nd machine, dism runs without a problem indicating that there is a .wim file somewhere.

    I have read that I could use the image from the fully functioning machine to try to repair the first machine, but I need to find the image file first.

    Any ideas?


    Wednesday, January 22, 2014 3:39 PM
  • colakid

    I tried the .../StartComponentCleanup with the same error. It seems that the .wim file isn't there.  A search of the machine could not find any .wim files.

    On another fully functional 8.1 machine, dism runs fine but I cannot find any .wim files there either.

    Where are they stored?

    From looking at the dism log, it looks like it is on harddisk0 partition1 which is the System Reserved Partition. I read about how to get there, but don't remember the details and have no idea where I read it.  Any ideas?


    Wednesday, January 22, 2014 3:50 PM
  • dism /online /cleanup-image /restorehealth

    This check online for the image and fixed them with those files. Check to see if your connections settings are not set to automatic. From what I see your recovery path is ok.

    To check the path of the wimre, Look for current in the bootloader section


    reagentc /info 

    more detailed run bcdedit /enum all

    You do not need the file unless your doing a reset or recover.

    If dism does not work try here

    Method 3:

    1. Type Notepad on start screen, and press enter.
    2. Copy the following text, and then paste the text into Notepad.

    net stop wuauserv

    cd %systemroot%\SoftwareDistribution

    ren Download Download.old

    net start wuauserv

    net stop bits

    net start bits

    net stop cryptsvc

    cd %systemroot%\system32

    ren catroot2 catroot2old

    net start cryptsvc

    3. Click File, click Save As, and then type Repair.bat.

    4. In the Save as type box, click All Files.

    5. In the Save in box, click Desktop, and then click Save.

    6. On the File menu, click Exit.

    7. Double-click the Repair.bat file that you saved in step 5.

    • Edited by colakid Wednesday, January 22, 2014 8:26 PM
    Wednesday, January 22, 2014 6:55 PM
  • Ok I found your path, trust me, it was hard to find, for sure, It is there and hidden and guess what the good old tool windows gives in the view panel does not change the attriibs of C drive at all. The give away is this \\?\GLOBALROOT\device\harddisk1\partition1\Recovery\WindowsRE\Winre.wim

    Globalroot device C on the ntfs partition. So we look at C:\Recover\windowsRE\winre.wim.

    But of course hidden system folders do not show even after check marking in explorer window option. Humm. Well I use this tool called filemenu tools. In there is a attribute file changer and it works sweet. change the attribute of C to show hidden and system folders and bingo your Recovery WindowsRE folder is there with your winre.wim.

    The folder of windows system32/recover is only for an online fix using the dism command and it uses the agent in that folder to locate the winre.wim.

    I have been ringing my brains out on this trying to figure out why all my test to discover winre.wim and all showed it is in c:/recover/windowsRE and every search did not find it.

    Well I went to my good old filemenu tools and went to attribute, check show hidden system files and there it was. I had to assign me access to the file but all was there.  Download here filemenu tools its good to have

    So now we know the image is there and a online fix returns an error, the fix given with the BAT file may work for you, or you can go through the online tutorials to reroute the dism location of the image, this will allow you to do a off line fix, then you can update your winre online using the dism command, fixing files using sfc /scannow command.


    • Edited by colakid Wednesday, January 22, 2014 9:59 PM
    Wednesday, January 22, 2014 9:34 PM
  • Colakid,

    The winre.wim file is indeed stored in the System Reserved partition and not on drive C. 

    What Windows shows as drive C is GLOBALROOT\device\harddisk#\partition0.  The System Reserved partition is GLOBALROOT\device\harddisk#\partition1 which is where dism is looking for the file.

    I finally was able to find a couple of articles about the System Reserved partition and they indicated that is where it was.  It is why it grew from 100mb to 350mb in Windows 8.

    If you assign a drive letter to the System Reserved partition and look at it, you will find the Recovery folder and it contains the winre.wim file.

    Now that I have found this, I have a fully operating machine with a healthy wim file that I have read that I can use as the image to restore by bad machine from.

    Wednesday, January 22, 2014 10:01 PM
  • I missed the part, partition 1, I should have known partition 0 is C. Are you able to do an online fix for your files now? It seems like the path is correct, you should not have a problem with reset finding the path . I do believe if it cant find the file, reset will ask for the CD.

    • Edited by colakid Wednesday, January 22, 2014 10:17 PM
    Wednesday, January 22, 2014 10:10 PM
  • The problem is that on my troubled machine, the System Restore partition seems to be corrupted.  According to what I have read I can use the wim file from another machine and use it as the source for dism.  I haven't tried it yet.  I have some work that I need to finish first in case it all goes horribly wrong and I have to start from scratch.
    Wednesday, January 22, 2014 10:22 PM
  • These are the commands to service your winre.wim the parts you will need to manually complete are the bold underlined text


    ▼Checking if path is correct

    Dism /Get-ImageInfo /ImageFile:C:\Recovery\windowsRE\winre.wim


    ▼Created path in C:Mount, Mounted my winre.wim to the created directory

    Dism /Mount-Image /ImageFile:C:\Recovery\windowsRE\winre.wim /Index:1 /MountDir:C:\mount

    ▼Checking packages from the mount

    Dism /Image:C:\mount /Add-Package /PackagePath:C:\mount\windows\servicing\packages

    ▼Confirming packages can be called with the get command

    Dism /Image:C:\mount /Get-Packages

    ▼Comfirming if remove packages work

    Dism /Image:C:\mount\ /Remove-Package /PackageName:Microsoft.Windows.Calc.Demo~6595b6144ccf1df~x86~en~

    ▼completing the mount by unmouting with a commit command

    Dism /Unmount-Image /MountDir:C:\mount /Commit

    This saved my newly serviced winre package and used on a different computer using a 64 bit OS.

    Edit tested the image with

    Dism /Online /Cleanup-Image /RestoreHealth /Source:c:\Recovery\windowsRE/winre.wim /LimitAccess

    • Edited by colakid Thursday, January 23, 2014 7:01 AM
    Thursday, January 23, 2014 6:44 AM
  • Roger,

    The drive value for drive is correct.

    There isn't a c:\Recovery directory on this machine or on my other Win 81 machines.  The \GLOBALROOT\device... refers to the System Reserved partition and the winre.wim file on their seems to be corrupted.

    I have copied a winre.wim file from another machine and have attempted to use it as a source for the repair with no success.  The command used was dism /online /cleanup-image /restorehealth /source:d:\winre\...

    This gives exactly the same error with no changes in the log file.

    I am lost and the thought of reloading my machine from scratch in not appealing, as you might imagine.

    Any ideas?


    Thursday, January 23, 2014 8:25 PM
  • Understood, I would have been setup already. If the first don't work I don't waste my time. However you may want to consider why this happened. This seems to be suspicious.
    • Edited by colakid Thursday, January 23, 2014 9:45 PM
    Thursday, January 23, 2014 9:43 PM
  • Hi Glen,

    Did you get this resolved or reload Windows as Cola suggested?


    Windows Outreach Team - IT Pro

    Wednesday, February 19, 2014 9:57 PM
  • I gave up and had to reload windows which is a TOTAL pain, not the reloading Windows part, but having to reinstall all of my applications.  It is horrible that these files cannot be rebuilt without basically doing a fresh install.  I would hope that this can be addressed in the future.


    Wednesday, February 19, 2014 10:03 PM
  • I researched the 14098 error on another thread, and the end result of that particular error message is usually the need for a re-install... A lot of corruption can be fixed with the DISM commands posted above. Unfortunately, not every error can be fixed that way.

    Thanks for coming back and letting us know.


    Wednesday, February 19, 2014 10:07 PM
  • Don't get me wrong, I like Windows 8.1 but it does seem delicate.  It seems like a lot of people have stuff like this happen.  I liked when we could refresh the OS without loosing all of the installed programs.

    What is also irksome is that WHS11 doesn't seem to be able to restore a Windows 8 machine so it seems like it is time to abandon that and move to Server 2012 Essentials.

    Thursday, February 20, 2014 4:30 PM
  • damn maybe i should go back to windows 7, because having installed an application and now having to reinstall windows is a huge pain. I guess it serves me right for replacing the external backup of my OS with files. Sighs. Not happy.
    Sunday, July 12, 2015 10:48 AM
  • Never reinstall windows Vista, 7, 8, 8.1

    Problem, get my last backup. 

    Friday, August 21, 2015 3:59 AM
  • "Sure MS can live in a dictatorship roll and continue to bully users to use the product, there is a consequence to this" >> i guess microsoft is somewhat copying Apple Machintosh's style of crapping users with non compatible stuff? but still, microsoft is Always open to share knowledge and power, as apple is don't shoot who wants a better world, a better window for everyone instead of a half eaten piece of fruit..

    Tuesday, June 7, 2016 12:31 PM
  • " a half eaten piece of fruit.."

    Love it. Going to use it!

    Sunday, July 17, 2016 12:15 AM