HDDs in RAID have started spinning down then back up again at restart and shutdown. RRS feed

  • Question

  • Hi,

    Pointed here after posting this at answers.microsoft.com

    I have a head scratcher of an issue. I have scoured the internet but cannot find a mention of anyone else with the issue or fixes.

    After doing a clean installing of Windows 10 Home 2004, my hardware Raid setup has demonstrated a new and worrying behaviour (vs 1909 I was on before). That behaviour is that when you tell Windows to ‘shut down’ or ‘restart’, just before the PC restarts or powers down, my HDD’s spin down and then instantly spin up again. This is different to the normal behaviour I had on my previous pre 2004 installs. That being that, when you restart the disks keep spinning and when shut down the disks keep spinning until the PC powers down. This spin down and then back up behaviour causes delays in shut down and restarting as either does not happen until the disks have spun up again, with the HDD activity light on solid while the spin down and back up happens. Not to mention the extra drive wear, from having to stop and start spinning unnecessarily. It appears to be the same kind of spin down that would happen if you had the ‘turn off hard disk drive’ timer set in windows power options. These I have always had set as never. I only went to reinstall my OS as my Windows started having issues with installing some ASUS lighting and fan management software.

    I assumed this was an issue with 2004, which is fine, as it pretty new, so decided to try 1909 again. Unfortunately I over wrote the USB stick I used to install 1909 with the 2004 install. Of course it was not easy to find 1909 media to put on the stick again, but that means I was not installing from the same media I previously installed 1909 from (I.e. made with media creation tool). That install of 1909 did not have this HDD issue. Unfortunately that clean 1909 install also had the issue. I also tried 1903 and 1803, not from official MS source though as I could not obtain that frustratingly. Also the same, it can also be seen when restarting from the install media itself, i.e. not doing an install and telling it to quit instead, which causes a restart.

    I also tried upgrading my motherboard bios to the latest and then down to an earlier bios with an older Raid version.

    I tried swapping the power cabling and SATA cables for the HDD’s.

    I then tried deleting and recreating the RAID after installing Windows.

    I tried swapping the HDD’s for another couple of spare drives I have. Same issue.

    After further investigation I found that this only happens when there is a RAID setup. It does not happen when the BIOS is set to ACHI or RAID mode, it only happens when drives have been set to be in a raid, whether RAID 0 or 1.

    Finally just to see, I had some Windows 8.1 install media kicking around, so tried that. On Windows 8.1, the drives setup in a RAID behaved as normal.

    So from the testing it looks like a software issue rather than a hardware one, otherwise I would expect have expected Windows 8.1 to have the same issue. Also I would be surprised if the hardware just suddenly had an issue when installing the updated version of Windows as that is too much of a coincidence.

    Quick note on SATA drivers. I have only ever used the standard windows installed drivers and have never used Intel’s RST drivers, so that is not a variable. I did try installing the latest version of RST to see if that helped, but was no help.

    So I am at a complete loss as to what is happening here. I have no idea why rolling back to the version of Windows 10 I was on has not helped, but again the install media I use for the install was not exactly the same as I used to install 1909. In the mean time I have had to give up with the hardware Raid and use the software Raid function in Windows 10, but that is obviously not as good with less performance.

    PC spec:
    CPU: Intel i9 9900k
    Motherboard: Asus Maximus XI Hero (WiFi) Intel Z390 Motherboard Bios Ver 1502
    Memory: 16 Gb Corsair F43200C14-8GTZR
    GPU: GeForce GTX1080ti GPU
    Samsung 960 Pro M.2 SSD (Windows Installation location)
    x2 WDC WD1000DHTZ Raid 0 in (connected to Motherboard SATA connections)
    Windows 10 Home Ver:2004

    Tuesday, July 14, 2020 11:06 AM

All replies

  • Hi
    Thank you for posting in our forum
    According to your description, the situation is more complicated and I need to do more research.
    With the latest progress, I will update in time
    Thank you for your understanding and support
    Best wishes

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, July 15, 2020 8:16 AM
  • Hi,


    Just checking in to see if the information provided was helpful. Please let us know if you would like further assistance.


    Best Regards,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, July 17, 2020 8:25 AM
  • Hi,

    I am confused, there has been no information provided that was helpful in resolving my issue. So far there was only a message to say that it looks like a complicated problem that will have to be researched further and time would be needed to do that..... Unless I am missing another post somewhere?



    Saturday, July 18, 2020 11:41 AM
  • Hi,
    Thank you for your update. According to my knowledge and the search I have done, your question seems to exceed my knowledge. I recommend you to find a professional engineer for help


    Hope this information can help you

    Best wishes

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, July 22, 2020 7:42 AM
  • Hi,

    Thanks for the response, but it did not help as I am a professional engineer and I had already asked myself about this issue before posting...

    Anyway for anyone else who may run across this issue, I did get somewhere with it as to why it was not an issue before I had to reinstall Windows due to Windows store apps not playing nice with system restore, (but that is a whole other issue and different Microsoft forum post).

    What I found was that odd behaviour of the disks only happens when a pagefile is not set in Windows. A soon as one is set the HDD's in a raid behave normally at restart and shut down. I have not a clue why a pagefile setting would affect the HDD behaviour at restart. I m not someone who does the crazy thing of not running a pagefile, but I don't run one on my OS drive.

    I don't get why I was seeing the issue just after installing Windows as then the pagefile would have been enabled as default.

    It does explain why the HDD behaviour is seen when in Windows install media or the recovery part of windows as that does not have page filing as far as I am aware.

    If I have the enthusiasm I will try further testing at some point to get more detail, but at this stage this is just a pointer that if you have the same issue, have a look at your pagefile setup. 

    It is an issue with Windows that will have to be looked into as whether a pagefile is setup or not should cause HDD's to do funny spinning down and up when you restart or shut down the system, but Microsoft will not look into it until more people post to say they have the same issue, which is fair enough.

    Tuesday, July 28, 2020 9:52 PM