locked
Anonymous FTP login to Windows 7 Home Premium (64 bit) RRS feed

  • Question

  • I have a Windows 7 Home Premium (64 bit) with the FTP server running.  I ~think~ I have everything configured correctly for anonymous access, but my ftp sessions look like this:

    C:\Users\user1>ftp user1-pc
    Connected to user1-pc.
    220 Microsoft FTP Service
    User (user1-PC:(none)): anonymous
    331 Anonymous access allowed, send identity (e-mail name) as password.
    Password:
    230 User logged in.
    ftp> dir
    530 Please login with USER and PASS.
    530 Please login with USER and PASS.
    ftp>

    It looks like I've been logged in (the anonymous and password are accepted) but then I am told to login with user and pass again and I cannot list the directory contents or PUT anything to the server.

    The ftp folder in question has been set to give everyone and anonymous login full control.
    Thursday, October 28, 2010 12:56 PM

Answers

All replies

  • Hi, thank you for posting here.

     

    These articles maybe helpful to you:

     

    Configure the Anonymous Authentication Identity (IIS 7)

     

    Enable Anonymous Authentication (IIS 7)

     

    Hope it helps.

     

    Regards,

    Leo   Huang


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Leo Huang Thursday, November 4, 2010 6:08 AM
    Monday, November 1, 2010 8:46 AM
  • Did you ever find a solution for what you described in this thread.  I have the exact same issue and can't figure this out.

    Thanks for any help.

    Friday, May 6, 2011 7:18 PM
  • I just got this to work. I made a few changes trying to figure it out, but the key was finding out that ftp anonymous authentication uses the IUSR to access the files on the system. Once I gave IUSR access to the folder i was sharing via ftp, everything worked.

     

    One thing to note is that i did at one point enable the "Let everyone permissions apply to anonymous user" security policy, but once i set the IUSR permission i flipped it back off and it didn't change the functionality.

     

    Friday, December 9, 2011 5:00 AM