none
Unable to access network share W10 1607 RRS feed

  • Question

  • Hello,

    Just installed the Anniversary Update of Windows 10. I am now unable to access a network share on a QNAP NAS, It was working fine before I updated from Windows 10 1511. I can access shares on other windows servers (2012R2) without problems.

    When trying to access \\blah\ a list of all available shares comes up, choose blah from the list, loginwindow appears, enter credentials. After a while I get:

    \\blah\blah is not accessible. You might ...... followed by, The specified network name is no longer available.

    This worked fine in W10 1511.

    Any suggestions?


    • Edited by lasseponken Wednesday, August 31, 2016 11:06 AM typo
    Wednesday, August 31, 2016 11:04 AM

Answers

  • Hi lasseponken,

    Is it available to access the other network share?

    If it is not available to access any network folder, please disable the firewall and the antivirus software temporarily and run the following command line to reset the tcp/ip stack.
    ipconfig /flushdns (Clear the dns cache)
    nbtstat -RR (release and refesh NetBIOS names)
    netsh int ip reset (reset ip settings)
    netsh winsock reset (Reset Winsock Catalog)
    Reboot

    If the issue persists, try the following command line to force the machine to use SMB 1.0 to access the NAS share.
    sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
    sc.exe config mrxsmb20 start= disabled

    Re-enable:
    sc.exe config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi
    sc.exe config mrxsmb20 start= auto

    Best regards


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    • Marked as answer by lasseponken Thursday, September 1, 2016 12:01 PM
    Thursday, September 1, 2016 7:47 AM
    Moderator

All replies

  • Hello,

    See if fixes mentioned here helps you:

    http://www.kapilarya.com/error-0x800704cf-the-network-location-cant-be-reached

    Hope this helps, Good luck :)

    Windows Insider MVP | Windows troubleshooting and how-to guides - http://www.kapilarya.com

    Wednesday, August 31, 2016 12:33 PM
  • Hi lasseponken,

    Is it available to access the other network share?

    If it is not available to access any network folder, please disable the firewall and the antivirus software temporarily and run the following command line to reset the tcp/ip stack.
    ipconfig /flushdns (Clear the dns cache)
    nbtstat -RR (release and refesh NetBIOS names)
    netsh int ip reset (reset ip settings)
    netsh winsock reset (Reset Winsock Catalog)
    Reboot

    If the issue persists, try the following command line to force the machine to use SMB 1.0 to access the NAS share.
    sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
    sc.exe config mrxsmb20 start= disabled

    Re-enable:
    sc.exe config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi
    sc.exe config mrxsmb20 start= auto

    Best regards


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    • Marked as answer by lasseponken Thursday, September 1, 2016 12:01 PM
    Thursday, September 1, 2016 7:47 AM
    Moderator

  • If the issue persists, try the following command line to force the machine to use SMB 1.0 to access the NAS share.
    sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
    sc.exe config mrxsmb20 start= disabled

    Re-enable:
    sc.exe config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi
    sc.exe config mrxsmb20 start= auto


    This solution solves the issue, but why is the network protocol different in the anniversary update? Also found a setting in the NAS admin interface to change it to smb 3.0 , then it works without having to set windows to use smb 1.0 . more info on the Qnap forum here:

    https://forum.qnap.com/viewtopic.php?f=185&t=112857

    Thursday, September 1, 2016 12:01 PM
  • So if you disable SMB2/3 and it works, then the issue is more than likely the firmware drivers for your QNAP device are outdated. SMB1 is deprecated and on it's way out so it's not a good solution to force it to use SMB1, see this blog for more information.

    If you want, capture me a working vs non-working trace on the Windows TH2 build (1511) and the Windows RS1 build (1607) and I can try to pinpoint your exact root cause. More than likely though as I indicated above, it might be the driver for QNAP device is outdated and is not compliant with the SMB protocol specifications.

    Please let me know what the firmware version on your QNAP device are. If you decide to capture network traces, please send to me directly at arudell at microsoft dot com.


    Adam Rudell | Windows Networking Beta | Microsoft Corporation


    Thursday, September 8, 2016 8:58 PM