none
USB 3 external hard drives keep "disappearing" RRS feed

  • Question

  • My external hard drives keep "disappearing" from "This PC." 
    Everything worked fine in Windows 7 64bit and Windows 8 Pro. 
    As soon as I upgraded to Windows 8.1 Pro, the problem started.

    Drives are present and working for approximately 10-15 minutes, then they "disappear."
    System must be restarted or sometimes removing and reinserting the USB cable will bring back drives.

    From my searches, apparently this is a widespread issue.

    I have a Mediasonic ProBox HF2-SU3S2 4-bay JBOD enclosure with four HD's in it connected to my laptop via USB 3. 
    The laptop is an ASUS g74SX. 
    The USB controller is Fresco Logic xHCI FL1000. 
    All drivers and firmware for every bit of hardware is most recent. 
    I have tried drivers for all hardware both from the manufacturer, as well as Microsoft.
    Power management for all devices, USB sleep, etc. have been turned off.
    Hard drives have been checked for S.M.A.R.T. issues, as well as any other issues - no problems.
    USB cables have been changed.

    USB thumb drives work fine.
    Uspeed Superspeed HD dock on USB 3 works fine.

    I, as well as other ProBox owners, have talked with Mediasonic who essentially says the problem is not their hardware.
    Mediasonic points to people using other USB devices as having the same dropout issues. 
    Indeed, upon checking, it appears that others with different systems are experiencing the issue.

    The common denominator is, people did not have this issue under Windows 8, but do under Windows 8.1

    The general consensus seems to be that Windows 8.1 has some kind of USB ports power problem.

    Can anybody offer any help? Thanks. 

    Thursday, October 31, 2013 6:40 AM

Answers

All replies

  • Hi,

    It is probably the driver compatibility problem that caused this problem, please make sure the driver is up-to-date.

    Meanwhile, please refer to this article to have a try.

    Some USB devices do not recharge in Windows 8.1

    http://support.microsoft.com/kb/2900614

    In addition, please check the Event Log, verifying whether there is any relate error report about this problem.

    Best regards,

    Karen Hu


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Friday, November 1, 2013 2:58 AM
    Moderator
  • Same here. Just installed Win8.1 this weekend. I have 3 external drives. HD1, HD2 and HD3....1 and 2 seem to have no problems but HD3 will show up and then just POOF..its gone. I tried the clearing of USB drivers to reinstall but that doesn't work. Unplug/Plug back in works...but so many mins later if I go to look at all the drive, ill actually just see it disappear off the list.

    What the fudge?

    Sunday, November 17, 2013 7:03 PM
  • Actually, it has nothing to do with drivers, nor is it your hard drive's fault. It's actually a Microsoft issue, although I'm not sure anybody has stated it as such. Anyway, the problem does have to do with how Windows 8.1 deals with power management of USB. It took weeks to uncover the solution, but here it is. Also, this solution has been confirmed to work for many people with many different devices from different manufacturers. Cheers!

    http://blogs.msdn.com/b/usbcoreblog/archive/2013/11/01/help-after-installing-windows-8-1-my-usb-drive-disappears-or-file-transfers-stop-unexpectedly-r-a-post-title.aspx?CommentPosted=true#commentmessage

    • Marked as answer by dlant Sunday, November 17, 2013 7:46 PM
    Sunday, November 17, 2013 7:46 PM
  • Hi, Karen

    I had been using the Windows 8.1 enterprise preview for quite sometimes.

    It has shown fully compatible to all my owned USB 3.0 devices without any issue.

    May be you can try it too ?!

    Best regards

    PC Enthusiast

    Monday, November 18, 2013 2:32 AM
  • How to Fix USB 3.0 external HDD problem on Windows 8.1

    https://www.youtube.com/watch?v=ISR0wGXJb_Q

    Friday, November 22, 2013 11:08 AM
  • Actually, it has nothing to do with drivers, nor is it your hard drive's fault. It's actually a Microsoft issue, although I'm not sure anybody has stated it as such. Anyway, the problem does have to do with how Windows 8.1 deals with power management of USB. It took weeks to uncover the solution, but here it is. Also, this solution has been confirmed to work for many people with many different devices from different manufacturers. Cheers!

    http://blogs.msdn.com/b/usbcoreblog/archive/2013/11/01/help-after-installing-windows-8-1-my-usb-drive-disappears-or-file-transfers-stop-unexpectedly-r-a-post-title.aspx?CommentPosted=true#commentmessage

    Woohoo...worked for me...so far anyway. Thanks for the info!

    Now...to just figure out why my screen just goes black when i try to remote into my home PC with 8.1 on it.

    Saturday, November 23, 2013 6:06 PM
  • This issue was effecting my Windows Server 2012 Essentials unit and caused one of my disks to go raw I thought that it was the fault of the USB 3.0 card I had installed in the server (Asus CG290 Core i7/24 GB of RAM) I have two Mediasonic ProBox HF2-SU3S2 4-bay JBOD enclosure and they would constantly be dropping in and out so I installed Windows 8.1 over the server install and got a new Asus M51AC and installed Windows Server 2012 Essentials R2 on it only to find that I am having the same issues but only more frequently. I installed the drive enclosures to another desktop that I have that is running Window Home Server 2011 and both boxes were preforming just fine without any noticeable dropouts. I see that this issue was solved but I wanted to report that the WSE2012 R2 was having the same issues.

    Derek Smith

    Went into power management as the link says only to find out that on Windows Server 2012 Essentials R2 the hard drives defaults are to never shutdown not the 20 minutes that Windows 8.1 is set to.
    Ok I have gone into the device manager\usb controllers then went into the properties of all usb hubs then went into the power management tab and unclicked the checkbox that allow for usb devices to be turned of to save power so far so good.

    On more review this hasn't fixed the problem guess I will attempt the registry changes.

    Registry Hack didn't work either I have now went into power options and set it up so my hard drives don't shut down for 1 million minutes so almost two years I hope that it works.
    Sunday, December 8, 2013 7:17 AM
  • This is the answers, just checking the article I find out that there was the update KB2911106 waiting to be selected.

    Thanks.

    Saturday, February 1, 2014 11:52 PM
  •      I think I have cleared up my problem by enabling the write cache on the drive.

         After rebooting, while the drive is still visible,

              Control Panel -> System -> Device Manager -> Disk drives -> Seagate Expansion Desk SCSI Disk Device -> Properties -> Policies -> Click "Better Performance" (override "Quick removal"); I also checked "Enable write caching on the device"

         After doing this, the drive has remained available for at least two hours.  I thought it was dropping out after twenty minutes before I made the change.

         I selected this thread as close to what I was experiencing, but it's not a perfect match.  Contrary to the many items I've found online complaining that there was no problem with Windows 8, but that the problem started with Windows 8.1, I am running Windows 8.  Every time I boot, the drive is visible and usable (by which I mean "Computer" displays drive letters corresponding to the Windows-acceptable partitions on the drive).  While I'm sitting at the computer, and not using the external drive, I hear what I think are the "device disconnect" and "device connect" alert sounds.  After several pairs of sounds I notice that the drive letters corresponding to the external drive are no longer being displayed in "Computer".  There is a balloon notice in the lower right corner of the screen claiming that Windows doesn't recognize the last device I plugged in -- I haven't plugged in anything.  "Device Manager" no longer shows the external drive under "Disk drives".  Instead, there is a top-level entry with a name like "Unrecognized devices" with a single item under it.

         I had tried selecting each item under "Universal Serial Bus controllers" in "Device Manager", going to Properties, and, if there is a Power Management tab, clearing the check box for "Allow the computer to turn off this device to save power."  I had also gone into Control Panel -> System -> Performance Information and Tools -> Adjust Power Settings -> Change Plan Settings -> Change advanced power settings -> USB settings -> USB selective suspend setting -> Setting -> select Disabled.

         Updating drivers didn't seem to be an option:  Intel doesn't provide a USB controller driver; Seagate doesn't provide a driver associated with the drive.

         Before I had an external drive I disabled Quick Boot / Hibernate -- whatever I could find to get to the point where when I Shut Down, it really shuts down.

         I tried to confirm that I had found a critical setting to solve the problem. I disabled the write caching on the drive. If forced me to reboot -- I don't remember being forced to reboot when I enabled write caching. It's been over an hour and the drive letters are still in Computer.



    Tuesday, August 5, 2014 6:03 AM
  • THANK YOU!!!!

    I have a PowerBox HDD Docking Station and I've been trying to move massive amounts of data. On larger files of several gigabytes the docking station seems to go to standby. I had disabled all the USB suspend options in Windows 10 power settings and even turned off the USB power saving/standby feature in Device Manager for all the USB controllers. Nothing worked. Had tried the registry edit suggested but there were no numbers associated with the device as listed. However the script seems to have done it!! HOORAY!!

    Moments after running the script Windows seemed to disconnect and reconnect the drives but didn't put the docking station in standby mode. Hopefully there isn't another issue. Fingers crossed. Thank you so much for pointing me in the right direction. Had been searching high and low for a solution.

    THANK YOU!

    Thursday, April 7, 2016 11:01 PM
  • I did all of these things too. From changing my computers power setting to never turning off hard disks to disabling the USB power management in Device Manager for all root hubs. The powershell/registry edit now prevents my Mediasonic ProBox 4-bay from going in to standby but the drives still disappears every few minutes, stopping the copy and I have to retry to resume. With Teracopy I have to cancel the transfer and then re-copy and with Windows copy function it just says the copy was interupted and that the resource is no longer available but as soon as I hit retry, it will work for a few more minutes. I'm stuck in this loop. Did you ever solve it? 

    Using Win 10.  

    Friday, April 8, 2016 4:35 AM
  • I get the same issue as you when copying large amounts of data (anything over about 15GB) though it only seems to happen when copying from one of my 2TB HDDs which is the first one in one of the 2 PRoBox HF2's I have.  It only happens copying large amounts of data - if I drag and drop smaller folders or single files all is Ok so  I was wondering if it's got something to do with the Probox USB3 interface over-heating - but then if it was that I guess it would fail on a copy to/from any drive.

    I haven't tried any of the hacks above as yet as I'm thinking I might get rid of that one drive, even though it checks out with 100% health - perhaps the pins on the back are damaged or overheating.

    All very frustrating but as it only happening on one of my 8 2TB drives (so far) I can live with it.... hoping a replacement drive will sort the issue out for me but still suspect it's the ProBox that is the issue.

    Monday, April 18, 2016 3:56 AM
  • I have been battling this issue, FOR MONTHS.  It is exacerbated in my situation because I have 16+ disks connected via USB 3.0 in addition to 6 internal disks on my Windows 2012r2 Server.  The core blog post mentioned early DOES NOT solve my problems.  And none of my vantec docks are actually prevented from sleeping with the power-management fixes.  It seems the vantec docks kill the disk power regardless of what I set them too (as do other brands I've tried).  My docks are similar to this one: http://www.vantecusa.com/gl/product/view_detail/665

    I've tried

    1. Updating my motherboard bios
    2. Using a PCI-express add-on USB3.1 card
    3. Getting the latest Windows Updates

    No dice.  I'm really frustrated with this... now I'm about to drop $300 on an external eSata enclosure with port-sharing.

    Monday, June 6, 2016 9:47 PM