none
Domain Computers get Local Only Network, Unidentified Network (Public)

    Question

  • Ok here is the problem my business has been having. We've been upgrading all of our computers to Vista these past few weeks, and we've noticed that some of the computers tend to drop off the network at random, sometimes after returning from hibernate or sleep. Most require a reboot to get Internet access back, however a few, all Dell Optiplex 745s with Broadcom 57XX NICs will not restore internet and remain on local only.

     

    We have a Windows 2003 R2 server, which we use as our DC, to manage both our AD and GP. These 745s had Vista installed and updated then were joined to the domain. We take them to the user and then sometimes the user will have a couple of days with perfect internet service and then we will get a call that it is out.

     

    I've seen this type of problem out there, but never exactly like this one. We've done all the possible solutions we could think of. We've restarted, then disabled IPv6, run the Network Diagnostics tools, uninstalled the Broadcom NIC and reinstalled, made sure we had the latest Broadcom drivers, Flushed the DNS, Disabled the card in the Network Settings, Disabled the card in the BIOS then renenabled, etc etc etc. We've done everything we can think of to try and get these computers to regain internet connectivity to no avail.

     

    We now have 3, 745s that we know are having this exact problem. However, we have discovered that if we take the computer off the domain and join it to a workgroup, when we restart we have full internet connectivity, we deleted the old computer account out of AD and rejoined the computer to the domain and made sure it was in the correct OU. And we have full internet with the computer joined to the domain. But a few days later the problem repeats itself.

     

    What my question is now is, why? We've checked our GPO that this computer is under and we cannot see a possible cause. Possibly something related to Windows Firewall, or Link Layer Topology, or some DNS setting in GP? I think the fact that the internet works on a workgroup but not a domain almost rules out any hardware problems, though it's possible it could be a combination of issues with Vista.

     

    If anyone has any ideas or suggestions please post them.

     

    Thanks.

    Thursday, August 02, 2007 3:59 PM

All replies

  • I've ran into many Vista computer/laptops that have had this problem.  I don't have a fix for this issue as of yet but I do not believe that the issue is caused by your network setup.  I've seen this issue mostly with Windows Vista Business, however, I have heard of it with Windows Vista Ultimate.  Just recenlty, I had a customer who puchased an Hp laptop with Windows Vista Home Premium and they purchased an upgrade to Business. After Vista business was installed the laptop did not want to connect to the internet via Lan or WLAN.  (unidentified network - local access only)  Before the Vista Business install the internet worked fine.    This case, as was all other cases i have come across so far, was not in a domain environment.

    So, my point is that I believe this to be a glitch in Vista rather than a problem with your setup.  If I come across an fix I'll post again.  If you find a fix please do the same.

     

     

     

    Saturday, August 04, 2007 6:17 PM
  • I have Vista Ultimate.  Never had this problem until now.  I'm staying at a Howard Johnson's Motel, with 5 or 6 different wireless accounts available.  They all behave the same way as above description.  I admit, I've not done as much troubleshooting as described above (just re-boot and "diagnose and repair" and try different HoJo account).  None of these actions has produced a permanent solution.  During my most recent "diagnose and repair" attempt, I received a message that my TCP settings were not optimized; I gave the OK for the Diagnostic Policy Service to optimize them.  No info provided on which changes were made.  We'll see if this particular change does the trick.

     

    BTW:  I've used plenty of public networks before; never had this problem until now.  However, I've not tried too many public networks since I did a "Vista Stripdown" -- in which I disabled pretty much everything internet geeks tell you can be disabled (including Diagnostic Policy Service, which is now on manual startup).

     

    Good luck

     

    Tuesday, August 14, 2007 1:55 PM
  • Well I have a good one also. I just purchased two brand new Dell Latitude D830 with VISTA within a week of each  other. The first one will not connect to our wireless system here at work which is a series of access points we use for our RF bar code scanners in the plant. It connects fine to my Linksys wireless router at home. The second one connects here just fine, didn't bother taking it home to try.

    A wasted phone call to Dell support revealed that they do not offer support after you join your laptop or PC to a Windows Domain. They also concluded that it was not a hardware problem since it connected at my home. I installed a D-Link PCMCIA wireless card and it connects fine. I too installed all the latest drivers with no success. I do believe it is a VISTA problem.

    So far I've not had any problems with the LAN cards, just this one wireless laptop. Granted I only have 3 VISTA machines total in my network of 135 so I'm still a novice with VISTA. Hopefully someone out there can shed some light on this problem.

     

    Thursday, August 16, 2007 6:50 PM
  •  

    I had a similar problem with my computer dropping connection randomly.  The two things I did were updating the driver (The problem came back about a day or so later).  The Next thing I did was in the device properties for a LAN card, under the power management tab was uncheck the Allow the computer to turn off this device to save power.  For my wireless card was in the device management under the advanced tab was set the minimum power consumption value to disabled.  After I did all that I haven’t randomly dropped any of my connection.  Hope this helps

    Friday, August 17, 2007 7:37 PM
  • Okay, I have been tracking a number of these reports and now everything seems random except that it happens to Vista PCs in a domain environment.

     

    But it's not happening to everyone... Can I check, I have the same problem. My PCs are connected via Cisco 2940 switches running IOS 12.2 Ever since I turned off the VISTA feature Receive Window Auto Tuning I have not been getting the drop outs. This feature is only supported on modern devices and on Cisco 12.3(12) or above. Can you guys check to see if this is similar in your circumstances?

     

    see http://support.microsoft.com/kb/934430 for reference...

     

    Friday, August 17, 2007 7:53 PM
  • I am seeing a simmilar problem with vista DHCP clients on our network here.  THese computers are domain members and this problem just started when we changed our DHCP servers (we run Solaris DHCP computer).  Unfortunately i don't know a lot about the actual server but I found Friday that installing one of the new Vista Reliablity patches has fixed this problem on multiple computers.

    It looks that one of the reliability patches that MS released fixes this problem, but it does not really mention any network issues addressed in the KB article for the patch.

    Anyway, the patch that fixes this issue (at least for me, on multiple computers) is:

    http://support.microsoft.com/Default.aspx?kbid=938979

    If I install this patch, reboot, BAM, it works, uninstall it, reboot, bam, broken again.  I can do this over and over on multiple computers (although all computers have broadcom NICS in them and are all Dell laptops).

    Anyway, i'd love it if you could let me know if this also resolves yoru problem.

    Thanks

    KG
    Monday, August 27, 2007 3:33 PM
  • We've seen this patch.The only difference we found was that after dropping out it reconnected again. However the same actual problem still existed.

     

    We have seen a great improvement since removing ASF software and Dell's OMCI Altiris solution...

     

    Monday, August 27, 2007 4:12 PM
  • Thanks for the post.  I have been dealing with this for a couple of weeks now and had been limping my comp along.  I tried tech services and they just made the problem worse not to mention they told me to reinstall windows on a 3day old computer.  I hung up on the guy and almost returned the computer.  anyways thanks to your post about the update, which seems to be the problem or solution, I was able to fix my comp.  I uninstalled the update K938979 and rebooted then reinstalled it and rebooted and renewed my ip and it fixed my problem.  this is only after I tried everythings else mentioned above and then some inlucding turning off my broadcast flags in my registry editor.  so thanks again. 

     

    Scorpion

    Friday, September 21, 2007 6:00 AM
  • I've also been experiencing problems with a Dell Latitude D830 running Vista Business x32 connected to a Server 2003 x64 but the internal network card disables "automatically", I've set the power management to not allow it to be disabled, it seems that the problems started after connecting to a public Wireless access point. We've also got 2 identical Dells running vista not doing the same.  

    Tuesday, March 04, 2008 9:25 PM
  •  

    Got the same probleming running Vista Home premium ran every diagnostic and updated/reinstalled every driver I could think of still won't identify my network.

    Other machine is running Xp SP2 thought that might be the issue but don't fancy installing Vista on the "old" machine due to current problems and stability I am having with the new one. Would ring tech support but bought OEM version and from past experience of the fools that work in that dept and the fact they don't understand a word of english...

     

    Anyone with a fix would be greatly appreciated.

    Saturday, April 19, 2008 5:09 PM
  • Hello All,

    I do not know if you guys have gotten a fix.
    Have any of you guys tried to disable the Allow the machine to turn off this device option for your NIC?

    Many of us forget this feature has been implemented on all NIC (not just laptops).  Normally when a Laptop or PC sits idle for  a while (I haven't discovered the amount of time) the NIC will power off.  Technically when activity begins it should send a message out to the network and re-establish a connection. 

    However, many times it doesn't and it will not come back.  Even disabling and re-enabling the NIC does not do the trick and requires a reboot or a shutdown and magically it begins to work.  If you turn off the ability for your PC or Laptop to turn off the NIC (at the Power Managment Tab in the Configuration Settings for the NIC) to save power then you should not have any issues with the machine comming out of Hibernation or Sleep mode.



    Friday, May 30, 2008 1:25 PM
  • I too have the same problem with Dell's.. Not sure what the model is since I am not there but all four of them are doing the same thing. I updated the BIOS, updated Windows Business Vista to service pack 1, and updated the drivers. All four are using the Broadcom 57XX NICs. When you put it in sleep mode or it goes in sleep mode it never comes back up with network connections. I check the card and the loopback works but any pings to the gateway or outside get unrecognized or unreachable. This is so frustrating since now we are turning off sleep in power management which is allowing for access from anyone. NOT A GOOD THING.
    So if someone at Microsoft can fix this problem I think all of us would be happier.

     

    I think it is a 3400 but I will update this on Thursday when I get there.

    Tuesday, June 03, 2008 5:22 AM
  • If you can ping gateway and resolve dns but not able to ping external ip address  problem is conflict with mac address check  DHCP server  or give a usable static ip address.

     

    Finney Zechariah

    Monday, November 17, 2008 9:16 PM
  • Make sure that Network Discovery is still turned ON. i had this issue with vista turning it off from time to time.

    also, if it is showing as local public or home network, under your network and sharing center, click the ICON next to the name of the network and change it to Work.

    This will re-identify the network to the machine.

    If you get Intranet but not Internet, then try deploying the machine with a different machine name. I found we kept having issues with our systems that had this issue when we used the same machine name. Change it from like 20N001 to 20N002 and it may be a resonable work around. After the rename we wouldnt have the issue anymore. The machines were upgrades from XP to W7.

     

     

    • Proposed as answer by Bsharpe Friday, October 01, 2010 6:05 PM
    Tuesday, July 20, 2010 9:21 PM