none
Windows 7 Disk Image Burner went away

    Question

  • Somewhere I lost the built-in Disk Image Burner. It no longer appears in the context menu for an ISO file. It does not appear as a selection in Default Programs, nor in Assign File Types. Where can I find it and reinstall or reactivate it? In the context menu for an ISO file, this appears"-exit -isowrite".

    Assistance please

    Saturday, April 17, 2010 1:52 PM

Answers

  • Hi,

     

    Do you have any other CD\DVD burning software installed? If so, it could be that they've associated themselves with ISO files.

     

    I would like to suggest you try to select the ISO file, then right clicking it, then selecting "Open With" and see if Windows Disc Image Burner is one of the selections.

     

    I also would like to suggest you uninstall any other CD\DVD burning software you have installed and see if it restores the Windows Disc Image Burner option.

     

    Regards,


    Arthur Li - MSFT
    Tuesday, April 20, 2010 5:32 AM
    Moderator

All replies

  • Wish I could help you out, but I am having the same problem and was looking for a solution when I came across your post. Did you load any 3rd party iso tools, as I did? I believe my problem stems from improperly uninstalling one of those.
    Monday, April 19, 2010 2:51 AM
  • Hi,

     

    Do you have any other CD\DVD burning software installed? If so, it could be that they've associated themselves with ISO files.

     

    I would like to suggest you try to select the ISO file, then right clicking it, then selecting "Open With" and see if Windows Disc Image Burner is one of the selections.

     

    I also would like to suggest you uninstall any other CD\DVD burning software you have installed and see if it restores the Windows Disc Image Burner option.

     

    Regards,


    Arthur Li - MSFT
    Tuesday, April 20, 2010 5:32 AM
    Moderator
  • Not sure if you still need this but i got this off another forum here,

    "What to do when Burn Disc Image does not appear?


    I recently found that after right clicking on an ISO the Burn Disc Image menu selection did not appear. This will happen after installing a 3rd party program that has associated itself with ISO files. This makes another program the default program for handling .iso files.

    To fix this you have to reassociate Windows Disc Image Burner with the default file types it can handle, which are .img and .iso files. Here is how to do it: click the start button, control panel, programs, set your default programs, select Windows Disc Image Burner in the left hand column, and click Set this program as default. You can also verify which programs will open with Windows Disc Image Burner by clicking Choose Defaults for this program. The types .img and .iso should be checked.

    Handling default programs and associating file types with them is much easier in Windows 7."

    • Proposed as answer by Korbman Tuesday, November 19, 2013 7:07 PM
    Saturday, May 08, 2010 8:05 AM
  • I also have this issue after installing a 3rd party burning software. However, under the default programs, Windows Disc Image Burner is not listed as an option to default to. Anyone know where it lives?
    Tuesday, May 25, 2010 2:15 AM
  • Ok, So this will show you how to get the 'Windows Disk Image Burner' back in the 'Open with' menu:

     

    1. Browse to the .iso file you would  like to burn
    2. Right click on it, move the courser to the
      'Open with' Sub Menu box
    3. Click on 'Choose Default Program...'
    4. Click on 'Browse'
    5. In the address bar (The bar at the top of the
      window that shows the current directory 
      [location]) type in: "%SystemRoot%\System32"
    6. ** Alternatively to Step 5** Browse to your local
      'System32' folder
    7. Press the Enter Key (or Return Key)
    8. (The files / folders that you were looking at should
      change to the contents of 'System32'
    9. In the 'File Name:' field, type in "isoburn.exe"
    10. Click 'Open'
    11. **optional** Verify that the checkbox is selected so
      that this becomes the default
    12. Click 'Ok'
    And there you have it!! :)
    It should now remain as the default burner for iso's until you install something else.

    I hope this helped!!!

    Let me know if you have any questions (and please don't hesitate)

     

    • Proposed as answer by jjames Sunday, May 06, 2012 4:41 AM
    Thursday, July 08, 2010 4:02 AM
  • After been looking for loooong time , finally its done +10 pt to u teckMaster :D
    Tuesday, August 17, 2010 9:38 PM
  • Thanks A LOT. This tip was really helpful. I couldn't find the windows image disk burner and didn't know the name of the software to open it with. Your instructions were clear and lead me to the solution. Thank you once again.
    Sunday, October 31, 2010 3:35 AM
  • Just so all you M$ geniuses out there know, THERE IS NO OPEN WITH! It is just Open.

    jeez

    Friday, April 13, 2012 5:55 PM
  • Thank you TeckMaster.  Your instructions fixed my computer.
    Wednesday, August 29, 2012 11:39 AM
  • Actually, there is an "Open with". Right click the file and just under open, there is "Open with". I have it on Windows 7 and on Windows 8. Also, you can right click the file, select "Properties". There is an "Opens with:" that has the application associated with that file type and a "Change" button next to it so as to change the file association.

    You may want to verify your statements to be relevant for the kind of file you are right clicking. The menu changes based on options available / relevant. For example, .exe files wont have an "open with" option. But .zip or .iso files will. To know what files extensions will have an open with available, you can go to the control panel and open Default Programs. Then open Associate a file type or protocol with a program (this is based on Windows 8). In Windows 7 you can search for it in the search bar in the start menu if you prefer. 

    Friday, September 07, 2012 2:24 AM
  • Great post TeckMaster. Hopefully the moderator will mark your answer as an answer too...Hint hint...wink wink Arthur_Li. I know this is the fix in Windows 8 as the Windows Disc Image Burner isn't an option if WinZip took over file association.
    Friday, September 07, 2012 2:31 AM
  • What does this say about you?!

    Burdoc = non-sense?

    Everyone thanks you for walking us off a cliff.

    I too was so confused that I could not find WDIB after using it multiple times..  I followed the instructions voted as the answer which include using 'Open With' to bypass the file association and was able to find the executable in there.

    Thanks TeckMaster

    • Edited by billjhil Monday, December 17, 2012 2:51 AM useful edit
    Monday, December 17, 2012 2:47 AM
  • This method worked for me!

    Monday, June 24, 2013 4:56 PM
  • Thankxxx a lot Finally problem Solved.
    Wednesday, December 25, 2013 2:00 AM
  • Thanks
    Friday, April 11, 2014 3:08 PM
  • Worked Great thanks for the help.
    Monday, June 02, 2014 4:39 PM
  • The interesting thing is that I had a new install of Windows 7 and did not have the ISO burner options. On one computer, I even downloaded a separate plugin Windows XP-designed that would add that feature, not knowing it was already there. (The plugin uses the DLL hooks that were already used for burning CDs from Explorer.)
    Wednesday, July 09, 2014 3:58 PM
  • This worked for me in Windows 7, with a slight modification for my situation, so maybe it will help others as well:

    1. "Open With" was not in the context menu either, so I chose "Open".

    2. For some reason on my system the .iso file type was not associated with any currently installed programs, so it popped up with the window, "Windows can't open this file: ... Windows needs to know what program you want to use to open it. ... I chose the "Select a program from a list of installed programs" option.

    3. Then it finally gave me the "Open With" window where Windows Disc Image Burner was present as the only selection. I checked the "Always use the selected program to open this type of file" checkbox, and clicked OK.

    Now "Burn disc image" is back in the context menu for .iso files. Groovy. 

    Monday, October 06, 2014 4:37 AM
  • Have you tried right clicking on the .iso file and click Burn disc image ?
    Monday, December 01, 2014 12:55 PM
  • I have the same issue. There is no "Open with" on my ISO image file it appears with other files but not the ISO one.
    Tuesday, January 27, 2015 11:16 PM
  • Right click the file choose "properties" under the General Tab click on "unblock" at the bottom on the right. Then in the same window choose "Opens with:" toward the top and select the "Windows ISO". That's worked for me!
    Tuesday, January 27, 2015 11:23 PM
  • Thanks you solved my problem. I copy and pasted the location, I was wondering where to locate the burner and even went as far as installing 3rd party software. Thanks!!  I voted for you seeing as you had a fix that was simple and to the point.
    Saturday, January 31, 2015 10:56 PM
  • This is the best answer. I don't have "other 3rd party disk burner" installed, only the Daemon Lite, and it modified the Default program for .iso. After operating as Quincieadams' suggestion, it works.


    • Edited by Ben 0 Saturday, February 14, 2015 4:55 PM
    Saturday, February 14, 2015 4:54 PM
  • That fixed it. Thanks! :)
    Sunday, March 08, 2015 10:36 AM
  • Actually there is both open and open with
    Sunday, March 08, 2015 10:39 AM
  • That works ! Thank you !!
    Sunday, April 05, 2015 1:19 PM